Jump to content
The Dark Mod Forums

TDM only playing audio, no video is shown.


Recommended Posts

I just installed tdm, and I clicked on the exe, when it loaded, the screen is all black, and what I assume is the main menu music is playing, with no video or graphics in the slightest. Any help is appreciated, thanks.

Link to post
Share on other sites

Another idea. Add the line:

    seta logFile "2"

to darkmod.cfg, then start TheDarkMod, close it, and find qconsole.log file (I guess in fms directory).

Attach this log here.

 

Link to post
Share on other sites

Radeon HD 4000 series, just like in the other thread with same problem.

Among extensions, I find it strange that GL_ARB_texture_swizzle is not supported --- it has become core feature of OpenGL 3.3, which this video card should support. Although the game should run without it: I verified the code, and even tried to run 2.08 with marking all the same extensions as disabled in debugger.

Could you please follow these instructions and record a trace?
Please use the script that I have attached.
Note that if the game closes by itself and the trace is less than 1 MB, than it would be useless.

 

apitrace_record.cmd

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...