Jump to content
The Dark Mod Forums

Always "Failed to load savegame" & Unable to Play!


Recommended Posts

  Hey guys. Recently got me an updated computer to play on and so, of course, installed TDM and have been itching to try it out on the new system.

  UNFORTUNATELY, every single time I try to load up ANY mission, I get kicked immediately after hitting "attack" post mission-load to actually enter the mission / game, and the error message is always the same: "Failed to load savegame."

  Latest and updated Windows 10 Pro.
  Intel i9 9880H; ATI Radeon 5500M 4GB; 16GB RAM.
  Loaded onto internal SSD (C:) under a unique folder.

  I have, of course, used the installer to download and install the latest version of TDM - 2.09a and am NOT attempting to load any saved games whatseoever - I'm just trying to load up ANY mission which was downloaded via the in-game download manager.

  PLEASE!!!???! Any and all help would be HUGELY appreciated!!!

  ~Menageryl

Link to post
Share on other sites

What is your status of the write permissions of the tdm folder?

Please test if you can you download  & run new missions, using the ingame mission downloader.
If not, please ad the write permissions to the tdm folder.

Do this automatically by using the new version of my installer,
See post in topic: 

 

During the installation point it at your tdm folder. At the last page  you dont have to run the official tdm installer, when asked.
(This will ad also some shortcuts and a uninstaller, as it should)

Or set the write permission to the folder yourself.
(right click on the darkmod folder > preferences > tab "security > edit > select users > full control + write > ok > ok)

Edited by freyk

Info: My portfolio and darkmod graphical installer
Amnesty for Bikerdude!

Link to post
Share on other sites

As per earlier: Used the in-game mission downloader to grab a whole fistful of missions to try, and that worked perfectly. Until I tried to start the missions, of course.

In addition, I did edit the cfg file to use uncompressed textures as I thought the mission load-times were a little ludicrous.

Both actions above were done without any restriction.

Buuuuut: Just to be thorough: I went to check permissions and all looked fine. Just to be safe (and despite my own ID being the folder owner) I added my own userID explicitly with all (full control) permissions.

STILL no dice! Same issue exactly, unfortunately. :(

 

... Whilte we haven't hit on a solution yet, I do want to express my thanks for the quick responses so far and the willlingness to help guys. MUCH appreciated!!!

Oh! And BTW I myself am an IT tech with backgrounds in Unix, Windows and Mac. So yáll don't have to be gentle with me. 😉

Link to post
Share on other sites

Which missions did you try?
Did you try prebundled missions like "Tears of Saint Lucia" or "New Job" ?

What happens if you install Saint Lucia FM, then open game console and execute "map saintlucia" ?
You won't have any items this way, but at least: does it start the map properly?

Do you have any command line parameters passed to executable?

If you did some configuration already, I'd suggest temporarily removing it.
Move these files to some directory: darkmod.cfg and DarkmodKeybinds.cfg.
Just to be sure you did not accidentally bind something like "left click" to quick load.

I guess you can share some logs, although I'm not sure they will help.
First of all, you can attach condump, made after you catch the bad error message: https://wiki.thedarkmod.com/index.php?title=Reporting_Problem#condump
Second, you can find tdm_installer_XXXXXX.log files, zip them all and share here (I think I only need the latest one, but better just send all).

Link to post
Share on other sites

To be more thorough,
automatically start the game, do a condump, a load mission and do a condump again. This using the commandline.
And load a mission that everybody have in earlier versions, not new job or saintlucia, but trainings_mission.

  1. Use windows explorer and navigate to your darkmod folder.
  2. open the file "currentfm.txt" with notepad. And change the single line to following line, save file, close notepad: training_mission
  3. At you windows explorer click file (menu) > open in powershell
  4. in powershell run the following command:
    .\TheDarkModx64.exe +condump mycondump1.txt +map training_mission +condump mycondump2.txt +exit
    After this TDM starts automatically, load the trainingsmission, generates two condumps and quits.
  5. Attach files "mycondump1.txt" and "mycondump2.txt" to a new forumpost, so people can analyse the files.
  6. end.

If you cannot you find the second condump after this, people want to analyze application memory dumps.
(stgatilov loves them 😉 😛)
Follow the last part of section "record a dump" at TDM-wiki article: Save a Memory Dump for debugging Crashes
 

 

Edited by freyk

Info: My portfolio and darkmod graphical installer
Amnesty for Bikerdude!

Link to post
Share on other sites
1 hour ago, freyk said:

Cant you find any crashdumps after this, people want to analyze application memory dumps.
(stgatilov loves them 😉 😛)
Follow the last part of section "record a dump" at TDM-wiki article: Save a Memory Dump for debugging Crashes

Hey, memory dump can be useful only if done at the right moment!
I'm not sure if there is such moment in this case.
If only when the problematic message shows up but before closing it...

Link to post
Share on other sites

Menageryl get "kicked" after missionload. To me that is a described sign, that TDM crashes without any error mesages. So i think dat the second condump is unsufficient (or not created), but a memorydump is more meaninful.

Edited by freyk

Info: My portfolio and darkmod graphical installer
Amnesty for Bikerdude!

Link to post
Share on other sites
4 hours ago, freyk said:

To be more thorough,
automatically start the game, do a condump, a load mission and do a condump again. This using the commandline.
And load a mission that everybody have in earlier versions, not new job or saintlucia, but trainings_mission.

  1. Use windows explorer and navigate to your darkmod folder.
  2. open the file "currentfm.txt" with notepad. And change the single line to following line, save file, close notepad: training_mission
  3. At you windows explorer click file (menu) > open in powershell
  4. in powershell run the following command:
    .\TheDarkMod.exe +condump mycondump1.txt +map training_mission +condump mycondump2.txt +exit
    After this TDM starts automatically, load the trainingsmission, generates two condumps and quits.
  5. Attach files "mycondump1.txt" and "mycondump2.txt" to a new forumpost, so people can analyse the files.
  6. end.

If you cannot you find the second condump after this, people want to analyze application memory dumps.
(stgatilov loves them 😉 😛)
Follow the last part of section "record a dump" at TDM-wiki article: Save a Memory Dump for debugging Crashes
 

 

  Not entirely sure if this will help as it didn't prompt me to "click attack" to start the mission. It's only at that point that the crash occurs. I do seem to load into the mission just before that - I get the typical first-person view with the light-gem down bottom, then the prompt to "click attack" and then the crash.

  Nevertheless... Followed instructions and herewith the files!

mycondump1.txt mycondump2.txt

Link to post
Share on other sites
7 hours ago, stgatilov said:

Which missions did you try?
Did you try prebundled missions like "Tears of Saint Lucia" or "New Job" ?

What happens if you install Saint Lucia FM, then open game console and execute "map saintlucia" ?
You won't have any items this way, but at least: does it start the map properly?

Do you have any command line parameters passed to executable?

If you did some configuration already, I'd suggest temporarily removing it.
Move these files to some directory: darkmod.cfg and DarkmodKeybinds.cfg.
Just to be sure you did not accidentally bind something like "left click" to quick load.

I guess you can share some logs, although I'm not sure they will help.
First of all, you can attach condump, made after you catch the bad error message: https://wiki.thedarkmod.com/index.php?title=Reporting_Problem#condump
Second, you can find tdm_installer_XXXXXX.log files, zip them all and share here (I think I only need the latest one, but better just send all).

  The mission I tried first and have tried the most was the training mission. I kinda always use that as my starting point - it's a good mission to get a feel for the performance of a computer and configuration I find and shows off a lot of the basics. And of course it gives you the space you need to have a good look around. :)

  I also tried one of the other bundled missions before then trying to download a whole bunch of others, thinking that perhaps it had something to do with an issue with the bundled missions themselves.

  No. No command line parameters. Only thing that was changed was the textrure compression now set to off. But I had the same issues before making those changes too.
  Hell, I've tried a repair install already once, and a complete uninstall and re-install once. Keep experiencing the exact same issue.

  Herewith the log file from the process you linked to (stil using the Training Mission. Seems to be the best starting point...).

qconsole.log

  • Like 1
Link to post
Share on other sites

  Okay... So.. I was curious and started poking around the log files you guys had me collect.

  And it looks like all is well up to the point the player spawns, and then it seems to be trying to load a quicksave!?!?!????
  WTF!?!?? Why????

  Okay, yáll know this game and it's parameters and logs better than I do, so I'll continue to poke around a bit and see what sense I can make of things whilst I wait on feedback from you more knowledgeable folks!

  THANKS!

  • Haha 1
Link to post
Share on other sites

thanks for sending them in.
Im not experienced in reading these logs.

But I compared your mycondump-logs with mine and it looks the almost same.
(except system specs, some different settings, etc)

At the moment, i can only see in mycondump2.txt that the trainings mission is not fully loaded, without any errors(?).
I expect in mycondump2.txt to see multiple map info log-lines, but your log doesnt have any.
(this after line "----- idImageManager::EndLevelLoad -----")

Edited by freyk

Info: My portfolio and darkmod graphical installer
Amnesty for Bikerdude!

Link to post
Share on other sites
1 hour ago, Menageryl said:

  And it looks like all is well up to the point the player spawns, and then it seems to be trying to load a quicksave!?!?!????
  WTF!?!?? Why????

Yes, something triggers quickload after the level loading ends.
No freaking idea what it is! That's the most hilarious technical issue I have even seen 😁

Try to bind quickload to something ordinary... like NumPad9 or something.
Also, you can look through DarkmodKeybinds.cfg and DarkmodPadbinds.cfg and comment/delete all lines which have "loadgame" in them.

Which language do you use in TDM?
Which is the default language of Windows? Default input language?
Which keyboard layout do you use?

Link to post
Share on other sites

  Oh my frickin’ GAWD!!! 🤦‍♂️

  I cannot believe something as STOOPID as this has messed me up so badly and pushed me into roping others into a pointless chase for help!

  After all of this, I went through my keybinding configuration again and found that when I was reassigning keys for screenshots and quick-save / quick-load I had looked right past the fact that it had mistakenly taken the left-click as my binding instead of the key I had intended!!!

  Until looking at these log files I hadn’t even bothered to look at the bindings because I was CONVINCED they were correct!!!! 🤦‍♂️

  Apologies guys. Pointless chase, but we have success... I have a working game now.

  SO sorry to have wasted your time like this!!!

  I am, however, extremely grateful!!!!!

  • Like 2
  • Haha 2
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...