Jump to content
The Dark Mod Forums

make complains (debian10)

Recommended Posts

Hello, i cant compile for some reasons

i downloaded with github and had to add libeigen3-dev to the list from the instructionpage. Cmake misses test modules.

In file included from /home/chris/DarkRadiant/include/iselectiongroup.h:4,
                 from /home/chris/DarkRadiant/plugins/script/interfaces/SelectionGroupInterface.h:7,
                 from /home/chris/DarkRadiant/plugins/script/interfaces/SelectionGroupInterface.cpp:1:
/home/chris/DarkRadiant/include/iselectable.h: In function ‘void Node_setSelected(const INodePtr&, bool)’:
/home/chris/DarkRadiant/include/iselectable.h:31:37: error: ‘node_cast’ is not a member of ‘scene’
  ISelectablePtr selectable = scene::node_cast<ISelectable>(node);
/home/chris/DarkRadiant/include/iselectable.h:31:58: error: expected primary-expression before ‘>’ token
  ISelectablePtr selectable = scene::node_cast<ISelectable>(node);
/home/chris/DarkRadiant/include/iselectable.h: In function ‘bool Node_isSelected(const INodePtr&)’:
/home/chris/DarkRadiant/include/iselectable.h:41:37: error: ‘node_cast’ is not a member of ‘scene’
  ISelectablePtr selectable = scene::node_cast<ISelectable>(node);
/home/chris/DarkRadiant/include/iselectable.h:41:58: error: expected primary-expression before ‘>’ token
  ISelectablePtr selectable = scene::node_cast<ISelectable>(node);
make[2]: *** [plugins/script/CMakeFiles/script.dir/build.make:297: plugins/script/CMakeFiles/script.dir/interfaces/SelectionGroupInterface.cpp.o] Error 1
make[1]: *** [CMakeFiles/Makefile2:368: plugins/script/CMakeFiles/script.dir/all] Error 2
make: *** [Makefile:130: all] Error 2

i tried to make a log file       make > make.log      but that failed , although it gives the progress

[  1%] Built target math
[  2%] Built target xmlutil
[  4%] Built target scenegraph
[ 10%] Built target wxutil
[ 10%] Built target module
[ 10%] Building CXX object plugins/script/CMakeFiles/script.dir/interfaces/SelectionGroupInterface.cpp.o

is this missing libraries or wrong ones?


Edited by CrisiusXIII
Link to comment
Share on other sites

i use

git clone https://github.com/codereader/DarkRadiant.git --recurse-submodules

with https instead of git:

is that different? since with git: nothing is downloaded at all


first conclusion 2 instructions missing in debian10 install

libeigen3-dev libgit2-dev


second conclusion, some someelse is still missing

git clone https://github.com/codereader/DarkRadiant.git --recurse-submodules

Cloning into 'DarkRadiant'...
remote: Enumerating objects: 162889, done.
remote: Counting objects: 100% (33651/33651), done.
remote: Compressing objects: 100% (10563/10563), done.
remote: Total 162889 (delta 24575), reused 31976 (delta 22932), pack-reused 129238
Receiving objects: 100% (162889/162889), 96.95 MiB | 3.30 MiB/s, done.
Resolving deltas: 100% (124371/124371), done.

sudo apt-get install git cmake pkg-config gettext zlib1g-dev libjpeg-dev libwxgtk3.0-dev libgtest-dev
sudo apt-get install libxml2-dev libsigc++-2.0-dev libpng-dev libftgl-dev libglew-dev libalut-dev libvorbis-dev python3-dev

Installed the following packages:
libeigen3-dev (3.3.7-1)
libeigen3-doc (3.3.7-1)

Installed the following packages:
libgit2-27 (0.27.7+dfsg.1-0.2)
libgit2-dev (0.27.7+dfsg.1-0.2)
libhttp-parser-dev (2.8.1-1+deb10u2)
libmbedcrypto3 (2.16.0-1)
libmbedtls-dev (2.16.0-1)
libmbedtls12 (2.16.0-1)
libmbedx509-0 (2.16.0-1)
libssh2-1-dev (1.8.0-2.1)

cd DarkRadiant
~/DarkRadiant$ cmake .

-- The C compiler identification is GNU 8.3.0
-- The CXX compiler identification is GNU 8.3.0
-- Check for working C compiler: /usr/bin/cc
-- Check for working C compiler: /usr/bin/cc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Detecting C compile features
-- Detecting C compile features - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Detecting CXX compile features
-- Detecting CXX compile features - done
-- Found PkgConfig: /usr/bin/pkg-config (found version "0.29") 
-- Checking for module 'libxml-2.0'
--   Found libxml-2.0, version 2.9.4
-- Checking for module 'sigc++-2.0'
--   Found sigc++-2.0, version 2.10.1
-- Checking for module 'ftgl'
--   Found ftgl, version 2.4.0
-- Checking for module 'freetype2'
--   Found freetype2, version 22.1.16
-- Checking for module 'gl'
--   Found gl, version 18.3.6
-- Checking for module 'glew'
--   Found glew, version 2.1.0
-- Checking for module 'libjpeg'
--   Found libjpeg, version 1.5.2
-- Checking for module 'libpng'
--   Found libpng, version 1.6.36
-- Checking for module 'openal'
--   Found openal, version 1.19.1
-- Checking for module 'ogg'
--   Found ogg, version 1.3.2
-- Checking for module 'vorbisfile'
--   Found vorbisfile, version 1.3.6
-- Checking for module 'x11'
--   Found x11, version 1.6.7
-- Checking for module 'zlib'
--   Found zlib, version 1.2.11
-- Checking for module 'glib-2.0'
--   Found glib-2.0, version 2.63.5
-- Checking for module 'eigen3'
--   Found eigen3, version 3.3.7
-- Found wxWidgets: -L/usr/lib/x86_64-linux-gnu;-pthread;;;-lwx_baseu-3.0;-lwx_gtk2u_core-3.0;-lwx_gtk2u_stc-3.0;-lwx_gtk2u_adv-3.0;-lwx_gtk2u_gl-3.0;-lwx_gtk2u_xrc-3.0;-lwx_gtk2u_aui-3.0 (found version "3.0.4") 
-- Found Python: /usr/lib/python3.7/config-3.7m-x86_64-linux-gnu/libpython3.7m.so (found version "3.7.3") found components:  Development 
-- Checking for module 'libgit2'
--   Found libgit2, version 0.27.7
-- Checking for module 'gtest'
--   No package 'gtest' found
-- Checking for module 'gtest_main'
--   No package 'gtest_main' found
-- Configuring done
-- Generating done
-- Build files have been written to: /home/chris/DarkRadiant


~/DarkRadiant$ make
Scanning dependencies of target math
[  0%] Building CXX object libs/math/CMakeFiles/math.dir/AABB.cpp.o
[  0%] Building CXX object libs/math/CMakeFiles/math.dir/Frustum.cpp.o
[  0%] Building CXX object libs/math/CMakeFiles/math.dir/Matrix4.cpp.o
[  0%] Building CXX object libs/math/CMakeFiles/math.dir/Plane3.cpp.o
[  0%] Building CXX object libs/math/CMakeFiles/math.dir/SHA256.cpp.o
[  0%] Linking CXX shared library libmath.so
[  0%] Built target math
Scanning dependencies of target xmlutil
[  0%] Building CXX object libs/xmlutil/CMakeFiles/xmlutil.dir/Document.cpp.o
[  0%] Building CXX object libs/xmlutil/CMakeFiles/xmlutil.dir/Node.cpp.o
[  0%] Building CXX object libs/xmlutil/CMakeFiles/xmlutil.dir/XmlModule.cpp.o
[  1%] Linking CXX shared library libxmlutil.so
[  1%] Built target xmlutil
Scanning dependencies of target scenegraph
[  1%] Building CXX object libs/scene/CMakeFiles/scenegraph.dir/ChildPrimitives.cpp.o
[  1%] Building CXX object libs/scene/CMakeFiles/scenegraph.dir/InstanceWalkers.cpp.o
[  1%] Building CXX object libs/scene/CMakeFiles/scenegraph.dir/LayerUsageBreakdown.cpp.o
[  1%] Building CXX object libs/scene/CMakeFiles/scenegraph.dir/ModelFinder.cpp.o
[  1%] Building CXX object libs/scene/CMakeFiles/scenegraph.dir/Node.cpp.o
[  1%] Building CXX object libs/scene/CMakeFiles/scenegraph.dir/merge/MergeOperation.cpp.o
[  2%] Building CXX object libs/scene/CMakeFiles/scenegraph.dir/merge/MergeOperationBase.cpp.o
[  2%] Building CXX object libs/scene/CMakeFiles/scenegraph.dir/merge/MergeActionNode.cpp.o
[  2%] Building CXX object libs/scene/CMakeFiles/scenegraph.dir/merge/GraphComparer.cpp.o
[  2%] Building CXX object libs/scene/CMakeFiles/scenegraph.dir/merge/ThreeWayMergeOperation.cpp.o
[  2%] Building CXX object libs/scene/CMakeFiles/scenegraph.dir/SelectableNode.cpp.o
[  2%] Building CXX object libs/scene/CMakeFiles/scenegraph.dir/SelectionIndex.cpp.o
[  2%] Building CXX object libs/scene/CMakeFiles/scenegraph.dir/TraversableNodeSet.cpp.o
[  2%] Building CXX object libs/scene/CMakeFiles/scenegraph.dir/Traverse.cpp.o
[  3%] Linking CXX shared library libscenegraph.so
[  3%] Built target scenegraph
Scanning dependencies of target wxutil
[  3%] Building CXX object libs/wxutil/CMakeFiles/wxutil.dir/ConsoleView.cpp.o
[  3%] Building CXX object libs/wxutil/CMakeFiles/wxutil.dir/dataview/DeclarationTreeView.cpp.o
[  4%] Building CXX object libs/wxutil/CMakeFiles/wxutil.dir/dataview/KeyValueTable.cpp.o
[  4%] Building CXX object libs/wxutil/CMakeFiles/wxutil.dir/dataview/ResourceTreeView.cpp.o
[  4%] Building CXX object libs/wxutil/CMakeFiles/wxutil.dir/dataview/ResourceTreeViewToolbar.cpp.o
[  4%] Building CXX object libs/wxutil/CMakeFiles/wxutil.dir/dataview/ThreadedResourceTreePopulator.cpp.o
[  4%] Building CXX object libs/wxutil/CMakeFiles/wxutil.dir/dataview/TreeModel.cpp.o
[  4%] Building CXX object libs/wxutil/CMakeFiles/wxutil.dir/dataview/TreeModelFilter.cpp.o
[  4%] Building CXX object libs/wxutil/CMakeFiles/wxutil.dir/dataview/TreeView.cpp.o
[  5%] Building CXX object libs/wxutil/CMakeFiles/wxutil.dir/dataview/VFSTreePopulator.cpp.o
[  5%] Building CXX object libs/wxutil/CMakeFiles/wxutil.dir/decl/DeclarationSelectorDialog.cpp.o
[  5%] Building CXX object libs/wxutil/CMakeFiles/wxutil.dir/decl/DeclarationSelector.cpp.o
[  5%] Building CXX object libs/wxutil/CMakeFiles/wxutil.dir/dialog/DialogBase.cpp.o
[  5%] Building CXX object libs/wxutil/CMakeFiles/wxutil.dir/dialog/Dialog.cpp.o
[  5%] Building CXX object libs/wxutil/CMakeFiles/wxutil.dir/dialog/MessageBox.cpp.o
[  5%] Building CXX object libs/wxutil/CMakeFiles/wxutil.dir/fsview/FileSystemView.cpp.o
[  5%] Building CXX object libs/wxutil/CMakeFiles/wxutil.dir/fsview/Populator.cpp.o
[  6%] Building CXX object libs/wxutil/CMakeFiles/wxutil.dir/DirChooser.cpp.o
[  6%] Building CXX object libs/wxutil/CMakeFiles/wxutil.dir/EntityClassChooser.cpp.o
[  6%] Building CXX object libs/wxutil/CMakeFiles/wxutil.dir/FileChooser.cpp.o
[  6%] Building CXX object libs/wxutil/CMakeFiles/wxutil.dir/FreezePointer.cpp.o
[  6%] Building CXX object libs/wxutil/CMakeFiles/wxutil.dir/GLWidget.cpp.o
[  6%] Building CXX object libs/wxutil/CMakeFiles/wxutil.dir/menu/PopupMenu.cpp.o
[  6%] Building CXX object libs/wxutil/CMakeFiles/wxutil.dir/menu/FilterPopupMenu.cpp.o
[  7%] Building CXX object libs/wxutil/CMakeFiles/wxutil.dir/ModalProgressDialog.cpp.o
[  7%] Building CXX object libs/wxutil/CMakeFiles/wxutil.dir/MouseToolHandler.cpp.o
[  7%] Building CXX object libs/wxutil/CMakeFiles/wxutil.dir/PanedPosition.cpp.o
[  7%] Building CXX object libs/wxutil/CMakeFiles/wxutil.dir/PathEntry.cpp.o
[  7%] Building CXX object libs/wxutil/CMakeFiles/wxutil.dir/preview/GuiRenderer.cpp.o
[  7%] Building CXX object libs/wxutil/CMakeFiles/wxutil.dir/preview/GuiView.cpp.o
[  7%] Building CXX object libs/wxutil/CMakeFiles/wxutil.dir/preview/ModelPreview.cpp.o
[  8%] Building CXX object libs/wxutil/CMakeFiles/wxutil.dir/preview/ParticlePreview.cpp.o
[  8%] Building CXX object libs/wxutil/CMakeFiles/wxutil.dir/preview/RenderPreview.cpp.o
[  8%] Building CXX object libs/wxutil/CMakeFiles/wxutil.dir/SerialisableWidgets.cpp.o
[  8%] Building CXX object libs/wxutil/CMakeFiles/wxutil.dir/sourceview/DeclarationSourceView.cpp.o
[  8%] Building CXX object libs/wxutil/CMakeFiles/wxutil.dir/sourceview/DefinitionView.cpp.o
[  8%] Building CXX object libs/wxutil/CMakeFiles/wxutil.dir/sourceview/SourceView.cpp.o
[  8%] Building CXX object libs/wxutil/CMakeFiles/wxutil.dir/Splitter.cpp.o
[  9%] Building CXX object libs/wxutil/CMakeFiles/wxutil.dir/WindowPosition.cpp.o
[  9%] Building CXX object libs/wxutil/CMakeFiles/wxutil.dir/WindowState.cpp.o
[  9%] Building CXX object libs/wxutil/CMakeFiles/wxutil.dir/window/TransientWindow.cpp.o
[  9%] Linking CXX shared library libwxutil.so
[  9%] Built target wxutil
Scanning dependencies of target module
[  9%] Building CXX object libs/module/CMakeFiles/module.dir/ApplicationContextBase.cpp.o
[ 10%] Building CXX object libs/module/CMakeFiles/module.dir/CoreModule.cpp.o
[ 10%] Building CXX object libs/module/CMakeFiles/module.dir/DynamicLibrary.cpp.o
[ 10%] Building CXX object libs/module/CMakeFiles/module.dir/StaticModule.cpp.o
[ 10%] Linking CXX static library libmodule.a
[ 10%] Built target module
Scanning dependencies of target script
[ 10%] Building CXX object plugins/script/CMakeFiles/script.dir/interfaces/BrushInterface.cpp.o
[ 10%] Building CXX object plugins/script/CMakeFiles/script.dir/interfaces/CameraInterface.cpp.o
[ 10%] Building CXX object plugins/script/CMakeFiles/script.dir/interfaces/CommandSystemInterface.cpp.o
[ 10%] Building CXX object plugins/script/CMakeFiles/script.dir/interfaces/DeclarationManagerInterface.cpp.o
[ 10%] Building CXX object plugins/script/CMakeFiles/script.dir/interfaces/DialogInterface.cpp.o
[ 10%] Building CXX object plugins/script/CMakeFiles/script.dir/interfaces/EClassInterface.cpp.o
[ 11%] Building CXX object plugins/script/CMakeFiles/script.dir/interfaces/EntityInterface.cpp.o
[ 11%] Building CXX object plugins/script/CMakeFiles/script.dir/interfaces/FileSystemInterface.cpp.o
[ 11%] Building CXX object plugins/script/CMakeFiles/script.dir/interfaces/FxManagerInterface.cpp.o
[ 11%] Building CXX object plugins/script/CMakeFiles/script.dir/interfaces/GameInterface.cpp.o
[ 11%] Building CXX object plugins/script/CMakeFiles/script.dir/interfaces/GridInterface.cpp.o
[ 11%] Building CXX object plugins/script/CMakeFiles/script.dir/interfaces/LayerInterface.cpp.o
[ 11%] Building CXX object plugins/script/CMakeFiles/script.dir/interfaces/MapInterface.cpp.o
[ 12%] Building CXX object plugins/script/CMakeFiles/script.dir/interfaces/MathInterface.cpp.o
[ 12%] Building CXX object plugins/script/CMakeFiles/script.dir/interfaces/ModelInterface.cpp.o
[ 12%] Building CXX object plugins/script/CMakeFiles/script.dir/interfaces/PatchInterface.cpp.o
[ 12%] Building CXX object plugins/script/CMakeFiles/script.dir/interfaces/RadiantInterface.cpp.o
[ 12%] Building CXX object plugins/script/CMakeFiles/script.dir/interfaces/SceneGraphInterface.cpp.o
[ 12%] Building CXX object plugins/script/CMakeFiles/script.dir/interfaces/SelectionGroupInterface.cpp.o
In file included from /home/chris/DarkRadiant/include/iselectiongroup.h:4,
                 from /home/chris/DarkRadiant/plugins/script/interfaces/SelectionGroupInterface.h:7,
                 from /home/chris/DarkRadiant/plugins/script/interfaces/SelectionGroupInterface.cpp:1:
/home/chris/DarkRadiant/include/iselectable.h: In function ‘void Node_setSelected(const INodePtr&, bool)’:
/home/chris/DarkRadiant/include/iselectable.h:31:37: error: ‘node_cast’ is not a member of ‘scene’
  ISelectablePtr selectable = scene::node_cast<ISelectable>(node);
/home/chris/DarkRadiant/include/iselectable.h:31:58: error: expected primary-expression before ‘>’ token
  ISelectablePtr selectable = scene::node_cast<ISelectable>(node);
/home/chris/DarkRadiant/include/iselectable.h: In function ‘bool Node_isSelected(const INodePtr&)’:
/home/chris/DarkRadiant/include/iselectable.h:41:37: error: ‘node_cast’ is not a member of ‘scene’
  ISelectablePtr selectable = scene::node_cast<ISelectable>(node);
/home/chris/DarkRadiant/include/iselectable.h:41:58: error: expected primary-expression before ‘>’ token
  ISelectablePtr selectable = scene::node_cast<ISelectable>(node);
make[2]: *** [plugins/script/CMakeFiles/script.dir/build.make:297: plugins/script/CMakeFiles/script.dir/interfaces/SelectionGroupInterface.cpp.o] Error 1
make[1]: *** [CMakeFiles/Makefile2:368: plugins/script/CMakeFiles/script.dir/all] Error 2
make: *** [Makefile:130: all] Error 2


Link to comment
Share on other sites

I pushed a fix, I think this should do it.

It's interesting that this compilation problem doesn't arise on the Ubuntu machine that is used to automatically compile the source in Github after every push. I usually get notified when gcc compilation breaks by the build process.

libgit2 is used for the optional VCS plugin, it's not a deal-breaker if it's not present. Nonetheless, I've included the synaptic package on the wiki page.

edit: pushed another VCS build fix. My Debian 10 machine has been using 3-year-old libgit2 headers.

Link to comment
Share on other sites

next attempt:

Scanning dependencies of target vcs
[ 15%] Building CXX object plugins/vcs/CMakeFiles/vcs.dir/GitModule.cpp.o
[ 15%] Building CXX object plugins/vcs/CMakeFiles/vcs.dir/Index.cpp.o
[ 15%] Building CXX object plugins/vcs/CMakeFiles/vcs.dir/Repository.cpp.o
/home/chris/DarkRadiant/plugins/vcs/Repository.cpp: In member function ‘std::__cxx11::string vcs::git::Repository::getUpstreamRemoteName(const vcs::git::Reference&)’:
/home/chris/DarkRadiant/plugins/vcs/Repository.cpp:107:5: error: ‘git_buf_dispose’ was not declared in this scope
/home/chris/DarkRadiant/plugins/vcs/Repository.cpp:107:5: note: suggested alternative: ‘git_buf_set’
/home/chris/DarkRadiant/plugins/vcs/Repository.cpp: In member function ‘void vcs::git::Repository::fastForwardToTrackedRemote()’:
/home/chris/DarkRadiant/plugins/vcs/Repository.cpp:168:70: error: ‘GIT_OBJECT_COMMIT’ was not declared in this scope
     auto error = git_object_lookup(&target, _repository, &targetOid, GIT_OBJECT_COMMIT);
/home/chris/DarkRadiant/plugins/vcs/Repository.cpp:168:70: note: suggested alternative: ‘GIT_OBJ_COMMIT’
     auto error = git_object_lookup(&target, _repository, &targetOid, GIT_OBJECT_COMMIT);
/home/chris/DarkRadiant/plugins/vcs/Repository.cpp: In member function ‘void vcs::git::Repository::abortMerge()’:
/home/chris/DarkRadiant/plugins/vcs/Repository.cpp:428:65: error: ‘GIT_OBJECT_COMMIT’ was not declared in this scope
     error = git_object_lookup(&target, _repository, &targetOid, GIT_OBJECT_COMMIT);
/home/chris/DarkRadiant/plugins/vcs/Repository.cpp:428:65: note: suggested alternative: ‘GIT_OBJ_COMMIT’
     error = git_object_lookup(&target, _repository, &targetOid, GIT_OBJECT_COMMIT);
make[2]: *** [plugins/vcs/CMakeFiles/vcs.dir/build.make:89: plugins/vcs/CMakeFiles/vcs.dir/Repository.cpp.o] Error 1
make[1]: *** [CMakeFiles/Makefile2:484: plugins/vcs/CMakeFiles/vcs.dir/all] Error 2
make: *** [Makefile:130: all] Error 2


what is the difference between

git clone git://


git clone https://

do both involve the extra    --recurse-submodules


do i need an update of git itself perhaps

git version 2.20.1

Edited by CrisiusXIII
Link to comment
Share on other sites

These are problems in the source code and/or libraries used during building (e.g. libgit-dev). They have nothing to do with the Git version or command you used to check out the DarkRadiant git repository itself. Git is used internally to build the version control functionality inside DarkRadiant, and it is this version control plugin which is failing to build.

Link to comment
Share on other sites

deb10 give




its git2 !!

(edit: that confusing since yesterday that was solved!!)

further atleast 2 dozen variations on  gitdev + some prg combination

I wonder if i should reinstall git as that git-desktop which seems the only one offered by them

Edited by CrisiusXIII
Link to comment
Share on other sites

The Debian 10 package of libgit2 is 3 years old and the libgit2-Team introduced a lot of new functions since then, deprecating old ones, that's why it fails so hard. I've been trying to get it to compile, maybe it's just a few preprocessor #IFs.

I also spotted a couple of other compilation problems in Debian 10, which are mostly due to missing #includes, I intend to sort that out.

Link to comment
Share on other sites

hi, make is at 31%  thank you

this might take another 20 minutes and then the install it self

tomorrow we know for sure and it feels good.

i have a simple start idear with just a single room. maybe a type off escape room. talking waybefore i have everdone some, i would like to take a eye with red or green ligth and turn it in a laser detection on the floor. i guess its reducing the surface off the ligth into a very small spot , then you have to use a gas arrow to enlight that laser with smoke reflexion.

but i realy never done anything like 3d at all. even blender complains about me that i start but never finish anything.

46% and counting


Link to comment
Share on other sites





its a single step lacking for the make routine


[ 98%] Building CXX object radiant/CMakeFiles/darkradiant.dir/xyview/tools/MeasurementTool.cpp.o
[ 98%] Building CXX object radiant/CMakeFiles/darkradiant.dir/xyview/XYWnd.cpp.o
[ 99%] Linking CXX executable darkradiant
/usr/bin/ld: //usr/local/lib/x86_64-linux-gnu/libgio-2.0.so.0: undefined reference to `g_utf8_validate_len'
/usr/bin/ld: //usr/local/lib/x86_64-linux-gnu/libgio-2.0.so.0: undefined reference to `g_source_set_dispose_function'
/usr/bin/ld: //usr/local/lib/x86_64-linux-gnu/libgio-2.0.so.0: undefined reference to `g_unix_get_passwd_entry'
collect2: error: ld returned 1 exit status
make[2]: *** [radiant/CMakeFiles/darkradiant.dir/build.make:2669: radiant/darkradiant] Error 1
make[1]: *** [CMakeFiles/Makefile2:1008: radiant/CMakeFiles/darkradiant.dir/all] Error 2
make: *** [Makefile:130: all] Error 2


but you  DEVeNIGHTly  solved the -dev problems

Link to comment
Share on other sites

Not sure I can do anything about the linker problems, that's something that seems related to the deb packages. Do you have the libwxgtku3.0-devel packages installed correctly? It links fine on my Deb10 machine.

Link to comment
Share on other sites

hi my deb10 has no libwxgtku3.0 at all

its libwxgtk3.0-dev with out the   U

are you sure its a debian file and not an ubuntu file?

I should upgrade deb10 to deb12 anyway, since deb10 is not he strongest version off debian afa understood.

the strength off linux is the same as its weakness, its the enormous amount off variations and possibilities... its a chuwinggum stretched in impossible forms.

meanwhile ubuntu is based on debian BUT by now debian is hanging on the back off that same ubuntu , that makes it more difficult

Link to comment
Share on other sites

12 minutes ago, datiswous said:

You could also use the Flatpak version instead.

i can try, i am not used to it. thanks for the reminder


edit, result until now


 flatpak install --user flathub net.darkradiant.DarkRadiant

Note that the directories


are not in the search path set by the XDG_DATA_DIRS environment variable, so
applications installed by Flatpak may not appear on your desktop until the
session is restarted.

Looking for matches…
error: No remote refs found similar to ‘flathub’

apperently i have to do much more

and even VERY OFF TOPIC by now


sudo add-apt-repository ppa:alexlarsson/flatpak.
[sudo] password for chris:
Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/softwareproperties/ppa.py", line 102, in _get_https_content_py3
    lp_page = urllib.request.urlopen(request, cafile=LAUNCHPAD_PPA_CERT)
  File "/usr/lib/python3.7/urllib/request.py", line 222, in urlopen
    return opener.open(url, data, timeout)
  File "/usr/lib/python3.7/urllib/request.py", line 531, in open
    response = meth(req, response)
  File "/usr/lib/python3.7/urllib/request.py", line 641, in http_response
    'http', request, response, code, msg, hdrs)
  File "/usr/lib/python3.7/urllib/request.py", line 569, in error
    return self._call_chain(*args)
  File "/usr/lib/python3.7/urllib/request.py", line 503, in _call_chain
    result = func(*args)
  File "/usr/lib/python3.7/urllib/request.py", line 649, in http_error_default
    raise HTTPError(req.full_url, code, msg, hdrs, fp)
urllib.error.HTTPError: HTTP Error 404: Not Found

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/softwareproperties/ppa.py", line 327, in get_ppa_info
    ret = get_ppa_info_from_lp(user, ppa)
  File "/usr/lib/python3/dist-packages/softwareproperties/ppa.py", line 92, in get_ppa_info_from_lp
    return get_info_from_lp(lp_url)
  File "/usr/lib/python3/dist-packages/softwareproperties/ppa.py", line 88, in get_info_from_lp
    return _get_https_content_py3(lp_url)
  File "/usr/lib/python3/dist-packages/softwareproperties/ppa.py", line 108, in _get_https_content_py3
    raise PPAException("Error reading %s: %s" % (lp_url, reason), e)
softwareproperties.ppa.PPAException: 'Error reading https://launchpad.net/api/1.0/~alexlarsson/+archive/ubuntu/flatpak.: Not Found'

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/softwareproperties/ppa.py", line 393, in shortcut_handler
    return PPAShortcutHandler(shortcut)
  File "/usr/lib/python3/dist-packages/softwareproperties/ppa.py", line 356, in __init__
    info = get_ppa_info(self.shortcut)
  File "/usr/lib/python3/dist-packages/softwareproperties/ppa.py", line 339, in get_ppa_info
    _get_suggested_ppa_message(user, ppa))
softwareproperties.shortcuts.ShortcutException: Cannot add PPA: 'ppa:~alexlarsson/ubuntu/flatpak.'.
The user named '~alexlarsson' has no PPA named 'ubuntu/flatpak.'
Please choose from the following available PPAs:
 * 'flatpak':  Flatpak
 * 'glib260':  Glib 2.60
Error: 'ppa:alexlarsson/flatpak.' invalid





at least TDM itself works fine !!

Edited by CrisiusXIII
Link to comment
Share on other sites

41 minutes ago, CrisiusXIII said:

sudo add-apt-repository ppa:alexlarsson/flatpak

Is this to install Flatpak?

To install Flatpak follow this guide:


See also: https://wiki.thedarkmod.com/index.php?title=DarkRadiant_-_Flatpak_Installation_Guide

Sorry if this is redundent info. I wasn't sure if you do it right.


Sorry for derailing the topic.

  • Like 1
Link to comment
Share on other sites

2 hours ago, CrisiusXIII said:

hi my deb10 has no libwxgtku3.0 at all

its libwxgtk3.0-dev with out the   U

are you sure its a debian file and not an ubuntu file?

Sorry, I meant that package: libwxgtk3.0-dev

There's usually only one wxgtk dev package in every package manager, so yes, that's the correct one. It should work fine though, so I can't tell you exactly why it's not linking. Maybe make clean and a full rebuild helps. I could recompile just fine in my Debian 10 machine, with all the aptitude stuff upgraded to the latest version (though I remember having to set the --allow-releaseinfo-change option when using apt-get update)

Upgrading is probably a wise choice, but that's up to you.

  • Like 1
Link to comment
Share on other sites

  • 3 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recent Status Updates

    • peter_spy

      Perhaps an unpopular opinion: TDM team might benefit from someone with actual QA experience; someone with naturally and professionally developed curiosity, who is interested in how and why things work, how they break At least to me it's kind of mind-boggling how untested some rather important features are (first the absence alert feature for items, now the rope +body carry behavior).
      · 4 replies
    • nbohr1more

      The Dark Mod is hosting an Ask Me Anything thread on the PC Gaming reddit forum:  https://www.reddit.com/r/pcgaming/comments/10nfcwj/hello_we_are_the_international_development_team/
      Feel free to join the discussion there
      · 2 replies
    • stgatilov

      Bumped into an interesting piece of wisdom called Hyrum's Law:
      With a sufficient number of users of an API, it does not matter what you promise in the contract: all observable behaviors of your system will be depended on by somebody.
      · 5 replies
    • The Black Arrow

      I love playing The Dark Mod when it's cold in my place. Bonus points when it's a bit (or even very) dark and it's raining, too.
      · 2 replies
    • The Black Arrow

      I've been having stutters in Vulkan, apparently it's Nvidia Drivers' fault, so I reverted to 512 according to this: https://www.nvidia.com/en-us/geforce/forums/geforce-graphics-cards/5/505679/regular-microstutter-in-vulkan-applications-after-/?topicPage=40

      And no, that did NOT fix it. What's going on? My GPU is an RTX 2070, by the way.
      · 4 replies
  • Create New...