Jump to content
The Dark Mod Forums
Sign in to follow this  
devilofneurosis

Strange stuttering after about 5-10 minutes of playing.

Recommended Posts

Hi Guys, hoping someone can help with this.

I have a strange issue where the game starts stuttering after a few minutes of play (Currently noticed on the 2nd included mission Tears of St. Lucia). Its starts out fine, and extremely smooth, but then a micro stutter appears and gets progressively worse until it is completely unplayable. After a restart, its perfectly fine again for 5 minutes or so, then it starts again. I have tried with Vsync on and off (both through the game menu and through the nvidia control panel. With and with out capped fps (I would rather not cap to 60hz if I can help it as my monitors refresh is 144hz). I have an RTX 2080, I7 6700k and 16gb of ram so raw power is certainly not the issue.

 

Thanks in advance for your help!

Share this post


Link to post
Share on other sites

Yes, I experience the same micro stuttering. Actually, I played so many mission with it, I got used to it. Until I came across this article on how to fix micro stuttering in the doom 3 engine:
https://pcgamingwiki.com/wiki/Doom_3#Micro_stuttering

I opened Darkmod.cfg with a text editor and used these two settings as explained in that article:

seta r_swapInterval "1"
seta com_fixedTic "1"

And the game runs really smooth. That seems to fix the problem. I've only just found out, so I don't know if it creates any other glitches.

Share this post


Link to post
Share on other sites

After these changes, I don't see any glitches. The smooth frame rate as a result makes the game a much more immersive and enjoyable experience for me. Can other people try these settings too and see if it makes any difference for them?

If I understand this article correctly, all games using the doom 3 engine are affected by micro stutters, but not everyone notices them:
https://steamcommunity.com/sharedfiles/filedetails/?id=891278647

If that's true and there's no downside to it, can these settings be made standard in TDM for a default smooth frame rate for everyone?

Share this post


Link to post
Share on other sites

It might have been common knowledge that D3 engine was not VSync friendly.

The TDM community consensus was have VSync off for this or other reasons.

Since 2.06 however players have more options

  1. vsync off, capped fps, old school gameplay with screen tearing
  2. vsync on, capped fps, risk of microstuttering
  3. vsync on, uncapped fps, (the new recommendation)
  4. vsync off, uncapped fps, Q3 style

Share this post


Link to post
Share on other sites

Recently we fixed  issue 4514 about random sluggishness with default settings.

There is some hope that the problem will not appear any more in 2.08.

Share this post


Link to post
Share on other sites
8 minutes ago, stgatilov said:

Recently we fixed  issue 4514 about random sluggishness with default settings.

There is some hope that the problem will not appear any more in 2.08.

Thank you! I hope that fixes the issue.

In my case, the stuttering is definitely caused by the capped FPS. Vsync has no effect on the stuttering. Also, with com_showfps I see the same 50+ FPS with both capped and uncapped, so the stuttering is not reflected in the in-game FPS counter. As if there's no performance difference, only visual stuttering. I'll play uncapped, that fixes everything for me. I'll let you know if this problem is gone in capped once I can try 2.08.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...