Jump to content


Photo

Destined's Animations


37 replies to this topic

#26 Arcturus

Arcturus

    Advanced Member

  • Development Role
  • PipPipPip
  • 1577 posts

Posted 21 September 2016 - 11:12 AM

Do you have "Reorient" enabled during export?

As for floating, NPCs are using inverse kinematics to determine where to put feet on. This potentially could cause problems. There is an md5 viewer. You could use it to check on exported animations.


It's only a model... /// My channel on YouTube /// CGtrader , Turbosquid


#27 Destined

Destined

    Advanced Member

  • Member
  • PipPipPip
  • 1191 posts

Posted 21 September 2016 - 11:34 AM

Yep, "Reorient" was on. I will export and try again.

I will also check the md5 viewer.

 

Thanks a lot!


Edited by Destined, 21 September 2016 - 11:34 AM.

  • Anderson likes this

#28 Destined

Destined

    Advanced Member

  • Member
  • PipPipPip
  • 1191 posts

Posted 21 September 2016 - 11:48 AM

Ok, this is strange: the md5 viewer displays the animations correctly, it is only in-game that the erratic behaviour appears. Can I do anything against the inverse kinematics, if they are at fault here?


  • Anderson likes this

#29 Arcturus

Arcturus

    Advanced Member

  • Development Role
  • PipPipPip
  • 1577 posts

Posted 23 September 2016 - 12:43 AM

You could try removing IK from def file and see what it does. I don't know if it's possible to disable IK per animation.


It's only a model... /// My channel on YouTube /// CGtrader , Turbosquid


#30 Destined

Destined

    Advanced Member

  • Member
  • PipPipPip
  • 1191 posts

Posted 23 September 2016 - 01:42 AM

According to the "Frame Commands" Wiki entry, it should be able to turn off the walkIK off, per animation. However, when I add the command to the def file and try to load the test map the following error occurs:

"Joint 'Hips' not found for attachment position 'hip_sheath_l' on entity 'atdm_ai_proguard_1' " This error does not occur with the "disableWalkIK" missing...

 

This is how the def of the animaiton looks:

        anim climb_ladder_8step                   models/md5/chars/guards/proguard/proguard_climb_ladder_8step.md5anim
{
disableWalkIK
}


  • Anderson likes this

#31 Sotha

Sotha

    Vertical Contest Winner

  • Active Developer
  • PipPipPipPipPip
  • 5557 posts

Posted 23 September 2016 - 06:48 AM

Should it be
frame 1 DisableWalkIK
?

If it is a frame command, it needs the frame section.
Clipper
-The mapper's best friend.

#32 Destined

Destined

    Advanced Member

  • Member
  • PipPipPip
  • 1191 posts

Posted 23 September 2016 - 07:40 AM

You are right. If I had been more observant, I would have seen, the difference between global commands and frame commands in the example :-/

Hm, I hope I don't have to use this command for every frame (for this animation it would be 165). I will just have to try when I get home today. Thanks a lot!


  • Anderson likes this

#33 Sotha

Sotha

    Vertical Contest Winner

  • Active Developer
  • PipPipPipPipPip
  • 5557 posts

Posted 23 September 2016 - 08:42 AM

I am now sure it works. For example, here is my praying animation, which is tough for the AI legs. It could not work with IK on. Here is the def:

anim pray					models/md5/chars/guards/proguard/pray.md5anim
{
prevent_idle_override
frame 1         disableWalkIK	
frame 1                 call overrideLegs	    
}	

For climbing animation you probably must also prevent_idle_override so that the AI does not look around.

For the praying, I've disabled walk IK via frame command. Also "call overrideLegs" was used. I am not sure why it put that there, but it was necessary for the praying anim to look ingame the same as in blender.

 

Best of luck!


Clipper
-The mapper's best friend.

#34 Destined

Destined

    Advanced Member

  • Member
  • PipPipPip
  • 1191 posts

Posted 23 September 2016 - 10:46 AM

Disabling IK did the trick. And I really just missed the "frame 1". Thank you very much Arcturus and Sotha! Now the animation plays as intended in game :) . However, I still have the problem, that the animation brings the AI to a new location, but when the animation is over, the AI snaps back to the original location. Do you know how I can circumvent that? This is the final missing piece to get an AI climbing a ladder.


  • Anderson likes this

#35 Sotha

Sotha

    Vertical Contest Winner

  • Active Developer
  • PipPipPipPipPip
  • 5557 posts

Posted 23 September 2016 - 10:53 AM

Does the AI origin move? If the AI moves, the origin should stay with them. Otherwise the AI will be centered back on origin after the animation finishes playing.
Clipper
-The mapper's best friend.

#36 Arcturus

Arcturus

    Advanced Member

  • Development Role
  • PipPipPip
  • 1577 posts

Posted 23 September 2016 - 10:56 AM

I was about to write the same thing. Origin bone has to move.


It's only a model... /// My channel on YouTube /// CGtrader , Turbosquid


#37 Destined

Destined

    Advanced Member

  • Member
  • PipPipPip
  • 1191 posts

Posted 23 September 2016 - 01:09 PM

Ah, yes that is the problem. I should have noticed that, when I compared to the walk animation. Will correct that. Thanks!



#38 Destined

Destined

    Advanced Member

  • Member
  • PipPipPip
  • 1191 posts

Posted 23 September 2016 - 02:15 PM

Drat, I have not used the origin, while doing the animation. Thus, the whole animation is wrong. If I move the origin, I move the rest relative to the origin. Consequently, I have to remove all movement of the complete body... So I know what I will do for the next couple of hours in blender...





Reply to this topic



  


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users