Jump to content
The Dark Mod Forums

Graphic error


Recommended Posts

Hello,

 

since I bought a video card capable of running Doom 3 recently(Radeon 6850) I wanted to try this mod.

Doom 3 is running fine, but I have a severe error when playing the mod.

 

When changing the screen resolution, it certainly does change more than the graphic detail.

 

This is a screen in 1600*1200 resolution:

 

http://www.abload.de...23-10-bjy9v.png

 

Everything looks really trippy and when I press the forward key, I move diagonally forward.

 

This is a screen in 1024*768 resolution:

 

http://www.abload.de...23-12-b8ad2.png

 

Now it looks better and when I press forward I actually walk forward- but it does not quite look like the preview on the loading screen and something still feels weird about this.

 

Anybody got an idea what´s going on there? I read smth about the CCC causing trouble but I´m not sure if this is it?

 

Thanks

Edited by Nox
Link to post
Share on other sites

Try to disable it, it solves many problems, you´ll definitely need this for sky looking properly, maybe it will also help with your problem.

He was sneeking silently in the night, moonlight was his enemy.

(Im not a native speaker, sorry for all miscleanous caused by my english..)

Link to post
Share on other sites

What kind of moinitor do you have, LCD? Also, do you have the newest drivers?

"The reasonable man adapts himself to the world; the unreasonable one persists in trying to adapt the world to himself. Therefore, all progress depends on the unreasonable man." -- George Bernard Shaw (1856 - 1950)

 

"Remember: If the game lets you do it, it's not cheating." -- Xarax

Link to post
Share on other sites

Unfortunately disabling Catalyst AI on ATI hardware newer than the HD 4xxx series is not an easy task. Though the problems described here might be exascerbated by the FOV and ratio chosen. Correcting those settings and disabling the Post Process should clear this up. There is a thread about the many ways folks have disabled Catalyst AI so I would scan that too. Finaly, one of the ways you can disable Catalyst Ai is to rename the Doom3 executable so the profiler doesnt know what profile to use. Did Baddcog verify that this works with v1.08 (it worked in the past except missions wouldn't stay installed without a lot of cumbersome workarounds)?

Please visit TDM's IndieDB site and help promote the mod:

 

http://www.indiedb.com/mods/the-dark-mod

 

(Yeah, shameless promotion... but traffic is traffic folks...)

Link to post
Share on other sites

No, I was going to try the new TheDarkMod.exe , but I'm not working out of SVN, no HD space (also makes it harder to tweak files and only upload what I work on). And it wasn't working in 1.07 for me.

 

I rolled back to Catalyst control 10.8 which is the latest one that allows to to turn Cat AI off completely. Turning it down still gives the inverted/moving sky. Turning off post processing makes it so you don't end up upside down (if running cat ai).

Dark is the sway that mows like a harvest

Link to post
Share on other sites

Here is the Disabling Catalyst AI discussion so you may look at the various proposed workarounds, Nox:

 

http://forums.thedarkmod.com/topic/12398-disabling-catalyst-ai/

Please visit TDM's IndieDB site and help promote the mod:

 

http://www.indiedb.com/mods/the-dark-mod

 

(Yeah, shameless promotion... but traffic is traffic folks...)

Link to post
Share on other sites

10.11 still allows you to turn it off, but after watching 10.11 butcher Deus Ex, I reverted to 10.10 which also allows you to turn of Cat AI. Pretty sure only 11.xx onwards prevents you turning it off directly, and people worked around that by disabling (I beleive it was) Surface Format Optimisation

Intel Sandy Bridge i7 2600K @ 3.4ghz stock clocks
8gb Kingston 1600mhz CL8 XMP RAM stock frequency
Sapphire Radeon HD7870 2GB FLeX GHz Edition @ stock @ 1920x1080

Link to post
Share on other sites

Yeah pretty much everything is caused by the whole 'Surface Format Optimisation' setting, since it flips cubemaps and loses rotation on RTT. Hence why the sky moves in the wrong direction and the screen is painted upside down.

 

The problem is that sometimes the setting is triggered by a profile, and other times it's the setting. If you're lucky just disabling the setting will be fine (it also makes things look a bit better).

 

This miiight be fixed in 1.08, just having trouble finding a way to test it on my boxes, without quick testing it's hard to fix it in the most correct way. I have a tester lined up to test nearer release, so don't need offers or anything — just letting you know why it's hard to provide a Yes/No.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...