Jump to content

TDM Standalone 2.0 Black or Invisible Menu


Recommended Posts

Rather than necro couple year old thread I figured I should just make a new post in case others had the same issue I was and couldn't find an answer. I had the issue a couple months ago when I got Doom3 to try it and decided to give up figuring it was something with Steam version etc.


Trying the Stand Alone 2.0 I had the same issue. I was able to launch the game and change game settings (which were muddied) but after I chose to restart the game the screen would be black and could hear the flicking over menu options with the mouse. In order to see the game again I had to delete darkmod.cfg (and run tdm_update.exe to replace it). After looking through old posts (and trying one? FAQ) I couldn't find the answer but did figure out through trial and error that Anti-aliasing was the issue. I have an AMD 5850 and in the Control Center>Gaming>3D Applicating Settings I found that under Anti-aliasing the Filter "EDGE DETECT" was the issue. I could set it to Wide Tent or Box and leave all the other settings alone and The Dark Mod would work. Hopefully if you have the issue you can find something similar in your cards settings. Also for me at least aliasing is limited to x8 in game so just set it to that instead of x16 just in case.


The other little issue I had was the training mission not downloading and Tears of St. Lucia not loading after a save. However trying to download training mission and restarting did clear up the muddied menu settings. Anyway found out I had to rename and move the folder which I had so far left where it downloaded. So moving it to C:\games and renaming it simply "darkmod" (and probably running tdm_update.exe which was down the previous day) solved those issues. I don't appear to have any other issues so thanks to the folks who made this! hoping to dive in asap!

  • Like 1
Link to comment
Share on other sites

I have this issue, the screen goes black after the initial briefing for missions. I haven't been able to pay anything except for the training mission. I use an Nvidia card, there is no options relating to "edge detection".. I guess I could use the work-around of deleting the .cfg every time, but it'd be a giant hassle to rebind all my keys and change settings again.


I'm open to any other suggestions, if anyone has any.

Link to comment
Share on other sites

Checked Nvidia control panel, nothing looks forced, things are left up to applications.  The updater was crashing instantly so I tried a fresh copy of the game, updated, same problem in the game even with default in-game settings.


I can get one or two 1 frame flashes on the pre-mission screen, then just black.  If I can find any solutions on my own by messing with things, I'll post it.Found the problem (sort of).  Alberic's Curse mission was causing the problem.  Other missions work fine, but the pre-mission menu for that one mission causes a black screen.  No idea why, I'll try uninstalling it  and re-downloading it.

Edited by hangphyr
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recent Status Updates

    • nbohr1more

      Anyone have any luck with light.setShader( string ) ? It seems to make whichever light you apply it to full-bright on the initial invoke?
      · 0 replies
    • thebigh

      I'm starting to think we need another mapping contest.
      · 9 replies
    • kano

      Don't you hate it when there's a quality discussion on a forum somewhere online about something, but then two disagreeing users derail and transform it into a back-and-forth poo slinging competition at one another?
      · 9 replies
    • Diego

      Oh look the status updates are back! 
      · 2 replies
    • JackFarmer

      After watching the first three and a half episodes of "The Sandman" last night, I realize once again that overly imaginative narratives are not for me. Also, the main actor looks like he has a toothache.
      Which makes me wonder, is there a Dark Mod mission with a medieval dentist?
      · 4 replies
  • Create New...