Jump to content
The Dark Mod Forums

2.08: Unable to frob/pick up items, Game or FM issue, not sure


Recommended Posts

I finally had some time to get back into TDM, but encountered a bizarre issue in that I'm no longer able to pick up (frob) items. I can still open doors, toggle switches, but the items just never light up for me to pick up 🤨

Specifically, the first mission I tried was "Shadows of Northdale ACT I", and after entering the shop I couldn't actually pick up anything to buy. Then went back to the home, behind the painting are several item that also cannot be picked up. See the attached screenshot from the save game.

It might be a real noob issue, it's been a while since I last tried TDM, but played it a lot some years ago.

Maybe it's a FM-specific issue, so I tried also "Dragon's Claw" but not sure if I've encountered any items I should be able to pick up yet. I'm trying to think of an old FM where there's some items at the very start I could test with.

I use a custom controller config through XPadder, so my first idea was that it was broken, but the same happens using just RMB for frob. 
I run Windows 10 at 150% scaling, and some older games have problems with this, so I disabled scaling for the TDM exe, but no help.
I also have a triple-monitor setup (TV, two regular screens), but that's never caused an issue in TDM before. I'm running TDM at 1920x1080 on the TV.

I run "TheDarkModx64.exe" but I also tried the regular "TheDarkMod.exe".

One thing I've not tried is a complete reinstall of TDM, I might try that later as well.

Other possibly relevant information:
OS Name    Microsoft Windows 10 Pro (version 20H2)
Version    10.0.19042 Build 19042
Processor    Intel(R) Core(TM) i7-4790K CPU @ 4.00GHz, 4001 Mhz, 4 Core(s), 8 Logical Processor(s)
Installed Physical Memory (RAM)    16,0 GB
Adapter Type    GeForce GTX 970, NVIDIA compatible

TDM is installed at "f:\Games\Darkmod"

Any ideas?
I just hope I'm not being a total noob here... 😅


Link to comment
Share on other sites

Hmm, what are you using for your lean forward key? Can you still press "F" to lean forward?

Did you enable the frob helper in the gameplay settings menu and center the helper dot on the objects?

Did you try closing and opening this compartment again?

  • Thanks 1

Please visit TDM's IndieDB site and help promote the mod:




(Yeah, shameless promotion... but traffic is traffic folks...)

Link to comment
Share on other sites

If would recommend trying to rename darkmod.cfg to darkmod_old.cfg, i.e. do "config reset".
It will drop all your settings (keybindings are stored separately). If that would help, then something is wrong with your config. If not, then you can rename file back.

At least it should be tried before clean reinstall.

  • Thanks 1
Link to comment
Share on other sites

Thanks for the replies guys, appreciated 👍

Renaming the CFG was a good idea for doing a quick test - and it's back to working! 😄 🎆

Since it's apparently some setting, I'm curious which one it might have been, or maybe a combination of settings (I hope not). I'll have a look and test the most obvious looking ones.


EDIT: Apparently it was this line in the CFG:

seta tdm_frob_distance_default "0"

Default is 63. I have no idea how that setting could have been changed, maybe it happened on update?

Edited by Shadrach
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...