Jump to content
The Dark Mod Forums

[DR 1.5] Multi-Monitor


Recommended Posts

I recently got a new lcd screen. Now I am working on the new one (1920x1080) and the old one (1024x768) together in enhanced desktop mode. I find this useful for many applications, but as I tried to start my Dark Radiant 1.5 today, it doesn't work anymore.

 

When Dark Radiant has loaded, I can navigate through the menus, but there's a glitch in the four windows as there is no grid, nor rendered preview. And everything that was once above of one of the 4 views, it stays there forever.

 

I didn't had the glitch before (as I were using just one monitor). As I put off my old monitor, so that only the new one was used, it worked fine again (after restarting my pc of course).

 

I did alter the multi monitor setting in the preferences, but no matter which monitor I use for this application, as long as there's another monitor plugged in, the 4 view windows woun't work. I also deactivated the "advanced desktop visual effects" in windows for Dark Radiant, but it woun't help either.

 

My OS: Windows XP

Graphics card: ATI Radeon HD 5770 (newest drivers)

 

I hope someone else did work with two monitors in Dark Radiant, as I really need help on this for completing my Fan Mission :(

 

Thanks alot guys!!

post-3542-130184332645_thumb.jpg

"Einen giftigen Trank aus Kräutern und Wurzeln für die närrischen Städter wollen wir brauen." - Text aus einem verlassenen Heidenlager

Link to post
Share on other sites

Try creating a 2 monitor Eyefinity displaygroup and then loading it.

Intel Sandy Bridge i7 2600K @ 3.4ghz stock clocks
8gb Kingston 1600mhz CL8 XMP RAM stock frequency
Sapphire Radeon HD7870 2GB FLeX GHz Edition @ stock @ 1920x1080

Link to post
Share on other sites

I recently got a new lcd screen. Now I am working on the new one (1920x1080) and the old one (1024x768) together in enhanced desktop mode. I find this useful for many applications, but as I tried to start my Dark Radiant 1.5 today, it doesn't work anymore.

 

When Dark Radiant has loaded, I can navigate through the menus, but there's a glitch in the four windows as there is no grid, nor rendered preview. And everything that was once above of one of the 4 views, it stays there forever.

 

I didn't had the glitch before (as I were using just one monitor). As I put off my old monitor, so that only the new one was used, it worked fine again (after restarting my pc of course).

 

I did alter the multi monitor setting in the preferences, but no matter which monitor I use for this application, as long as there's another monitor plugged in, the 4 view windows woun't work. I also deactivated the "advanced desktop visual effects" in windows for Dark Radiant, but it woun't help either.

 

My OS: Windows XP

Graphics card: ATI Radeon HD 5770 (newest drivers)

 

I hope someone else did work with two monitors in Dark Radiant, as I really need help on this for completing my Fan Mission :(

 

Thanks alot guys!!

 

I think the ability to turn off desktop composition is broken in 1.5, so you have to disable it in windows itself.

 

Control panel / system / advanced tab / performance settings.

 

Make sure desktop composition is unchecked.

Link to post
Share on other sites

Desktop composition = windows aero? My DR 1.05 turns that off. If not, then I'm probably not thinking of the right thing.

Intel Sandy Bridge i7 2600K @ 3.4ghz stock clocks
8gb Kingston 1600mhz CL8 XMP RAM stock frequency
Sapphire Radeon HD7870 2GB FLeX GHz Edition @ stock @ 1920x1080

Link to post
Share on other sites

I'm using the x86 build, so that should help narrow it down.

Intel Sandy Bridge i7 2600K @ 3.4ghz stock clocks
8gb Kingston 1600mhz CL8 XMP RAM stock frequency
Sapphire Radeon HD7870 2GB FLeX GHz Edition @ stock @ 1920x1080

Link to post
Share on other sites

hmm, I am, but I dont have this issue. But I am using an nVidia gfx card. Of the top of my head, setup a 3d profile for Darkradiant and make sure that catalyst Ai is turned of.

 

I uninstalled my ATI-drivers and uninstalled the Catalyst Control Center. Then I reinstalled my ATI drivers (without CCC). Then I installed "Radeon Pro" with that I created a profile for dark radiant.exe in which I disabled everything ATI-related including "AI".

Doesn't solve it.

 

 

Try creating a 2 monitor Eyefinity displaygroup and then loading it.

Don't I need CCC again for that??

 

 

I think the ability to turn off desktop composition is broken in 1.5, so you have to disable it in windows itself.

 

Control panel / system / advanced tab / performance settings.

 

Make sure desktop composition is unchecked.

 

Didn't work either, its not related to the enhanced desktop look (since its XP and I only encountered this problem in Vista).

 

I did try another way after searching and trial & error tactics:

I opened my desktop properties - clicked on settings tab - advanced settings - problem solving. There I changed the hardware acceleration to "disable Direct Draw, Direct 3d, cursor- and drawing acceleration. use this if you encounter problems with direct x applications"

(see the screen, if you don't know what I mean. Sorry it's german, but as the window layout is still the same, you might can imagine).

This lead me to finally see the 4 views in DR again - only problem now is, that camera movement is juttering very ugly and when I load my level with many entities and brushes, the editor crashes right away.

 

I'm so desperate about that :(

I cannot crawl behind my desk and restart everything after plugin'-in /-out my monitor everytime for the rest of my life :-/

 

Someone's got any ideas or suggestions? Phaww.... darn...

post-3542-130194619092_thumb.jpg

"Einen giftigen Trank aus Kräutern und Wurzeln für die närrischen Städter wollen wir brauen." - Text aus einem verlassenen Heidenlager

Link to post
Share on other sites
  • 2 weeks later...

Anybody out there? No one talks to me: This isn't a good sign, is it?

 

I installed the newest ATI drivers without any Catalyst Control shit - just the Display Drivers! Still it won't work.

I don't know it is an ATI related problem or a Dark Radiant one, but I wanted to try a last time, to get some help, though all signs point to no one knows .. :(

"Einen giftigen Trank aus Kräutern und Wurzeln für die närrischen Städter wollen wir brauen." - Text aus einem verlassenen Heidenlager

Link to post
Share on other sites

To make a displaygroup IIRC you will need to install CCC, I don't know if there is a way to do it without, unless something like RadeonPro can do it for you

Intel Sandy Bridge i7 2600K @ 3.4ghz stock clocks
8gb Kingston 1600mhz CL8 XMP RAM stock frequency
Sapphire Radeon HD7870 2GB FLeX GHz Edition @ stock @ 1920x1080

Link to post
Share on other sites

Didn't notice that 1.6 is already out - thanks for the hint!

 

I don't know if I tried this already in 1.5 - may the solution lied in 1.6, I am not sure, but here's the solution that may be for interest for bug fixing:

 

I solved the problem by

opening DR 1.6

change from full screen to windowed mode

close DR 1.6

open DR 1.6 again

 

--

It seems that DR can't handle the two screens when started in full screen mode. I don't use Catalyst Control Centre, I just use the Windows XP 2 monitor settings provided. So this is a DR-related bug in my opinion, which may can be hunted down now.

 

I look forward to your responses on this (but foremost I am so glad and very happy, that I can map again)!

Edited by SeriousToni

"Einen giftigen Trank aus Kräutern und Wurzeln für die närrischen Städter wollen wir brauen." - Text aus einem verlassenen Heidenlager

Link to post
Share on other sites

Ive been running DR on my HD5870 since version 1.3.2, and on dual screens since 1.4. I have been using Win7 since 1.4 so I have to conclude that your problem is windows Xp related or something else running in the background as now else has reported this issue.

 

Something else to try, is to update your version of DirectX. Alsio what antivirusa program do you have installed, have you tried disabling that and see what happens? Also do you have UltraMon or anything like it installed..?

Link to post
Share on other sites

Odd. I plugged in secondary monitor, and I just got this bug, too.

 

Strangest thing: I fixed the problem by swapping which windows get put on which monitor. Preview render camera from right now goes on left. Orthoviews from left monitor now go on right. And now they render properly. :wacko:

yay seuss crease touss dome in ouss nose tair

Link to post
Share on other sites

Odd. I plugged in secondary monitor, and I just got this bug, too.

 

Mortem Desino, thank you very much for testing this too! Now we see that I am not the only one with this bug.

 

hmmm ok, thats good to know its not just Toni then.

 

Ok can both of you set up your desktop and DR the same as mine to see if you have the problem then.. I will attach a screenshot..

 

DR is totally fucked up (windows float everywhere over the screen) when I go to full screen mode and change the window settings, it even crashed when I chose the last window setting in line.

Edited by SeriousToni

"Einen giftigen Trank aus Kräutern und Wurzeln für die närrischen Städter wollen wir brauen." - Text aus einem verlassenen Heidenlager

Link to post
Share on other sites

Ok, do me a favour, go into your "c:\documents and settings\<your user name>\Application Data\DarkRadiant" and nuke the folder, this will remove all of DR's setting and set it back to default. I am running DR in embedded mode, hence on one window for orthoview.

 

Then see if DR keeps crashing or not.

Link to post
Share on other sites

If I tell DR to start on my primary monitor, I get this very rendering bug. Grr -- angry face.

 

So, instead, I tell DR to start on my smaller secondary monitor, and everything works.

BUT I DON WANNA HAVE DR ON TAHT MONITOR !!11 So I drag DR over to my primary monitor. Everything still works.

yay seuss crease touss dome in ouss nose tair

Link to post
Share on other sites

I got 16000 kbit, but recently my speed is much too low and I'm gonna contact my provider tomorrow :angry:

 

May I can help you in another way. What do you need?

"Einen giftigen Trank aus Kräutern und Wurzeln für die närrischen Städter wollen wir brauen." - Text aus einem verlassenen Heidenlager

Link to post
Share on other sites

I got 16000 kbit, but recently my speed is much too low and I'm gonna contact my provider tomorrow :angry:

 

May I can help you in another way. What do you need?

 

EDIT: I currently noticed, that some windows are cut off in the secondary window and I can't seem to move them to fit in the window (see screen)

 

See the surface inspector in the left screen??

post-3542-130305744592_thumb.jpg

Edited by SeriousToni

"Einen giftigen Trank aus Kräutern und Wurzeln für die närrischen Städter wollen wir brauen." - Text aus einem verlassenen Heidenlager

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...