Jump to content
The Dark Mod Forums

Recommended Posts

Hi. I am a new person here. I played some TDM a year ago, on my old computer. TDM was good when it started, but it's better now, and there are many more fan missions now. I am delighted to be back. biggrin.gif

 

I am now playing on a Nvidia GTX 580 with 1.5GB vram. Already, 2 FM's have used all 1.5GB vram: Fiasco at Fauchard Street and Return to the City V2.

 

From my experiences in directX games, when all vram is used, fps will greatly decrease and the game will be very laggy.

 

I am absolutely shocked that in 2FM's, all vram is used and fps is a constant smooth 60fps. How is this possible?

 

Is it normal in openGL games that fps will not decrease even if there is too little vram?

Or does doom3 have special vram handling? Did TDM coders make special code to handle vram?

 

Seriously, I wish all PC games could handle vram as effectively as TDM does. It's very satisfying to use all vram without any negative effects.

Edited by Partol
Link to post
Share on other sites

OpenGL can have less draw call overhead than DX is many cases.

 

It is entirely possible that poorly optimized maps will perform worse than what you've experienced.

 

Oddly... part of the reason that Deferred engines like UE3 perform so well is that they have more scene management overhead to prevent overdraw. In cases where you hit high vram usage in these engines you are pushing the edge where this overhead starts to be more of a burden. Though the tradeoff is worth it because UE3 can make scenes that look like the equivalent Doom 3 scenes with much less ram. Some UE3 detractors would say it isn't worth it due to the buggy way that deferred render engines deal with AA and filtering...

 

I am a little surprised by your vram numbers though...

 

I know that in v1.04 some folks found that texture compression was disabled... are your DoomConfig.cfg settings as listed below?

 


image_usePrecompressedTextures "1"
image_useNormalCompression "2"
image_useAllFormats "1"
image_useCompression "1"
image_preload "1"

Please visit TDM's IndieDB site and help promote the mod:

 

http://www.indiedb.com/mods/the-dark-mod

 

(Yeah, shameless promotion... but traffic is traffic folks...)

Link to post
Share on other sites

I am running TDM v1.05

 

Here are my settings in DoomConfig.cfg located in doom3/returntothecityv2/

and also here doom3/darkmod/

 

image_usePrecompressedTextures "1"

image_useNormalCompression "0"

image_useAllFormats "1"

image_useCompression "0"

image_preload "1"

 

 

game settings:

1920x1080

AA = 8x and AF = 8x

ambient rendering = enhanced

interaction shader = enhanced

post processing = enabled

object detail = very high

 

When I first start Return to the city v2 or Fiasco at Fauchard Street,

I see "mission loading". (I assume main ram is loading).

 

Next I see, "Mission Loaded please wait" while vram usage increases. When vram reaches 1520-1530MB, there is a very brief pause and the map starts.

Edited by Partol
Link to post
Share on other sites


image_usePrecompressedTextures "1"
image_useNormalCompression "2"
image_useAllFormats "1"
image_useCompression "1"
image_preload "1"

 

I just tested Fiasco at Fauchard Street with your settings.

vram usage is now only 800MB.

Which do you think is better? your settings or my settings? compression on or off?

 

frame rate seems to be the same, but I'll do more testing.

Link to post
Share on other sites

The intended settings for the mod are to use compression where available. Not using compression may decrease your load times but, as you can see, the maps are way up there in vram consumption when compression is not used. Both RTTC and FAFS are relatively small missions, when larger missions appear you may get malloc errors.

 

It's cool that you've got the hardware to handle this but I suspect you would not see any appreciable quality loss for enabling compression. (Especially since 99.9999% of the normal maps aren't compressed anyway...)

Edited by nbohr1more

Please visit TDM's IndieDB site and help promote the mod:

 

http://www.indiedb.com/mods/the-dark-mod

 

(Yeah, shameless promotion... but traffic is traffic folks...)

Link to post
Share on other sites

I'll keep an eye on the image quality and cpu/gpu usage with compression on. If I dont see any difference, then compression stays on. I am still shocked that there was no performance problem, even when my graphics card ran out of vram.

 

Thanks for helping.

Edited by Partol
Link to post
Share on other sites

Doom 3 loads all the textures for the whole level at once. Because of this, most of the initial views you would see are not going to be paged out to "whatever the PCI-E equivalent of AGP Aperture" (PCI_E Aperture?). Normally engines would only load a small fraction of the map into vram then page in and out when you've passed certain distance markers. If you have filled-up your vram in those types of engines you have no place to swap so therefore the game becomes very laggy.

Please visit TDM's IndieDB site and help promote the mod:

 

http://www.indiedb.com/mods/the-dark-mod

 

(Yeah, shameless promotion... but traffic is traffic folks...)

Link to post
Share on other sites

There is no stutter. I am just pointing out that vram usage is high (without compression). Yes, I check vram usage in all games which I play. My vram usage is displayed on-screen while gaming. Most games do not come close to using 1.5GB vram at 1920x1080. I played several other TDM missions (without compression) and they used 1000-1500MB of vram.

Link to post
Share on other sites

Here is my system configuration.

 

http://modetwo.net/d...post__p__257367

 

Is this enough information for you?

 

To anyone who has system issues .... I highly recommend that you monitor cpu and gpu stats while gaming. MSI afterburner and EVGA Eleet can show gpu stats on-screen while gaming. I always display on-screen: gpu frequency,gpu temperature,gpu fan speed,gpu usage, vram usage, and frame rate. cpu usage can be checked in windows task manager. ctrl+alt+del to open and alt+tab to switch to windows task manager while in game.

Edited by Partol
Link to post
Share on other sites

Hmm, well the GTS250 is a re-baged/overclocked 9800GTX, which itself was a re-baged/overclocked 8800GTS, all of which are fast enough to play TDM. The only thing I can think that maybe be limited is the amount of ram your gfx card has. So in that case using the .cfg file optimizations is a must. What frame rates do you get beforew and after using said .cfg file changes..? And when you say laggy, in what way? low fps or judder..? What fps are you getting..

Link to post
Share on other sites

Shadowhide,

 

I played your mission (Winter Harvest) last night. It's different than other missions, not like typical thief missions, which explains why some people will not like it. Personally, I welcome alternative styles, especially horror and even sometimes interesting combat. It needs some polish for sure, but I like your style very much.

 

Let me make my point. Even with an older video card, the graphics settings can simply be lowered. But to reduce cpu load is not so easy. In the forest, on your map, sometimes, my fps was only 20-30. And I dont believe it's because of my graphics card. My graphics card gpu usage is always less than 100% on all TDM missions which I tested.

 

Seems to me, a very powerful cpu is needed to run The Dark Mod at 60 fps at all times. Unfortunately, doom3 is single-core threaded. If the doom3 engine was dual core-threaded, performance would be much better, I think. Crysis 2 runs well for you because it can use 100% of your dual-core cpu. TDM can only use 50% of your dual-core cpu.

 

I am playing TDM on a dual-core i3 530@ 4.15GHz and my frame rate is usually 60 but in some places in your forest (especially at the end , when it is bright), my frame rate drops to 20-30. The only solutions I know are to redesign the map or to buy a powerful,fast cpu. With a E7400 @ 2.8GHz, I think there will be bad lag in some places. Overclocking your cpu should help a lot (may need new cpu cooler). You could download and install MSI afterburner and show gpu data on-screen, then look at gpu usage. If gpu usage is less than 100%, then probably, it's a cpu bottleneck. If gpu usage is at 99-100%, then lower the graphics settings and/or resolution.

Edited by Partol
Link to post
Share on other sites
Hmm, well the GTS250 is a re-baged/overclocked 9800GTX, which itself was a re-baged/overclocked 8800GTS, all of which are fast enough to play TDM. The only thing I can think that maybe be limited is the amount of ram your gfx card has. So in that case using the .cfg file optimizations is a must. What frame rates do you get beforew and after using said .cfg file changes..? And when you say laggy, in what way? low fps or judder..? What fps are you getting..

getting around 30-35 fps in RTTC2 start area

Shadowhide,

 

I played your mission (Winter Harvest) last night. It's different than other missions, not like typical thief missions, which explains why some people will not like it. Personally, I welcome alternative styles, especially horror and even sometimes interesting combat. It needs some polish for sure, but I like your style very much.

thanks,mission will be updated

Seems to me, a very powerful cpu is needed to run The Dark Mod at 60 fps at all times. Unfortunately, doom3 is single-core threaded. If the doom3 engine was dual core-threaded, performance would be much better, I think. Crysis 2 runs well for you because it can use 100% of your dual-core cpu. TDM can only use 50% of your dual-core cpu.

I see

Proceed with caution!

Link to post
Share on other sites
  • 1 year later...

The high vram usage / uncompressed data problem is happening again!

 

Here's how I fixed it this time:

 

I uninstalled Doom 3 and deleted everything in ...\steamapps\common\Doom 3

Re-downloaded and re-installed Doom 3.

downloaded tdm_update.exe and installed TDM v1.07

 

Immediately noticied that vram usage is maxed out (1.5GB) in all recent fan missions.

Several times, I enbabled compression in ...\darkmod\DoomConfig.cfg

Each time, after starting TDM, ...\darkmod\DoomConfig.cfg would revert back to it's original uncompressed settings.

I figured out the reason.

The DoomConfig.cfg in ...\common\Doom 3\name_of_FM\DoomConfig.cfg must also be changed.

 

The final solution (for me) was to manually delete all FM's and delete the training mission too.

Next, I enabled compression in \darkmod\DoomConfig.cfg

Finally, FM's are downloaded and installed and compression is working fine now.

 

Just letting everyone know that compression seems to be disabled by default in TDM v1.07 (fresh install).

My OS is 32-bit windows 7.

Edited by Partol
  • Like 1
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...