Jump to content
The Dark Mod Forums

Question about patches


Recommended Posts

So, I've been playing with patches in my practice level, and I'm trying to make a basement door (like, a door outside the goes into a cellar that is almost parallel with the ground). The problem is, all the ground around my church is a patch mesh, which means I cant really subtract a hole in it. I've got a ton of patches together meaning its a pain in the ass to do anything to a single piece because it misaligns it with everything else, so is there any good way of putting a hole in it without blowing up everything else? If need be I can always move all the vertices's away from the building and make a square hole and what not, but it will be a pain and it would be nice to have another way to do it.

 

If I can do that I can see it being useful in other places. Any ideas?

 

Thanks!

Link to post
Share on other sites

Putting a hole in a patch is not possible, however, in DoomEd you can select the patch and export it to obj. Afterwards you load it up into milkshape3D, remove the necessary polygons, and then export to lwo. Then you load it up into your map.

 

If you don't have milkshape or whatnot, it's probably easier to make 4 patches instead, thus you'd have a hole in the middle.

Link to post
Share on other sites
Putting a hole in a patch is not possible, however, in DoomEd you can select the patch and export it to obj. Afterwards you load it up into milkshape3D, remove the necessary polygons, and then export to lwo. Then you load it up into your map.

 

If you don't have milkshape or whatnot, it's probably easier to make 4 patches instead, thus you'd have a hole in the middle.

 

Thanks! I'll probably do the later, perhaps learn the former at some point. While I'm asking about patches, I've made terrain and some of it looks OK, but some of it is really stretched and strange looking. I know it should be streched, but the texture tiling is all wrong. I'm not sure how those pieces got that way, but I imagine it has to do with being 3x3 vs 5x5 etc, does that sound right? I'll include some screenshots later if that doesn't make any sense. I'd like to be able to adjust that after the fact rather than having to recreate the piece if possible.

Link to post
Share on other sites
Thanks! I'll probably do the later, perhaps learn the former at some point. While I'm asking about patches, I've made terrain and some of it looks OK, but some of it is really stretched and strange looking. I know it should be streched, but the texture tiling is all wrong. I'm not sure how those pieces got that way, but I imagine it has to do with being 3x3 vs 5x5 etc, does that sound right? I'll include some screenshots later if that doesn't make any sense. I'd like to be able to adjust that after the fact rather than having to recreate the piece if possible.

 

Yep this is easy to fix. I assume you are using Dark Radiant? You can use middle mouse to "copy" texture stats from a brush and paste it onto the currently selected one. You have to first select it though. So select you patch/es and middle click on a brush with the correct sizing.

 

Alternatively you can select the patches and set them to "natural" and then scale it accordingly.

Link to post
Share on other sites
Yep this is easy to fix. I assume you are using Dark Radiant? You can use middle mouse to "copy" texture stats from a brush and paste it onto the currently selected one. You have to first select it though. So select you patch/es and middle click on a brush with the correct sizing.

 

Alternatively you can select the patches and set them to "natural" and then scale it accordingly.

 

I was able to fix it somewhat by going into surface inspector and clicking naturalize, but I wasn't able to quite figure out what you meant. Do you select both brushes at the same time and then use the middle click on the one you want to copy to? Or do you first select the brush you want to copy from, middle click on it and then how do you paste that into the new brush/patch? I might have manged to do it when I was messing around, but the brushes I was playing with might have been too much the same to notice. What does it copy exactly? Texture properties as in which texture they use or horizantle/vert shift type settings that you see in the surface inspector?

 

I was previously using d3edit but I've been going back and forth, I can see a lot of things that dark radiant does a lot better but I've also had it crash on me some, and since Im using vanilla d3 I cant insert zombies and what not to help me size things (I could probably edit it somehow to find the models and what not though).

 

Thanks :)

Link to post
Share on other sites

There is a wiki article which explains the commands: Texturing in DarkRadiant

 

Basically, you don't need to have anything selected/highlighted when copy/pasting textures. Just use the MMB to select a source, and then hit Shift- or Ctrl- or Ctrl-Alt-MMB to apply the shader to the target.

 

Crashes in DarkRadiant should be reported, if possible. So if you experience a reproducible crash, please let us know.

Link to post
Share on other sites
There is a wiki article which explains the commands: Texturing in DarkRadiant

 

Basically, you don't need to have anything selected/highlighted when copy/pasting textures. Just use the MMB to select a source, and then hit Shift- or Ctrl- or Ctrl-Alt-MMB to apply the shader to the target.

 

Crashes in DarkRadiant should be reported, if possible. So if you experience a reproducible crash, please let us know.

 

Thanks for the tip. As for bugs, mostly its just been little 1 time quirks, meaning I could load it back up and be on my merry way, but it takes longer to load than regular D3 and sometimes I just get lazy and use D3. I will make a concerted effort to use DR (and I do notice improvements in most areas). I did however just have a bug that has happened to me twice in a row (I tried to repeat it), how do you prefer to have it reported? I'm registering for the bugtracker atm (waiting on a confirmation email), if it doesn't have instructions for what info it wants, is there anything special (log files, what system specs etc) that you guys want?

Link to post
Share on other sites
how do you prefer to have it reported? I'm registering for the bugtracker atm (waiting on a confirmation email), if it doesn't have instructions for what info it wants, is there anything special (log files, what system specs etc) that you guys want?

Generally, I don't need any system specifications (apart from your Operating System, perhaps). I just need the DarkRadiant version you're using, plus enough information to be able to reproduce the experienced fault on my system. The more detailed the steps to reproduce are, the faster I can nail down the bug and fix it. Maybe even a testmap, if you're ambitious. Just think about anything that would make my life easier. ;)

 

Look at this for a good example of a detailed issue report: http://bugs.angua.at/view.php?id=660

 

Btw: I enabled your account a minute ago.

Link to post
Share on other sites
Generally, I don't need any system specifications (apart from your Operating System, perhaps). I just need the DarkRadiant version you're using, plus enough information to be able to reproduce the experienced fault on my system. The more detailed the steps to reproduce are, the faster I can nail down the bug and fix it. Maybe even a testmap, if you're ambitious. Just think about anything that would make my life easier. ;)

 

Look at this for a good example of a detailed issue report: http://bugs.angua.at/view.php?id=660

 

Btw: I enabled your account a minute ago.

 

Cool, I submitted my report. Oddly enough I managed, while registering with the bug tracker to report any errors I encountered, to create a bug that make me unable to drag to create a brush in grid view in my map that I cant seem to fix. Its not a big deal though because I've saved like 10 different backups of this map. I submitted the map in case you want to look at it (though then I cant deny ownership of it :/) but as I have a very recent backup that works fine its not particularly pressing.

 

I did, however, manage to forget to mention I use XP pro.

Edited by BEAR
Link to post
Share on other sites

Ok, thanks for the map, I'll try to reproduce that when I find some time - I'm quite busy at the moment with other coding stuff, so please don't be disappointed if you have to wait a bit for the fix. :)

Link to post
Share on other sites
Ok, thanks for the map, I'll try to reproduce that when I find some time - I'm quite busy at the moment with other coding stuff, so please don't be disappointed if the fix takes a bit. :)

 

Hah, I actually would prefer you don't waste too much time on it. It was just an odd thing, I loaded a backup and just redid a few minor things so I'm not hampered by it. It might be useful to know what was causing it eventually to make the editor nice and clean, but its not pressing in the least.

 

Thanks for the help though.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...