Jump to content
The Dark Mod Forums
Sign in to follow this  
Gothsinner

Training mission bug

Recommended Posts

I don't know if this has already been said, I could not find anything about it anywhere, and I hope this is the right place to point this out.

I found this weird bug in the training mission, where the screen goes crazy if I go underwater when the health is not full. The majority of the screen freezes, and I can only see a smaller screen in the bottom left corner in which I can continue to play. If I return on surface, everything turn back ok, same thing if I cure full health (even underwater). I noticed this in the training mission only, in "Tears of St Lucia", for example, everything goes perfectly underwater even if damaged.

post-38356-0-73975200-1541030680_thumb.png

  • Like 1

Share this post


Link to post
Share on other sites

The OpenGL programmer in me thinks that looks like the underwater effect is supposed to be rendered to an FBO for some post-processing to be applied, but the FBO is not being bound correctly and the render is happening to the screen instead.

Share this post


Link to post
Share on other sites

As it often happens with bug reports, it would be useful to get two things:

1) Console messages. Enter condump command into game console, then find the file and attach it here.

2) Config file. Attach darkmod.cfg which you use.

 

In this particular case, which version/build of TDM is it?

The console log could clarify this.

Share this post


Link to post
Share on other sites

It's a kind of awkward thing to say, but after trying for 3-4 days straight and always having that problem, no matter if I reinstalled only the training mission or the whole game (version 2.06 btw), it now seems to work properly, so I don't honestly know if it is a real bug or something else with my pc it didn't like.
Anyway, Here are both the condump and the config files.

https://ufile.io/pj97u

 

As for adding it to the bug tracker, I didn't know I could do it (and how to do it), sorry.

 

Feel free to decide if this topic is worth existing any long or not, since it seems I happened to be the only one to have this issue and now it seems fine.

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...