Jump to content
The Dark Mod Forums
Sign in to follow this  
Anderson

Updated to 2.07, game won't launch

Recommended Posts

Downloaded 2.07 update, neither the x64 launcher nor the normal x32 launcher work. The x64 launcher only gives me a black screen and then goes back to desktop.

The usual x32 launcher gets me a black screen with the TDM mouse in the center and nothing more, if I click around the game goes into not responding mode and crashes as well.

Tried deleting and redownloading the game but still doesn't work.

 

 

Is the forum working correctly? Can't upload any files from my game directory, but I can upload the DxDiag file (it says "Error You aren't permitted to upload this kind of a file").

DxDiag_laptop.txt

Edited by Anderson

Share this post


Link to post
Share on other sites

It seems you are allowed to attach only txt files.

Rename any text file you want to attach to have .txt extension. Upload binary files somewhere and post a link.

 

Please provide:

1) darkmod.cfg contents.

2) Add logfile 2 line to darkmod.cfg. Run TDM. Then provide contents of qconsole.log (it should be created somewhere in fms directory --- according to the currently installed FM).

 

You may also try to rename darkmod.cfg to darkmod_old.cfg and run TDM. It will reset your config file to defaults --- sometimes it helps.

  • Like 1

Share this post


Link to post
Share on other sites

It seems you are allowed to attach only txt files.

Rename any text file you want to attach to have .txt extension. Upload binary files somewhere and post a link.

 

Please provide:

1) darkmod.cfg contents.

2) Add logfile 2 line to darkmod.cfg. Run TDM. Then provide contents of qconsole.log (it should be created somewhere in fms directory --- according to the currently installed FM).

 

You may also try to rename darkmod.cfg to darkmod_old.cfg and run TDM. It will reset your config file to defaults --- sometimes it helps.

 

Here is Darkmod.cfg (added .txt just so it accepts the file).

 

I do not see any gsconsole.log appearing anywhere. I don't even know which FM is currently installed, I deleted TDM and reinstalled, maybe it can't figure which FM is installed yet at this point because it won't launch. Checking all FM folders didn't seem to help me find any gconsole.log file.

Renaming darkmod.cfg didn't seem to help.

Darkmod.cfg.txt

Share this post


Link to post
Share on other sites

I do not see any gsconsole.log appearing anywhere. I don't even know which FM is currently installed, I deleted TDM and reinstalled, maybe it can't figure which FM is installed yet at this point because it won't launch. Checking all FM folders didn't seem to help me find any gconsole.log file.

Sorry, I said it wrong.

Please remove the logFile 2 line that you added at the very beginning --- that was a bad idea from my side.

 

Then find the following line at the end of the file:

  seta logFile "0"

And turn it into:

  seta logFile "2"

Then run TDM again.

 

Then search for qconsole.log.

You can look into currentfm.txt file: it usually contains the name of the currently installed FM.

Then go to fms/{installedfm}/, the qconsole.log file must be created there.

  • Like 1

Share this post


Link to post
Share on other sites

One more thing to try.

 

Add the following line to the end of darkmod.cfg:

seta tdm_invgrid_hud_file "guis/tdm_invgrid_parchment.gui"

Then try to start TDM again. Hope it helps.

  • Like 1

Share this post


Link to post
Share on other sites

Sorry, I said it wrong.

Please remove the logFile 2 line that you added at the very beginning --- that was a bad idea from my side.

 

Then find the following line at the end of the file:

  seta logFile "0"

And turn it into:

  seta logFile "2"

Then run TDM again.

 

Then search for qconsole.log.

You can look into currentfm.txt file: it usually contains the name of the currently installed FM.

Then go to fms/{installedfm}/, the qconsole.log file must be created there.

 

 

qconsole.log

 

Found it in the base fms folder and not in any particular fm subfolder

qconsole.log.txt

Edited by Anderson

Share this post


Link to post
Share on other sites

seta tdm_invgrid_hud_file "guis/tdm_invgrid_parchment.gui"

The new parchment style inventory grid has not been included in the 2.07 release.
  • Like 1

Share this post


Link to post
Share on other sites

What is the CPU/GPU model?

Try r_useGLSL 0.

Try changing GLSL version in interaction.fs to 130.

 

Here is my CPU/GPU model: http://forums.thedarkmod.com/topic/19450-fan-missions-stop-loading-and-go-back-to-menu-solved/?p=422282

 

Where can I find interaction.fs ?

Edited by Anderson

Share this post


Link to post
Share on other sites

Where can I find interaction.fs ?

It is in tdm_base01.pk4/glprogs.

 

Do I understand it right that you don't even see the main menu?

This is something weird, because main menu does not use interaction.fs or any other fancy GLSL shaders.

  • Like 1

Share this post


Link to post
Share on other sites

What is the CPU/GPU model?

Try r_useGLSL 0.

Try changing GLSL version in interaction.fs to 130.

 

 

It is in tdm_base01.pk4/glprogs.

 

Do I understand it right that you don't even see the main menu?

This is something weird, because main menu does not use interaction.fs or any other fancy GLSL shaders.

 

Okay, I changed #version 120 to #version 130.

 

Yes, correct I only get the TDM mouse but no main menu and no music. Just black screen.

 

Unfortunately still did not help.

Share this post


Link to post
Share on other sites

 

 

 

Okay, I changed #version 120 to #version 130.

 

Yes, correct I only get the TDM mouse but no main menu and no music. Just black screen.

 

Unfortunately still did not help.

Are you running TDM in a window or in full screen?

  • Like 1

Share this post


Link to post
Share on other sites

No music is super weird.

It means that the problem cannot be in graphics only.

 

Unfortunately, the qconsole.log file does not contain the info about loading pk4 files :unsure:

Condump has this information, but doing it blind is not very convenient.

Could you please add line:

condump qqq

To darkmod.cfg and run TDM once again?

Then post qqq.txt contents in spoiler.

 

I guess it might be corrupt TDM installation.

How did you get this version? Which updater did you use and from which version?

Are there any subdirectories in TDM directory (except for fms and screenshots maybe) ?

Perhaps you should try to rerun updater, or even do a fresh install.

 

  • Like 1

Share this post


Link to post
Share on other sites

Are you running TDM in a window or in full screen?

 

Full screen.

Just tried running in windowed by changing the Darkmod.cfg setting. Still showing black screen with TDM mouse.

 

No music is super weird.

It means that the problem cannot be in graphics only.

 

Unfortunately, the qconsole.log file does not contain the info about loading pk4 files :unsure:

Condump has this information, but doing it blind is not very convenient.

Could you please add line:

condump qqq

To darkmod.cfg and run TDM once again?

Then post qqq.txt contents in spoiler.

 

I guess it might be corrupt TDM installation.

How did you get this version? Which updater did you use and from which version?

Are there any subdirectories in TDM directory (except for fms and screenshots maybe) ?

Perhaps you should try to rerun updater, or even do a fresh install.

 

 

I've got this version originally by updating from 2.06 to 2.07. The result was the same as now.

Then I deleted all files except fms folder and downloaded the updater again from www.thedarkmod.com

There are no subdirectories except fms and screenshots (which I deleted when I reinstalled TDM so now I only have missionshots folder inside fms and no screenshots folder anymore).

I'll try reinstalling again and report back.

qqq.txt

Edited by Anderson

Share this post


Link to post
Share on other sites

 

Just tried running in windowed by changing the Darkmod.cfg setting. Still showing black screen with TDM mouse.

Black screen or black window?

 

Perhaps a screenshot of the files in your tdm folder (detailed view with file sizes, etc)

  • Like 1

Share this post


Link to post
Share on other sites

Black screen or black window?

 

Perhaps a screenshot of the files in your tdm folder (detailed view with file sizes, etc)

 

Well, when playing full screen it is a black screen with a TDM mouse. When playing windowed screen it is a black screen inside a window with a TDM mouse.

 

Here are the screenshots.

 

post-23762-0-32050100-1549394988_thumb.png

Share this post


Link to post
Share on other sites

Screenshot number two.

post-23762-0-64506200-1549395110_thumb.png

Share this post


Link to post
Share on other sites

Screenshot number three.

post-23762-0-52315100-1549395166_thumb.png

Share this post


Link to post
Share on other sites

Screenshot number four.

post-23762-0-39501900-1549395239_thumb.png

Share this post


Link to post
Share on other sites

Screenshot number five - fms folder.

post-23762-0-08724300-1549395316_thumb.png

Share this post


Link to post
Share on other sites

Mkay, how about cpu / gpu / driver version?

 

Intel HD Graphics (GPU I think) - version 9.17.10.4459

 

Intel® Celeron® CPU B830 @ 1.80 Ghz - version 10.0.17134.1

Share this post


Link to post
Share on other sites

You said that 32-bit and 64-bit versions behave differently: one of them exits itself.

Does it look like a crash in this case?

What are the contents of qconsole.log in the case when TDM exits itself?

 

If there is a crash, please record crashdump and share it.

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...