Jump to content


Photo

No rendering on screen (and no way to fix it without accessing newer assets)

linux rendering

  • Please log in to reply
15 replies to this topic

#1 Hamlet

Hamlet

    Member

  • Member
  • PipPip
  • 25 posts

Posted 14 October 2017 - 12:32 AM

Hello all,

I am trying to compile and play The Dark Mod under my platform (Gentoo Linux).
After patching the patchable to make it compile, it turns out that no rendering is shown on screen at all: black screen (with resolution change), mouse is responsive and I can hear the reaction of the GUI to its movement (clicks and all); also the background music (soothing, charming, beautiful... but that you know already) cuddles my ears.
I started the bisection of the code from version 2.05 (I think... it was r6753) to r7203. It took me a while (none of the commits compiles out of the box, and different ones require different patches), and in the end I found that r6834 works for me (at least the menu screen!), while r6835 does not any more (as above).
I have the output to screen of two runs. In Attached File  thedarkmod-r6834.txt   23.78KB   2 downloads, I started it with no arguments, and then quit. In Attached File  thedarkmod-r6835.txt   21.24KB   1 downloads, I started it with no arguments, then I switched to a text console and killed it (because I could not see the GUI to quit). The only files that changed between the two runs are thedarkmod.x86, gamex86.so and tdm_game02.pk4.

Any suggestion for me to have this work?


Edited by Hamlet, 02 November 2017 - 10:14 PM.


#2 duzenko

duzenko

    Advanced Member

  • Active Developer
  • PipPipPip
  • 951 posts

Posted 14 October 2017 - 05:10 AM

You need the new glprocs from the assets svn


  • stgatilov likes this

#3 Hamlet

Hamlet

    Member

  • Member
  • PipPip
  • 25 posts

Posted 14 October 2017 - 01:16 PM

O, I see... I think. The updater log reports updating to version 2.05, and SVN code requires "assets" newer than that.

 

My peruse of the forum search suggests that the assets repository is not public. Anything I can do to work around that?



#4 duzenko

duzenko

    Advanced Member

  • Active Developer
  • PipPipPip
  • 951 posts

Posted 14 October 2017 - 01:19 PM

I already voiced making the assets svn public in the internal forums.

Can't do anything beyond this other than suggest bumping this thread monthly.


  • stgatilov likes this

#5 Hamlet

Hamlet

    Member

  • Member
  • PipPip
  • 25 posts

Posted 14 October 2017 - 01:36 PM

Thank you for the answer.



#6 nbohr1more

nbohr1more

    Darkmod PR, Wordsmith

  • Development Role
  • PipPipPipPipPip
  • 8214 posts

Posted 14 October 2017 - 01:51 PM

I'll try to get you a pack of assets when I get a chance. I agree with Duzenko though. We need public read only assets for SVN builds. Even if it's just for glprogs and material defs.
  • VanishedOne likes this
Please visit TDM's IndieDB site and help promote the mod:

http://www.indiedb.c...ds/the-dark-mod

(Yeah, shameless promotion... but traffic is traffic folks...)

#7 duzenko

duzenko

    Advanced Member

  • Active Developer
  • PipPipPip
  • 951 posts

Posted 14 October 2017 - 01:52 PM

I'll try to get you a pack of assets when I get a chance. I agree with Duzenko though. We need public read only assets for SVN builds. Even if it's just for glprogs and material defs.

And scripts, importantly.


  • VanishedOne likes this

#8 VanishedOne

VanishedOne

    Advanced Member

  • Member
  • PipPipPip
  • 819 posts

Posted 14 October 2017 - 01:59 PM

And scripts, importantly.

Seconded; SteveL once had to PM me some bugfixed scripts after I pointed out there was no public access to them.


Some things I'm repeatedly thinking about...

- louder scream when you're dying


#9 freyk

freyk

    Advanced Member

  • Member
  • PipPipPip
  • 540 posts

Posted 02 November 2017 - 12:37 AM

just for my info,
have you played/runned tdm yet, whithout compiling the code, hamlet?

edit:
i have tot read the ts better.
without compiling code,
to me, its a video driver problem.

Edited by freyk, 02 November 2017 - 12:44 AM.


#10 duzenko

duzenko

    Advanced Member

  • Active Developer
  • PipPipPip
  • 951 posts

Posted 02 November 2017 - 03:05 AM

just for my info,
have you played/runned tdm yet, whithout compiling the code, hamlet?

edit:
i have tot read the ts better.
without compiling code,
to me, its a video driver problem.

No, it's missing glprocs



#11 Hamlet

Hamlet

    Member

  • Member
  • PipPip
  • 25 posts

Posted 02 November 2017 - 10:15 PM

just for my info,
have you played/runned tdm yet, whithout compiling the code, hamlet?

 

I successfully run with version 2.05 (downloaded binaries), and with compiled sources (with some patching, up to commit r6834).



#12 nbohr1more

nbohr1more

    Darkmod PR, Wordsmith

  • Development Role
  • PipPipPipPipPip
  • 8214 posts

Posted 02 November 2017 - 10:30 PM

I thought you already got SVN asset access?

 

Anyway, to confirm Duzenko's assertion, here are the glprogs:

 

Attached File  glprogs.zip.txt   84.68KB   18 downloads


Please visit TDM's IndieDB site and help promote the mod:

http://www.indiedb.c...ds/the-dark-mod

(Yeah, shameless promotion... but traffic is traffic folks...)

#13 duzenko

duzenko

    Advanced Member

  • Active Developer
  • PipPipPip
  • 951 posts

Posted 03 November 2017 - 04:54 AM

I thought you already got SVN asset access?

 

Anyway, to confirm Duzenko's assertion, here are the glprogs:

 

attachicon.gifglprogs.zip.txt

Might also need the new scripts, depending on where the breaking change happened.



#14 nbohr1more

nbohr1more

    Darkmod PR, Wordsmith

  • Development Role
  • PipPipPipPipPip
  • 8214 posts

Posted 03 November 2017 - 06:47 AM

Might as well hand over GUI and Scripts:

 

https://drive.google...VUFkQ3RDN1VVcmM


Please visit TDM's IndieDB site and help promote the mod:

http://www.indiedb.c...ds/the-dark-mod

(Yeah, shameless promotion... but traffic is traffic folks...)

#15 Crinkelite

Crinkelite

    Member

  • Mission Beta Tester
  • PipPip
  • 26 posts

Posted 16 December 2017 - 08:44 AM

I'm having the same issue, where do I place the files from the glprocs.zip?



#16 teh_saccade

teh_saccade

    Advanced Member

  • Member
  • PipPipPip
  • 570 posts

Posted 17 December 2017 - 12:52 AM

I might be wrong but...

Backup your tdm_base01.pk4 and tdm_gui01.pk4

the scripts will go into the tdm_base01.pk4 (as zip) /scripts, overwrite all

and the guis as... tdm_gui01.pk4/gui, overwrite all.

 

 

 

 

// that was terrible english... corrected.


Edited by teh_saccade, 17 December 2017 - 12:53 AM.

  • Crinkelite likes this





Also tagged with one or more of these keywords: linux, rendering

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users