Jump to content
The Dark Mod Forums

failed to load map after 64bit Win7 instal


Recommended Posts

OK, installed win7 64 bit, was using Vista 32 bit.

 

uninstalkle DR 32, reinstalled 64. (1.0.2)

 

Open map, it loads half entities the fails to load. Tried several maps that worked fine before.

----------

Problem Event Name: BEX64

 

Application Name: DarkRadiant.exe

 

Application Version: 0.0.0.0

 

Application Timestamp: 4ae5d1a1

 

Fault Module Name: StackHash_2c9c

 

Fault Module Version: 0.0.0.0

 

Fault Module Timestamp: 00000000

 

Exception Offset: 0000000000000000

 

Exception Code: c0000005

 

Exception Data: 0000000000000008

 

OS Version: 6.1.7600.2.0.0.256.48

 

Locale ID: 1033

 

Additional Information 1: 2c9c

 

Additional Information 2: 2c9c3cbcc11bafbf2cae6e91f575c41d

 

Additional Information 3: aaed

 

Additional Information 4: aaed9b92fe18867c910b38cf9c5765e2

 

Read our privacy statement online:

 

http://go.microsoft.com/fwlink/?linkid=104288&clcid=0x0409

 

If the online privacy statement is not available, please read our privacy statement offline:

 

C:\Windows\system32\en-US\erofflps.txt

 

Dark is the sway that mows like a harvest

Link to post
Share on other sites

OK, scratch that last post.

 

Forgot to update my display drivers to nvidia win7 64 bit. Funny thing is I have been playing World of Goo and Tf2 just fine. Had some weird issues trying to play Thief2 though. Blackscreen which took several restarts to clear. Don't know if the new driver will help...

---------------

 

But now another issue with DR.

 

Much like the Vista issue, all windows with map loaded are now blank white, no grid, nothing. Got to compatibility mode and my only choices are Server 2008 and various Vista SP's. All have Blank white screen, but take quite awhile to load even a small text map.

Funny enough, I can choose Windows 95 through XP SP 3 and even Vista for other programs like Doom3.

 

It also won't let me check any of the compatibility boxes at all.

 

Wow, now I change to win7 basic theme and it's working. Something about Aero for sure (running Win7 Pro 64).

 

Tried making Aero Windows NOT transparent, but that doesn't work either. :(

 

So I guess I can still work and not be in classic mode, but it is strange for sure.

Dark is the sway that mows like a harvest

Link to post
Share on other sites

I'm using Win7 x64 here too, I have an nVidia 9700M GT so it's not due to Win7 and not due to x64 nor due to nvidia in general - yet people observe this, so I assume it's got to be something driver-related?

Link to post
Share on other sites

Well I think the reasons your choices are limited is that the program is a 64bit version while the others you tried were 32bit.

 

Aero seems to be the cause for a few things with DR, mainly I have to disable it to be able to move around the viewports without wait five to ten seconds, once Aero is off it works fine. I have it checked to disable Desktop Composition in compatibility mode so it does it it automatically when I start the program.

 

Windows 7 64bit and a gtx260 with latest drivers for the card. Tried both 64bit DR and 32bit, and am using 32bit as it works.

Link to post
Share on other sites

I've got the latest Dx10 and Nividia 64 drivers I believe. And anything that came with Win7 Pro. And 64 bit sound card (not that that matters).

 

Do have some weird Doom3 error thing I gotta fix, but I'll have to wait until the weekend.

Dark is the sway that mows like a harvest

Link to post
Share on other sites

hmm, I'm running 195.62 , the most current win7 64 bit drivers.

Just can't figure out why I can't 'disable desktop comp', all those boxes are greyed out for DR

 

OK, I reinstalled 32 bit DR in another location just to check. I can set it to 'disable desktop comp'. SO I don't have to switch manually which is nice. But am I going to lose performance running 32 bit?

Dark is the sway that mows like a harvest

Link to post
Share on other sites

OK, I reinstalled 32 bit DR in another location just to check. I can set it to 'disable desktop comp'. SO I don't have to switch manually which is nice. But am I going to lose performance running 32 bit?

No, the application just won't be able to use more than 2 GB, if I recall correctly. Performance should be similar, although x64 claims to be faster in situations - I don't think anybody will notice.

Link to post
Share on other sites
  • 1 month later...

Do I understand correctly that DR works fine in the 32 bit build with Aero enabled? I hate always having to disable Aero before starting DR and since I am mostly just creating small testmaps and stuff like that anyway, I don't mind the performanceloss.

 

I am using Win 7 Professional x64 here with the 196.21 on my 8800 GTS by the way.

Link to post
Share on other sites

Yeah, works fine for me IF:

 

win7 64 bit

 

DR 32 bit

 

And set compatibility for XP sp3, disable desktop comp, disable themes. Aero turns off when DR starts up, but you don't have to manually do it.

I wish there was a way to change colors from aero basic blue though.

DR 64 bit however only has Vista compatibility mode, so you have to manually turn off aero.

Dark is the sway that mows like a harvest

Link to post
Share on other sites

Anything special setup or does it run out of the box? I had to follow the steps BC posted and it works now with the 32 bit version, tanks! Did some experimenting on the 64 bit one, but no luck...

Link to post
Share on other sites

greebo, what compatibility mode are you using with 64 bit windows. My only choices are vista, server 2008, and I think 2000NT?

Vista has same aero issues as not running compatibility mode (white windows, stuff only shoes when clicking on window (if at all, no 3d window), I think server and NT were REALLY slow and laggy and possibly didn't draw 3d window also ( been awhile since I tried them - I could try again and list specifics if needed)

 

That was all with the 2 checkboxes checked too (disable desktop, disable themes)

 

(I have 7 Pro, so wouldn't think compatibility modes would change to ultimzte, but maybe)

Dark is the sway that mows like a harvest

Link to post
Share on other sites

greebo, what compatibility mode are you using with 64 bit windows. My only choices are vista, server 2008, and I think 2000NT?

I don't run it in any compatibility mode, I'm running it as normally as it can get.

 

I really suspect that the graphics drivers are making up the difference.

 

Mine is an old nvidia driver (the one that shipped with my laptop) - Forceware 176.05.

Link to post
Share on other sites

I don't think that the 32-bit and 64-bit DarkRadiant versions will make much of a difference, they are using the same GTKGLext libraries after all, which I compile directly from source for the Windows builds. For me, I can use the 32-bit DarkRadiant just as fine too, without troubles or special settings.

Link to post
Share on other sites

No, I just run it. I'm compiling DarkRadiant on my own, of course, but that should be unrelated to any Aero issues. Maybe the drivers are different who knows.

 

I just wanted to chime in to say that since a few months ago, DR 64 isn't having any issues with leaving Aero on for me either. I also compile from source, not sure if that means anything.

 

I'm running 195.81 64 bit, With Nvidia GeForce 260M GT in SLi mode.

I always assumed I'd taste like boot leather.

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...