Jump to content
The Dark Mod Forums

DarkRadiant Camera Issue


Recommended Posts

Hey!

I hope this is the right section for this. I'm currently working on my first mission, entitled The Joyau Rouge. I haven't really got anywhere with it yet apart from the planning, because of what's either a bug or me being stupid. I'm running Siduction (a Linux distribution based on Debian unstable) and I don't seem to be able to free-look using the camera in DarkRadiant. I've attached a video of it—the context menu and dialog box are invisible in the recording, but at the start I'm adding a prefab. I hope someone can help me get around this issue.

Thanks!

—Xaeman

2020-11-26 21-46-44.mkv

Link to comment
Share on other sites

It seems the crosshair is appearing in the middle of the camera view, which means that you entered the free look mode. But it seems, you aren't able to rotate the view using the mouse, is that correct?

Is there something to see in the map in the first place? The ortho views seem terribly empty to me.

Link to comment
Share on other sites

8 hours ago, greebo said:

It seems the crosshair is appearing in the middle of the camera view, which means that you entered the free look mode. But it seems, you aren't able to rotate the view using the mouse, is that correct?

Is there something to see in the map in the first place? The ortho views seem terribly empty to me.

Correct. And as I said in my original post, I added a prefab at the beginning of the video, although I may be doing something wrong.

Link to comment
Share on other sites

Ok, ok. I need to know more about your setup. Which DarkRadiant version are you using, and where did you get it from? Did you compile from source? What wxWidgets version is it built against? Are there any other steps you had to perform before you got it running? This is running on an actual PC, I suppose, or are you perhaps using a virtual machine? Any warnings in the console, or the command line?

I know nothing about that distribution, but if it's Debian-based, it should work in principle.

Link to comment
Share on other sites

5 hours ago, greebo said:

Ok, ok. I need to know more about your setup. Which DarkRadiant version are you using, and where did you get it from? Did you compile from source? What wxWidgets version is it built against? Are there any other steps you had to perform before you got it running? This is running on an actual PC, I suppose, or are you perhaps using a virtual machine? Any warnings in the console, or the command line?

I know nothing about that distribution, but if it's Debian-based, it should work in principle.

  • I'm running DarkRadiant 2.8.0
  • I got it from the Debian repository
  • No, I didn't compile it from source
  • I'm not sure what wxWidgets version it's built against
  • There were no other steps I had to perform before running it
  • Yes, this is an actual PC, not a virtual machine
  • I'm getting some warnings and errors in the command line:
(darkradiant:30793): Gtk-CRITICAL **: 21:02:33.497: gtk_distribute_natural_allocation: assertion 'extra_space >= 0' failed

(darkradiant:30793): Gtk-WARNING **: 21:02:33.498: Negative content width -6 (allocation 2, extents 4x4) while allocating gadget (node toolbar, owner GtkToolbar)

(darkradiant:30793): Gtk-WARNING **: 21:02:33.498: Negative content height -7 (allocation 1, extents 4x4) while allocating gadget (node toolbar, owner GtkToolbar)

(darkradiant:30793): Gtk-WARNING **: 21:02:33.585: Negative content width -6 (allocation 2, extents 4x4) while allocating gadget (node toolbar, owner GtkToolbar)

(darkradiant:30793): Gtk-WARNING **: 21:02:33.585: Negative content height -7 (allocation 1, extents 4x4) while allocating gadget (node toolbar, owner GtkToolbar)

(darkradiant:30793): Gtk-WARNING **: 21:02:33.585: Negative content height -6 (allocation 1, extents 3x4) while allocating gadget (node button, owner GtkToggleButton)

(darkradiant:30793): Gtk-WARNING **: 21:02:33.586: Negative content width -6 (allocation 2, extents 4x4) while allocating gadget (node toolbar, owner GtkToolbar)

(darkradiant:30793): Gtk-WARNING **: 21:02:33.586: Negative content height -7 (allocation 1, extents 4x4) while allocating gadget (node toolbar, owner GtkToolbar)

(darkradiant:30793): Gtk-WARNING **: 21:02:33.586: Negative content width -14 (allocation 1, extents 7x8) while allocating gadget (node button, owner GtkToggleButton)

(darkradiant:30793): Gtk-WARNING **: 21:02:33.587: Negative content width -7 (allocation 1, extents 4x4) while allocating gadget (node toolbar, owner GtkToolbar)

(darkradiant:30793): Gtk-WARNING **: 21:02:33.587: Negative content width -7 (allocation 1, extents 4x4) while allocating gadget (node toolbar, owner GtkToolbar)

 

Link to comment
Share on other sites

Hm, everything sounds pretty normal to me. The wxWidgets version of your system can be seen in the Help > About dialog, but I assume it's something like 3.0.4 or 3.0.5, since the debian package is referencing those.

There is a newer DR 2.9.1 package for Debian sid: https://packages.debian.org/sid/darkradiant - is this available for your distro too?

Apart from those things, I don't have any idea what might be going wrong. I'd need to set up that distro of yours in a VM to check it out myself.

Link to comment
Share on other sites

18 hours ago, greebo said:

Hm, everything sounds pretty normal to me. The wxWidgets version of your system can be seen in the Help > About dialog, but I assume it's something like 3.0.4 or 3.0.5, since the debian package is referencing those.

Yep, wxWidgets is at 3.0.5.

19 hours ago, greebo said:

There is a newer DR 2.9.1 package for Debian sid: https://packages.debian.org/sid/darkradiant - is this available for your distro too?

Just tried updating to that via the command line but to no avail.

19 hours ago, greebo said:

Apart from those things, I don't have any idea what might be going wrong. I'd need to set up that distro of yours in a VM to check it out myself.

Yeah, sounds like the best idea. Thanks for your help so far.

Link to comment
Share on other sites

Ok, what was your installation experience with siduction like and how long have you been running siduction? I've failed two times now trying to install it and update it to the latest packages - the installation medium is from 2018, and it's full of old packages. Running updates / dist-upgrades (downloading almost 1.5 gigabytes of new sid packages everytime) etc. manoevred my system into a state where I cannot get past the login screen anymore (I can only log in through the Ctrl-Alt-F2 TTYs). It happened twice now, and I don't know what I could have done wrong, didn't find any solutions either.

This is really frustrating. I've seen quite a few distro installations and installers in the meantime, Debian, Fedora, Gentoo, Slackware, Arch, openSUSE, Mageia, countless Ubuntus - but this is by far the worst of it all.

Link to comment
Share on other sites

1 hour ago, greebo said:

Ok, what was your installation experience with siduction like and how long have you been running siduction? I've failed two times now trying to install it and update it to the latest packages - the installation medium is from 2018, and it's full of old packages. Running updates / dist-upgrades (downloading almost 1.5 gigabytes of new sid packages everytime) etc. manoevred my system into a state where I cannot get past the login screen anymore (I can only log in through the Ctrl-Alt-F2 TTYs). It happened twice now, and I don't know what I could have done wrong, didn't find any solutions either.

This is really frustrating. I've seen quite a few distro installations and installers in the meantime, Debian, Fedora, Gentoo, Slackware, Arch, openSUSE, Mageia, countless Ubuntus - but this is by far the worst of it all.

I'm afraid I don't remember what it was like—it was about a year ago now. I don't know what's going wrong with the installation for you but I do have a development on the camera issue. Upon opening the main map file for The Tears of St. Lucia, I was able to move the camera around and see everything. I'm following Springheel's New Mappers Workshop on YouTube, and in the episode I'm currently on, he adds a prefab and is able to view it in the camera. I'm assuming the issue is the prefab, so I don't understand why Springheel was able to do see it and I'm not. Either I'm doing something wrong or it's just a bug.

Link to comment
Share on other sites

15 hours ago, greebo said:

Might be the cubic clipping setting which might hide the prefab if it's too far from the camera.

Just tried disabling that (I think) and it doesn't seem to be doing anything.

Link to comment
Share on other sites

Can you confirm that there is something rendered in the 2D views after importing the prefab? If the 2D views are empty then there will be nothing to see in the 3D view either.

Does this happen with every prefab and every model you import, or just a specific one? Is anything ticked in the Filters menu that might be hiding particular objects?

Link to comment
Share on other sites

5 hours ago, OrbWeaver said:

Can you confirm that there is something rendered in the 2D views after importing the prefab? If the 2D views are empty then there will be nothing to see in the 3D view either.

All I can see in the 2D views is a point labelled with some co-ordinates which I was assuming was the prefab.

5 hours ago, OrbWeaver said:

Does this happen with every prefab and every model you import, or just a specific one? Is anything ticked in the Filters menu that might be hiding particular objects?

It seems like all prefabs from what I can tell.

Link to comment
Share on other sites

On 12/5/2020 at 9:18 PM, Xaeman said:

All I can see in the 2D views is a point labelled with some co-ordinates which I was assuming was the prefab.

If it's just appearing as point, can you confirm you've appropriately zoomed in? In the video above, I notice you're almost completely zoomed out with coordinates around 8k to 16k. That's awfully large, a prefab is usually just a few dozen units.

Link to comment
Share on other sites

On 12/12/2020 at 12:02 PM, IZaRTaX said:

Press P > Camera, uncheck "freelook mode can be toggled" then you have to keep pressing RMB to have the camera free mod, try it

That seemed to work. Any idea why it wouldn't work when free look mode could be toggled?

On 12/12/2020 at 12:02 PM, IZaRTaX said:

Edit: as Greebo says your prefab has x5467 and y-9519 it's a complete map ?

I don't understand what you mean.

Edited by Xaeman
Accidentally posted without finishing
Link to comment
Share on other sites

  • 2 weeks later...

Sorry, I totally forgot about this. Thanks to all of you who mentioned zooming in—that was why I couldn't see the prefabs in the map. I guess that's everything sorted then. Should I mark this as solved, or...?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recent Status Updates

    • Nort

      I did it! I finally did it! After 48 hours of frustration and confusion, I managed to finally sort out how to attach equipment to NPC:s properly, and write down coherent instructions on how to do it, both in my manual, and in this forum.
      I can finally rest. I can finally eat breakfast.
      · 0 replies
    • Nort

      Spent most of the day learning and writing about AI navigation. It's stuff I already know, but the magic about writing something down as clearly formulated as possible, is that you then see things that much more clearly. You also find what's unclear to you, and then you figure out exactly how things work. I was hoping to get through it all within just a day, but it looks like this will take tomorrow as well, at this rate. There's also plenty of other nonsense I have to get through as well. Everything's a chore.
      · 0 replies
    • Nort

      I want to be a fish, but I'm not a fish. My mom wants to be a fish too, and so she's killing herself eating plankton and sh***ng blood, and tells me to stop nagging her about taking her medication. I spent several hours today, just lying in bed, having anxiety over just existing, and not being a fish. You fish, you don't know how lucky you are. You can eat all the plankton you want. I tried eating plankton again yesterday, and I just got sick. I hate being a shark.
      · 0 replies
    • Nort

      I just gave myself vertigo. A pleasant kind of vertigo, like the world has been lifted off my shoulders. I'll explain:
      Yesterday I saw to my dismay, that I had made my entire map two - two - units too short on every level - that every set01 piece was sticking 2 units into the ceiling. That's basically 402 brushes that needs to be realigned (minus the ground floor brushes).
      I knew enough about selections to do all of that in a very tense five minutes, and it compiled without leaks. (Thank you so much, Dark Radiant devs, for making an editor with such care for precision that you can align hundreds of brushes perfectly at once (which is not something I can say for Valve's Hammer editor, which has some serious issues on that front, which actually made me just quit it in disgust).) However, the result is that the entire level has now been stretched a barely noticable 2 units, and it will take some getting used to psychologically.
      · 0 replies
    • Nort

      My workflow is basically running from a chain of disasters, eventually trying to seek shelter in former disasters. It's not ideal - it's just my life.
      When I abandoned my first map, it was out of a typical mental breakdown, and so I returned to find a skybox void where the kitchen door should have been (due to a misplaced visportal) and two overlapping brushes Z-fighting on the kitchen floor.
      I've now cleaned up the last bit of mess, by cleanly separating every floor into its own layer. Now I can finally work on each floor in peace.
      ...not that I really needed to. Once you get skilled enough, the orthographic messes, well, I'll let this video speak for itself:
       
      · 1 reply
×
×
  • Create New...