Jump to content
The Dark Mod Forums

Loading a map with thiefs den


Recommended Posts

I've got DR set up to use the thiefs den assets (which are great btw), and I was curious to know whether or not I can actually load that map using the thiefs_den mod as it is installed. I tried it and it had an error, but that could be just part of my map (though it compiles fine).

 

If not, is it possible to get vanilla D3 to recognize the assets? Due to a few bugs in my map I have to do a few things in D3 editor, but all the thiefs den assets are black, and I can't see any of the textures when running the map in D3, which at this point is the only place I can.

 

Any ideas?

 

Thanks.

Link to post
Share on other sites
I've got DR set up to use the thiefs den assets (which are great btw), and I was curious to know whether or not I can actually load that map using the thiefs_den mod as it is installed. I tried it and it had an error, but that could be just part of my map (though it compiles fine).

 

If not, is it possible to get vanilla D3 to recognize the assets? Due to a few bugs in my map I have to do a few things in D3 editor, but all the thiefs den assets are black, and I can't see any of the textures when running the map in D3, which at this point is the only place I can.

 

Any ideas?

 

Thanks.

 

You should just be able to build your map, open up thiefs den, drop down the console and start up your map that way. Should work fine.

Link to post
Share on other sites

Hmm, thats what I tried and it didn't work. I'll play around with it I guess. I wonder if D3 has some logfiles somewhere? The program doesn't crash, it just has an error trying to load so I can still see the error message.

Link to post
Share on other sites

The black textures problem is almost certainly a path error. When you set up Thief's Den presumably you set up a Doom shortcut as described on our wiki page (Right-click, choose Properties and edit the command line) something like C:\games\doom3\DOOM3.exe +set fs_game thiefs_den. I think you need to do the same for your DoomEdit shortcut, something like +set fs_game thiefs_den +editor.

 

Post again if that doesn't fix it and let us know what the error is in the console. You can type condump console.txt in the console to dump the console text to console.txt (any name you choose) in the doom or thiefs_den folder.

Link to post
Share on other sites

Oddly enough it is working now. I've had a few problems that seem to have been resolved by restarting the editor and or game. A few times I've compiled a map only to load it and have half the brushes I had added recently not exist or other weridness, then I recompile and it works fine. In this case I think I just tried it once, got an odd error and didn't try again figuring that something was wrong since I wasn't sure that I was going to be able to do that. I've been running around my map in thiefs den mod and it works like a charm.

 

Setting a shortcut to fs_game thiefs_den and + editor didn't fare as well, it barely ran at all before getting shut down, but since the map seems to work just fine in thiefs den then I don't need to run it in doom 3.

 

Its funny how different the map looks within a day's worth of texturing!

 

Thanks guys

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...