Jump to content


Photo

Prefabs can't be separated?


  • Please log in to reply
11 replies to this topic

#1 Springheel

Springheel

    Creative Director (retired)

  • Admin
  • 36405 posts

Posted 28 March 2017 - 01:04 PM

I'm using the most recent version of DR, and I'm seeing prefab behaviour that I'm not used to.  When I insert a prefab, it seems like the entire prefab is a singular entity?  Even though the prefab is made out of multiple models, I can't select any of the models individually to move them.  Clicking on any part of the prefab selects the entire thing.

 

Is this the new behaviour for prefabs?  Is there some option to turn this off? 



#2 Destined

Destined

    Advanced Member

  • Member
  • PipPipPip
  • 1253 posts

Posted 28 March 2017 - 01:17 PM

Prefabs are automatically grouped, when you insert them. You can simply right-click the prefab and use "Ungroup Selection" (or you can use Edit->Ungroup Selection). I believe grouping is one of the latest features for DR.


  • Springheel likes this

#3 Spooks

Spooks

    Member

  • Member
  • PipPip
  • 366 posts

Posted 28 March 2017 - 01:50 PM

There is also a checkbox in the prefab window that can be unchecked to disable this behaviour.


  • Destined likes this

My FMs: The King of Diamonds (2016)

 

Visit my Mapbook thread sometimes!


#4 Bikerdude

Bikerdude

    Mod hero

  • Member
  • PipPipPipPipPip
  • 18642 posts

Posted 28 March 2017 - 01:52 PM

Yeah Greebo introduced this cool new feature in DR 2.2.1, its makes moving FS around much much easier. And as I have discovered, pretty much cures vert-point-drift!


  • Melan, nbohr1more and Goldwell like this

#5 Springheel

Springheel

    Creative Director (retired)

  • Admin
  • 36405 posts

Posted 28 March 2017 - 03:31 PM

Definitely very useful! 


  • Bikerdude and Goldwell like this

#6 Melan

Melan

    Contest Winner, Wordsmith

  • Campaign Dev
  • PipPipPipPip
  • 4386 posts

Posted 29 March 2017 - 01:26 AM

This is pretty important, and should be documented on the wiki.


Come the time of peril, did the ground gape, and did the dead rest unquiet 'gainst us. Our bands of iron and hammers of stone prevailed not, and some did doubt the Builder's plan. But the seals held strong, and the few did triumph, and the doubters were lain into the foundations of the new sanctum. -- Collected letters of the Smith-in-Exile, Civitas Approved

#7 Bikerdude

Bikerdude

    Mod hero

  • Member
  • PipPipPipPipPip
  • 18642 posts

Posted 29 March 2017 - 03:04 AM

When I get time I will look at doing this during the week then, otherwise anyone else is free to.



#8 Destined

Destined

    Advanced Member

  • Member
  • PipPipPip
  • 1253 posts

Posted 29 March 2017 - 10:55 AM

I added the topic "Grouped Prefabs" to the Wiki-article. Feel free to point me to any mistakes or missing points.



#9 Bikerdude

Bikerdude

    Mod hero

  • Member
  • PipPipPipPipPip
  • 18642 posts

Posted 29 March 2017 - 11:57 AM

I added the topic "Grouped Prefabs" to the Wiki-article. Feel free to point me to any mistakes or missing points.

Good man.

#10 Springheel

Springheel

    Creative Director (retired)

  • Admin
  • 36405 posts

Posted 13 April 2017 - 07:40 PM

While I'm totally sold on having prefabs start grouped, I'm finding that this doesn't always happen.  There seem to be certain prefabs, bunkbeds, for instance, that refuse to start grouped, even when they are grouped before saving.  Is there any trick to making sure they start grouped?

 

edit:  No, it's not that...all prefabs are loading ungrouped now.  Is there a setting I unintentionally switched?



#11 grayman

grayman

    Master Builder, Coder

  • Active Developer
  • PipPipPipPipPip
  • 11826 posts

Posted 13 April 2017 - 09:46 PM

edit:  No, it's not that...all prefabs are loading ungrouped now.  Is there a setting I unintentionally switched?

 

"Create group out of prefab parts" checkbox in the prefab dialogue box?



#12 Springheel

Springheel

    Creative Director (retired)

  • Admin
  • 36405 posts

Posted 14 April 2017 - 06:59 AM

That was it, thanks.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users