Jump to content
The Dark Mod Forums
Destined

used_by_inv_id not working

Recommended Posts

I am currently trying to set up a situation, in which the player has to use two inventory items on another entity. It all works fine, when I use used_by_inv_name, but I would like to change the inventory name into something quite long, so I am not sure if this will work. According to the Wiki article, it can be replaced with used_by_inv_id (to avoid translation problems), but if I use the setup with this, it does not register the inventory item anymore. Am I missing something or was inv_id not implemented so far?

The corresponding spawnargs I used are:
item1: name FinanceBook1; inv_id Finances1, inv_name Finances of Greyhill Church Book 1
item2: name FinanceBook2; inv_id Finances2, inv_name Finances of Greyhill Church Book 2
entity to be used on: used_by_inv_id1 Finances1, used_action_script_Finances1 BurnBook, used_by_inv_id2 Finances2, used_action_script_Finances2 BurnBook

Share this post


Link to post
Share on other sites

Looking at the code, used_by_inv_id spawnarg is not read anywhere. I guess that note on wiki is a king of feature request.

UPDATE: I don't see inv_id either.

  • Like 1

Share this post


Link to post
Share on other sites

Ah ok, that explains it. Maybe it really is only a suggestion on the Wiki. Then I will work with inv_name. Thanks a lot for checking!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...