Jump to content
The Dark Mod Forums

2D views - geometry is blue lines??


Recommended Posts

Hello, Updated to version 2.9.0 x64 and in the 2D views all of my geometry is blue. These lines use to be white, and were only blue when I would "group".

The "colours" menu doesn't give me an option to change this back to white. what's missing, or what am I missing?

colors.JPG

Link to post
Share on other sites

I really can't map this way because the blue is overpowering no matter the background color... hope you guys can relate.

 

- is this site dead?

Edited by Deep
question
Link to post
Share on other sites

Can you zip and send me the .xml files in your C:\users\<USER>\AppData\Roaming\DarkRadiant folder, please?

If that doesn't help, I'm going to need more info about your game/project setup, but let's have a look at those files first.

Link to post
Share on other sites

Ok, your Super Mal scheme in that file is definitely not the same as the factory default.

To reset your colour schemes:
Close DR, remove the colours.xml file from your AppData and restart. Then you can select the Super Mal scheme again to have the default colours back.

Link to post
Share on other sites

ok, this is what I got: resizing the "colors" window (grabbing one edge and shrinking it - then stretching it back left artifacts as you can see. Also the unselected brushes are still blue. hmmm.

colors_brushes.JPG

Link to post
Share on other sites

yes, and how would you go about changing that color is the issue. All of my unselected geometry is blue when it used to be grey-white. So where in here is the proper color to adjust for this? ( also "brushes" is shown as black)

colors_3.JPG

Edited by Deep
added info
Link to post
Share on other sites

Are you using the portable version or the installer? I have to find out how on earth DR can mess up the colours after starting the new version.

2 hours ago, Deep said:

yes, and how would you go about changing that color is the issue. All of my unselected geometry is blue when it used to be grey-white. So where in here is the proper color to adjust for this? ( also "brushes" is shown as black)

Some colour changes require a restart of the app, I think the brush colour is one of them.

Link to post
Share on other sites

well yes I have restarted since this began. I "installed" this. Here's the version:

about DM.JPG

speccy.JPG

Link to post
Share on other sites

First, there is a newer version 2.9.1, that should fix a freeze when saving during shut down, which you might want to get. But you can upgrade whenever you feel like it, there's no change with regard to the colours.

Speaking of the colours, can you give me another dump of your settings files in AppData\Roaming, please? You're saying the brushes stay blue even though the "Brushes" are set to black?

edit: tracked in https://bugs.thedarkmod.com/view.php?id=5430

Link to post
Share on other sites

One more thing: can you please open the menu option Entity > Entity Class Tree... and show me the worldspawn entity (type "worldspawn" to highlight it in the tree). I'd like to see the spawnargs it has defined, especially the editor_color spawnarg. (The entityDef in your project can define a default colour for any primitives below that entity.)

Link to post
Share on other sites

Yes I can. It IS strange because when I draw out a brush, it is white in the 2D views, deselect and it turns blue.

World_spawn shows nothing for values - see pic / The entities def is from the project / new settings files zip.

* just by chance should I uninstall my other Radiants? (ie: net radiant / gtk etc) ? maybe they rewrite or conflict in some way?

- ALSO.. (sorry) If upgrade to the newer DM Radiant will it overwrite the roaming/settings files? or leave the existing ones there to spread the joy into the new version?

thank u

wprld_spawn.JPG

entities.def DarkRadiant.zip

Edited by Deep
added Q.
Link to post
Share on other sites
17 minutes ago, Deep said:

Yes I can. It IS strange because when I draw out a brush, it is white in the 2D views, deselect and it turns blue.

World_spawn shows nothing for values - see pic / The entities def is from the project / new settings files zip.

* just by chance should I uninstall my other Radiants? (ie: net radiant / gtk etc) ? maybe they rewrite or conflict in some way?

- ALSO.. (sorry) If upgrade to the newer DM Radiant will it overwrite the roaming/settings files? or leave the existing ones there to spread the joy into the new version?

thank u

wprld_spawn.JPG

entities.def 8.4 kB · 1 download DarkRadiant.zip 10.66 kB · 1 download

oh narg.

 

Link to post
Share on other sites
52 minutes ago, Deep said:

World_spawn shows nothing for values - see pic / The entities def is from the project / new settings files zip.

Oh wow, that's a Quake .def file? Looks completely different from what Doom 3 is using. (I never had any Quake in my hands, so I don't know anything.)

It doesn't show any default values in the entity class tree, it seems, and I think that's why it falls back to a blue value - it's the hardcoded default in DarkRadiant for entities that don't define any editor_color in their .def - that might explain a few things, since I added a fix to DR 2.9.0 to respect the colourscheme setting , but obviously this is not working in your case. Since your worldspawn is not defining any colour, it seems DR is falling back to the blue default.

We have to find out why the older DR 2.8.0 fell back to black, and we'll find something to work with.

56 minutes ago, Deep said:

* just by chance should I uninstall my other Radiants? (ie: net radiant / gtk etc) ? maybe they rewrite or conflict in some way?

No, that shouldn't interfere at all, since DR has its own settings folder.

57 minutes ago, Deep said:

ALSO.. (sorry) If upgrade to the newer DM Radiant will it overwrite the roaming/settings files?

DarkRadiant is using the same AppData\Roaming\DarkRadiant folder for all versions regardless of version or whether it's portable or installed. So any version you're using will write its settings to that folder, overwriting any existing ones. Usually going back to previous versions is causing troubles, since there exists no forward compatibility in DarkRadiant's setting handling (older versions just might fail to load the settings created in newer versions).

Normally, going forward is not causing much troubles, but it seems I missed the mark for the 2.9.0 release. Many architectural changes and too little testing involved.

Link to post
Share on other sites

What's q4base in that screenie? Is that a Quake 4 installation? If yes, it might contain an entityDef with the editor_color spawnarg set that DR might be able to use too.

Link to post
Share on other sites

The version before 2.9.0 worked like a charm as far as color customization. I'm no coder, but is it as easy as adding another color selector in the "colors" window that represents all unselected geometry in the 2D views? There is one for "selected group items" , "brushes".

I'm afraid to ask dumb questions b'cuz of a lack of understanding, but I DO realize that stuff can be a spaghetti monster sometimes. The style of development we're doing is densely populated with geometry in most areas, and was already a challenge mapping without "H" to assist. seeing the blue just gave me a coronary cuz I couldn't make out the "layers" of development in the maps to navigate properly. - In a nutshell. lol

monster.JPG

Edited by Deep
Link to post
Share on other sites

The colour for unselected geometry should indeed be the one in the Colours dialog, it just doesn't seem to take effect on your end and I need to find out why.

(I know that it might be frustrating, since 2.8.0 worked and 2.9.0 does not, but I cannot just revert things since I would lose the fixes I need for other the TDM game setup, which is the main focus for DarkRadiant. We'll find a way to make it work for you too, I just need some more info.)

Can you paste that in the Script tab input field in DR and hit "Run script", please? It should print the effective value of the worldspawn entity, regardless where it is defined, I'd like to see that output.

print(GlobalEntityClassManager.findClass("worldspawn").getAttribute("editor_color").getValue())
print(GlobalEntityClassManager.findClass("worldspawn").getDefFileName())

 

Link to post
Share on other sites

Thanks. It confirms that there is indeed no worldspawn entityDef defined anywhere, which makes me wonder how your game is working. The target engine is Q4, isn't it?

Anyway, I'll try to replicate that setup on my machine.

Link to post
Share on other sites

Hey that's cool! good job!... btw - I am simply developing maps or should I say using Darkmod to create the textured geometry which we can then add to with other programs such as Blender. There is no playing these maps in a game engine as of yet. (This may address some of the confusion on that)

Kudos to DM for being my editor of choice for this project! I'm avid Radiant for sure. I do know that the base is Q4 instead of Doom3 because of added functionality, but is a 100% project overhaul. Maps and layout to be built in Radiant/s along with other 3D dev programs.

Edited by Deep
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...