Jump to content
The Dark Mod Forums

Mission downloader issue


Recommended Posts

Hi all

I'm running TDM 2.09/64 code rev 9108 on a Zorin 15.3 64 bit  (Ubuntu fork) system ( 7.7Gb, Intel® Core™ i7-4770 CPU @ 3.40GHz × 8, Quadro K600/PCIe/SSE2)

When I download a new mission with the built in downloader, TDM either hangs or crashes to desktop when I get to 100%

The missions appear to download OK, I can read all the text files & the PK4's open & dl'd missions play OK, not spotted any new log files or dumps is there anything I can enable that would give you more info ?


Link to comment
Share on other sites

Sounds like the recurring file permission problem. Solve this by setting some write permissions on the tdm gamefolder.

This by

  • adding yourself to, a by zorin specified, usergroup. (See group owner of the tdm game folder)
    (edit: checked it. thats usergroup root for their games. So, use the following point)
  • Or setting the write permission yourself (Use commands like "chmod" and "chown" and some pointers in tdm wiki article: https://wiki.thedarkmod.com/index.php?title=Installer_and_Manual_Installation#Linux
    (Note: article points to the updater, but use the tdm installer.
    You dont have to use it, to solve this filesystem permission problem. but it is easier, see following point)
  • Or redownload (or move) the game files to a folder in your homefolder, by downloading/placing/running the tdm installer in a folder inside your homefolder. (For instructions, see https://www.thedarkmod.com/downloads/)

How did you install the game?

Edited by freyk

Info: My portfolio and darkmod graphical installer
Amnesty for Bikerdude!

Link to comment
Share on other sites

I can't analyze such problems in detail right now, but I also wonder how did you install the game.

Rev 9108 looks like original 2.09 release (unless I'm mistaken).
You need to update to 2.09a (hotfix release), because it includes some fixes for in-game downloader.

Just run tdm_installer from the directory where TDM is installed, and go forward on default settings.
You probably want to restore your config on the last page (not a good idea in general, but 2.09 -> 2.09a should be fine).

Link to comment
Share on other sites

Posted (edited)

Sorry for the delay, real life got in the way

The darkmod folder is /home/darkmod the owner is me, permissions say I can create & delete files in it, group is my username, permissions say I can access files, everyone else can access files

TDM was installed by downloading tdm_installer.linux64.zip  to the darkmod folder, extracting & running the installer, since then I've run tdm_update.linux64 a couple of times to keep up to date, the last time was on 11th August

I've not noticed this issue for a few months because again real life got in the way & I haven't played for a few months

**EDIT** - there is no tdm_installer so I couldn't run it, should I download again ? **EDIT**

Just ran tdm_update.linux64 again, one update - newjob.pk4, TDM still seems to be 2.09/64 and my memory just blanked as I can't remember where I found the revision number but I'm guessing that hasn't changed either

Started TDM, downloaded "Hare in the Snare", crashed to desktop when it completed downloading, download appears to be OK though

Guys, if this is going to be fixed in a later update I can live with it until then, don't let me divert you from important stuff, it's not a showstopper

Edited by esme
Link to comment
Share on other sites

Please delete tdm_update and forget about it.
I believe it should give you a warning when you run it, saying that it is not going to work anymore.

tdm_update cannot be used to install TDM 2.09a.
If you ignore its warning, it will install original/old 2.09 version.

You need to get tdm_installer.linux64.zip and run tdm_installer.linux64.
If you don't have it, download it from website and unpack to the directory where TDM is installed.


Link to comment
Share on other sites

On 8/27/2021 at 12:19 AM, Araneidae said:

Hi @stgatilov, didn't realise it was time to drop tdm_update altogether.  Can I suggest that tdm_installer delete it, then?

Yes, sound like a good idea.
I wanted for both installer to coexist for a bit of time, but that time is already over now.

Link to comment
Share on other sites

Okidoki, downloaded the installer & extracted tdm_installer.linux64 to /home/darkmod, it wasn't marked as executable so I changed it's permissions

Slight correction it's actually /home/karen/darkmod, files just shows it as Home/darkmod

Properties for /home/karen are drwxr-xr-x

Properties for /home/karen/darkmod are drwxr-xr-x

Double clicked it & got a very nice GUI front end, clicked OK without touching anything else, the text indicated 2.09a was being installed

Had a look at the tdm_installer log file once it finished, no errors that I could see "Closing installer after successful install" is the last line. I can upload the log if you need it

tdm_update seems to have been deleted by the installer

Ran TDM, the screen resolution had reset to 800x600 at 4:3 resolution so I reset that, front screen still says version "2.09/64", installer log file says "release209a"

Set up "Living expenses" & "The Painters Wife" for download & told it to go do it

"Living expenses" was downloaded & TDM crashed to desktop without attempting "The Painters Wife"

Looking in the fms folder there's a "living_expenses.pk4" file, this seems to be OK, I can open it & see the contents

Rerunning TDM & selecting "new mission" I get the in game pop up saying "Living expenses" is available as a new mission

Exiting TDM & looking at the fm's folder "living_expenses.pk4" appears to have been installed in a "living_expenses" subfolder

"living_expenses" seems to play OK

Just in case it's a hangover from an earlier install/update I would have no issue wiping the entire TDM installation & restarting from scratch if that would help


Link to comment
Share on other sites

  1. tdm_installer_XXX.log files

  2. .zipsync/lastscan.ini

  3. manifest.iniz

    Says it's too big to attach here can I mail it to you ?
  4. condump (open game console with tilde and execute "condump qq")
Edited by esme
Removed uploaded files to save taaki's space as they're now on the web
Link to comment
Share on other sites

52 minutes ago, esme said:

Says it's too big to attach here can I mail it to you ?

Maybe upload somewhere and post link?

Anyway, I looked through the files which you provided, everything exactly matches what I have locally.
All pk4 files are present, have same size and same number of files.
I think your installation is fine, and that's some sort of bug that hits you.

Could you please record core dump of TDM next time it crashes?
Note that it will be really big (hundreds of megabytes), so you will need some cloud storage like google drive...

Link to comment
Share on other sites

The game seems to play perfectly, downloader is the only problem, it doesn't seem to happen every time either, I've downloaded at least one mission without a crash or hang, maybe it's some sort of race condition & my system is just on the edge of the sweet spot ?

The target drive is an SSD if that's any use to you

I'll sort out some web/cloud space & get back to you

How do I get a core dump ?

And thanks for all the help so far


Sorted my web space, I think, let me know if you have any problems





Edited by esme
sorted out web space
Link to comment
Share on other sites

1 hour ago, esme said:

How do I get a core dump ?

This link describes ulimit command.
I think you run the command, then run TDM and get crash, after that search for a large file (nearby? at some predefined location?)

I checked your manifest.iniz: all the files have exactly the same contents as on server.
So your installation is perfectly good.

Link to comment
Share on other sites

Generating a dump looks to be a little more complicated than just using ulimit as I've failed to make a core dump twice so far

I opened a terminal window in the darkmod folder & executed the following

ulimit -a
ulimit -c unlimited

First line checks the current setting, second sets the size as unlimited, third runs tdm, I tried downloading a few missions and annoyingly it seemed to work until I tried setting up more than one mission for download, then I got a crash to desktop, but no dump file

Just in case it's of any use this is the log from the terminal window terminal.log

I'll get back to you when I work out why I'm not generating a core dump

Edited by esme
Link to comment
Share on other sites

You can set "com_error_crash 3", then TDM will crash on any error or warning.
This way it is easier to test code dump saving.

Also, sometimes TDM exits without hard "crash", maybe it's this cae.
You can try to set "com_error_crash 2" (crash hardly on error or fatal error) and use mission downloader.
Maybe it will help...

Link to comment
Share on other sites

OK, I repeated the previous test, as soon as TDM was running I opened the console and entered "com_error_crash 2" assuming that was more sensitive than 3, closed the console & downloaded files until I got a crash to desktop, still no core file anywhere to be found, I even tried searching from the root

My system is obviously stopping it being created, so I'll have a dig around, there may be something on the Zorin forums that'll help

I've just cleaned out all but the "training mission", "newjob" & "stlucia"  missions & edited missions.tdminfo to remove all but these, is there an easier way of cleaning these up ? I know I don't need to but I'm downloading just to test at the moment and it gets a little cluttered

Link to comment
Share on other sites

OK, not good news I'm afraid

For linux experts out there, there may be better or simpler ways of doing this, however this is the way I went, please don't shout at me

I've dug around and found the following site to be useful Understand and configure core dumps on Linux

As my system is a systemd system I needed to install coredumpctl to access any dump files, this was installed with

sudo apt install systemd-coredump

It's possible I didn't need this but I found it useful

To test if dumps were working I created a small program that would crash, NB I was working in the darkmod folder & made sure I didn't overwrite anything accidentally

File crash.c contains

int main()
 return 1/0;

I compiled this with

gcc -o crash crash.c

I ignored the compilation warnings & ran it with

ulimit -S -c unlimited

which gave me

Floating point exception (core dumped)

Running the following

coredumpctl list 

Shows I've successfully produced a dump file

TIME                            PID   UID   GID SIG COREFILE  EXE
Mon 2021-09-06 17:08:57 BST    3600  1000  1000   8 present   /home/karen/darkmod/crash

So far so good, my system does produce a crash dump & I can see it & extract it

Now we get to the not so good part

I ran TDM with

ulimit -S -c unlimited

I opened a console window, entered "com_error_crash 2", closed the console, went to the mission downloader, selected a bunch of missions for download and let it rip

TDM dutifully downloaded a few of the files in the list & then crashed to the desktop with a segmentation fault error

However coredumpctl isn't showing any new dump files, so I'm stumped


Tried TDM again using "com_error_crash 3" instead, and again no core dump produced

In case it's useful the last lines of the terminal log are

Couldn't exec autocommands.cfg - file does not exist.
Found 0 new mission packages.
Found 9 mods in the FM folder.
]com_error_crash 3
munmap_chunk(): invalid pointer
signal caught: Aborted
si_code -6
Trying to exit gracefully..
Shutting down sound hardware
double fault Segmentation fault, bailing out
shutdown terminal support
About to exit with code 11


Edited by esme
Link to comment
Share on other sites


What if you just execute "crash" command in TDM console, will you get code dump then?

Trying to understand what's going on straight on your machine won't be fun at all. I have uploaded debug symbols in case you have GDB skills.

I will also try to reproduce the problem myself in Linux VM (in fact, I should have done it much earlier), but I don't have much hope on it.

Also, you can try cleaning TDM directory --- maybe some old files cause the problem.
As a rule of thumb, you can delete all files except *.pk4 and *.zip. After that, unpack contents of tdm_shared_stuff.zip or simply run tdm_installer.
Note: I checked that your pk4/zip files are correct, but I cannot check the other files.
For instance, delete currentfm.txt, startingmap.txt, maybe fms/missions.tdminfo (that would delete marks about which mission you have played).

Clean install is also worth trying.

Link to comment
Share on other sites

As it failed with a SIGABRT I wondered if this was being handled differently so I rewrote the crash.c program & replaced the divide by zero with an explicit call to abort(), still produced a core dump, so that wasn't it

I'm sorry but I've never used GDB, just checked & I'd have to install it & I'd still need a crash dump to work on

So, I decided to go nuclear, I wiped my TDM installation, blew away the darkmod folder & started fresh

I've uploaded the filed you requested last time lastscan.ini, manifest.iniz, tdm_installer_1631024110.log & qq.txt

There's also the terminal log from the install process terminal.log

Just did the ulimit & run thing on the fresh install, selected the first 6 files for download, let rip & got 3 before seeing the desktop again, with the same last lines as before & no logfile, restarting TDM tells me I have 3 new missions

If I try a fresh install again remind me to reset the display resolution first

I've also tried opening the console & typing "crash" but still no core dump, well none that I can find

As this seems to be only happening on my system, I am OK to live with it, it's not a showstopper, the game itself plays great, don't let me drag you down some rabbit hole when you could be doing something fun

Edited by esme
my spelling sucks
  • Sad 1
Link to comment
Share on other sites

OK, I have a laptop, also with Zorin on, it has nowhere near the grunt needed to play TDM, but it should manage the downloads, I'm going to see if I can replicate the error & hopefully get a dump

Thoughts and prayers appreciated, the laptop is slooooooooow

Link to comment
Share on other sites

Couldn't sleep so I had a go with the laptop, still failed to get a crash dump of TDM even after verifying crash dumps were working with the crash.c program from earlier

I did however get a terminal log including a backtrace just in case that's any use to you

TDM complained mightily about opengl & glsl on this system but as I said the laptop doesn't have anywhere near the grunt needed for TDM but as all I was doing was testing the downloads I ignored the complaints

Link to comment
Share on other sites

On 9/9/2021 at 9:52 AM, esme said:

Couldn't sleep so I had a go with the laptop, still failed to get a crash dump of TDM even after verifying crash dumps were working with the crash.c program from earlier

I did however get a terminal log including a backtrace just in case that's any use to you

TDM complained mightily about opengl & glsl on this system but as I said the laptop doesn't have anywhere near the grunt needed for TDM but as all I was doing was testing the downloads I ignored the complaints

I tried to decipher it but failed.

There is another way to create core dump.

  1. Run the game under GDB: gdb ./thedarkmod.x64
  2. Type "run" and enter to start program
  3. When the game crashes, gdb will most likely break
  4. Run command in GDB: generate-core-file


Link to comment
Share on other sites

Ahhhhh, I didn't know you could do that

OK, installed gdb

Opened a terminal & cd'd to the darkmod folder

ulimit -S -c unlimited

gdb ./thedarkmod.x64


Picked 4 random missions for download & let rip

Didn't crash to desktop but TDM stopped so I alt tabbed to the terminal window & found a gdb prompt waiting for me did a generate-core-file & hallelujah we have a bouncing baby 1.3Gb core file 😃 🥳

core.6200 (1.3Gb)

I've downloaded & compared the files with no differences reported, md5sum for both files is "fcda3699c4a0b00f981018c2f407fd7d"

I really hope this helps

  • Thanks 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recent Status Updates

    • STiFU

      We are taking our son on his very first holiday trip to see the sea for the first time. 🙂 Will be back in a week.
      · 0 replies
    • Gilkar

      When I was a young man my father was so ignorant I could hardly stand to have him around. As I grew older I was amazed at how much the old man had learned in such a short time.
      · 1 reply
    • jaxa

      RTX 3090 Super, RTX 3070 Ti 16 GB, RTX 2060 12 GB
      · 0 replies
    • duzenko

      CPU benchmark time - compiling DarkRadiant (2nd run)
      i5 8600K 6C/6T@4.4GHz DDR4 2x2133MHz 9MB cache
      Parallel builds: 1. 3:57 Parallel builds: 6 (default). 2:28 r5 1600AF 6C/12T@3.3GHz DDR4 1x2666MHz 16 MB cache, temp folder on HDD
      Parallel builds: 1. 5:05 Parallel builds: 4. 2:47 Parallel builds: 6. 2:55 Parallel builds: 12 (default). 2:57
      · 6 replies
    • nbohr1more

      Status updates are back so it is also a good time to return to contests!
      · 0 replies
  • Create New...