Jump to content
The Dark Mod Forums
Sign in to follow this  
greebo

DarkRadiant 2.3.0 released

Recommended Posts

After updating, I noticed that my media tab is gone and I can't seem to get it back (hitting the shortcut doesn't do anything either). I don't get an AI tab when I click on an AI either. There appears to be something odd going on at the start of the tabs at the top.

post-9-0-69178900-1502807828_thumb.jpg

Share this post


Link to post
Share on other sites

I had the exact same glitch you had Springheel. I don't know if it's the case for you but I noticed it when I had multiple windows of Dark Radiant running. Needless to say, I stopped doing that.

Share this post


Link to post
Share on other sites

I only have one copy running. I see that the problem isn't there when I go to the embedded layout, but I'm used to using floating.

Share this post


Link to post
Share on other sites

I already fixed that one in source, expect it to be gone in the next release or pre-release, which isn't too far away. In the meantime, I can only suggest to use the Embedded layout as a workaround.

Share this post


Link to post
Share on other sites

Is there a way to split the big xy window into two in the embedded layout?

Share this post


Link to post
Share on other sites

No, I'd need code support for that. If there's a favourite layout you'd like to have, I can look into that, work-wise it's in the reachable range.

Share this post


Link to post
Share on other sites

No need, once the fix is in I'll go back to the floating windows.

Share this post


Link to post
Share on other sites

Something I've noticed that started happening last version and is continuing this version. It's as if selections are not being fully cleared under certain conditions:

 

1. Select an object in your map, then deselect it.

 

2. Add a new model.

 

3. Rotate the model with the rotation button.

 

4. The model does not rotate around its origin point. It rotates around a point as if the object in step 1 were still selected.

 

Unfortunately this isn't 100% replicable, but it has been happening to me fairly frequently.

 

In perhaps a related issue, I just had the following happen:

 

1. Selected a path_corner, moved it, deselected.

 

2. Added a model.

 

3. The model was added to the path_corner as if I had not deselected it. This happened multiple times until I selected a bunch of other things.

 

 

edit: I just caught it happening while recording. I selected an AI, deselected him, drew a brush, and when I went to free-rotate the brush it rotated around the AI's axis:

 

 

Share this post


Link to post
Share on other sites

Something I've noticed that started happening last version and is continuing this version. It's as if selections are not being fully cleared under certain conditions:

 

1. Select an object in your map, then deselect it.

 

2. Add a new model.

 

3. Rotate the model with the rotation button.

 

4. The model does not rotate around its origin point. It rotates around a point as if the object in step 1 were still selected.

 

Unfortunately this isn't 100% replicable, but it has been happening to me fairly frequently.

 

In perhaps a related issue, I just had the following happen:

 

1. Selected a path_corner, moved it, deselected.

 

2. Added a model.

 

3. The model was added to the path_corner as if I had not deselected it. This happened multiple times until I selected a bunch of other things.

 

 

edit: I just caught it happening while recording. I selected an AI, deselected him, drew a brush, and when I went to free-rotate the brush it rotated around the AI's axis:

 

I see what's happening there in the video, but I can't get it to replicate on my end. Is this affecting the rotation manipulator only?

 

I don't understand the part "The model was added to the path_corner as if I had not deselected it." You mean the model was added as child of the path_corner? Or its selection bounds were still including the path_corner?

 

I would have figured that I forgot to put code to reset the pivot point when switching manipulators, but I just checked the code, and when switching from the Drag tool to the Rotation tool the pivot point (the center point of those circles) is already recalculated from the current selection. So there must be indeed something dangling in the background causing the previously selected item to be included in the calculations.

 

Does it happen after some mapping time or right away after a fresh DarkRadiant startup as well?

Share this post


Link to post
Share on other sites
I can't get it to replicate on my end. Is this affecting the rotation manipulator only?

 

 

It affects both the rotate button and the manual rotate manipulator, and possibly more (see below).

 

 

I don't understand the part "The model was added to the path_corner as if I had not deselected it." You mean the model was added as child of the path_corner? Or its selection bounds were still including the path_corner?

 

 

What I mean is that when I added the chair model, a new "model" spawnarg was added to the path_corner, and both the chair and path_corner were considered a single entity.

 

I just quickly tried to reproduce it and couldn't either...I'll try to keep track of what conditions trigger it.

Share this post


Link to post
Share on other sites

What I mean is that when I added the chair model, a new "model" spawnarg was added to the path_corner, and both the chair and path_corner were considered a single entity.

 

I just quickly tried to reproduce it and couldn't either...I'll try to keep track of what conditions trigger it.

 

So it's definitely the selection tracking that's going wrong in the background, this is very odd. Yes, please keep an eye out for the actions you did before DR screws it up, it's most likely a specific sequence that is derailing the code.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...