Jump to content


Photo

DarkRadiant 2.3.0 pre-release phase


  • Please log in to reply
52 replies to this topic

#26 Bikerdude

Bikerdude

    Mod hero

  • Member
  • PipPipPipPipPip
  • 18447 posts

Posted 16 July 2017 - 08:47 AM

ad 1) what does the "Report..." dialog say? It should give some more information about what happened.

https://pastebin.com/SHkpe0KW



#27 greebo

greebo

    Heroic Coder

  • Root
  • 15950 posts

Posted 16 July 2017 - 11:56 AM

Thanks, there's more info in there than I'd hoped. I can see that CamWnd destructor is called far too late during shutdown, I need to check why this happens in OSX.



#28 greebo

greebo

    Heroic Coder

  • Root
  • 15950 posts

Posted 16 July 2017 - 01:27 PM

No luck here, I set a breakpoint to the location in question, but the app behaved by design, exactly the same as in Windows. I wonder if there's a difference when running DR in the newer macOS version (I'm on El Capitan here, I think that's 10.11).

 

Did you do anything in particular before shutting down the application? Switching layouts or creating additional Cam Views or something?

 

At least I can confirm that the crash is occurring very late during shutdown so everything has already been shut down and saved, no data loss is occurring.



#29 Nightcrawler

Nightcrawler

    Member

  • Member
  • PipPip
  • 76 posts

Posted 16 July 2017 - 01:39 PM

Greebo, I need some help obtaining the newest code from your git repository. I try to follow the instructions here: http://bugs.thedarkm...p?id=4490#c8999

But when I enter git pull, the following error message appears:

remote: Counting objects: 5, done.
remote: Total 5 (delta 4), reused 5 (delta 4), pack-reused 0
Unpacking Objects: 100% (5/5), ready.
From git://github.com/codereader/DarkRadiant
   510c6da00..cc51a0158  2.3        -> origin/2.3
Actualizing 929f4307c..2f8a5732e
error: Your local changes in the following files would be overwritten when merging:
    ltmain.sh
Please commit or stash your changes before merging
Canceled
How can I tell git to ignore the changes I made and just merge? Or would it be better to create a new directory and clone again?

#30 greebo

greebo

    Heroic Coder

  • Root
  • 15950 posts

Posted 16 July 2017 - 02:02 PM

You need to clean up the working copy before you pull. It's the autoconf-generated files that have been moved to the ignore list, somehow they are bothering git if they exist locally.

 

Just enter git stash to buffer your changed files to a local commit and pull again. Or clone afresh, it's not that much bandwidth. Afterwards, you'll have to run ./autogen.sh in any case before configure.



#31 Bikerdude

Bikerdude

    Mod hero

  • Member
  • PipPipPipPipPip
  • 18447 posts

Posted 16 July 2017 - 02:05 PM

  • I wonder if there's a difference when running DR in the newer macOS version (I'm on El Capitan here, I think that's 10.11).
  • Did you do anything in particular before shutting down the application? Switching layouts or creating additional Cam Views or something?
  • At least I can confirm that the crash is occurring very late during shutdown so everything has already been shut down and saved, no data loss is occurring.
  • Im running 10.12, should be close enough to the way 10.11 operates, but Im not a mac expert.
  • Nope, I can get that error to happen closing the DR with or without a map loaded.
  • Yeah, hence why i said it was a minor bug. I think DR on the PC did do this in some early versions of 2.x.x.


#32 greebo

greebo

    Heroic Coder

  • Root
  • 15950 posts

Posted 16 July 2017 - 11:35 PM

There's a new pre-release build (pre4) available in the first post, read there for details.

 

I'm aiming for a release upcoming weekend, so please give this a try if you can.



#33 Bikerdude

Bikerdude

    Mod hero

  • Member
  • PipPipPipPipPip
  • 18447 posts

Posted 17 July 2017 - 03:31 AM

Downloading and testing....



#34 teh_saccade

teh_saccade

    Member

  • Member
  • PipPip
  • 472 posts

Posted 17 July 2017 - 03:29 PM

it's certainly less painful on the retinas with the darker colours.



#35 Nightcrawler

Nightcrawler

    Member

  • Member
  • PipPip
  • 76 posts

Posted 17 July 2017 - 05:05 PM

I'm happy to confirm that the crash when importing prefabs is finally gone :)
 
Unfortunately there are a few more things in DR that I'm not happy with:
 
1) Selected models and entities become invisible in the 2D grid. To illustrate this:
 
Here nothing is selected:
AI_unselected.jpg?raw=1
 

Here only a entity is selected (and it is invisible in the 2D grid!):
AI_selected.jpg?raw=1
 

When entities/models are selected together with a worldspawn brush however they stay visible in the 2D grid
AI_and_worldspawn_selected.jpg?raw=1


That's a quite old bug (also had this in 2.2. and 2.1) but I was too lazy to find out how to upload images of DR and report it until now (sorry).

#36 Nightcrawler

Nightcrawler

    Member

  • Member
  • PipPip
  • 76 posts

Posted 17 July 2017 - 05:28 PM

2) The readable editor seems broken. At least I can't choose a GUI definition for two-sided books. This is what I did:

1. Create Entity -> readables -> atdm:readable_mobile_book01

2. Open the readable editor. Give the book an inventory name and an XData name.

3 .Click on the button right of the GUI Definitiion field.

4. Choose let's say readables -> books -> book_calig_summertime

The Layout switches to One-sided and the GUI Definition switches to guis/readables/sheets/sheet_paper_hand_nancy.gui, no matter what I select.

#37 Nightcrawler

Nightcrawler

    Member

  • Member
  • PipPip
  • 76 posts

Posted 17 July 2017 - 05:46 PM

3) The MD5 animation viewer doesn't work as I hoped. Here is what I mean:

1. I open the MD5 animation viewer and choose e.g. "tdm_ai_builderguard" from the list. Nothing appears in the 3D view window.

2. Only when I click on the "Pause render time" or "Stop render time" button, the model appears.

3. When I then choose an animation - let's say "bottle_idle01" again nothing happens, the model won't move/animate.

4. However when I then press the "Pause render time" button, the model changes its state (as if it just carried out the animation).

Well that is complicated to explain. I hope I expressed myself in an understandable manner...

#38 nbohr1more

nbohr1more

    Darkmod PR, Wordsmith

  • Development Role
  • PipPipPipPipPip
  • 7569 posts

Posted 17 July 2017 - 11:47 PM

Hmm.

The "Describes available Mouse Commands" window in the lower left appears to be covering some menu options
and there's no way to scroll or navigate to them.

(Windows 10 64-bit)

 

Screenshot?

 

Attached File  DR_2.3_v4.jpg   22.61KB   0 downloads


Please visit TDM's IndieDB site and help promote the mod:

http://www.indiedb.c...ds/the-dark-mod

(Yeah, shameless promotion... but traffic is traffic folks...)

#39 greebo

greebo

    Heroic Coder

  • Root
  • 15950 posts

Posted 18 July 2017 - 12:13 AM

I'm happy to confirm that the crash when importing prefabs is finally gone :)
 
Unfortunately there are a few more things in DR that I'm not happy with:
 
1) Selected models and entities become invisible in the 2D grid. To illustrate this:
 
Here nothing is selected:
 
Here only a entity is selected (and it is invisible in the 2D grid!):
 
When entities/models are selected together with a worldspawn brush however they stay visible in the 2D grid

That's a quite old bug (also had this in 2.2. and 2.1) but I was too lazy to find out how to upload images of DR and report it until now (sorry).

 

Hm, I don't see that in my Ubuntu 16.04 virtual machine.
 

 

2) The readable editor seems broken. At least I can't choose a GUI definition for two-sided books. This is what I did:

1. Create Entity -> readables -> atdm:readable_mobile_book01

2. Open the readable editor. Give the book an inventory name and an XData name.

3 .Click on the button right of the GUI Definitiion field.

4. Choose let's say readables -> books -> book_calig_summertime

The Layout switches to One-sided and the GUI Definition switches to guis/readables/sheets/sheet_paper_hand_nancy.gui, no matter what I select.

 

Confirmed, please open an issue for this. (Nevermind, created it here: http://bugs.thedarkm...ew.php?id=4575)

 

3) The MD5 animation viewer doesn't work as I hoped. Here is what I mean:

1. I open the MD5 animation viewer and choose e.g. "tdm_ai_builderguard" from the list. Nothing appears in the 3D view window.

2. Only when I click on the "Pause render time" or "Stop render time" button, the model appears.

3. When I then choose an animation - let's say "bottle_idle01" again nothing happens, the model won't move/animate.

4. However when I then press the "Pause render time" button, the model changes its state (as if it just carried out the animation).

Well that is complicated to explain. I hope I expressed myself in an understandable manner...

 

I can see there's weird behaviour. The render time is not displayed correctly either. Please open another issue for this.



#40 Bikerdude

Bikerdude

    Mod hero

  • Member
  • PipPipPipPipPip
  • 18447 posts

Posted 18 July 2017 - 03:32 AM

Selected models and entities become invisible in the 2D grid. To illustrate this:

All you need to do is change the colour of selected entities in the colour prefs.



#41 Nightcrawler

Nightcrawler

    Member

  • Member
  • PipPip
  • 76 posts

Posted 18 July 2017 - 06:23 AM

I did change the colour of "selected items" and "selected items (camera)", restarted DR but the selected entities and models were still invisible in 2D grid. You can see my colour scheme preferences here, but I doubt that this is a problem of prefereces.

 

DR%20Colour%20Scheme.jpg?raw=1



#42 Bikerdude

Bikerdude

    Mod hero

  • Member
  • PipPipPipPipPip
  • 18447 posts

Posted 18 July 2017 - 06:53 AM

Ah ok, and I see your on linux rather than windows.



#43 greebo

greebo

    Heroic Coder

  • Root
  • 15950 posts

Posted 21 July 2017 - 11:30 PM

New pre5 build is available in the first post.

 

@Spooks: please confirm the fixes for the issues you reported, if you get a chance.



#44 Bikerdude

Bikerdude

    Mod hero

  • Member
  • PipPipPipPipPip
  • 18447 posts

Posted 22 July 2017 - 04:46 AM

I did a bunch of mapping yesterday and the day before and I didn't noticed anything unusual, so on to testing pre5.



#45 Bikerdude

Bikerdude

    Mod hero

  • Member
  • PipPipPipPipPip
  • 18447 posts

Posted 22 July 2017 - 06:06 AM

Got some old bugs from 2.2.1 that are still present in 2.3.1.pre -

  • DR dosent initially remember location of surface inspector or Arbitrary transform  child windows, takes about dozen or so 'open and close' of the application before it remembers.
  • Drag-select while in texture tool window gets stuck on when the cursor dragging the selection box goes outside the texture tool window.
  • The tick selection tickbox in the Layers inspector, dosent disappear when pressed once DR has been open for a while. But colour of button does change and the layer is toggled - only fix is to restart DR.

@Greebo, would you like me to log detailed bug trackers for these..?


Edited by Bikerdude, 22 July 2017 - 07:45 AM.


#46 greebo

greebo

    Heroic Coder

  • Root
  • 15950 posts

Posted 22 July 2017 - 10:41 AM

DR dosent initially remember location of surface inspector or Arbitrary transform  child windows, takes about dozen or so 'open and close' of the application before it remembers.

 

When this happens, I need you to do the following, please: start up and confirm that the dialog is not showing up where it should be. Don't close the application (that would overwrite the user.xml file), but instead go and copy the user.xml in your Roaming\DarkRadiant folder to somewhere safe and show me its contents. Then we can compare the values saved there with the location you expected the dialog to show up.

 

(You can of course check yourself: open the user.xml file and look for the <surfaceInspector> tag, it should look something like this:

 

<surfaceInspector><window xPosition="200" yPosition="100" width="370" height="440"/> </surfaceInspector>

 

If these values aren't anywhere near the position you want them to show up, then we need to investigate further.
 

Drag-select while in texture tool window gets stuck on when the cursor dragging the selection box goes outside the texture tool window.

 

If this is reproducible (sounds like it is), then please open an issue for it.

 

The tick selection tickbox in the Layers inspector, dosent disappear when pressed once DR has been open for a while. But colour of button does change and the layer is toggled - only fix is to restart DR.

 

This only happens after a session has been going on for long? Care to take a screenshot of the faulty window?

 

Thanks for testing anyhow, this is appreciated.



#47 Bikerdude

Bikerdude

    Mod hero

  • Member
  • PipPipPipPipPip
  • 18447 posts

Posted 22 July 2017 - 11:18 AM

Grand, I will create trackers with detailed steps etc.



#48 Bikerdude

Bikerdude

    Mod hero

  • Member
  • PipPipPipPipPip
  • 18447 posts

Posted 22 July 2017 - 12:14 PM



#49 greebo

greebo

    Heroic Coder

  • Root
  • 15950 posts

Posted 22 July 2017 - 01:33 PM

Ok, thanks. It's unlikely I can fix any of these for the upcoming release, but at least the reports are here now, so chances are higher for them to get fixed in the next version.



#50 Judith

Judith

    Advanced Member

  • Member
  • PipPipPip
  • 516 posts

Posted 22 July 2017 - 05:01 PM

One minor thing that I just noticed: texture scale in surface inspector is limited to 3 digits after the decimal point. With big textures like 2048 you need precise scale values like 0.125 or 0.0625, and the latter gets rounded to 0.063.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users