Jump to content


Photo

TDM x64 blank screen


  • Please log in to reply
16 replies to this topic

#1 koo

koo

    Newbie

  • Member
  • Pip
  • 4 posts

Posted 08 November 2018 - 05:12 AM

TDM x64 starts with blank screen. Music is playing.

 

I get these warnings:

 

WARNING:shaderCompileFromFile(glprogs/shadowMap.vs) validation
0:1(10): error: GLSL 1.30 is not supported. Supported versions are: 1.10, 1.20, and 1.00 ES


WARNING:shaderCompileFromFile(glprogs/stencilShadow.fs) validation
0:1(10): error: GLSL 1.30 is not supported. Supported versions are: 1.10, 1.20, and 1.00 ES

 

The same happens even if I use the settings described in the http://wiki.thedarkm...06#Old_TDM_Look .

 

I also used the patch provided on the https://www.moddb.co...-intel-glsl-fix without success. I don't know if I applied the patch correctly. I have simply overwritten the file. Is that OK?
 

The operating system I use is Linux. The VGA Controller is Intel.

 

Abayo.


Edited by koo, 08 November 2018 - 05:13 AM.


#2 Bikerdude

Bikerdude

    Mod hero

  • Member
  • PipPipPipPipPip
  • 20223 posts

Posted 08 November 2018 - 06:09 AM

While you wait for one of the Linux guru's to get back to you, trying deleting the darkmod.config file and then restart.



#3 duzenko

duzenko

    Advanced Member

  • Active Developer
  • PipPipPip
  • 1705 posts

Posted 08 November 2018 - 08:36 AM

TDM x64 starts with blank screen. Music is playing.

 

I get these warnings:

 

WARNING:shaderCompileFromFile(glprogs/shadowMap.vs) validation
0:1(10): error: GLSL 1.30 is not supported. Supported versions are: 1.10, 1.20, and 1.00 ES


WARNING:shaderCompileFromFile(glprogs/stencilShadow.fs) validation
0:1(10): error: GLSL 1.30 is not supported. Supported versions are: 1.10, 1.20, and 1.00 ES

 

The same happens even if I use the settings described in the http://wiki.thedarkm...06#Old_TDM_Look .

 

I also used the patch provided on the https://www.moddb.co...-intel-glsl-fix without success. I don't know if I applied the patch correctly. I have simply overwritten the file. Is that OK?
 

The operating system I use is Linux. The VGA Controller is Intel.

 

Abayo.

I'd say your GPU is not compatible with TDM 2.06

I wish it was beta tested on a system old like that but it's quite rare I guess



#4 nbohr1more

nbohr1more

    Darkmod PR, Wordsmith

  • Development Role
  • PipPipPipPipPip
  • 9034 posts

Posted 08 November 2018 - 09:26 AM

Try setting:

r_softShadowsQuality 0
r_useFBO 0
r_useGLSL 0
Please visit TDM's IndieDB site and help promote the mod:

http://www.indiedb.c...ds/the-dark-mod

(Yeah, shameless promotion... but traffic is traffic folks...)

#5 koo

koo

    Newbie

  • Member
  • Pip
  • 4 posts

Posted 08 November 2018 - 11:02 AM

Did that. Won't work.

 

How can I download previous version/s?

 

Abayo.



#6 nbohr1more

nbohr1more

    Darkmod PR, Wordsmith

  • Development Role
  • PipPipPipPipPip
  • 9034 posts

Posted 08 November 2018 - 11:09 AM

Download the 2.0 full installer from this listing:

https://www.moddb.co...k-mod/downloads

then use the tdm_updater to upgrade from 2.0 to 2.01 and so on then interrupt the 2.05 to 2.06
step.

Otherwise, use the 2.0 to 2.01 (etc) zip packages on that same page to iteratively update.
Please visit TDM's IndieDB site and help promote the mod:

http://www.indiedb.c...ds/the-dark-mod

(Yeah, shameless promotion... but traffic is traffic folks...)

#7 noni

noni

    Newbie

  • Member
  • Pip
  • 1 posts

Posted 08 November 2018 - 11:13 AM

Try if you have a distribution based on Ubuntu or derivatives:

sudo add-apt-repository ppa:ubuntu-x-swat/updates

sudo apt-get update

sudo apt dist-upgrade

 

For uninstall:

sudo apt-get install ppa-purge && sudo ppa-purge ppa:ubuntu-x-swat/updates


Edited by noni, 08 November 2018 - 11:17 AM.


#8 nbohr1more

nbohr1more

    Darkmod PR, Wordsmith

  • Development Role
  • PipPipPipPipPip
  • 9034 posts

Posted 08 November 2018 - 11:18 AM

Another option:

http://forums.thedar...r-tdm-versions/
Please visit TDM's IndieDB site and help promote the mod:

http://www.indiedb.c...ds/the-dark-mod

(Yeah, shameless promotion... but traffic is traffic folks...)

#9 freyk

freyk

    Advanced Member

  • Member
  • PipPipPip
  • 701 posts

Posted 08 November 2018 - 04:10 PM

And upgrade to version 2.05.

#10 duzenko

duzenko

    Advanced Member

  • Active Developer
  • PipPipPip
  • 1705 posts

Posted 09 November 2018 - 03:54 AM

I think it's best for everyone if we fix this in 2.07 alpha

 

@koo, please try this and report the errors you have 

http://forums.thedar...cache/?p=429158



#11 stgatilov

stgatilov

    Lead Programmer

  • Active Developer
  • PipPipPip
  • 1049 posts

Posted 09 November 2018 - 09:08 AM

I believe it is possible to create updated version of shaders for 2.06.

Someone needs to unpack all shaders, then switch their version pragma to 120, then use glslvalidator on all of them.

Replace some in/out-s with varying/whatever, probably remove some code, and it will work.



#12 duzenko

duzenko

    Advanced Member

  • Active Developer
  • PipPipPip
  • 1705 posts

Posted 09 November 2018 - 09:57 AM

I believe it is possible to create updated version of shaders for 2.06.

Someone needs to unpack all shaders, then switch their version pragma to 120, then use glslvalidator on all of them.

Replace some in/out-s with varying/whatever, probably remove some code, and it will work.

I'm afraid it's not that simple

Shadowmap.gs will certainly break in any case and the only workaround for that is to delete the .pk4

We need to fix this in 2.07 anyway



#13 koo

koo

    Newbie

  • Member
  • Pip
  • 4 posts

Posted 12 November 2018 - 09:54 AM

I think it's best for everyone if we fix this in 2.07 alpha

 

@koo, please try this and report the errors you have 

http://forums.thedar...cache/?p=429158

 

Since I haven't found the instructions for applying the 2.07 version I assumed overwriting the contents of my darkmod folder with the zip file contents should do the trick.

I have tried the configuration for old tdm look. (r_nvidiaOverride 0, r_softShadowsQuality 0, r_useFBO 0, r_useGLSL 0) as well as the default configuration file and both return the same result.

------------- Warnings ---------------
during The Dark Mod initialization...
WARNING:Couldn't load sound 'sound' using default
WARNING:file materials/tdm_epi_shader_2.mtr, line 462: material 'wizard_cloth_001' previously defined at materials/tdm_epi_shader_2.mtr:366
WARNING:file materials/tdm_water.mtr, line 1208: material 'textures/particles/ripple_1' previously defined at materials/tdm_particles_ripple.mtr:1
WARNING:shaderCompileFromFile(glprogs/ambientInteraction.fs) validation
0:1(10): error: GLSL 1.30 is not supported. Supported versions are: 1.10, 1.20, and 1.00 ES


WARNING:shaderCompileFromFile(glprogs/ambientInteraction.vs) validation
0:1(10): error: GLSL 1.30 is not supported. Supported versions are: 1.10, 1.20, and 1.00 ES


WARNING:shaderCompileFromFile(glprogs/blend.fs) validation
0:1(10): error: GLSL 1.30 is not supported. Supported versions are: 1.10, 1.20, and 1.00 ES


WARNING:shaderCompileFromFile(glprogs/blend.vs) validation
0:1(10): error: GLSL 1.30 is not supported. Supported versions are: 1.10, 1.20, and 1.00 ES


WARNING:shaderCompileFromFile(glprogs/cubeMap.fs) validation
0:1(10): error: GLSL 1.30 is not supported. Supported versions are: 1.10, 1.20, and 1.00 ES


WARNING:shaderCompileFromFile(glprogs/cubeMap.vs) validation
0:1(10): error: GLSL 1.30 is not supported. Supported versions are: 1.10, 1.20, and 1.00 ES


WARNING:shaderCompileFromFile(glprogs/depthAlpha.fs) validation
0:1(10): error: GLSL 1.30 is not supported. Supported versions are: 1.10, 1.20, and 1.00 ES


WARNING:shaderCompileFromFile(glprogs/depthAlpha.vs) validation
0:1(10): error: GLSL 1.30 is not supported. Supported versions are: 1.10, 1.20, and 1.00 ES


WARNING:shaderCompileFromFile(glprogs/fog.fs) validation
0:1(10): error: GLSL 1.30 is not supported. Supported versions are: 1.10, 1.20, and 1.00 ES


WARNING:shaderCompileFromFile(glprogs/fog.vs) validation
0:1(10): error: GLSL 1.30 is not supported. Supported versions are: 1.10, 1.20, and 1.00 ES


WARNING:shaderCompileFromFile(glprogs/interaction.fs) validation
0:1(10): error: GLSL 1.30 is not supported. Supported versions are: 1.10, 1.20, and 1.00 ES


WARNING:shaderCompileFromFile(glprogs/interaction.vs) validation
0:1(10): error: GLSL 1.30 is not supported. Supported versions are: 1.10, 1.20, and 1.00 ES


WARNING:shaderCompileFromFile(glprogs/oldStage.fs) validation
0:1(10): error: GLSL 1.30 is not supported. Supported versions are: 1.10, 1.20, and 1.00 ES


WARNING:shaderCompileFromFile(glprogs/oldStage.vs) validation
0:1(10): error: GLSL 1.30 is not supported. Supported versions are: 1.10, 1.20, and 1.00 ES


WARNING:shaderCompileFromFile(glprogs/shadowMap.fs) validation
0:1(10): error: GLSL 1.30 is not supported. Supported versions are: 1.10, 1.20, and 1.00 ES


WARNING:shaderCompileFromFile(glprogs/shadowMap.gs) validation
P�,

WARNING:shaderCompileFromFile(glprogs/shadowMap.vs) validation
0:1(10): error: GLSL 1.30 is not supported. Supported versions are: 1.10, 1.20, and 1.00 ES


WARNING:shaderCompileFromFile(glprogs/stencilShadow.fs) validation
0:1(10): error: GLSL 1.30 is not supported. Supported versions are: 1.10, 1.20, and 1.00 ES


WARNING:shaderCompileFromFile(glprogs/stencilShadow.vs) validation
0:1(10): error: GLSL 1.30 is not supported. Supported versions are: 1.10, 1.20, and 1.00 ES


22 warnings
terminal support enabled ( use +set in_tty 0 to disabled )
pid: 15663
Async thread started
Couldn't exec autocommands.cfg - file does not exist.
Killed

 

 

Abayo.


Edited by koo, 12 November 2018 - 09:57 AM.


#14 duzenko

duzenko

    Advanced Member

  • Active Developer
  • PipPipPip
  • 1705 posts

Posted 12 November 2018 - 12:16 PM

 

Since I haven't found the instructions for applying the 2.07 version I assumed overwriting the contents of my darkmod folder with the zip file contents should do the trick.

I have tried the configuration for old tdm look. (r_nvidiaOverride 0, r_softShadowsQuality 0, r_useFBO 0, r_useGLSL 0) as well as the default configuration file and both return the same result.

Abayo.

Thanks

 

I will try to come up with a patch over the next few days



#15 duzenko

duzenko

    Advanced Member

  • Active Developer
  • PipPipPip
  • 1705 posts

Posted 13 November 2018 - 07:03 AM

Try this: https://drive.google...iew?usp=sharing

Also, add

seta r_fullscreen "0"

to your darkmod.cfg



#16 koo

koo

    Newbie

  • Member
  • Pip
  • 4 posts

Posted 14 November 2018 - 02:52 AM

I unpacked the contents of the zip file to my darkod directory.

 

The main screen works both ways, r_fullscreen 0 or 1. :)

 

I have successfullystarted the training mission and it looks like this https://we.tl/t-ME5PVgzRWg

 

Abayo.



#17 duzenko

duzenko

    Advanced Member

  • Active Developer
  • PipPipPip
  • 1705 posts

Posted 14 November 2018 - 03:43 AM

Try
Reloadglslprograms
In game console
Also, attach your darkmod.cfg

Edit
Oh wait - you're on linux, right?
Someone will have to compile the main executable binary for you.

If you could build on your system, that would be great




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users