Jump to content
The Dark Mod Forums

Search the Community

Showing results for 'black screen' in content posted in TDM Tech Support.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General Discussion
    • News & Announcements
    • The Dark Mod
    • Fan Missions
    • Off-Topic
  • Feedback and Support
    • TDM Tech Support
    • DarkRadiant Feedback and Development
    • I want to Help
  • Editing and Design
    • TDM Editors Guild
    • Art Assets
    • Music & SFX

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

  1. As far as I remember, TDM 2.09 requires OpenGL 3.3 to start. So either your OpenGL does not fit the requirement, or (as I guessed above) it has separate GL versions for core and deprecated profile. Perhaps version in core profile is newer than 3.3, but the version in deprecated profile is only 3.1 By the way, do you also have the problem with black screen in main menu and sound playing?
  2. I only have the default missions installed, the menu isn't visible at all. just a black screen with sound.
  3. Right, The game now runs but the screen is black. I can hear the menu music and when I move the mouse I can hear the menu names being selected.
  4. @duzenkoTwo problems, first I did have my folders named darkmod in succession so I renamed to tdm and darkmod respectively. But the asset issue was fixed cause I forgot to run the flippin launcher... LOL So the engine boots up however... @stgatilovThe first time running, it decompressed textures but the game wouldn't start. Launched a second time and I get a fullscreen window, but it hangs on a black screen, last item in terminal is "Async thread started". When I run "thedarkmod.custom.debug" I get an ELF Exec error like it's compiled for wrong architecture, however a 'file' shows it is an aarch64 ARM executable. My terminal output below: EDIT: I noticed below the line "Unknown command '#'", I do know one project I was compiling on required me to modify a C file and change the # hashtags to // double forward slashes as ARM assembly uses // for comments. *Shrug* wooty@wootylx2k-ubn:~/build/tdm/darkmod$ ./thedarkmod.custom TDM 2.10/64 #9574 (1435:9574M) linux-aarch64 Aug 23 2021 01:34:57 failed parsing /proc/cpuinfo measured CPU frequency: 1000.1 MHz 1000 MHz unsupported CPU found interface lo - loopback found interface enx00249b1e62ae - 151.151.88.220/255.255.0.0 found interface virbr0 - 192.168.122.1/255.255.255.0 Found Unsupported CPU, features: TDM using Generic for SIMD processing. Found 0 new missions and 0 packages. ------ Initializing File System ------ Current search path: /home/wooty/build/tdm/darkmod/ /home/wooty/build/tdm/darkmod/tdm_textures_wood01.pk4 (376 files) /home/wooty/build/tdm/darkmod/tdm_textures_window01.pk4 (389 files) /home/wooty/build/tdm/darkmod/tdm_textures_stone_sculpted01.pk4 (463 files) /home/wooty/build/tdm/darkmod/tdm_textures_stone_natural01.pk4 (133 files) /home/wooty/build/tdm/darkmod/tdm_textures_stone_flat01.pk4 (302 files) /home/wooty/build/tdm/darkmod/tdm_textures_stone_cobblestones01.pk4 (224 files) /home/wooty/build/tdm/darkmod/tdm_textures_stone_brick01.pk4 (520 files) /home/wooty/build/tdm/darkmod/tdm_textures_sfx01.pk4 (69 files) /home/wooty/build/tdm/darkmod/tdm_textures_roof01.pk4 (72 files) /home/wooty/build/tdm/darkmod/tdm_textures_plaster01.pk4 (142 files) /home/wooty/build/tdm/darkmod/tdm_textures_paint_paper01.pk4 (63 files) /home/wooty/build/tdm/darkmod/tdm_textures_other01.pk4 (127 files) /home/wooty/build/tdm/darkmod/tdm_textures_nature01.pk4 (286 files) /home/wooty/build/tdm/darkmod/tdm_textures_metal01.pk4 (497 files) /home/wooty/build/tdm/darkmod/tdm_textures_glass01.pk4 (51 files) /home/wooty/build/tdm/darkmod/tdm_textures_fabric01.pk4 (43 files) /home/wooty/build/tdm/darkmod/tdm_textures_door01.pk4 (177 files) /home/wooty/build/tdm/darkmod/tdm_textures_decals01.pk4 (465 files) /home/wooty/build/tdm/darkmod/tdm_textures_carpet01.pk4 (92 files) /home/wooty/build/tdm/darkmod/tdm_textures_base01.pk4 (407 files) /home/wooty/build/tdm/darkmod/tdm_standalone.pk4 (4 files) /home/wooty/build/tdm/darkmod/tdm_sound_vocals_decls01.pk4 (27 files) /home/wooty/build/tdm/darkmod/tdm_sound_vocals07.pk4 (1111 files) /home/wooty/build/tdm/darkmod/tdm_sound_vocals06.pk4 (696 files) /home/wooty/build/tdm/darkmod/tdm_sound_vocals05.pk4 (119 files) /home/wooty/build/tdm/darkmod/tdm_sound_vocals04.pk4 (2869 files) /home/wooty/build/tdm/darkmod/tdm_sound_vocals03.pk4 (743 files) /home/wooty/build/tdm/darkmod/tdm_sound_vocals02.pk4 (1299 files) /home/wooty/build/tdm/darkmod/tdm_sound_vocals01.pk4 (82 files) /home/wooty/build/tdm/darkmod/tdm_sound_sfx02.pk4 (605 files) /home/wooty/build/tdm/darkmod/tdm_sound_sfx01.pk4 (966 files) /home/wooty/build/tdm/darkmod/tdm_sound_ambient_decls01.pk4 (8 files) /home/wooty/build/tdm/darkmod/tdm_sound_ambient03.pk4 (24 files) /home/wooty/build/tdm/darkmod/tdm_sound_ambient02.pk4 (163 files) /home/wooty/build/tdm/darkmod/tdm_sound_ambient01.pk4 (220 files) /home/wooty/build/tdm/darkmod/tdm_prefabs01.pk4 (961 files) /home/wooty/build/tdm/darkmod/tdm_player01.pk4 (125 files) /home/wooty/build/tdm/darkmod/tdm_models_decls01.pk4 (103 files) /home/wooty/build/tdm/darkmod/tdm_models02.pk4 (2053 files) /home/wooty/build/tdm/darkmod/tdm_models01.pk4 (3163 files) /home/wooty/build/tdm/darkmod/tdm_gui_credits01.pk4 (49 files) /home/wooty/build/tdm/darkmod/tdm_gui01.pk4 (721 files) /home/wooty/build/tdm/darkmod/tdm_fonts01.pk4 (696 files) /home/wooty/build/tdm/darkmod/tdm_env01.pk4 (152 files) /home/wooty/build/tdm/darkmod/tdm_defs01.pk4 (187 files) /home/wooty/build/tdm/darkmod/tdm_base01.pk4 (198 files) /home/wooty/build/tdm/darkmod/tdm_ai_steambots01.pk4 (24 files) /home/wooty/build/tdm/darkmod/tdm_ai_monsters_spiders01.pk4 (80 files) /home/wooty/build/tdm/darkmod/tdm_ai_humanoid_undead01.pk4 (55 files) /home/wooty/build/tdm/darkmod/tdm_ai_humanoid_townsfolk01.pk4 (104 files) /home/wooty/build/tdm/darkmod/tdm_ai_humanoid_pagans01.pk4 (10 files) /home/wooty/build/tdm/darkmod/tdm_ai_humanoid_nobles01.pk4 (48 files) /home/wooty/build/tdm/darkmod/tdm_ai_humanoid_mages01.pk4 (8 files) /home/wooty/build/tdm/darkmod/tdm_ai_humanoid_heads01.pk4 (100 files) /home/wooty/build/tdm/darkmod/tdm_ai_humanoid_guards01.pk4 (378 files) /home/wooty/build/tdm/darkmod/tdm_ai_humanoid_females01.pk4 (172 files) /home/wooty/build/tdm/darkmod/tdm_ai_humanoid_builders01.pk4 (91 files) /home/wooty/build/tdm/darkmod/tdm_ai_humanoid_beasts02.pk4 (229 files) /home/wooty/build/tdm/darkmod/tdm_ai_humanoid_beasts01.pk4 (23 files) /home/wooty/build/tdm/darkmod/tdm_ai_base01.pk4 (9 files) /home/wooty/build/tdm/darkmod/tdm_ai_animals01.pk4 (82 files) File System Initialized. -------------------------------------- Couldn't open journal files failed parsing /proc/cpuinfo alternative method used /proc/cpuinfo CPU processors: 16 /proc/cpuinfo CPU logical cores: 16 ----- Initializing Decls ----- ------------------------------ I18N: SetLanguage: 'english'. I18N: Found no character remapping for english. I18N: 1277 strings read from strings/english.lang I18N: 'strings/fm/english.lang' not found. Couldn't exec editor.cfg - file does not exist. execing default.cfg Unknown command '#' Couldn't exec autoexec.cfg - file does not exist. I18N: SetLanguage: 'english'. I18N: Found no character remapping for english. I18N: 1277 strings read from strings/english.lang I18N: 'strings/fm/english.lang' not found. ----- Initializing OpenAL ----- Setup OpenAL device and context [ALSOFT] (EE) Failed to set real-time priority for thread: Operation not permitted (1) OpenAL: found device 'SB Omni Surround 5.1 Analog Stereo' [ACTIVE] OpenAL: found device 'Kensington SD4700P Dual Video Dock Digital Stereo (IEC958)' [ALSOFT] (EE) Failed to set real-time priority for thread: Operation not permitted (1) OpenAL: device 'SB Omni Surround 5.1 Analog Stereo' opened successfully OpenAL: HRTF is available OpenAL vendor: OpenAL Community OpenAL renderer: OpenAL Soft OpenAL version: 1.1 ALSOFT 1.21.1 OpenAL: found EFX extension OpenAL: HRTF is enabled (reason: 1 = ALC_HRTF_ENABLED_SOFT) OpenAL: found 256 hardware voices ----- Initializing OpenGL ----- Initializing OpenGL display Borderless fullscreen - using current video mode for monitor 0: 3440 x 1440 ...initializing QGL ------- Input Initialization ------- ------------------------------------ OpenGL vendor: AMD OpenGL renderer: AMD Radeon (TM) Pro WX 4100 (POLARIS11, DRM 3.40.0, 5.11.0-31-generic, LLVM 12.0.1) OpenGL version: 4.6 (Core Profile) Mesa 21.3.0-devel (git-2b4b310 2021-08-21 hirsute-oibaf-ppa) core Checking required OpenGL features... v - using GL_VERSION_3_3 v - using GL_EXT_texture_compression_s3tc Checking optional OpenGL extensions... v - using GL_EXT_texture_filter_anisotropic maxTextureAnisotropy: 16.000000 v - using GL_ARB_stencil_texturing v - using GL_EXT_depth_bounds_test v - using GL_ARB_buffer_storage v - using GL_ARB_texture_storage v - using GL_ARB_multi_draw_indirect v - using GL_ARB_vertex_attrib_binding v - using GL_ARB_bindless_texture X - GL_ARB_compatibility not found v - using GL_KHR_debug Max active texture units in fragment shader: 32 Max combined texture units: 192 Max anti-aliasing samples: 8 Max geometry output vertices: 256 Max geometry output components: 4095 Max vertex attribs: 16 ---------- R_ReloadGLSLPrograms_f ----------- Linking GLSL program cubeMap ... Linking GLSL program bumpyEnvironment ... Linking GLSL program depthAlpha ... Linking GLSL program fog ... Linking GLSL program oldStage ... Linking GLSL program blend ... Linking GLSL program stencilshadow ... Linking GLSL program shadowMapA ... Linking GLSL program shadowMapN ... Linking GLSL program shadowMapNG ... Linking GLSL program ambientInteraction ... Linking GLSL program interactionStencil ... Linking GLSL program interactionShadowMaps ... Linking GLSL program interactionMultiLight ... Linking GLSL program frob ... Linking GLSL program soft_particle ... Linking GLSL program tonemap ... Linking GLSL program gaussian_blur ... --------------------------------- Font fonts/english/stone in size 12 not found, using size 24 instead. --------- Initializing Game ---------- The Dark Mod 2.10/64, linux-aarch64, code revision 9574 Build date: Aug 23 2021 Initializing event system ...852 event definitions Initializing class hierarchy ...172 classes, 1690368 bytes for event callbacks Initializing scripts ---------- Compile stats ---------- Memory usage: Strings: 45, 7160 bytes Statements: 20303, 812120 bytes Functions: 1278, 166124 bytes Variables: 91948 bytes Mem used: 2019680 bytes Static data: 3989840 bytes Allocated: 5034004 bytes Thread size: 7904 bytes Maximum object size: 884 Largest object type name: weapon_arrow ...6 aas types game initialized. -------------------------------------- Parsing material files Found 0 new missions and 0 packages. Found 3 mods in the FM folder. Parsed 0 mission declarations, no mission database file present. -------- Initializing Session -------- session initialized -------------------------------------- Font fonts/english/mason_glow in size 12 not found, using size 48 instead. Font fonts/english/mason_glow in size 24 not found, using size 48 instead. Font fonts/english/mason in size 12 not found, using size 48 instead. Font fonts/english/mason in size 24 not found, using size 48 instead. --- Common Initialization Complete --- WARNING: terminal type 'xterm-256color' is unknown. terminal support may not work correctly terminal support enabled ( use +set in_tty 0 to disabled ) pid: 4706 Async thread started Killed
  5. Alright: When I load my FM in DarkRadiant I see just a handful of relevant messages highlighted in orange or red in its console. Stage keyword not recognised: portalrendermap Stage keyword not recognised: screen ShaderLibrary: definition not found: black ShaderLibrary: definition not found: Default ShaderLibrary: definition not found: textures/darkmod/wood/floor/boa Error parsing mirrorRenderMap. Expected two integers: stoi Stage keyword not recognised: _scratch2 [shaders] Unable to load texture: textures/decals/stain01bwet.tga ShaderLibrary: definition not found: tudor01_doorwin_mix ShaderLibrary: definition not found: models/md5/chars/nobles/noblewoman/noblelegs The last two lines seem to address exactly what I'm seeing: Missing leg texture for the female mage, plus a missing window texture for one of the Tudor buildings.
  6. Wow, this is impressive I think crash on shader compilation is like getting internal compiler error from ordinary C++ compiler. Except that GLSL compiler is embedded, so consequences for crashing are much worse. Luckily, the problem can be worked around by simply removing the manylight shader. I think the black screen issue will return back to you after that By the way, do you want to go into the quest of reporting the issue to AMD? I recall I did it with the bug that texture fetches in global variable initializers didn't work, and got response like "upgrade GLSL version". At least that was response from someone from AMD, as far as I understood. Maybe a crash will get more attention. Also, it is very easy to debug if you attach a full crash dump...
  7. @Jedi_Wannabe, could you please check something about this issue? As written above, the problem depends on r_glCoreProfile cvar, which must be set in darkmod.cfg before starting TDM. We know that "r_glCoreProfile 2" does not work for you, but "r_glCoreProfile 0" does work. Does "r_glCoreProfile 1" work for you? Or you get black screen?
  8. I don't know if it's the same issue or an unrelated one, but I just got this weird artifact after entering the basement sewer area of Blackgrove Manor. It's red rather than black, but does appear a similar shape. It started on the left and sort of spread across the screen towards the right. UPDATE: Further experimentation revealed that Bloom is the cause of this particular artifact. If I disable bloom, the red boxes disappear. I then noticed some much smaller patches of the same red colour which were not affected by the bloom settings; these disappeared when I switched color depth to 16 bits rather than 64 bits.
  9. Btw, I'm running into the same problem after updating to 2.09. Tried changing all of the aforementioned CVARs, but nothing solved it. I ended up updating to one of the test builds (I think test15973-8787). I'm on a laptop with an Intel UHD 620 and a dedicated nVidia GeForce MX150 here. Switching GPUs doesn't change anything, except that the screen is turning all white on Intel, instead of all black on nVidia. I haven't tried wiping the entire TDM tree to see if any old assets (like glprogs) might be lying around, conflicting with the downloaded ones. I also haven't tried yet recompiling TheDarkModx64.exe, to have the glprogs copied over afresh in the post-build step. edit: a fresh download of 2.09 is working, so it seems something in my existing darkmod/ tree is messing things up.
  10. Hi Thanks for the Dark Mod. Like other user i get a black screen with audio after executing "TheDarkModx64.exe" Version TDM 2.09. System Windows 7-64, latest updates. Custom install TDM Version "test15973-8778" works fine, so far Custom install TDM Version "test15973-8787" works fine, so far Custom install TDM Version "test15973-8793" --> black screen with audio Custom install TDM Version "test15973-8795" --> black screen with audio Custom install TDM Version "test15973-8797" --> black screen with audio Custom install TDM Version "test16019-8980" --> black screen with audio Custom install TDM Version "test16019-8981" --> black screen with audio Custom install TDM Version "test_release209_5542" --> black screen with audio ******************************************************************************* Setting r_glCoreProfile "0" in the file Darkmod.cfg is the solution that works for me! ******************************************************************************* Report with system images and log files: Thief - The Dark Mod BlackScreenSolution Regards elC Thief_-_The_Dark_Mod_BlackScreenSolution.zip
  11. If it were not compatible, you should be getting a black screen because nothing could be rendered without textures. But in practice, it does render, just with confused texture associations. It looks and feels very much like a bug, but unfortunately I don't (yet) have access to an AMD device myself, so it' very hard to debug...
  12. Addendum: if image_usePrecompressedTextures "0" -> BLACK SCREEN (game is working)
  13. Same problem (black screen on v2.09), same solution (setting r_glCoreProfile "0"). System specs:
  14. Hi guys, First of all (it's my 1st message), I would say thank you so much for TDM (all your work is amazing)! I love you (big fan of Thief series from first one, just discovered & playing now TDM since weeks). I want to help. I'm Arch Linux user & IT cybersecurity engineer. I would like to submit something I did try to troubleshoot. As said I use multi screens (3 screens). When running TDM (<=2.09), only main monitor display run TDM, others turns black I did try several things, using CLI, windows manager, TDM CVARS, etc... nothing worked. Then I did use nvidia-settings GUI and when running TDM i did see that X config is rewritten. 2 screens got resolution turned off (that's why they turns black). Maybe it should be a great thing to improve that behavior? improving screen parsing & using? Set an option to select a screen? I don't know what is the best solution. May I help? And how? Trying to create a new build on my own? Thanks again. S3ph
  15. @id3839315 says the fourth script shows black screen, just like the first two. So the final decision is that "r_glCoreProfile 0" works fine, but "r_glCoreProfile 2" gives black screen. This may be some driver problem, e.g. some of the GL features previously hidden behind extension is not enabled by the problematic AMD driver under GL 3.3, while it should according to the specs. It is not just some function, because calling missing function would give immediate crash. Most likely some constant of mode. I think I have already ruled out: ARB_fence_sync ARB_buffer_storage (persistent mapping) ARB_bindless_texture (not used in menu anyway) ARB_draw_indirect (multi draw indirect --- not used in menu too) ARB_vertex_attrib_binding What else it can be? Maybe glDrawElementsBaseVertex (it was previously behind extension), maybe UBOs --- who knows. What can help here: Use deprecated profile --- I think this will serve as workaround. Request greater OpenGL version (e.g. 4.1 instead of 3.3) --- maybe it would help Hope that driver update would fix it.
  16. _apitrace_record3.cmd works, but 1 and 2 result in the black screen.
  17. Ok, I'll try to get some more information, but that would need more complicated steps from you. 1) Run tdm_installer without any custom checks, and make sure it installs release209 properly. Do not use test/dev versions for this! 2) Delete "currentfm.txt" file in TDM installation directory (if it exists). 3) Download apitrace from this link. It is a 7z archive with a folder inside. Unpack the contents of the folder into "C:\apitrace". Make sure that path "C:\apitrace\bin\apitrace.exe" indeed points to the executable! 4) Download attached zip file. Unpack its contents into the root of your TDM installation directory. Make sure you see files like "_apitrace_record1.cmd" in the same directory where you see "TheDarkModx64.exe". 5) Action time Run "_apitrace_record1.cmd". It will start TDM game, and after a bit of time you will hear music. Now press Ctrl+Alt+Tilde (~) to open console. Type "condump 1" and hit Enter. Then exit game by pressing Alt+F4. Note that you'll have to do it blind, so verify that both "1.txt" and "res1.trace" have been created in TDM directory. 6) Repeat point 5, but now run "_apitrace_record2.cmd" and execute "condump 2". 7) Repeat point 5, but now run "_apitrace_record3.cmd" and execute "condump 3". 8|) Take files "1.txt", "2.txt", "3.txt", "res1.trace", "res2.trace", "res3.trace" in TDM installation directory, and pack them all into 7z/zip archive. Upload the archive somewhere and share it for download. P.S. And if you start seeing the menu instead of black screen in any of the runs, of course report it 209_blackmenu_apitrace.zip
  18. I have the same problem too, and I also have a Radeon card. On Linux, however, instead of a black screen, it produces a bunch of colored artifacts obstructing view on the menu. I'll try both test versions and see the results1000
  19. test15973-8793 and test15973-8795 both result in the black screen no matter if it's seta r_useNewBackend "1" or seta r_useNewBackend "0".
  20. I have a Radeon HD 6450 graphics card. test15973-8778 works but test15973-8797 starts with the black screen.
  21. @Jedi_Wannabe, "dev15976-8815" is the very first dev build. Are you sure 'dev15976-8815' gives you black screen but release208 works properly? I hope you do not restore config file when switching versions?
  22. This seems to happen while leaning forward and frobbing, possibly in noclip? Will edit if I can replicate/get it to occur. Solved by restarting the game. Happened on Requiem and Perilous Refuge. Update: I have recorded the bug in action. My settings. My specs. Processor Information: CPU Vendor: AuthenticAMD CPU Brand: AMD Ryzen 7 3700X 8-Core Processor CPU Family: 0x17 CPU Model: 0x71 CPU Stepping: 0x0 CPU Type: 0x0 Speed: 3593 Mhz 16 logical processors 8 physical processors HyperThreading: Supported FCMOV: Supported SSE2: Supported SSE3: Supported SSSE3: Supported SSE4a: Supported SSE41: Supported SSE42: Supported AES: Supported AVX: Supported AVX2: Supported AVX512F: Unsupported AVX512PF: Unsupported AVX512ER: Unsupported AVX512CD: Unsupported AVX512VNNI: Unsupported SHA: Supported CMPXCHG16B: Supported LAHF/SAHF: Supported PrefetchW: Unsupported Operating System Version: Windows 10 (64 bit) NTFS: Supported Crypto Provider Codes: Supported 311 0x0 0x0 0x0 Video Card: Driver: AMD Radeon RX 5600 XT DirectX Driver Name: aticfx32.dll Driver Version: 27.20.14501.18003 DirectX Driver Version: 27.20.14501.18003 Driver Date: 11 13 2020 OpenGL Version: 4.6 Desktop Color Depth: 32 bits per pixel Monitor Refresh Rate: 59 Hz DirectX Card: AMD Radeon RX 5600 XT VendorID: 0x1002 DeviceID: 0x731f Revision: 0xca Number of Monitors: 2 Number of Logical Video Cards: 2 No SLI or Crossfire Detected Primary Display Resolution: 1920 x 1080 Desktop Resolution: 3840 x 1080 Primary Display Size: 23.54" x 13.23" (26.97" diag) 59.8cm x 33.6cm (68.5cm diag) Primary Bus Type Not Detected Primary VRAM Not Detected Supported MSAA Modes: 2x 4x 8x Memory: RAM: 16292 Mb
  23. I just installed tdm, and I clicked on the exe, when it loaded, the screen is all black, and what I assume is the main menu music is playing, with no video or graphics in the slightest. Any help is appreciated, thanks.
  24. Presumably this part is the problem? If the lighting interaction shader cannot be compiled, a black screen is likely to result.
  25. Also, for some reason it often helps to delete darkmod.cfg after an update, so that you get a new one when you next start TDM. Worth keeping a backup of it in case that doesn't fix the black screen.
×
×
  • Create New...