Jump to content
The Dark Mod Forums

Very low performance on AMD GPU


lowenz
 Share

Recommended Posts

Radeon Software 22.8.1 -> massive performance hindrance somewhere (AMD has modified something in the driver this time too).

The-Dark-Modx64-2022-08-16-10-59-04-761.

 

There's no specif option - resolution apart - having influence on this 😐

Edited by lowenz

Task is not so much to see what no one has yet seen but to think what nobody has yet thought about that which everybody see. - E.S.

Link to comment
Share on other sites

It's ALWAYS off 😐

Re-generated the cfg, abysmal performance remains.

 

TDM-specific issue, RBDoom3 (OpenGL) has no problem at all......

Edited by lowenz

Task is not so much to see what no one has yet seen but to think what nobody has yet thought about that which everybody see. - E.S.

Link to comment
Share on other sites

Hmm...

Is Uncapped FPS enabled ?

The standard Doom 3 FPS cap ( com_fixedTic 0 ) is known to steal a ton of performance in the latest drivers.

How does the Dhewm3 Doom 3 port perform ?

Please visit TDM's IndieDB site and help promote the mod:

 

http://www.indiedb.com/mods/the-dark-mod

 

(Yeah, shameless promotion... but traffic is traffic folks...)

Link to comment
Share on other sites

2 hours ago, nbohr1more said:

Hmm...

Is Uncapped FPS enabled ?

The standard Doom 3 FPS cap ( com_fixedTic 0 ) is known to steal a ton of performance in the latest drivers.

How does the Dhewm3 Doom 3 port perform ?

Uncapped (set to 80). But that's not the culprit (already tested).

RBDoom3 (not Dhewm): https://github.com/RobertBeckebans/RBDOOM-3-BFG

Perfectly flat 120 FPS.

Edited by lowenz

Task is not so much to see what no one has yet seen but to think what nobody has yet thought about that which everybody see. - E.S.

Link to comment
Share on other sites

13 minutes ago, AluminumHaste said:

What performance do you get in the menu just after game load?

That's weird. I just updated SVN and built binaries from source. Now performance dropped 100+ FPS

WIHA8aT.png

No problem in the menu!

Task is not so much to see what no one has yet seen but to think what nobody has yet thought about that which everybody see. - E.S.

Link to comment
Share on other sites

  • 2 weeks later...
  • 4 weeks later...

Still having the same problem, RX 570 with 22.9.1 (yesterday) drivers, REALLY low framerate (15 FPS).

No problem in the menus

The-Dark-Modx64-2022-09-22-01-54-43-802.

Edited by lowenz

Task is not so much to see what no one has yet seen but to think what nobody has yet thought about that which everybody see. - E.S.

Link to comment
Share on other sites

6 hours ago, lowenz said:

Still having the same problem, RX 570 with 22.9.1 (yesterday) drivers, REALLY low framerate (15 FPS).

No problem in the menus

The-Dark-Modx64-2022-09-22-01-54-43-802.

Darkmod.cfg ?

Please visit TDM's IndieDB site and help promote the mod:

 

http://www.indiedb.com/mods/the-dark-mod

 

(Yeah, shameless promotion... but traffic is traffic folks...)

Link to comment
Share on other sites

1 hour ago, lowenz said:

Pretty standard: https://pastebin.com/24PcxhFe

Thanks!

 

Do either:

seta r_shadowMapSinglePass "1"

or

setting Stencil Shadows in the GUI

improve performance at all ?

 

How about toggling:

r_softShadowsMipmaps "0"

?

  • Like 1

Please visit TDM's IndieDB site and help promote the mod:

 

http://www.indiedb.com/mods/the-dark-mod

 

(Yeah, shameless promotion... but traffic is traffic folks...)

Link to comment
Share on other sites

@lowenz

I think we need to fix the visibility of this since the CVAR's don't print to darkmod.cfg but also try disable the BVH optimizations:

  • r_modelBvhLightTris 0
  • r_modelBvhShadows 0

 

 

  • Like 1

Please visit TDM's IndieDB site and help promote the mod:

 

http://www.indiedb.com/mods/the-dark-mod

 

(Yeah, shameless promotion... but traffic is traffic folks...)

Link to comment
Share on other sites

Of course stencil improves, from 15 to 19 as expected 😛

And single pass doesn't make any difference.

 

No, the problem is somewhere else (related to the new OpenGL Radeon drivers)

Edited by lowenz

Task is not so much to see what no one has yet seen but to think what nobody has yet thought about that which everybody see. - E.S.

Link to comment
Share on other sites

41 minutes ago, nbohr1more said:

@lowenz

I think we need to fix the visibility of this since the CVAR's don't print to darkmod.cfg but also try disable the BVH optimizations:

  • r_modelBvhLightTris 0
  • r_modelBvhShadows 0

No difference, but I see they reset to their default values (3 / 1) every restart.

Edited by lowenz

Task is not so much to see what no one has yet seen but to think what nobody has yet thought about that which everybody see. - E.S.

Link to comment
Share on other sites

Also not getting the greatest FPS here:

 

BtF5LfF.png

 

Like, what in the world is in this scene that requires 100% GPU usage at 2.2Ghz and only gets 173FPS???

 

Looking at this corner can't even max to 300 fps.

q0hYWiD.png

Intel 12700K

Radeon 6800XT

I always assumed I'd taste like boot leather.

 

Link to comment
Share on other sites

  • 2 weeks later...

Does FPS jump up dramatically if SSAO and \ or Soft Shadows are disabled... or does it stay relatively low?

Does FPS scale depending on your Render Scale value or does it remain low no matter how low you set the render scaling or resolution?

Does FPS improve dramatically if you issue "killmonsters" in the console ?

Please visit TDM's IndieDB site and help promote the mod:

 

http://www.indiedb.com/mods/the-dark-mod

 

(Yeah, shameless promotion... but traffic is traffic folks...)

Link to comment
Share on other sites

Stable low, the only thing that matters is the resolution.

I'll test "killmonsters".

EDIT: it doesn't affect

 

In other OpenGL games no issue at all: Wo-B-2022-10-04-23-06-39-741.jpg

Edited by lowenz

Task is not so much to see what no one has yet seen but to think what nobody has yet thought about that which everybody see. - E.S.

Link to comment
Share on other sites

  • 1 month later...
On 10/4/2022 at 10:25 PM, lowenz said:

New drivers set, same problem

The-Dark-Modx64-2022-10-04-22-18-50-322.

Same problem with the new build BUT here's the catch:

With MESA OpenGL->D3D12 ( https://github.com/pal1000/mesa-dist-win/releases/tag/22.3.0-rc1 ) TDM works like a charm!

OpenGL (RX 570 RS 22.10.2 waiting for the november release) - can't go over 15 FPS

0.jpg


MESA OGL->D3D12 - 70 FPS

1.jpg

 

Please, fix! The OGL driver is good enough, it's something in the engine

Edited by lowenz

Task is not so much to see what no one has yet seen but to think what nobody has yet thought about that which everybody see. - E.S.

Link to comment
Share on other sites

3 hours ago, lowenz said:

Same problem with the new build BUT here's the catch:

With MESA OpenGL->D3D12 ( https://github.com/pal1000/mesa-dist-win/releases/tag/22.3.0-rc1 ) TDM works like a charm!

OpenGL (RX 570 RS 22.10.2 waiting for the november release) - can't go over 15 FPS

0.jpg


MESA OGL->D3D12 - 70 FPS

1.jpg

 

Please, fix! The OGL driver is good enough, it's something in the engine

Would you be willing to capture a tracy timeline?

https://wiki.thedarkmod.com/index.php?title=Tracy:_timeline_profiler

Probably a good idea to get a condump and darkmod.cfg too (just for the sake of consistency).

There might be new OpenGL errors (etc).

https://wiki.thedarkmod.com/index.php?title=Reporting_Problem

@stgatilov do you suppose all those texture bind noise errors that show when r_debugGLSL is enabled might be at fault here?

Maybe AMD penalizes those errors more?

Please visit TDM's IndieDB site and help promote the mod:

 

http://www.indiedb.com/mods/the-dark-mod

 

(Yeah, shameless promotion... but traffic is traffic folks...)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share


  • Recent Status Updates

    • peter_spy

      Perhaps an unpopular opinion: TDM team might benefit from someone with actual QA experience; someone with naturally and professionally developed curiosity, who is interested in how and why things work, how they break At least to me it's kind of mind-boggling how untested some rather important features are (first the absence alert feature for items, now the rope +body carry behavior).
      · 4 replies
    • nbohr1more

      The Dark Mod is hosting an Ask Me Anything thread on the PC Gaming reddit forum:  https://www.reddit.com/r/pcgaming/comments/10nfcwj/hello_we_are_the_international_development_team/
      Feel free to join the discussion there
      · 2 replies
    • stgatilov

      Bumped into an interesting piece of wisdom called Hyrum's Law:
      With a sufficient number of users of an API, it does not matter what you promise in the contract: all observable behaviors of your system will be depended on by somebody.
      · 5 replies
    • The Black Arrow

      I love playing The Dark Mod when it's cold in my place. Bonus points when it's a bit (or even very) dark and it's raining, too.
      · 2 replies
    • The Black Arrow

      I've been having stutters in Vulkan, apparently it's Nvidia Drivers' fault, so I reverted to 512 according to this: https://www.nvidia.com/en-us/geforce/forums/geforce-graphics-cards/5/505679/regular-microstutter-in-vulkan-applications-after-/?topicPage=40

      And no, that did NOT fix it. What's going on? My GPU is an RTX 2070, by the way.
      · 4 replies
×
×
  • Create New...