Jump to content
The Dark Mod Forums

Itches, Glitches & Anything Else...


Recommended Posts

  • Replies 1.9k
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Since I've stumbled over the same issue (and even tracked a needless bugreport), I've just commited the following:   Index: def/tdm_mover_base.def ===================================================

That's a pretty ambitious project that will require almost every trick in the book. I can sort of envision how you might use fences, skyboxes, and archways to assist with compartmentalization but over

I'd say it is perfectly doable if you make it almost planar, or with only mild height differences. The images below show how I would do it:   See how the mountains and houses always block the view f

Posted Images

It must be pretty tiresome to write the script parser for that, I mean which other language is using whitespace as syntax?

 

Don't know about the parser. Should be simple enough. Instead of keeping a counter for the indentation leevl, you just count the whitespaces in front of a statement. Should be simple enough. But it's IMO quite cumbersome for the developers. For small procedures it's quite good, but for bigger programs, I alwas run into problems and you need an editor that knows about that. If you try to edit with a normal editor you easily get into problems as Orb mentioned.

Gerhard

Link to post
Share on other sites
You mean: Language 2.0? :D

...?

My games | Public Service Announcement: TDM is not set in the Thief universe. The city in which it takes place is not the City from Thief. The player character is not called Garrett. Any person who contradicts these facts will be subjected to disapproving stares.
Link to post
Share on other sites

I'm not sure why you felt the need. Your misplaced reference puzzles me, sir!

My games | Public Service Announcement: TDM is not set in the Thief universe. The city in which it takes place is not the City from Thief. The player character is not called Garrett. Any person who contradicts these facts will be subjected to disapproving stares.
Link to post
Share on other sites

Excellent, yet another victim of the Incredible Reference Misplacer, my plans are working out, har har. Fear my posts!

 

Ok, let's just forget my statement before it gets even more embarrassing...

Link to post
Share on other sites

For some bizarre reason on Linux, about 9 times out of 10 the splash screen shows up as a correctly-sized but empty grey box, without the image. I have investigated with GDB and it seems that the process_gui() line which runs the gtk_main loop is completing, but only an empty window is displayed. Strange.

Link to post
Share on other sites

I had this only once so far. Is there some GTK image caching involved? Maybe it could be resolved if the process_gui() call is invoked several times?

Link to post
Share on other sites

Any ETA on a new snapshot? No rush, especially if there are blocking issues. I only ask because the last is a couple weeks old, and it's best not to verify and track against an outdated build. Also there has been some discussion (Sorry, I'm a bit behind ATM! :wacko:) of crash issues, and new libraries required, and I wasn't sure what the current state of things is.

Link to post
Share on other sites

I'm about to finish another step of refactoring, so if you're feeling adventurous, I can give you another snapshot tonight or so (i.e. in a few hours).

 

There will be need for some ogg/vorbis/openAL DLLs, but I will package that along with the snapshot.

Link to post
Share on other sites

I guess this might fit here as long as you're talkin splash screens.

 

Do we have any plans of updating/correcting the current splash? The hour hand on the clock says it should be about 11:50, but the minute hand is at 20 minutes.

Dark is the sway that mows like a harvest

Link to post
Share on other sites

You're talking about the splash screen of the main mod? This is probably the wrong place for this, but I've noticed it too. There's a forum called Main Menu & GUIs where this belongs.

Link to post
Share on other sites
Any ETA on a new snapshot? No rush, especially if there are blocking issues. I only ask because the last is a couple weeks old, and it's best not to verify and track against an outdated build. Also there has been some discussion (Sorry, I'm a bit behind ATM! :wacko:) of crash issues, and new libraries required, and I wasn't sure what the current state of things is.

I uploaded a new snapshot to the known location, link is also on the website.

Link to post
Share on other sites

Take your time. I won't be able to do much progress the next few days, I'm afraid. My last regular exam (the last before my final one) is due on June 6th.

 

Btw: I just removed the legacy Stack container from the libraries. :)

Link to post
Share on other sites

arg! I;ve had DR lock up three times in the last two days while viewing models and once when I reshaped a brush so that it disappeared. The model viewer lock ups occur either while browsing models, or right when the viewer opens.

 

Also sometimes when you use the copy texture you and paste texture, you have to copy it and paste it twice in order to paste the x,y,z,scale attributes.

Link to post
Share on other sites

Does this occur on a particular model? Is there a way for me to reproduce it?

 

Brushes will disappear if they get "degenerate", i.e. it has zero volume. DarkRadiant detects this and completely removes the brush from the map. Was this such a case? If yes, when exactly did it lock up, were you still holding down the mouse button?

 

Regarding the copy&paste texture needing two clicks: I never had that happen on me, could it be that you had some objects hidden and they might have interfered (invisible, but still catching MMB clicks)? That's a bug angua told me a while ago.

Link to post
Share on other sites

This happened to me yesterday too. I was going through all the models too see what was already available before posting on the models wanted thread. I can't recall the exact model it crashed on but I did remember it at the time and noted that when I reloaded DR and started again I skipped through to just before that and continued through it without problem. I eventually got half way through the Doom ones before I started skipping quickly to the end. It wouldn't surprise me if you start at the beginning and try to go through the lot... Haha!

 

BTW I note that it takes quite a while to open the list when first used and it hangs half way through for a few seconds. I just assumed that it was because the list is getting so huge. Maybe it could be broken into sub-lists so there could be divisions in the selector somehow? I don't know how the data is stored but if it were divided into min type-selectors? To the user it would not be much different (edit - any less convenient I mean) to selecting different parts of the tree. Dunno how that might work but just a vague thought..

Link to post
Share on other sites

@jdude: Which type of paste operation did you use? Ctrl-MMB or Shift-MMB? They are doing technically completely different things, that's why I have to know.

 

@jdude & Fidcal: Things happening randomly is not good - I hardly stand a chance of finding that problem. I hope that it happens to me one time so that I can track it down, otherwise I can't really do anything about such problems. It could be anything.

 

The ModelSelector can probably be changed to reload dynamically, I think the VFSTreePopulator can handle that.

 

Could you add these three issues to the bugtracker please?

Link to post
Share on other sites

Do you have Purify available? IOf something crashes randomly, it's usually either because of a thread synchonrization problem (which problably doesn't apply here), or it is a memory corruption somehwere (which I think more likely). Using Purify to analyze it might help in such cases.

Gerhard

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...