Jump to content
The Dark Mod Forums

Doom 3 Widescreen problem


Carnage
 Share

Recommended Posts

A few days ago I installed Doom 3 again to ensure that it's working properly when TDM will be released. The game runs fine but I can't seem to get the widescreen working. I've looked on several forums but it still isn't working. I've created the AutoExec.cfg and filled in all the necesarry variables. The orginal config file keeps changing a few things. Setting stuff to ultra high quality in the cfg works but the multisampling and r_mode "-1" are constantly changing back to their default figures. Multisampling isn't a big issue and I just forced in my Nvidia Control Panel. The r_mode is because when it doesn't stay on -1 I can't and Doom 3 won't use my custom Height and Width (1680 x 1050). Just to be clear the settings in my AutoExec aren't changing but the settings in the orginal cfg are which isn't a big issue if it would be using my AutoExec settings, but it isn't. At least not all of them. Besides changing the cfg I also tried to play with the recommended settings for a bit and then change the cfg, which seems to work for some people, but that also doesn't make a difference. If anyone has a solution it would be much appreciated.

Link to comment
Share on other sites

Have you tried changing the settings in DoomConfig.cfg instead of autoexec.cfg? I don't think autoexec is fully working, is it?

 

r_mode -1

r_customWidth 1680

r_customHeight 1080

r_aspectRatio 2

 

For TDM, this is a non-issue, as we have all these settings handled via our menus.

Link to comment
Share on other sites

Have you tried changing the settings in DoomConfig.cfg instead of autoexec.cfg? I don't think autoexec is fully working, is it?

 

r_mode -1

r_customWidth 1680

r_customHeight 1080

r_aspectRatio 2

 

For TDM, this is a non-issue, as we have all these settings handled via our menus.

 

Yeah I tried that as well, the exact figures as above but r_mode changes to 3 after I start the game.

 

Oh I forgot to mention, I also tried it through console and then vid_restart but that doesn't work as well.

 

Haven't played any TDM mission in a while, but you're saying I can set widescreen settings through the menu?

Edited by Carnage
Link to comment
Share on other sites

No. When this file is there, D3 shouldn't do any auto-configuration anymore. There's probably something else amiss on your end.

 

The file is 0 kb as far as I can see. Is that okay?

 

You may also want to try r_mode -1 in your shortcut properties.

 

So that should make it something like this....?

 

"D:\Games\Doom 3\doom3.exe" -r_mode -1 or should it be -r_mode "-1"?

 

Another thing I tried was to change the orginal config and then make it read-only but that didn't work either. When I start the game and go to the console I do get a warning that it can't write that config but that is logical I guess.

Edited by Carnage
Link to comment
Share on other sites

Yes, config.spec is supposed to be empty.

 

Try this command line:

 

"D:\Games\Doom 3\doom3.exe" +set r_mode -1

My games | Public Service Announcement: TDM is not set in the Thief universe. The city in which it takes place is not the City from Thief. The player character is not called Garrett. Any person who contradicts these facts will be subjected to disapproving stares.
Link to comment
Share on other sites

Try this command line:

 

"D:\Games\Doom 3\doom3.exe" +set r_mode -1

 

Thanks for the suggestion but that isn't doing the trick either.

 

Are you sure you don't still have any conflicting settings in any autoexec.cfg in base or any game folder? Try removing that for now if so.

 

Yeah I'm sure. I deleted the AutoExec.cfg but it still isn't working. The weird thing is that all the settings I put in the AutoExec.cfg were also changed in orginal config except for the multisampling and the r_mode. It's just those two settings that keep changing to default on start up, all the other things I put in work.

 

Thanks for all your suggestions guys. If you more I'd love to hear them and will try them out, much appreciated

Link to comment
Share on other sites

Sometimes, goofy things can happen when the TDM code isn't properly extracted by Doom 3.

 

Open up doom3/saintlucia/darkmod.pk4 by temporarily renaming the archive "darkmod.zip". Extract the gamex86.dll inside to the saintlucia folder (overwrite if it asks you.) Don't forget to rename the archive "darkmod.pk4" before you start up the dark mod again.

yay seuss crease touss dome in ouss nose tair

Link to comment
Share on other sites

Sometimes, goofy things can happen when the TDM code isn't properly extracted by Doom 3.

 

Thanks for your reply Mortem Desino. My problem isn't with TDM but just Doom 3. If I understand Greebo correctly and remember it correctly, screen resolution in TDM can be done in the menu, also widescreen so that's not really an issue. Doom 3 doesn't has these settings and it has to be done in the config but some important settings (r_mode and a little bit less important multisampling) keep changing back to their default.

 

Any new solutions or maybe an explanation why these settings change to default every time are welcome.

 

Could it be a graphics card problem? I've got a 7800 GT but I can play NFS Shift and some other games that were released after Doom 3 on 1680x1050. It would still be game related then I guess, but could that be the problem?

Edited by Carnage
Link to comment
Share on other sites

Mine's a gtx280 and I have it on 1680 x 1050 so certainly doom is able to handle it.

 

OK, when the obvious doesn't work we have to try silly things just in case. Even I did a silly thing once.

 

How about a typo, rogue space or something? Check some other values in doomconfig. BTW I noticed that in autoexec I put stuff without quotes but in doomconfig in quotes but then you must know that. Try copy pasting this direct copy from my own doomconfig...

 

seta r_customHeight "1050"

seta r_customWidth "1680"

seta r_fullscreen "0"

seta r_mode "-1"

 

Then try 600 x 800 just to make sure they are having any effect.

Link to comment
Share on other sites

seta r_customHeight "1050"

seta r_customWidth "1680"

seta r_fullscreen "0"

seta r_mode "-1"

 

I'm certain that I didn't make a typo. I did look at that because I was starting to think like that as well. The only thing that is different from mine, is that I have the fullscreen on "1". Aren't you playing in windowed mode if you have that one on "0"? Oh ..... when I look at your config I have the 1050 and 1680 the other way around. I'm at work at the moment but I'll try your settings and will let you know if it worked. OMG it would be such a stupid mistake...... Oh can I keep fullscreen on 1 or is 0 needed?

Link to comment
Share on other sites

You can do either fullscreen or window. I use window for testing as it's easier to switch to a notepad or look at other references and 1680 fits perfectly virtually fullscreen on my desktop. Glad that's come to a happy resolution anyway. :laugh: The thing with them being the other way round of course is just alphabetical order but the opposite of what we normally use.

Link to comment
Share on other sites

Well as you probably expected it works like a gem now :D. I'll certainly never make that mistake again :P. It's just because normally you always say 1680x1050 and not 1050x1680 that I made the mistake and never took a closer look where I filled it in. Thank you very much for your assistance. Lots of thanks for the other people leaving replies as well.

Link to comment
Share on other sites

  • 4 weeks later...

I have the same problem: widescreen just won't work. Specifically, whenever I use r_mode -1, the resolution resets to 640x480. It always ignores my custom-set height and width.

 

This is from doomconfig:

 

seta r_customHeight "1050"

seta r_customWidth "1680"

seta r_fullscreen "1"

seta r_mode "-1"

 

And this is from autoexe:

 

seta r_customHeight "1050"

seta r_customWidth "1680"

seta r_mode "-1"

seta r_fullscreen "1"

 

Plus:

 

"B:\Games\DOOM 3\Doom3.exe" +set r_mode -1

 

Yet, nothing works. It doesn't matter what I set the custom width/height as, it always causes a reset to 640x480. Again, this is a Doom 3 issue, not a Dark Mod issue.

Edited by scarykitties
Link to comment
Share on other sites

I have the same problem: widescreen just won't work. Specifically, whenever I use r_mode -1, the resolution resets to 640x480. It always ignores my custom-set height and width.

 

This is from doomconfig:

 

seta r_customHeight "1050"

seta r_customWidth "1680"

seta r_fullscreen "1"

seta r_mode "-1"

 

And this is from autoexe:

 

seta r_customHeight "1050"

seta r_customWidth "1680"

seta r_mode "-1"

seta r_fullscreen "1"

 

Plus:

 

"B:\Games\DOOM 3\Doom3.exe" +set r_mode -1

 

Yet, nothing works. It doesn't matter what I set the custom width/height as, it always causes a reset to 640x480. Again, this is a Doom 3 issue, not a Dark Mod issue.

 

Do you have the aspect ratio on 2? This means that the ratio will be 16:10. You won't see the resolution change in the menu even if 1680x1050 works, it will still be on 640x480 but you'll certainly notice the difference ;).

 

seta r_aspectRatio "2"

Edited by Carnage
Link to comment
Share on other sites

Also see http://wiki.thedarkmod.com/index.php?search=doomconfig.cfg&go=Go

 

It is most important that you follow that or one doomconfig can overwrite another.

Currently, I've only got the one in Doom 3/base, and I'm only trying to get Doom 3 itself to work for starters, so this shouldn't be the problem. Thanks for the suggestion, though.

 

I've added the r_aspectRatio to the autexec file, although it was already defined as 2 (by my doing) in doomconfig. Still, I don't really see a difference, and it continues to refuse my custom height and width. Why would it refuse to accept any custom height or width when r_mode is set to -1? I've got the 1.131 patch (latest version, I believe), so it all SHOULD be enabled and working...

Link to comment
Share on other sites

What are your system specs. I read somewhere that some Nvidia cards with certain driver versions had problems with Doom 3.

 

EDIT Maybe it's also an idea to delete any duplicate files/lines.

 

So deleting the +set line in de shortcut and the autoexec.

 

Did you also try to start the game with the original cfg file in read-only?

Edited by Carnage
Link to comment
Share on other sites

This might seem a bit silly, but have you tried using the video setting menu in TDM to change your resolution?

 

Change it with the settings menu, and open your Ctrl-Alt-~ console and type vid_restart. (so you avoid the whole doom 3 cfg overwrite)

yay seuss crease touss dome in ouss nose tair

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...