Jump to content
The Dark Mod Forums
Geep

Unwanted square overlay in lower left hand screen corner (2nd camera view?)

Recommended Posts

I'm building my first FM in DR, and for some reason, when I'm testing my unpackaged build, on world spawn there's a fixed square overlay in the lower left screen corner, a few cm on a side, with vague contents that morph as the player moves. It could I guess be a secondary camera (perhaps downward facing). This square doesn't appear when running other FMs in Win10, so it must be a problem with my build. No odd spawnargs on the info_player, and nothing I could find in the wiki or forum. Any help as to what this is and how to find it/turn it off would be much appreciated.

Share this post


Link to post
Share on other sites

Do you have any engine debug visualization turned on, in the console? I seem to recall seeing something like that before, when I turned on some of idtech4 debug commands but i'm not sure if that is the same case. 

Share this post


Link to post
Share on other sites

Not intentionally. Looked over the available console commands, and those bound to my keys... nothing too obvious as a cause. Another finding, though: The rectangle is not really an overlay, but appears behind game objects on top of the surrounding night-time Portal Sky texture (which is much more encompassing in my FM than the average FM). The Portal Sky stars are visible through this square, which perhaps is more like a square lightening filter... but the degree of lightening flickers as motion occurs.

Share this post


Link to post
Share on other sites

Solved (sort of)! There is evidently a minor bug in the way skybox tdm_sky_starry1 works with portal sky. The somewhat different tdm_sky_starry2 doesn't suffer it. The bug is not typically visible due to ground structures and clutter.

To reproduce the problem:
1) Start a new project, with a hollow box as a room (e.g., 512 units per side)
2) Texture the sides with portal sky, except give the floor a typical (not too dark) texture.
3) Outside the room, create prefab nature/skybox/tdm_sky_starry1.pfb
4) In the room centroid, create entity Lights/sources/atdm_ambient_world. As usual, extend its scope to all the room.
5) For easy bug detection, change its colour spawnarg to be something too bright, e.g., RGB(255,255,255).
6) Set the player start, then save, dmap, run.
7) Run the player around the floor perimeter, with the black sky to the player's left, and the player viewing the floor. As you move the player around, look for a small square in the lower-left corner of the screen, when that corner is over the portal sky texture. It's as if it's the view of a high-contrast security camera (attached to the player's chin?)

Edited by Geep

Share this post


Link to post
Share on other sites

Further insight: perhaps the water layer in tdm_sky_starry2 suppresses this effect. This anomaly is also see with other skyboxes (e.g., "fog") that uses animated textures of twinkle_stars or clouds. Indeed, even non-skybox brush walls with twinkle_stars applied exhibit this effect (didn't try clouds). So it's the animation shader code for these textures that is the likely culprit.

BTW, it turns out tdm_sky_starry2 wasn't a viable solution for me. Instead, putting in an unlit dark iron perimeter wall in front of the skybox did the trick, hid the anomaly.

Share this post


Link to post
Share on other sites
6 hours ago, duzenko said:

Congratulations, you have just discovered the Lightgem

Sorry, duzenko, but he´s got a valid point. This is something I discovered myself during learning how to map. Maybe it is linked to incorrectly sealed geometry.

Edited by JackFarmer

Share this post


Link to post
Share on other sites

Yes, this has been an intermittent problem for the last few years.  The bugtracker is still down, but there are some entries there about it.

Share this post


Link to post
Share on other sites

I believe the final solution for this issue will be moving the lightgem render in its own FBO

Share this post


Link to post
Share on other sites

So, this is a known issue. When looking into this oddity, I did try to consult the bugtracker, but found it down, as Springheel notes. When the tracker revives, it might be helpful to add a link back to this thread to an appropriate existing bug report. Otherwise, I've little more to add here.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...