Jump to content

Getting 1.07


texmex
 Share

Recommended Posts

Not feasable. It is likely that running a some FM with an older version of TDM will simply crash.

 

What we need is a mac person to maintain current TDM version mac compatibility.

Clipper

-The mapper's best friend.

Link to comment
Share on other sites

If 1.06 was the latest then that's the one I'm looking for.

 

http://www.moddb.com...he-dark-mod-106

 

Not feasable. It is likely that running a some FM with an older version of TDM will simply crash.

 

Are you sure, have you tried. Surly it depends entirely on the way he mission was done as to wither it will crash in 1.06 or be simply mission textures or other resources.

 

But back to 1.08 and OSX, we do actually need testers -

 

- http://forums.thedarkmod.com/topic/14106-building-under-mac-os-x/

 

And this chap is building a graphical installer for OSX -

 

- http://forums.thedarkmod.com/topic/14339-graphical-darkmodinstaller-for-mac-os-x-or-linux/

Link to comment
Share on other sites

Any mission built or updated after the version you're running will be unstable, and will likely crash. But there are plenty of pre-1.06 missions to play (and I believe 1.07 was still Mac compatible; we lost that when we changed the folder structure for going standalone).

Link to comment
Share on other sites

I'd still be playing on the latest working version if I had backed it up before upgrading my OS. Figured I'd just download TDM again after the upgrade, but that was a bummer…

 

Thanks for the 1.06 link! I fully understand some missions will fuck up, but I don't mind. It's not like all missions prior to 1.08 were updated to run only on this version, right? Too bad I'm no dev, that way I could've solved this the right way.

 

Oh and if someone do find the 1.07 version, I'd be much obliged!

Edited by texmex
Link to comment
Share on other sites

Having you tried the OSX version of 1.08 yet?

 

http://forums.thedarkmod.com/topic/14106-building-under-mac-os-x/page__view__findpost__p__302111

 

At least two people (the only two who have indicated an interest in an OSX version) have been able to run it with minimal issues.

Link to comment
Share on other sites

Having you tried the OSX version of 1.08 yet?

 

http://forums.thedar...post__p__302111

 

At least two people (the only two who have indicated an interest in an OSX version) have been able to run it with minimal issues.

I'd be happy to try, but I get a 403 error on that one.

 

Btw, the mirror of the Doom 3 1.3.1 RevA patch you link to renders as text in the browser instead of being downloaded. The Aspyr hosted one is broken. Just thought I'd report that too while I'm at it. :)

Edited by texmex
Link to comment
Share on other sites

Link to comment
Share on other sites

The version was 1.08 and malex's build. Basically I did what the pathes.txt file said. I the darkmod directory i put TDM.app, tdm_game03.pk4, gdb.sh and tdm_update.macosx. Then launched the binary TDM.app.

 

Doing all this on a MacBook Pro 8,1 with Intel HD 3000 graphic chipset, 8 GB of RAM and on OS X 10.8.2. FPS got up to around ≈25.

 

I also made TDM portable, that is I made it possible for the files to be located anywhere by having a shell script create symlinks on every launch. But that's another story. ^_^

Edited by texmex
Link to comment
Share on other sites

Here's what I believe should work. As I said I wrote a shell script (and put all files withing an .app-structure) for portability, but this should be working just as well, right. Get someone to verify it regardless. Have no wiki privileges so I'll just post it here. In markdown for some reason xD

 

6. Download the experimental ![OS X launcher](http://path/to/OSX10_6_i386.7z).

 

7. Copy the following files into your ~/Library/Application Support/Doom 3/darkmod folder:

* TDM.app (the one in the release folder)

* tdm_game03.pk4

* gdb.sh

* tdm_update.macosx

 

8. Start The Dark Mod by double-clicking the TDM.app application in your ~/Library/Application Support/Doom 3/darkmod folder.

Edited by texmex
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recent Status Updates

    • nbohr1more

      Anyone have any luck with light.setShader( string ) ? It seems to make whichever light you apply it to full-bright on the initial invoke?
      · 0 replies
    • thebigh

      I'm starting to think we need another mapping contest.
      · 9 replies
    • kano

      Don't you hate it when there's a quality discussion on a forum somewhere online about something, but then two disagreeing users derail and transform it into a back-and-forth poo slinging competition at one another?
      · 9 replies
    • Diego

      Oh look the status updates are back! 
      · 2 replies
    • JackFarmer

      After watching the first three and a half episodes of "The Sandman" last night, I realize once again that overly imaginative narratives are not for me. Also, the main actor looks like he has a toothache.
      Which makes me wonder, is there a Dark Mod mission with a medieval dentist?
      · 4 replies
×
×
  • Create New...