Jump to content
The Dark Mod Forums

Recommended Posts

Opening a thread for the bugs.

 

*Filter / All entities crashed DR. I could repeat the crash twice, then it started working. I am unsure how to repeat it, but others should be on the lookout for this. Always save your work before utilizing the filters.

 

*Entity inspector data entry field is incorrectly positioned, see below:

YgkVVkr.png

When the window is resized, it used to be so that the data entry field was in the bottom. Now the entry field stays put when the window is resized, and the mapper cannot expand the window to see more spawargs at once.

Clipper

-The mapper's best friend.

Link to post
Share on other sites

Opening a thread for the bugs.

 

*Filter / All entities crashed DR. I could repeat the crash twice, then it started working. I am unsure how to repeat it, but others should be on the lookout for this. Always save your work before utilizing the filters.

If you run into this again, please try to record a crashdump. In the Task Manager you can right-click the DarkRadiant.exe process and select "Create dump fille" or something along these lines. The .dmp file can be compressed pretty well. I can use that to locate the crash.

 

*Entity inspector data entry field is incorrectly positioned, see below:

When the window is resized, it used to be so that the data entry field was in the bottom. Now the entry field stays put when the window is resized, and the mapper cannot expand the window to see more spawargs at once.

You can move the divider, try to move the mouse just below the second entry box.

Link to post
Share on other sites

If you run into this again, please try to record a crashdump. In the Task Manager you can right-click the DarkRadiant.exe process and select "Create dump fille" or something along these lines. The .dmp file can be compressed pretty well. I can use that to locate the crash.

 

Will do!

 

I tried to replicate it, but could not. Maybe it was just rats.

 

You can move the divider, try to move the mouse just below the second entry box.

 

Oh, so it seems. But it still is very clunky feeling. If I expand the window, I have to pull the entry box down. Then if I make the window smaller, the entry box get into the wrong position again and every time I expand the window again I have to pull the entry box down. Could the entry box be permanently docked into the lowest part of the window?

Clipper

-The mapper's best friend.

Link to post
Share on other sites

If you run into this again, please try to record a crashdump. In the Task Manager you can right-click the DarkRadiant.exe process and select "Create dump fille" or something along these lines. The .dmp file can be compressed pretty well. I can use that to locate the crash.

 

Ahha! Found it. Steps to reproduce:

1) Open DR. Make new map. (I am using splitpane window layout, I am not sure if that matters.)

2) Create entity. Add a AI noblewoman character (atdm:ai_noblewoman01).

3) In the enitity inspector, add spawnarg def_head and give it a random value.

4) click the def_head line and choose "choose AI head"

5) select a head. Close the entity inspector. (This is important. If you do not close the enitity inspector, the crash will not happen.)

6) activate filters/filter all entities

7) DR crashes!

 

I can do this every time now.

 

DMP file is available:

http://www36.zippyshare.com/v/55832350/file.html

Clipper

-The mapper's best friend.

Link to post
Share on other sites

Not a serious bug ... more like an annoyance but ever since I got it built for the first time DR would always show version 1.8.0 in the about dialog.

 

Also the shared objects are getting the version suffix 1.8.0... don't know if this is intended it just seems odd.

/usr/lib64/darkradiant
/usr/lib64/darkradiant/libdds-1.8.0.so
/usr/lib64/darkradiant/libdds.la
/usr/lib64/darkradiant/libdds.so -> libdds-1.8.0.so
/usr/lib64/darkradiant/libmath-1.8.0.so
/usr/lib64/darkradiant/libmath.la
/usr/lib64/darkradiant/libmath.so -> libmath-1.8.0.so
/usr/lib64/darkradiant/libpicomodel-1.8.0.so
/usr/lib64/darkradiant/libpicomodel.la
/usr/lib64/darkradiant/libpicomodel.so -> libpicomodel-1.8.0.so
/usr/lib64/darkradiant/libscenegraph-1.8.0.so
/usr/lib64/darkradiant/libscenegraph.la
/usr/lib64/darkradiant/libscenegraph.so -> libscenegraph-1.8.0.so
/usr/lib64/darkradiant/libwxutil-1.8.0.so
/usr/lib64/darkradiant/libwxutil.la
/usr/lib64/darkradiant/libwxutil.so -> libwxutil-1.8.0.so
/usr/lib64/darkradiant/libxmlutil-1.8.0.so
/usr/lib64/darkradiant/libxmlutil.la
/usr/lib64/darkradiant/libxmlutil.so -> libxmlutil-1.8.0.so

post-34130-0-99915700-1416085528_thumb.png

Edited by PrinzEnrique
Link to post
Share on other sites

I tried to use 2.0 yesterday, and it would repeatedly crash when attempting to set invert mouse in camera view under the camera settings pane of preferences, has anyone else reported this or was it just affecting me?

Intel Sandy Bridge i7 2600K @ 3.4ghz stock clocks
8gb Kingston 1600mhz CL8 XMP RAM stock frequency
Sapphire Radeon HD7870 2GB FLeX GHz Edition @ stock @ 1920x1080

Link to post
Share on other sites

Ahha! Found it. Steps to reproduce:

1) Open DR. Make new map. (I am using splitpane window layout, I am not sure if that matters.)

2) Create entity. Add a AI noblewoman character (atdm:ai_noblewoman01).

3) In the enitity inspector, add spawnarg def_head and give it a random value.

4) click the def_head line and choose "choose AI head"

5) select a head. Close the entity inspector. (This is important. If you do not close the enitity inspector, the crash will not happen.)

6) activate filters/filter all entities

7) DR crashes!

 

I can do this every time now.

Thanks, please put that on the tracker - I can reproduce this as well.

Link to post
Share on other sites

I tried to use 2.0 yesterday, and it would repeatedly crash when attempting to set invert mouse in camera view under the camera settings pane of preferences, has anyone else reported this or was it just affecting me?

Can't reproduce that. Can you try to save a crashdump if you're in Windows?

Link to post
Share on other sites

Thanks, it's fixed in src now.

 

Excellent, thanks!

 

Another bug:

PruM0Eb.png

Light inspector / light properties. No preview of the light texture is available, just gray box. If I scroll down the list, sometimes the texture appears. When I stop scrolling and go back, there is only a gray box where I was sure I saw a light texture flash by when I was scrolling.

Clipper

-The mapper's best friend.

Link to post
Share on other sites

Another bug:

Light inspector / light properties. No preview of the light texture is available, just gray box. If I scroll down the list, sometimes the texture appears. When I stop scrolling and go back, there is only a gray box where I was sure I saw a light texture flash by when I was scrolling.

Fixed as well.

Link to post
Share on other sites

I'm having trouble resizing light volumes with the mouse after rotating the light: when I hold down the mouse button in the orthoview to resize one, sometimes DR resizes the other axis than the expected one, and sometimes only one axis will resize at all.

Some things I'm repeatedly thinking about...

 

- louder scream when you're dying

Link to post
Share on other sites
I'm having trouble resizing light volumes with the mouse after rotating the light: when I hold down the mouse button in the orthoview to resize one, sometimes DR resizes the other axis than the expected one, and sometimes only one axis will resize at all.

Thats normal and has been around for a very long time, check and see if there is a bug tracker for it and if not please file one.

Link to post
Share on other sites

Thats normal and has been around for a very long time, check and see if there is a bug tracker for it and if not please file one.

 

Oh, here it is--from only two months ago, in fact. Cheers.

 

http://forums.thedarkmod.com/topic/16587-light-volume-resizing-bug/page__view__findpost__p__355352

http://bugs.thedarkmod.com/view.php?id=3860

Some things I'm repeatedly thinking about...

 

- louder scream when you're dying

Link to post
Share on other sites

A minor annoyance: in the Readable Editor, the field "XData Name" won't let the user put any other characters than letters and numbers, including the underscore. To enter a string with an underscore, you have to write it somewhere else and paste it to the field.

 

Another minor annoyance: Ctrl + Tab works inconsistently. Sometimes the orthographic view loses focus and requires clicking on it before the shortcut starts working again.

  • Like 1
Link to post
Share on other sites

can't compile codereader's branch @ github under ubuntu 14.10

 

I get the following error:

 

(...)
 CXX	  render/darkradiant-OpenGLModule.o
 CXX	  render/darkradiant-OpenGLRenderSystem.o
render/OpenGLRenderSystem.cpp: In member function ‘virtual ShaderPtr render::OpenGLRenderSystem::capture(const string&)’:
render/OpenGLRenderSystem.cpp:86:9: error: ‘wxTheApp’ was not declared in this scope
	 wxTheApp->ProcessIdle();
	 ^
Makefile:2838: recipe for target 'render/darkradiant-OpenGLRenderSystem.o' failed
make[2]: *** [render/darkradiant-OpenGLRenderSystem.o] Error 1
make[2]: Leaving directory '/usr/local/share/d3bfg/src/DarkRadiant/radiant'
Makefile:742: recipe for target 'all-recursive' failed
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory '/usr/local/share/d3bfg/src/DarkRadiant'
Makefile:482: recipe for target 'all' failed
make: *** [all] Error 2

Biel Bestué de Luna - Github

Link to post
Share on other sites

A minor annoyance: in the Readable Editor, the field "XData Name" won't let the user put any other characters than letters and numbers, including the underscore. To enter a string with an underscore, you have to write it somewhere else and paste it to the field.

Please open an item on the bugtracker, I'll look into that.

 

Another minor annoyance: Ctrl + Tab works inconsistently. Sometimes the orthographic view loses focus and requires clicking on it before the shortcut starts working again.

Are there any specific steps to follow to get that odd behaviour? Any windows to open beforehand, or an operation, or using an inspector?

Link to post
Share on other sites

Still can't get Darkradiant 2.0.1 to remember layout settings. Not getting the crash on shut down anymore though so there's progress lol.

Confirmed, please add this to the tracker. Thanks for taking the time to record the video.

Link to post
Share on other sites

Another minor annoyance: Ctrl + Tab works inconsistently. Sometimes the orthographic view loses focus and requires clicking on it before the shortcut starts working again.

Are there any specific steps to follow to get that odd behaviour? Any windows to open beforehand, or an operation, or using an inspector?

 

I thought Gantolandon was referring to the same focus problem that blocks Esc and Ctrl+S, but in practice it seems a bit different. Try this: open a new map, create an entity (a rat, say) and immediately press Ctrl+Tab. For me it does nothing (neither changing the orthoview nor tabbing through inspectors) even though Esc and Ctrl+S still work under those circumstances.

Some things I'm repeatedly thinking about...

 

- louder scream when you're dying

Link to post
Share on other sites
I thought Gantolandon was referring to the same focus problem that blocks Esc and Ctrl+S, but in practice it seems a bit different. Try this: open a new map, create an entity (a rat, say) and immediately press Ctrl+Tab. For me it does nothing (neither changing the orthoview nor tabbing through inspectors) even though Esc and Ctrl+S still work under those circumstances.

I can reproduce that. It seems that the TAB key doesn't produce keydown events in Windows. The OS doesn't send it to the app, so I can't intercept it in the shortcut handler. Can you open a tracker entry for this case, please?

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...