Jump to content
The Dark Mod Forums

Slow Performance Fix


Jay32
 Share

Recommended Posts

I am experiencing extremely low framerate(20-30FPS average) in The Dark Mod and I wish to know if there is a fix or more information available.

 

I am currently running:

AMD FX 8370

16GB DDR3

Sapphire Radeon R9 380X NITRO 4GB Edition (Driver Version 16.6.1)

Windows 10 Home

 

This system is able to run virtually any other game on high settings at 60FPS at 1080p. I am aware that there have been issues with ATI cards, but failed to find any relevant fixes. The only fix I found was to disable Catalyst AI, but that no longer seems to be an issue on newer driver versions. Any feedback is appreciated. Thanks in advance.

Link to comment
Share on other sites

I'd be interested in this topic, since my laptop runs Darkmod awfully slow.

​OS: Debian 8 32bit

​Acer aspire 5736z with 3GB ram

​I've seen on the community hardware feedback page older computers with less RAM running TDM "fine", so it's suprising my old laptop can barely run it. My FPS is roughly 5-20. I know Intel GMA 4500M is crap, but still.

Edited by mylaptopsbad
Link to comment
Share on other sites

Here are some good defaults:

 

seta image_usePrecompressedTextures "1"
seta image_useNormalCompression "2"
seta image_useAllFormats "1"
seta image_useCompression "1"
seta image_preload "1"
seta image_downSizeBump "1"
seta image_downSizeBumpLimit "256"
seta image_downSize "1"
seta image_downSizeLimit "512"
seta image_downSizeSpecular "1"
seta image_downSizeSpecularLimit "64"
seta com_videoRam "512" (or however much video RAM you have)

seta r_swapInterval "0"
seta r_useIndexBuffers "0"
seta r_useCachedDynamicModels "1"
seta r_useShadowVertexProgram "1"

seta r_useEntityCulling "1"

 

 

You can try the different options for:

 

r_useCulling

 

You can try reducing the Lightgem impact by rendering it less:

 

seta tdm_lg_interleave "2"

 

or making it less accurate:

 

seta tdm_lg_weak "1"

 

You can also try removing fog:

 

r_skipFogLights 1

 

You can try removing particles (last resort)

 

r_skipParticles 1

  • Like 3

Please visit TDM's IndieDB site and help promote the mod:

 

http://www.indiedb.com/mods/the-dark-mod

 

(Yeah, shameless promotion... but traffic is traffic folks...)

Link to comment
Share on other sites

Thanks for all of these suggestions! Using the settings listed a few posts above I am able to maintain 60FPS in most areas of the game(albeit, only with vertical synchronization disabled). It's strange, this is the only program that I have had major performance issues. Isn't my hardware powerful enough to handle a game engine nearly twelve years in age? Thanks for all of your help, the game runs much better now.

  • Like 1
Link to comment
Share on other sites

Oh, I forgot one:

 

r_useSoftParticles "0"

 

it wont gain you too much performance but it can help if you don't want to disable particles outright.

Please visit TDM's IndieDB site and help promote the mod:

 

http://www.indiedb.com/mods/the-dark-mod

 

(Yeah, shameless promotion... but traffic is traffic folks...)

Link to comment
Share on other sites

 

Isn't my hardware powerful enough to handle a game engine nearly twelve years in age?

 

 

AMD is antithetical to legacy OpenGL for a few reasons:

 

1) It was largely designed by Nvidia whose vote in the OpenGL ARB committee overrides everyone elses

2) Nvidia's hardware implementation was almost a direct mirror of the OpenGL pipeline so anything AMD creates that runs OpenGL well could collide with hardware patents

3) AMD has it's own vision for how OpenGL should be implemented but few in the coding community know how to adopt those practices

thus they internally do not see a problem on their side because their own developer examples "run fine"

4) They don't have the budget to maintain a large OpenGL driver team

5) They have a strategic alliance with Microsoft DirectX due to Xbox 360 and Xbox One

6) Knowing their past problems (1, 2, and 4) they are eager to push Vulkan instead which will level the playing field and save them money

 

The other issue is your AMD FX CPU. The Bulldozer architecture introduced the concept of "shared floating point units" on the CPU. The idea is

that Floating Point units eat up tons of transistors and the GPU already has lots of them so why waste those transistors on the CPU when you could

instead add more cores. This idea is fine in theory but in practice, most older games and even many modern games do Floating Point math on the CPU.

They should've made their CPU driver pass the work to the GPU but instead they have been trying to evangelize coders to rebuild their old code.

Doom 3 is affected heavily here. The skinning operations are done on the CPU and require lots of Floating Point math. If we implement GPU skinning

in the future, this will be improved.

 

Oh...

 

You can also try renaming your Darkmod executable to DarkAthena.exe or Amnesia.exe to see if a driver profile improves performance.

  • Like 2

Please visit TDM's IndieDB site and help promote the mod:

 

http://www.indiedb.com/mods/the-dark-mod

 

(Yeah, shameless promotion... but traffic is traffic folks...)

Link to comment
Share on other sites

AMD is antithetical to legacy OpenGL for a few reasons...

 

The other issue is your AMD FX CPU.

That's a shame. I chose my hardware with power and budget in mind. Everyone I spoke to said getting an AMD CPU was a bad idea. But, other than this particular incident, it had been treating me quite well(Even in the new DOOM title released this year for example). For a video card, I was deciding between the GTX 960 and the R9 380X. I went with the latter due to it generally performing better. I am in no position to upgrade anytime soon, but the performance I am currently getting is very manageable. Again, thank you for your continued help.

Link to comment
Share on other sites

One thing we could possibly do is get our fans to pester hardware benchmarking websites to include The Dark Mod in their testing.

AMD will optimize their drivers for games where the FPS results are highly publicized.

  • Like 2

Please visit TDM's IndieDB site and help promote the mod:

 

http://www.indiedb.com/mods/the-dark-mod

 

(Yeah, shameless promotion... but traffic is traffic folks...)

Link to comment
Share on other sites

Unfortunately without the built in timeDemo getting fixed, there's no way to reliably reproduce results.

Except maybe making save games and packaging them along with maps, in performance intensive areas.

I always assumed I'd taste like boot leather.

 

Link to comment
Share on other sites

Hi, slow performance issue from first post may be caused by

seta tdm_lg_interleave "1"

from DarkMod.cfg.

I am also experiencing this problem (20 FPS max), the only way to fix this is to set this to

seta tdm_lg_interleave "0"

in DarkMod.cfg, then i have constant 60fps everywhere, but sadly this will disable lightgem functionality for good :(

 

Strangely, i played darkmod last year and there was no performance issue with lightgem, no significant frame drops. Also i didnt changed anything in my PC.

 

I am currently running:

AMD Phenom II X4 965

8GB DDR2

NVIDIA GeForce GTX 660 Ti 2GB with driver 368.81

Windows 10 Home

 

Anyone know how to fix this?

Link to comment
Share on other sites

Yes. Turning off lightgem calculation would certainly increase performance. :) The lightgem takes a top and bottom snapsot of the prism model that represents the player for light calculation. When set to 1 the calculations alternate from top to bottom every frame. You could try setting it to 2 but that has been known to cause choppiness when fps drops below 30 fps.

Link to comment
Share on other sites

TDM 1.7 was the last "Doom 3 mod" version.

 

TDM 1.8 has it's own dedicated executable but requires Doom 3 assets.

 

TDM 2.0 is fully standalone.

Please visit TDM's IndieDB site and help promote the mod:

 

http://www.indiedb.com/mods/the-dark-mod

 

(Yeah, shameless promotion... but traffic is traffic folks...)

Link to comment
Share on other sites

Yes. Turning off lightgem calculation would certainly increase performance. :) The lightgem takes a top and bottom snapsot of the prism model that represents the player for light calculation. When set to 1 the calculations alternate from top to bottom every frame. You could try setting it to 2 but that has been known to cause choppiness when fps drops below 30 fps.

I tried this already, setted to 2, 3, 5 and 10. Everytime there is choppiness :(

 

I wonder is this performance issue occurs on newer gfx, expecially gtx 9xx series, and/or newest cpu like i5 or i7. Anyone experienced noticeable frame drops on darkmod 2.04 with this kind of hardware?

Edited by Prometheus
Link to comment
Share on other sites

I tried this already, setted to 2, 3, 5 and 10. Everytime there is choppiness :(

 

I wonder is this performance issue occurs on newer gfx, expecially gtx 9xx series, and/or newest cpu like i5 or i7. Anyone experienced noticeable frame drops on darkmod 2.04 with this kind of hardware?

 

 

I have an Nvidia Geforce GT 730 with an i3-2130 (3.4Ghz)

 

Performance is better on 2.04 than 2.03 for me and tdm_lg_interleave works as expected in most cases.

 

Driver settings:

 

Do you have vsync enabled?

 

Is your power profile set to maximum performance?

 

Is the profile set to Single Display?

 

Are threading optimizations enabled?

 

also, please post your Darkmod.cfg

Please visit TDM's IndieDB site and help promote the mod:

 

http://www.indiedb.com/mods/the-dark-mod

 

(Yeah, shameless promotion... but traffic is traffic folks...)

Link to comment
Share on other sites

Some drivers have optimizations for Doom 3 that don't quite work with the GPL version we use.

We can only guess what may have changed in the code from when it was at id Software to when

it was released to the public.

 

Also, 2.04 has a few new shader effects like soft particles and depth corrected water that are more expensive

than older versions. You can regain some of the lost performance by replacing the shaders in 2.04 with 1.07

or 1.02 versions... (Eg take the heatHaze.vfp and rename it to heatHazeWithDepth.vfp then overwrite the existing

one in the glprogs folder in the pk4 pack.) and using the r_useSoftParticles 0 cvar to disable the new stuff.

 

Finally, 2.04 has smarter AI than the older 1.07 and earlier versions.

Please visit TDM's IndieDB site and help promote the mod:

 

http://www.indiedb.com/mods/the-dark-mod

 

(Yeah, shameless promotion... but traffic is traffic folks...)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recent Status Updates

    • nbohr1more

      Anyone have any luck with light.setShader( string ) ? It seems to make whichever light you apply it to full-bright on the initial invoke?
      · 0 replies
    • thebigh

      I'm starting to think we need another mapping contest.
      · 9 replies
    • kano

      Don't you hate it when there's a quality discussion on a forum somewhere online about something, but then two disagreeing users derail and transform it into a back-and-forth poo slinging competition at one another?
      · 9 replies
    • Diego

      Oh look the status updates are back! 
      · 2 replies
    • JackFarmer

      After watching the first three and a half episodes of "The Sandman" last night, I realize once again that overly imaginative narratives are not for me. Also, the main actor looks like he has a toothache.
      Which makes me wonder, is there a Dark Mod mission with a medieval dentist?
      · 4 replies
×
×
  • Create New...