Jump to content
The Dark Mod Forums
Sign in to follow this  
greebo

DarkRadiant 2.7.0 released

Recommended Posts

DarkRadiant 2.7.0 is ready for download.

It's a maintenance build for the most part, but it contains a few smaller improvements. As usual, a bit of refactoring and improvement has been happening under the hood, but this shouldn't have any negative impact. It's recommended to prefer this version over any previous release.

A new DarkRadiant User Guide is being worked on and available on the website https://www.darkradiant.net/userguide (also accessible through the About > User Guide menu option).

Windows and Mac Downloads are available on github: https://github.com/codereader/DarkRadiant/releases/tag/2.7.0 and of course linked from the website https://www.darkradiant.net

Thanks go out to all who helped testing this release!

Please report any bugs or feature requests here in these forums, following these guidelines:

  • Bugs (including steps for reproduction) can go directly on the tracker. When unsure about a bug/issue, feel free to ask.
  • If you run into a crash, please record a crashdump: Crashdump Instructions
  • Feature requests should be suggested (and possibly discussed) here in these forums before they may be added to the tracker.

Changes since 2.6.0

  • Feature: A method to deprecate models without breaking existing maps
  • Feature: Game/Project Setup should show recently used custom paths in the mission drop down list
  • Feature: Add "Choose Skin" button when editing model spawnarg of an existing entity
  • Feature: Let the 'Matching skins' folder start in expanded state when showing the SkinChooser
  • Fixed: Unhandled exception on start up when user XMLs are corrupt
  • Fixed: Rotation of x-oriented particles in Particle Editor is different than in-game
  • Fixed: Highlighted vertices of hidden brushes will move when moving highlighted vertices of visible brushes.
  • Fixed: Unmaximised DarkRadiant not remembering main window size and location
  • Fixed: Reload Models option in Create Model dialog window doesn't update the model
  • Fixed: Problem with satisfying readable objective "when closed"
  • Fixed: DR thinks an entity name of the form "Cylinder01" is the same as "Cylinder1"
  • Fixed: Syntax error in "Test for missing targets" script
  • Fixed: Bad normals produced by .ASE exporter
  • Fixed: No confirmation dialogue box when exporting combined models
  • Fixed: Undo/Redo Does Not Restore Light Color
  • Fixed: Blend export script fails
  • Fixed: Mouse Binding settings for Aux1 do not work
  • Fixed: Exporting bell_hand.lwo as ASE is producing an invalid model, which will fail to dmap
  • Fixed: Model exporter doesn't remember last export location
  • Fixed: Buttons to change spawnargs can affect entities that aren't currently selected
  • Fixed: Search box persists for some seconds after closing window or shifting focus
  • Fixed: Connecting lines to targeted entities don't show up if 'Default' layer was hidden
  • Fixed: Layers window: first click after opening isn't registered properly
  • Fixed: Entities with non-existent classnames are shown white instead of blue in orthoview
  • Fixed: Hitting cancel in 'Create Speaker' still creates a speaker

The list of changes can be found on the our bugtracker changelog.

Have fun mapping!

Share this post


Link to post
Share on other sites

Thanks for the dump! I'm going to need more info here,  I must be missing a step to get it to hang on my system.

In the dump I'm able to see that you were pressing the "s" key while being focused on the MediaBrowser tree, is this correct? DR is hanging when trying to create the arrow buttons in the search popup. So the "s" key is processed by the MediaBrowser, which interprets it as type-ahead search opening the popup - then it hangs for whatever reason.

Can you try again, please, paying close attention to what stuff you are clicking on after starting up DR. The more precise info I can get about what items you clicked in which order and which controls are focused while you were pressing the "s" key, the better I can try to reproduce it.

Also, please tell me what Windows version you are on? A hang while creating a bitmap button is very strange and this might as well be a bug. Other dialogs are using it as well, can you check out if the Layer dialog is working? Other dialogs using bitmap buttons are the button when selecting an "angle" spawnarg in the EntityInspector, or the AAS file selector dialog.

Share this post


Link to post
Share on other sites

Thanks greebo! It was great watching you make short work of my bug reports as they came in, and I can really appreciate those QoL fixes (i.e. clicks in the layers window always hitting their mark, 'Choose ...' buttons always affecting the intended entity)

Share this post


Link to post
Share on other sites

@greebo

New DMP file + a video showing what I do https://easyupload.io/xm9u56

It freezes when I dubbleclicked the texture, go with my pionter out of the media browser and press s (2:20 in the vid .. forgot to record the pointer). I didn't click outside the media browser yet, so normally it would input s into the little searchfield in de MB. I tried to recreate it with just a brush, but then no problems. With this more complex brush and the caulk if freezes. Yesterday I got back to 2.60 to do the same and there I had no problems. By the way, I press s before clicking outside the media browser half the time ...

Windows version =  Windows 7 professional. Servicepack 1

Edited by STRUNK

Share this post


Link to post
Share on other sites

Thanks for the effort, I'll have a look!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...