Jump to content
The Dark Mod Forums

Recommended Posts

Yeah. That was exactly why I got pissed off about these postings. It's not as if everybody just sits here and waits for some Vista user to complain and immediatly rush to the rescue. It's an open project and anybody can do what he likes (sort of), but there is no obligation that we have to support soemthing that some users might deem absolutely necessary.

I would also like to get some models and sound effects for my maps, but I can't expect all the others stop working on their stuff just to accommodate me, so I have to either do it myself, or if I can't ask poeple if they can do it and wait until I find somebody who can do it.

Really! No matter how much some think that Vista will fly, which it may not, because MS has problems selling it, except to the stupid people who think they are cewl if they put up with everything that MS throws at them. If it works, it's fine, and if not, well that's a problem that early adopters always have.

Vista will fly.

 

Failing to get DR working for it will be detrimental to the project.

 

My only concern was for the future of the project. I could easily have a dual booting PC if I was willing.

 

I don't expect anyone to rush to fix things for Vista UNLESS the "nip in the bud" issue was a problem.

 

And if that were the case I would hope that all DR coding effort would be focused on fixing that since without Vista support this project will be in trouble because...

 

Vista will fly.

I want your brain... to make his heart... beat faster.

Link to post
Share on other sites
  • Replies 172
  • Created
  • Last Reply

Top Posters In This Topic

greebo - this time it doesn't start at all. I get an error saying: "The application has failed to start because its side-by-side configuration is incorrect. Please see the application event log for more detail."

 

The only radiant.log is from 7 days ago.

I want your brain... to make his heart... beat faster.

Link to post
Share on other sites
greebo - this time it doesn't start at all. I get an error saying: "The application has failed to start because its side-by-side configuration is incorrect. Please see the application event log for more detail."

Damn, it works fine on this Vista machine here. Maybe I forgot to package a DLL along with DarkRadiant?

 

How far does it get before the message pops up?

 

Please try to extract the above package into a new folder.

Link to post
Share on other sites

Pops up straight away. Even if I unpack into a new folder.

 

Guys - I'm thinking of posting a poll about Vista at TTLG to see how many Thief players/Dromeders this could potentially affect, WITH the Dark Mod mentioned in it. What do you all think?

I want your brain... to make his heart... beat faster.

Link to post
Share on other sites

To be honest, I just don't care about how many users there are. Can we please stop to discuss whether Vista will be a success or not and focus on debugging it? Thanks.

 

@Subjective Effect: Please try to extract the stuff into a new, blank folder and see what it does.

Link to post
Share on other sites

Yes, for god's sake. We've already said we'll get it working on Vista when we have time, and greebo is actually going out of his way to *make* time. I can't fathom why that isn't enough.

Link to post
Share on other sites
Could it be a graphics driver issue? I know they changed a lot of the graphics stuff in Vista, and it is possible that different drivers support OpenGL in a different way which could affect the GTKGLext stuff.

I think I can exclude this possibility. When no graphics drivers are installed, i.e. only the barebone ones provided by MS, DarkRadiant can still startup, but the camera window is white. Once the ATI drivers were installed, DR can run just fine. The About dialog in DR is very helpful, because it prints the OpenGL version and manufacturer.

 

In the case of the default Vista drivers, the OpenGL version is 1.1 and the manufacturer is Microsoft. The real driver has a higher version and manufacturer is ATI.

Link to post
Share on other sites
I think I can exclude this possibility. When no graphics drivers are installed, i.e. only the barebone ones provided by MS, DarkRadiant can still startup, but the camera window is white.

 

Technically I think that is a bug -- OpenGL 1.1 should be enough to render the 3D view in non-lit mode. It doesn't explain SE's crash though.

Link to post
Share on other sites
Technically I think that is a bug -- OpenGL 1.1 should be enough to render the 3D view in non-lit mode. It doesn't explain SE's crash though.

Yes, it probably is a bug. The weird thing is, the first time I posted back here I even got it working with the default Vista drivers, but after that point, I always got that white screen. I couldn't get it to work (both release and debug build), but as soon as I upgraded the drivers, everything was fine.

Link to post
Share on other sites
Guys - I'm thinking of posting a poll about Vista at TTLG to see how many Thief players/Dromeders this could potentially affect, WITH the Dark Mod mentioned in it. What do you all think?

 

Please, don't post any polls on this subject right now. We're only a few days into fixing the problem. Knowing the number of people it will affect won't get the problem fixed any faster. It's also not that people aren't concerned, but rather...as a whole...it's only one concern of many. I don't want to see any of our coders burning themselves out on any single issue. It will get fixed, like any other issue, in due time. Just be patient, please.

Link to post
Share on other sites

I've got another candidate ready, another release build. The previous package still seemed to rely on the MSVC80.Debug stuff, can't say why.

 

http://208.49.149.118/TheDarkMod/DarkRadia...ta_Debug_13.zip

 

Please note that this package includes a MSVCR71.DLL, which I'm probably not allowed to distribute, I reckon. I just downloaded it from one of the hundreds of DLL sites, it might already be installed on your system (through Office or something else). If it proves to be necessary we must tell our users to download it themselves, as I don't want to see DarkRadiant getting into any troubles.

Link to post
Share on other sites

What does the status bar below the splash screen say before DR dies? Can you read anything?

 

The radiant.log doesn't get updated/recreated?

 

Another thought: Did you extract the package into a new folder or an existing installation? Try a new folder, please.

 

edit: Also, I don't know what I can do more to reproduce the crash on my system here. I uninstalled almost everything, the entire build environment has been removed from my system, there is no debugging or development program left on my end. I extracted the exact same ZIP package as above in a new folder and it loads just fine.

 

I'll try to remove my D3 folder, maybe this gets DarkRadiant off its rails. edit2: Nope, still works fine.

Link to post
Share on other sites
Failing to get DR working for it will be detrimental to the project.

 

Yes. I guess you are right. The whole mod is really pointless if it wouldn't work on Vista, so I guess we should immediatley stop all the work on it and make sure that everything is Vista Ready instead. <_<

Gerhard

Link to post
Share on other sites

Ok, I've done another test and reinstalled Vista from scratch. I extracted the above package (Vista_Debug_13.zip) and it works. It's a barenaked Vista installation without anything, I really can't see any more I can do to get DR running. It must be something specific to your installation, please try the points in my post above.

 

edit: It's Vista Ultimate installation, for the records.

 

edit2: Also, I tested this Vista_Debug_13.zip package on Windows XP and it works just as fine. At least some good news. :)

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...