Jump to content
The Dark Mod Forums
Sign in to follow this  
greebo

DarkRadiant 2.0.4 pre-release testing

Recommended Posts

So far i've had no problems with 2.04 pre8 .. infact i'm quite impressed with how speedy it is. Well done Greebo you finally pulled me from the depths of 1.8.1 (and that's no easy feat :P)

 

A lot of the crashing I would get with the earlier pre's has stopped as well, so far no crashes on pre8. I will update if there are any other issues of course and i'll keep an eye out for that odd bug you have Sotha

Share this post


Link to post
Share on other sites

I'm on pre8 as of this morning, with no issues to report.

 

Rock solid so far.

Share this post


Link to post
Share on other sites

There's a darkradiant.log at %appdata%/DarkRadiant.

 

Is it known that pre8 seems to forget shaders randomly, but rarely?

 

I've had that happen on 2.0.3 as well, I'm pretty sure it's just some sort of memory error when your map is too big, so it's a rare issue, but not a new one.

 

EDIT: Greebo, is it possible something can be done about this - 4131 - by the time 2.0.4 releases? I've done some tests and it's actually the brush vert points that get moved. Flipping, rotating or moving will all cause the verts to go slightly offgrid. The bug even affects primitives inside func_statics, which is the worst part since going inside dozens of FSs and ctrl+Ging to snap the verts back to the grid is a huge pain.

Edited by Spooks
  • Like 1

My FMs: The King of Diamonds (2016)



| Visit my Mapbook thread sometimes! | Read my tutorial on Image-Based Lighting Workflows for TDM! |

Share this post


Link to post
Share on other sites

Ah damn I just got a crash... where are the logfiles for dark radiant?

When you run into the crash, the only way for me to get something useful to work with is you collecting a crashdump. When the "DarkRadiant.exe has stopped working" message appears, leave it like that and head to the Task Manager to view the processes running on your machine. Select the DarkRadiant.exe from the list and right-click it to select "Save dump file" or something like that. This will write a huge file to the location you specify, compress this and make sure I can download it from somewhere - then the chances for me to debug and fix the crash are much higher.

 

Any additional information, like exact DR version and the steps you did right before the crash are helpful too.

 

With crashes I'm highly dependend on that, without your assistance I can barely do anything about them.

Share this post


Link to post
Share on other sites

EDIT: Greebo, is it possible something can be done about this - 4131 - by the time 2.0.4 releases? I've done some tests and it's actually the brush vert points that get moved. Flipping, rotating or moving will all cause the verts to go slightly offgrid. The bug even affects primitives inside func_statics, which is the worst part since going inside dozens of FSs and ctrl+Ging to snap the verts back to the grid is a huge pain.

No, sorry. Something like this is more work to investigate than I can afford at the moment, and I want to get the 2.0.4 release off my agenda before I'm starting to lose steam again. I try to address easy stuff or crashes or regressions over previous releases only. I'm not surprised that repeated rotation operations introduce slight inaccuracies in the floating point representation, but one needs to investigate more deeply.

Share this post


Link to post
Share on other sites

I've uploaded a new pre9 test build. It improves the freelook mode behaviour over the previous test releases.

 

Please take a final round of testing. If map editing using the mouse works fine in this build, I'm going to push this out, regardless of minor issues that may remain unresolved.

Share this post


Link to post
Share on other sites

No, sorry. Something like this is more work to investigate than I can afford at the moment, and I want to get the 2.0.4 release off my agenda before I'm starting to lose steam again. I try to address easy stuff or crashes or regressions over previous releases only. I'm not surprised that repeated rotation operations introduce slight inaccuracies in the floating point representation, but one needs to investigate more deeply.

 

No problem, the fact that the longstanding rotation bug's finally gone makes me a happy enough camper as it is.

 

edit: just FYI it's not just repeated rotation, it's also repeated movement like alt+up and down'ing a clipped brush a bunch of times. Really weird.

 

edit: here's another small bug, I copied a shader from a patch and pasted it on a brush and the scaling was 0.0019500000000000001. In 2.0.3 it used to be scale of 1, which still wasn't ideal but this is worse.

 

I've formalized this in a tracker issue here: http://bugs.thedarkmod.com/view.php?id=4329

Edited by Spooks

My FMs: The King of Diamonds (2016)



| Visit my Mapbook thread sometimes! | Read my tutorial on Image-Based Lighting Workflows for TDM! |

Share this post


Link to post
Share on other sites

I just crashed on 2.04 Pre9 .. i'm pm'ing you the dump file now Greebo

I know GW is using Win10, are there any other DR users testing this build running the same version of windows?

Share this post


Link to post
Share on other sites

The patch error message bug is back on pre9. Just encountered it when shift+mmbing on a bevel endcap.

 

edit: more like it's a very specific thing that hasn't been fixed... I'll see about putting up a testmap or something in the tracker.

 

e:e: whoops uploaded the map to the wrong report by mistake, re-uploaded to the right one now but if anyone can remove the old one it'd be fine.

Edited by Spooks

My FMs: The King of Diamonds (2016)



| Visit my Mapbook thread sometimes! | Read my tutorial on Image-Based Lighting Workflows for TDM! |

Share this post


Link to post
Share on other sites

And to just to confirm I got a crash to desktop like Goldwell has been having, but it only happened once - so next I will take a dump of it.

Share this post


Link to post
Share on other sites

Yes, please keep trying to catch a dump for that crash, I've already been in touch with Goldwell but I couldn't draw any information from his dumps, strangely enough.

Share this post


Link to post
Share on other sites

I tried to submit this on the bug forum but I'm guessing as a "reporter" I cannot submit bugs there?

 

I found an easy to reproduce (and quite annoying) bug where target lines don't disappear from buttons if they are turned into worldspawn.

 

To reproduce:

 

1) Create a basic brush and in addition a light entity

2) Turn the brush into a mover_button

3) Set the light entity as a target on the mover_button

4) You will now see the blue target line drawn between them

5) Select the mover_button you created from the brush, right click and convert it to world spawn

6) The brush is back to being a world spawn brush but the target line is still visible

 

To ensure it's not an issue removing the target line I tried to remove the target spawnarg from the mover_button and the target line disappeared so it seems like a specific bug to the method mentioned above.

 

Edit: And I should note restarting DR does not help the issue. I had this problem on pre9 and just updated to pre10 where the issue is happening there too.

Edited by Goldwell

Share this post


Link to post
Share on other sites

I tried to submit this on the bug forum but I'm guessing as a "reporter" I cannot submit bugs there?

Anybody signed up on the tracker should be able to submit bugs, do you have an account there?

Share this post


Link to post
Share on other sites

this is the laggy brushes i was referring to. not sure if others are haing the same issue?

comparing pre10 to an older build

https://youtu.be/UznQ8mXr8qM

 

 

i do have another suggestion with the 3d view port.

when you are in free look mode and hold ctrl, the view pans.

would it be possible when not in free look mode, hold ctrl, then use right mouse.

it should enter pan mode but not free look. so once you let go of mouse 2 it return the cursor.

 

this might cause an issue if ctrl is let go first.

Share this post


Link to post
Share on other sites

There is something I'd like to see fixed and added to DR.

 

1. Snap to grid doesn't always snap, and you have to move it for it to snap, and even then sometimes it won't.

 

2. There used to be an option in View to Filter out common textures like Clip, Nodraw etc etc. Be great if that

came back.

 

There is something else, but I can't remember right now, I'll edit this if remember it. lol

 

Neon (formerly Venus)


I have an eclectic YouTube channel making videos on a variety of games. Come and have look here:

https://www.youtube.com/c/NeonsStyleHD

 

Dark Mod Missions: Briarwood Manor - available here or in game

http://forums.thedarkmod.com/topic/18980-fan-mission-briarwood-manor-by-neonsstyle-first-mission-6082017-update-16/

 

 

Share this post


Link to post
Share on other sites

this is the laggy brushes i was referring to. not sure if others are haing the same issue?

comparing pre10 to an older build

https://youtu.be/UznQ8mXr8qM

I'll see whether I can fix that easily.

 

 

i do have another suggestion with the 3d view port.

when you are in free look mode and hold ctrl, the view pans.

would it be possible when not in free look mode, hold ctrl, then use right mouse.

it should enter pan mode but not free look. so once you let go of mouse 2 it return the cursor.

 

this might cause an issue if ctrl is let go first.

 

You can add that to the tracker as a new feature request, so it might be considered in the next phase. I won't handle new features for this 2.0.4 release.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...