Jump to content
The Dark Mod Forums
Sign in to follow this  
Fidcal

Fan Mission: Chalice of Kings by Fidcal (2009/10/17)

Recommended Posts

Fun mission, my favourite out of those three. The AI was a bit oversensitive and some parts frustrating, but still, this played and felt like the real thief.

 

Almost makes me want to try the editor. Almost.

Share this post


Link to post
Share on other sites

And where is the

 

 

key to the library ? (Assuming that the library is the double door entrance near the elevator)

 

 

 

 

Mudgeon has it. (The guy dressed as a nobleman upstairs in the grand bedroom. If you've already been in there then read the next spoiler

 

 

 

Mudgeon has two keys on his belt

 

Share this post


Link to post
Share on other sites

 

Mudgeon has it. (The guy dressed as a nobleman upstairs in the grand bedroom. If you've already been in there then read the next spoiler

 

 

 

Mudgeon has two keys on his belt

 

 

I must have missed the other one. Thank you for your help and your map !

Share this post


Link to post
Share on other sites

Simply the best TDM mission until here! :rolleyes:

 

Very well done, i really liked the patroling and guard positions on the map.

 

I only have the

 

 

bug (i presume) with the chalice at the end, not frobable. But i placed a book there, so i finished the mission without problem!

 

 

Really thanks Fidcal! ;)

 

We all wait for your next work with impatiance!

Edited by Ladro

Share this post


Link to post
Share on other sites

This is the first TDM mission I tried (save The Tears of St. Lucia demo), and I was really impressed. It felt absolutely Thief. I just played through on expert (might try ghosting it tomorrow when I have more time), but I still really enjoyed it.

 

 

I too ran into the problem where the coin purse behind the brick falls into the wall, but fortunately I had saved just before so I reloaded and pulled out the brick more carefully. Also, I'm not sure if the wall hanging above the brick is supposed to cover the brick or not, but I get the feeling it was since the brick wasn't frobbable until the wall hanging was moved up and out of the way. However, for me, the wall hanging did not cover the brick to start with.

 

 

I also ran into some other general weirdness, mostly with the physics of moving bodies and occasionally items, and a few strange sound glitches (for instance, sometimes after quicksaving, certain sounds would stop playing; loading solved the problem), but I imagine none of these are map-specific, and none of them were game-breaking.

 

Also, I ended up a couple hundred short on loot, which I was surprised about because I was pretty meticulous (I thought). Any chance of a loot map at some point?

 

Anyway, thanks for the great map, looking forward to more in the future :)

  • Like 1

Share this post


Link to post
Share on other sites

Thanks Rivian. I won't have time for a full loot list but here are one or two that might be less obvious:

 

 

painting in parlour

plates and bottles and bowl I think in kitchen store

ring in Lucy's room (ah! these poignant little touches

purse under the chess board

 

Share this post


Link to post
Share on other sites

French version of Chalice (just texts like readables and briefing etc) now available at

 

http://www.megaupload.com/?d=W1UDVURC

 

This uses the same filenames so I recommend anyone wanting this that they UNinstall Chalice if it is installed, exit Dark Mod, delete or rename your old doom3/chalice and delete darkmod/fms/chalice and put this pk4 in the fms folder.

Share this post


Link to post
Share on other sites

I've uploaded the French Chalice to our download server, and renamed the PK4 to chalice_fr.pk4, this should avoid any filename clashes.

Share this post


Link to post
Share on other sites

Yes, I avoided that because it still will show twice in the New Missions list. Still, probably that's simpler and one will show the pre-briefing in french.

Share this post


Link to post
Share on other sites

So the name of the French mission is still "The Chalice" and not "Le Calice"?

Share this post


Link to post
Share on other sites

I imagine its technically possible but whether the team want to divert manpower to that rather than other priorities seems unlikely - unless a newcomer volunteers and does all the hard work!

 

Recalling how Thief 2 worked I imagine that relevant folders would have eg, english (which reminds me, the fonts folder already does) and then the code would read the install language from eg, the config, eg, english, and then insert that string into the relevant paths. It duplicates a lot of work, voices as well as texts so I doubt it will happen.

Share this post


Link to post
Share on other sites

Possible spoilers, meant for Fidcal more than anything.

 

Pretty fun mission so far. Haven't finished yet but close (still haven't figured out how to obtain Chalice)

 

I got the crown and left the replacement in the same exact spot, went back and around to the elevator and then I came out on the other side hallways the guard all of a sudden noticed and said 'We've been robbed!' and they all started searching. I thought using the decoy would fix that.

 

I got in the back corner of the armory, behind all the staffs. I think this represents the largest issue I have had with the FM's altogether and it seemed like everyone (authors) did it a bit.

Small spaces.

There's just something about Dark Mod that is different than T2. It's not bad, just a difference in perspective or something and I think authors need to be careful when building because of it.

The main issue in the armory specifially was I bumped one of the staffs, which tilted out and blocked me in. It was leaning towards the wall and when I grabbed it it was wedged in that small space. I ended up having a puzzle of 10 staffs to move carefully to not make noise, it was like pickup-stix ;)

Move this one out of the way, that one falls over, so move another one.... finally with almost all the staffs moved and piled on other side of rack I was free.

I also got stuck on the lit fire once trying to go through the fireplace.

 

I thought the wood pillars mid hallway were slightly odd. Usually those would be against the wall. Just something that stood out to me.

 

Other than those small isssues I had alot of fun and thought it was a pretty well done mission.


Dark is the sway that mows like a harvest

Share this post


Link to post
Share on other sites

You probably didn't place the decoy well. It needs to be on the same spot as the original or they'll notice. I kinda think it's more fun when they notice later and I'm just round the corner smirking in a shadow. :)

 

Tight spaces: That's just me. I love small cluttered rooms. Wide plain long empty corridors do nothing for me.

 

If you get stuck you do the same as in Thief - squirm, jump, mantle, turn, also try crouch mantle.

 

I know little about architecture. I just built it quick in less than a month. Maybe all those pillars are a reaction against the wide flat impossibly unsupported ceilings I see in some FMs like an acre of planks or worse, horizontal bricks. Dunno. I didn't think about it.

Share this post


Link to post
Share on other sites

Better cluttered than no details!! After all, we have powerfull mantling capabilities ingame, so you can just climb on any peace of furniture (or whatever) that might "clutter" the room. And besides, there were a lot of wide spaces I think, but not every room has to be so wide, like a parlour for instance. :) But I agree that the armory was a bit undersized...

Share this post


Link to post
Share on other sites

I liked the mission overall , especially the crown replacement part but I couldn't ever shake the feeling that it was a bit too cheesy in the sense that you were always just finding keys in a rather limited space before opening some other area, finding a key there and going elsewhere. I guess it felt too monorailed and too much find this, find that, do this and then that in this precise order. The mask placement I did like and the fact that you can go through the fire places to cut your routes short and make it easier. I guess the issue was that it felt constrained, I could always figure out where I had to go and what I had to do. The mission for me was just moving a few objects around and finding what I had to get to go to the next area.

Edited by DingDong

Share this post


Link to post
Share on other sites
But I agree that the armory was a bit undersized...
Actually you can blame Springheel for that. The size of the room defined itself with the yard on one side and the corridor on the other. Then Spring came up with a shedload of new weapons and those stands and I just had to cram in as many as possible!

 

You want to lure a guard in there and then loose a broadhead. He'll probably say "what's a weapon doing in here?" LOL :laugh: Geddit? It's an armoury choked with weapns see and he's saying ...

Share this post


Link to post
Share on other sites

No, the crown WAS EXACTLY where the old one was. I was very meticulous about it and made sure I also made a clean quiet get-away so as not to startle them.

 

Also, as I said, I was stuck behind the staff I bumped. I couldn't move it because it was wedged between the wall and the rack at an angle. I had to move other poles so I could slightly move it and rotate it out.

I was not physically stuck on a wall or anything. Couldn't crawl under or jump over.

So I should've said I was 'blocked', not 'stuck'.

It was pretty funny never the less.

 

The point I was making about small spaces has nothing to do with being cozy, or places being wide open boring hallways. It has to do with actual gameplay areas just being a bit too small.

I mentioned it as something authors should watch for/be aware of/ improve apon.

I like small places too but there's a poit between being small and being cramped. In this case it was being cramped which effect gameplay when you can't move around, get stuck easy, get locked in by AI, etc...

 

For the pillars, you might not know much about arch, OK, now you do. You would only need supports like that for long spans. The wood floor planks would be strong enough to span a hallway (remember, back then wood was cut thick) when it is supported on both sides by a wall.

I pointed it out because I read in another thread you didn't know much about arch and thought it would help you next time around.

 

Take posts with a grain of salt, telling me I did everything wrong isn't the way to solve problems. Maybe you didn't mean to come across that way but when I say I put something in the 'exact spot' and you say 'you didn't place it in the right spot' comes off as not listening and deffensive IMO.

If I didn't place it right then the trigger area is within millimeters and not forgiving in the least.

Same with spaces, I didn't say I wanted huge wide open corridors (which you find boring), I said there were spots which are just too small (regarding all the released FM's).

Didn't kill the missions for me, but a little extra room is always better than not enough, that is the point I was trying to make.

As for the armory, one less rack would probably be perfect for that amount of space.

In the fireplace getting stuck 1 of 5 tries (physically unable to move, then being spotted and killed stuck) means it is just too small.

 

I did really like details such as grabbing single water and moss arrows out of the broadheads. Details that you have to pay attention to notice, details alot of authors might not bother with...

 

@STiFU, I don't agree, cluttered is cluttered. Moving stuff just to move around (in some cases, like finding a hole behind a wall is OK), but having to move 20 staffs out of a rack because I bumped one isn't. I like details but there's a fine point between too empty and too much.

Especially gameplay wise, if stuff starts to impede movement that's not good.

Now Fidcal wasn't impending movement because of the staffs, they were all neatly organzied in the rack, and it was good details. It was just the circumstance happening in a small space that led to me being stuck for awhile. That might never happen to anyone else.


Dark is the sway that mows like a harvest

Share this post


Link to post
Share on other sites

Ah yeah. The physics might have been better disabled on those staffs, that's true... :D On the other hand, your described situation is indeed really funny!!

 

P.S. Erm, good one Fidcal! ;-)

Share this post


Link to post
Share on other sites

Sorry Baddcogg, there was absolutely no intent on my part to be critical it just sounded that way perhaps. I'm absolutely swamped with work as you can imagine plus light-headed at the reaction to DarkMod. So let's take each point one at a time:

 

When the crown is taken then an (invisible to player) absence marker is created in its place. I tested many times and when I failed I always found I had not placed it at the same place. I am indundated with questions that I am trying to answer and this has come up before so I just blurted out the stock probable reason before dashing off to the next task. I try to help as many as possible. Sometimes one misjudges the other persons feelings in the matter.

 

Next, the spacing and structure I agree probably the armoury is too tight but I didn't seriously care at the time I made it nor really do I now. I made this FM in a great hurry so people would have as many FMs to play as possible. The reason I gave was true. Springheel made a lot of new weapons and I was eager to get in as many as possible. Also I was reacting against the symbolic 2 staves and a hammer to represent an entire amoury. In Dark Mod we can actually have a lot of weapons so I put them in. Yes, it was probably 'wrong' in pure FM design terms. But it never bothered me and I don't remember any betamappers complaining. What more can I say?

 

I am no expert but I do know a little more about structure than perhaps Chalice suggests. But I did it in a hurry and I *wanted* it to be roughly how it was.

 

I was not aware I was telling you that you had done everything wrong. Nor did I wish to imply it was in any way your fault. My mistake for being light-hearted. On the contrary, the user (player) defines what is right. So if it did not work for you in some respects then I failed. I take responsibility and I apologize.

Share this post


Link to post
Share on other sites

Those of you with the crash when you enter certain rooms in Chalice and Trainer: try Malleus' (at ttlg) suggestion to update your DirectX. See if that fixes it.

Share this post


Link to post
Share on other sites

Little texture glitch ;)

 

shot00001zj.th.png


Task is not so much to see what no one has yet seen but to think what nobody has yet thought about that which everybody see. - E.S.

Share this post


Link to post
Share on other sites

No worries.

 

Anyway, started again from scratch to test the footsteps issue I had at first.

 

Almost got all the way through and my quick save got corrupted :(

Probably try again tommorrow. Gonna have to do some standard saves occasionally too I guess. First bad QS I had.

 

This time (new game) I came around back side of crown, laid down moss, put out 2 lights. Then went around to stair side of crown room. Now everytime I grab the crown they notice immediately it's missing and 5 guys search. I reloaded probably 10 times to see if I could grab it without them knowing. No luck, they noticed everytime. And they are at rest. Not saying anything, not searching, etc...

Haven't even got time to try and switch the crown.

IMO there should probably be a timer before the suspicious marker is placed, and it should be larger/more forgiving. Mainly because the decoy is for a clean ghost. Hard enough to get in close anyway, much less place the decoy from a crouched position trying to get it exact. I'd think on top of the pedestal should be good enough. Or ALL the ai need to leave long enough for you to get up close, standing with a tape measure and take some measurements ;)

 

One AI searched for me, got stuck in the armory (I was hiding in corner) and had to reload because he was just walking into a rack.


Dark is the sway that mows like a harvest

Share this post


Link to post
Share on other sites

Tip for preventing alert when getting crown:

The crown is just out of the line of sight of the guard standing in the doorway and the other one standing in the corner near the double doors. The only AI that will notice is the guy in the banquet hall who sometimes comes to the door of the main hall and the two patrollings sentries. Wait until they have left and you have the maximum time. Take the crown and there should be no alert until one of the patrolling characters comes along. During that time you can place the duplicate if you want that extra optional ghosting challenge. Alternatively just slip away and watch from a far shadow.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...