Jump to content
The Dark Mod Forums

For mappers releasing on 2.01


Recommended Posts

We found a problem in 2.01 where sounds aren't traveling as far as we think they should. It's most noticeable with warnings, death sounds, and noisemakers, but it affects every propagated sound. (Propagated sounds go to the AI, not to the player.)

 

After finding the root cause, we now know this problem has always been there.

 

It affects maps that use info_location entities.

 

It doesn't affect maps that don't.

 

The effect is that the attenuation of a propagated sound is 67x more than it should be. Since attenuation is subtracted from volume, and increases with distance traveled, sounds come up short and don't reach the ears of AI we expect to hear them.

 

This will be corrected in 2.02, along with another problem where tall or wide visportals can reduce the travel distance of sounds.

 

If you're planning to release a map before 2.02 (and we don't know when 2.02 will be released), you can work around the info_location problem by adding this spawnarg to your info_location entities:

 

"sound_loss_mult" "0.014"

 

Because many sounds were adjusted to be louder in 2.00 and 2.01, we'll need to scale them back for 2.02. So if you use the spawnarg setting and your map runs on 2.01, AI will hear some sounds you don't expect them to hear.

 

When 2.02 comes out, you won't need to reissue your map. And the problematic sounds will have had their volumes scaled back, so the better-hearing AI problem will go away.

 

This setting will not fix the tall/wide portal problem. You have to wait for 2.02 for that fix.

Link to post
Share on other sites

This is a pretty significant bug that affects about 2/3s of existing maps. It's why we've seen anomalous things like AI yelling for help and being ignored, players slaughtering AI in earshot of friends but they don't pay attention, and noisemakers often not alerting AI the way they should.

 

It also explains why some people have noticed AI being much sharper in hearing in some maps than others. It's not that mappers have altered the AI, it's because the maps with the sharp AI don't use location entities (so sounds travel as far as they're supposed to).

Link to post
Share on other sites

Well, grayman has already fixed it, but won't take effect until 2.02.

Link to post
Share on other sites

Why is there no ETA on 2.02? I figure if its such a tiny update to the game 0.01 of an update and the bug is quite concerning shouldn't that be enough cause to release 2.02 alone now?

 

Or are you waiting for something in particular?

Edited by Goldwell
Link to post
Share on other sites

We haven't assessed the things we want 2.02 to fix yet. taaaki's busy chasing down memory leaks, and I have a lighting problem to deal with. Both of those (at least) need to go in as well.

 

And we just came off of releasing 2.01 (and for me, two missions), so we're a bit burned out atm. (Well, I'm a bit burned out. Can't speak for the others.)

  • Like 1
Link to post
Share on other sites

Thanks for the notification/awareness!

 

I spent a good amount of time tweaking the volume of multiple alarms to draw appropriate AI, it sounds (heh, pun) like that'll need to be revised come 2.02 (will there be a pre-release for mappers to update accordingly)?

 

PS: 1/64 = 0.015 rounded from 0.0149253

"The measure of a man's character is what he would do if he knew he never would be found out."

- Baron Thomas Babington Macauley

Link to post
Share on other sites

BTW, it's probably not said enough, but big appreciation to everyone working and getting burned out!

 

Should this thread be pinned?

"The measure of a man's character is what he would do if he knew he never would be found out."

- Baron Thomas Babington Macauley

Link to post
Share on other sites
  • 1 month later...

I'm hesitant to edit the info_location entities in my WIP. If I do will they need to be edited from .014 and set back to 1.0 when 2.02 is released?

Edited by Tr00pertj

Laptop:Metabox P370SM3- Intel Core i7-4800MQ- 2x GTX780M SLI- 16G 1600Mhz- 500G Samsung mSata-1TB Hitachi HDD- 120Hz LG 1080p.Desktops:i75930k-2x GTX980 SLI-16G 2133Mhz-Evo120GSSD-Swift PG278Q1440p Gsync.Spare:AMD A10-7850K-APU-8G 1866Mhz-seagate 4TB-120G ssd. LoL Old:P75-1:1FSB-8M ram 512MB Maxtor HDD-1MB Cirrus Logic video chip-still got the parts somewhere?First PC-Tandy 512K Color computer.

Link to post
Share on other sites

OK Thanks Springheel.

Laptop:Metabox P370SM3- Intel Core i7-4800MQ- 2x GTX780M SLI- 16G 1600Mhz- 500G Samsung mSata-1TB Hitachi HDD- 120Hz LG 1080p.Desktops:i75930k-2x GTX980 SLI-16G 2133Mhz-Evo120GSSD-Swift PG278Q1440p Gsync.Spare:AMD A10-7850K-APU-8G 1866Mhz-seagate 4TB-120G ssd. LoL Old:P75-1:1FSB-8M ram 512MB Maxtor HDD-1MB Cirrus Logic video chip-still got the parts somewhere?First PC-Tandy 512K Color computer.

Link to post
Share on other sites
  • 2 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...