Jump to content
The Dark Mod Forums
Sign in to follow this  
greebo

DarkRadiant 1.6.0 available

Recommended Posts

DarkRadiant 1.6.0 is ready for download. Apart from the usual slew of bugfixes, new save/load code with support for Quake 4 maps as well as renderer speed improvements made it into this release.

 

Download DarkRadiant from our website: http://darkradiant.sourceforge.net/

 

Important: with this release Windows users will need to install a newer redistributable package in order to run this release:

 

The list of changes can be found on the website: Full list of changes and on our bugtracker changelog.

 

As usual, please report any bugs or feature requests here in these forums, following these guidelines:

 

  • Bugs (including steps for reproduction) can go directly on the tracker. When unsure about a bug/issue, feel free to ask.
  • Feature requests should be suggested (and possibly discussed) here in these forums before they may be added to the tracker.

As probably not everybody is reading the changelogs, here is the summary of changes:

 

New Features / Changes

 

  • Quake 4 Map Support
  • New grid rendering code contributed by radon.
  • Faster rendering in 3D views.

Bugfixes

 

  • Fixed Desktop Composition Disabling code (got broken in x64 builds)
  • Fixed the problem with models showing up as "Shader not Found" on a seemingly random basis.
  • Fixed the single-pixel lines showing between brushes/patch connections
  • Fixed a problem with mirroring func_statics - the child primitives won't be translated across the map and stay where they belong now.
  • Fixed ModelPreview problems on Eyefinity systems.
  • Fixed crash when importing Readables with more than 9 pages.
  • Fixed: Objectives Editor doesn't retain difficulty 2 mission success logic

Tweaks

 

  • none

Coding / Internal Design

 

  • Map saving/loading code has been redesigned

Share this post


Link to post
Share on other sites

There seems to be a problem in that the new c++ package requires Vista SP2 but I've got SP1. If I try to update then M$oft tell me they no longer update but I must buy Windows 7. Surely not?

Share this post


Link to post
Share on other sites

So, the C++ package refuses to install if you've got Vista SP1 running? There is definitely the SP2 package for Vista available here: http://www.microsoft.com/downloads/en/details.aspx?FamilyID=8ad69826-03d4-488c-8f26-074800c55bc3&displaylang=en (745 MB, watch out for your quota) so you surely aren't forced whatsoever to upgrade to Win7.

Share this post


Link to post
Share on other sites

Thank you for the new version. The "shader not found" bug on models alone drove me up the wall. B)


Come the time of peril, did the ground gape, and did the dead rest unquiet 'gainst us. Our bands of iron and hammers of stone prevailed not, and some did doubt the Builder's plan. But the seals held strong, and the few did triumph, and the doubters were lain into the foundations of the new sanctum. -- Collected letters of the Smith-in-Exile, Civitas Approved

Share this post


Link to post
Share on other sites

Greebs, I think we have a very minor bug. When installing the x64 version the installer is still using the pre2 install path

 

"C:\Program Files\DarkRadiant 1.6.0pre2 x64"

 

 

Shouldn't it be...

 

"C:\Program Files\DarkRadiant 1.6.0"

Share this post


Link to post
Share on other sites

Here is something interesting -- might be my stupidity: when I open the prefab browser window, only patches and entities are visible, brushes are not. I have checked my filters and it is not turned off; everything worked until I updated. :blink:

 

[edit]Also, new brushes created in the editor do not inherit the correctly selected textures on their faces.[/edit]

 

I have installed the redistributable. I am running Windows 7.

Edited by Melan

Come the time of peril, did the ground gape, and did the dead rest unquiet 'gainst us. Our bands of iron and hammers of stone prevailed not, and some did doubt the Builder's plan. But the seals held strong, and the few did triumph, and the doubters were lain into the foundations of the new sanctum. -- Collected letters of the Smith-in-Exile, Civitas Approved

Share this post


Link to post
Share on other sites
Here is something interesting -- might be my stupidity: when I open the prefab browser window, only patches and entities are visible, brushes are not.

Confirmed, but the prefab appears correctly in ortho.

Share this post


Link to post
Share on other sites

Greebs, I think we have a very minor bug. When installing the x64 version the installer is still using the pre2 install path

That's an innosetup issue I guess. It's detecting a prior version and suggests the same installation folder in the setup dialog. I guess if you uninstall the pre-release and then run the installer again it should suggest the correct folder.

 

Here is something interesting -- might be my stupidity: when I open the prefab browser window, only patches and entities are visible, brushes are not. I have checked my filters and it is not turned off; everything worked until I updated. :blink:

 

[edit]Also, new brushes created in the editor do not inherit the correctly selected textures on their faces.[/edit]

If this is reproducible, please add a tracker entry.

Share this post


Link to post
Share on other sites

Done. The second bug seems Media Browser-related.


Come the time of peril, did the ground gape, and did the dead rest unquiet 'gainst us. Our bands of iron and hammers of stone prevailed not, and some did doubt the Builder's plan. But the seals held strong, and the few did triumph, and the doubters were lain into the foundations of the new sanctum. -- Collected letters of the Smith-in-Exile, Civitas Approved

Share this post


Link to post
Share on other sites

So, the C++ package refuses to install if you've got Vista SP1 running? There is definitely the SP2 package for Vista available here: http://www.microsoft.com/downloads/en/details.aspx?FamilyID=8ad69826-03d4-488c-8f26-074800c55bc3&displaylang=en (745 MB, watch out for your quota) so you surely aren't forced whatsoever to upgrade to Win7.

Thanks greebo. That download installed OK. It's the automatic route to update that always goes to Windows 7 with no other option. I suspect a M$oft ploy to get users to buy 7.

 

Anyway, I'll now install the new DR.

Share this post


Link to post
Share on other sites

Ha! Now I try to install this new C++ package seems I already had it installed. I thought it was a new new one. Yet I know I saw a message somewhere that it needed SP2. Maybe its included in the SP2 I just installed. Oh well. I'll get there in the end.

Share this post


Link to post
Share on other sites

More stupid questions from this side of the globe:

 

Why isn't the releases of new editors announced on the News-section of the forum? As with the TDM-updates... :wacko:

Is it because it only appeals to the mappers?

Share this post


Link to post
Share on other sites

I've exported quite a few ase's without problem but in TDM update 1.06 & DR 1.60 64 bit I'm seeing a strange error. Horizontal surfaces of all new exported ase models (any texture) are extremely dark and do not respond to any local light. The surface is not black - I can see the texture and the normals that are not horizontal light up OK with local light. In this image the original brush is on the right and the exported model from it is on the left...

post-400-130307224789_thumb.jpg

 

They look OK in DR's render mode.

 

Normal models such as a crate are fine in TDM in-game.

 

I've tried disabling the various video enhancements in the TDM menu but it makes no difference.

 

I've not updated the export script for quite a while (although maybe it is now included with DR in which case I updated that recently.)

 

Earlier exports I made prior to the recent DR update still seem to be OK so that suggests a change in the script with DR?

Share this post


Link to post
Share on other sites

Using a case with the brush and model version next to eachother:

 

In TDM/d3, enter r_showNormals 0.5

Do the models have one of the three lines missing? Do they match what you see on the brush in any way? upload a screenshot of both if possible. You can also try opening the ASE in an editor and removing the whole "MESH_NORMALS" section, this will force doom to generate them - and that should work.

 

If it's the problem I'm having with my model converter - doom3 is for some reason accepting the normals specified in the ASE but for some reason it does not orient them correctly... tho this has just given me an idea.

Share this post


Link to post
Share on other sites

This is a screenshot with r_showNormals 0.5. All I see are some colored pixels at each corner.

 

post-400-130319062001_thumb.jpg

Share this post


Link to post
Share on other sites
Announcing editor releases in the TDM Editing forum sounds sensible to me, since they are not really important to the everyday players.

 

But those players, if they got excited about the possibilities of editing (like at the exciting new features of new DR versions), they may start to contribute missions. :) So I think they are worth a main page release (although probably not Moddb, since they have a different audience).


Come the time of peril, did the ground gape, and did the dead rest unquiet 'gainst us. Our bands of iron and hammers of stone prevailed not, and some did doubt the Builder's plan. But the seals held strong, and the few did triumph, and the doubters were lain into the foundations of the new sanctum. -- Collected letters of the Smith-in-Exile, Civitas Approved

Share this post


Link to post
Share on other sites

I think announcing all updates would be good at this point. Editor updates don't happen in a lot of engines, and to see that DR is constantly being improved is really cool imo.

 

It also shows players how much is going on behind the scenes.

 

Plus it's just extra bumps to keep TDM in the spotlight.


Dark is the sway that mows like a harvest

Share this post


Link to post
Share on other sites

I did that Moddb DR 1.5 article as a pre-promotion for the Seasons Contest. I was thinking of doing a 1.6 article but Mandrasola hit and then Fauchard is slated to be out soon so I wanted to leave the slate clean to make room for these then maybe do the 1.6 article.

 

Though Fauchard itself seems like a DR promotion of sorts... ^_^


Please visit TDM's IndieDB site and help promote the mod:

 

http://www.indiedb.com/mods/the-dark-mod

 

(Yeah, shameless promotion... but traffic is traffic folks...)

Share this post


Link to post
Share on other sites

Though Fauchard itself seems like a DR promotion of sorts... ^_^

 

Yes, it is. I think it would make a great multi-part article on Mod DB. Perhaps 3 or 4 parts documenting the speed creation of a mission in Dark Radiant.

Share this post


Link to post
Share on other sites

Yeah, that would probably be a good point to squeeze in DR update info too. Not so much mentioning WHAT was updated, but the fact that it's easy to build a small nice map in a short amount of time in an editor that's being constantly upgraded.

 

I'm working on getting a key bind setting matched up as close to Hammer's as possible too, hopefully that is something that will help encourage authors from that realm to give it a try.


Dark is the sway that mows like a harvest

Share this post


Link to post
Share on other sites

This is a screenshot with r_showNormals 0.5. All I see are some colored pixels at each corner.

 

Hmmm, can you upload a copy of the model? Seems like some of the vertices/normals are a bit wrong.

Share this post


Link to post
Share on other sites

Any will do. Just drag out a brush or horizontal patch, any visible texture and export it as an ase model then reload models and create model.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...