Jump to content
The Dark Mod Forums

corrupt (quick)saves


Flanders
 Share

Recommended Posts

Need details.

 

condump

 

savegame file

This seems to not be a problem now in #5888. I'll check my other system which hasn't yet been updated from #5883. If the problem is there, I'll post a condump and whether upgrade to #5888 fixes it.

 

Hmmm. No warnings or errors with #5883 that time. I followed the same pattern I always do at map starts. I create a save named '1', then another named '2' then I do an quicksave. Then I start playing, reserving save '1' for total mission restart without briefing.

Anyway. I made my saves and went all over and saw no problems with any quicksave.

My last dmap for siegeshop was done under #5888.

Edited by PranQster

System: Mageia Linux Cauldron, aka Mageia 8

Link to comment
Share on other sites

  • 4 weeks later...

The same issues happens now more often with every new mission I play. And in the new Siege shop I even got a CTD out of the blue when I wasn't even saving. Ill try a complete reinstall when traffic is slowed down a bit. In case it has something to do with corrupt files.

Link to comment
Share on other sites

Yeah, I had the same problem last night playing Alberic's Curse. I do use quicksave a lot, so I guess I have to try to use regular saves more often to avoid this until a solution is found.

 

If we attach the corrupted saves, is there not a way the devs can have a look see what causes the crash?

Link to comment
Share on other sites

Hey Serpentine, thanks for having a look :)

 

Here's the save file:

http://www.gamefront...6/savegames.zip

 

And another one I just got:

http://www.gamefront.com/files/23778582/savegames.zip

 

The size is only about 350k while a regular save is about 2 megs, so definitely it's been truncated somehow.

Maybe the place where the file is stopped is a clue to what caused the crash and corrupt save.

 

The place it's happened has been the same twice now. In Alberic's Curse, in the gallery in the church, just next to the altar;

http://imgur.com/ExQXmWr

Not been able to reproduce it after the last crash I had.

Edited by Shadrach
Link to comment
Share on other sites

I got the same error, except for the number:

idRestoreGame: InitializeCache: Bad Cache offset (0)

it is.

When I tried to quicksave, the Windows "loading" mouse-thingy appeared. An attempt to get back into the game just closed it. And now I keep getting these errors whenever I try to load the game

here's the file, if anyone wants to find the solution :)

http://www.file-uplo...egames.rar.html

Edit: I'm using TDM 2.0

Edited by Kekshexe
Link to comment
Share on other sites

Was playing Moonbo's Requiem mission last night and quicksaved numerous times and reloaded quicksaves numerous times as well. I encountered the "bad cache offset" error as well. It was only 1 time but it was present.

 

I also, having already read this thread, created numerous regular hard saves. Something I noticed that I don't recall from TDM 1.08 was that if I created a quicksave and then, say 5min later I created a hard save. Then loaded my quicksave back again it would load the "last" save whether it be the quicksave or the hardsave. 1.08 used to treat them independently. I also got a crash hitting F9 to reload my quicksave after having created a hardsave AFTER the quicksave.

 

Has the code here changed in regards to "which save is loaded" because it appears that it has. If you create a quicksave and then create 1-? hard saves afterward, you can no longer reference that original quicksave by hitting F9 to quick load. F9 now loads the last chronological save be it quicksave or hard save. As I said, these were treated separately in 1.08. Is this where the "bad cache offset" message is coming from?

 

This is on a fresh install of TDM in its own directory on Windows 7 x64, 8GB RAM, with all files verified by updater.

 

Never had a crash in TDM prior to this. (had 2 both of which occurred loading using F9 after creating a hard save AFTER the quicksave).

Edited by Lux
Link to comment
Share on other sites

I got a corrupt quicksave on lords & legacy... :( Damn it, I was quite far in. Gotta reactivate my old quicksave toggle script, so that hitting F5 alters between two save slots. TDM says "Game Error: IdPhysics_AF:AddBody: A Body with the name 'IdMoveable_ATDM:Prop_Single_Card_21564656896' already exists".

 

Download the corrupt quicksave here, if you need: https://www.dropbox..../Quicksave.save

 

Maybe it's not a bad idea to have the code actually backup savegames by default, in case the pc crashes while saving or something like that.

 

In case anyone having problems is interested in my quicksave toggle script, here is how to do it. In the darkmod folder create two files called "quicksave1.cfg" and "quicksave2.cfg" with the following contents:

quicksave1.cfg:

savegame quicksave1

bind f5 "exec quicksave2.cfg"

bind f9 "loadgame quicksave1"

quicksave2.cfg

savegame quicksave2

bind f5 "exec quicksave1.cfg"

bind f9 "loadgame quicksave2"

Now simply open the console in TDM and enter: bind f5 "exec quicksave1,cfg". And you're done.

Link to comment
Share on other sites

Please file a bugtracker issue, and attach the quicksave. It sounds like the game was saved between the moment that a single card was spawned in a card-player's hand and the moment when that card was to be removed. This is when the animation picks up a card from the table and places it in the player's card hand.

 

When the game was restored, that card was restored and somehow that conflicted with the animation's desire to spawn another card.

Link to comment
Share on other sites

Please file a bugtracker issue, and attach the quicksave. It sounds like the game was saved between the moment that a single card was spawned in a card-player's hand and the moment when that card was to be removed. This is when the animation picks up a card from the table and places it in the player's card hand.

 

When the game was restored, that card was restored and somehow that conflicted with the animation's desire to spawn another card.

 

You know that reminds me... my crash happened in Requiem when I quicksaved directly after activating the

last pillar/earth-air-fire-water thing that unlocks the cage

 

and directly after the quicksave an animation or script or something kicked off to open the cage. When I tried quick loading that save it was borked.

Edited by Lux
Link to comment
Share on other sites

  • 2 weeks later...

Having the same problem the TDM 2.0 on several games. The TDM package occasionally crashes on quick save. The "idRestoreGame::InitializeCache..." error message happens on the quick restore attempt to restart the game after successfully restarting TDM. Most recently this happened with "The Seige Shop", but it has happened on other games missions too.

Link to comment
Share on other sites

  • 3 months later...

So I think this is some memory issue. On large missions like home again or requiem it happens for me after about 45 mins of playing. I got around it by saving a lot with incremental numbers, and then load the next to last save if the last one got corrupted.

Link to comment
Share on other sites

I've only ever had the issue with quicksaving. Regular saves seem to always work fine but that could be coincidence.

 

i also got this on normal saves. But it happens more frequent on Quicksaves (and Loads) then normal saves, but i also do more Quicksaves then normalsaves, so.

Link to comment
Share on other sites

I have this frequently for both quicksave and regular save, in fact it is very rare for me that a save actually works.

Sometimes it crashes too while saving, so TDM is the only game i know in which saving is more dangerous than not lol

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share


  • Recent Status Updates

    • peter_spy

      Deathloop – what a mess of a game. I'd love to see a post-mortem on it some day. I hope Arkane is doing okay though.
      · 15 replies
    • OrbWeaver

      I like house-cleaning and taking out the trash.
      · 1 reply
    • STiFU

      Be honest: Who of you have actually finished Cuphead? This game is freaking tough! It might even be harder than Sekiro. Dark Souls is a joke in comparison to Cuphead! :-D 
      · 8 replies
    • duzenko

      Please, can we finally group the missions by year in the game menu?
      · 6 replies
    • duzenko

      I vaguely recall someone recently complained about two-sided materials (curtains?) not getting lighting from both sides
      I just found a piece of code that's supposed to do just that
      Where was that discussed? (@nbohr1more?)
      · 9 replies
×
×
  • Create New...