Jump to content
The Dark Mod Forums

Newbie DarkRadiant Questions


Recommended Posts

Another question.

 

The Startpack Mappers' Guide says, for Common projects:

 

"You also need to copy the file doom3\mymap\xdata\startmap.xd to doom3\darkmod\xdata"

 

But startmap.xd doesn't exist. I found briefing.xd and custom.xd (only) in the xdata folder.

 

Is this missing, or is the Guide out-of-date?

Link to post
Share on other sites
  • Replies 10.1k
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

So I have this gigantic scorpion, it is made out of pendulums bound together. I had an idea about dragging whole thing through a piled up crates (pretending to be stone blocks in a wall), but it looks

I'm just going to make the lute player an undead immortal skeleton called Ralph who is eternally bound to play his lute in the tavern, the residents are used to him now so they just happily co-exist a

So I just did a little test because I was curious to know this as well.   So far i've figured out that the mesh we see in the mirror is located as "models\md5\chars\thief\tdm_ai_thief.md5mesh" and if

Posted Images

That needs correcting. It may be that in the original version I had a startmap.xd (or anticipated it before I finished it) I can't remember now. No need to change the names of the xd files though you can if you want. The actual xdata file names do not affect functionality anyway; all that matters is that it is suffixed .xd and in the xdata folder. I'll fix that next update. Thanks.

Link to post
Share on other sites

That needs correcting. It may be that in the original version I had a startmap.xd (or anticipated it before I finished it) I can't remember now. No need to change the names of the xd files though you can if you want. The actual xdata file names do not affect functionality anyway; all that matters is that it is suffixed .xd and in the xdata folder. I'll fix that next update. Thanks.

 

Ok, thanks.

Link to post
Share on other sites
  • 2 weeks later...

I'm revisiting a few things from the beginner guide, and I've got 2 issues.

 

1. the bit with putting an ambient light into the pool. no matter what i do, if i put the edges of the ambient light radius flush against the pool walls, the lighting will not show up at all, even when i remove the water out of the pool. if i extend the radius out farther, the light somehow glitches out when i test the map, and extends at weird angles to portions of the poolwall brushes above the surface of the water, which should not happen. and it looks really bad too. how i fix bad thing?

 

2. Problem with... an unknown ghost image. There was a light, or a speaker, or something that i moved, but theres now a ghost image of a black box up in the sky where it used to be. I have scoured the map in DR for the source of this, but theres just nothing theeeere. its a ghost! I'm not sure exactly what it was, but i think it was a light, and i think i renamed it before moving it. not sure if that helps..

 

edit: 3. after moving the rain and rainsplatter brushes off to a remote corner of the map, it still rains in the courtyard, and splashes on the ground. ....what??

Edited by ungoliant
Link to post
Share on other sites

I'm revisiting a few things from the beginner guide, and I've got 2 issues.

 

1. the bit with putting an ambient light into the pool. no matter what i do, if i put the edges of the ambient light radius flush against the pool walls, the lighting will not show up at all, even when i remove the water out of the pool. if i extend the radius out farther, the light somehow glitches out when i test the map, and extends at weird angles to portions of the poolwall brushes above the surface of the water, which should not happen. and it looks really bad too. how i fix bad thing?

The wall surfaces must be within the radius to be illuminated so the ambient should reach or extend beyond the walls. If the pool is submerged then that should be no problem for the sides and bottom. But make the radius flush with the surface. It's not clear what you mean by glitching out. If that somehow looks ugly then try a different ambient light texture. Look for one that fades at the edges. You will then need to extend it further beyond the walls though to illuminate them. I can't recall exactly what I said about the pool and light in the tutorial but it might not even need a separate ambient light if your main ambient_world extends down into it (which it should.)

 

2. Problem with... an unknown ghost image. There was a light, or a speaker, or something that i moved, but theres now a ghost image of a black box up in the sky where it used to be. I have scoured the map in DR for the source of this, but theres just nothing theeeere. its a ghost! I'm not sure exactly what it was, but i think it was a light, and i think i renamed it before moving it. not sure if that helps..

In the Dark Mod console enter g_showEntityInfo 1 and then noclip so you can fly up to the black box and you should see its name and/or number I forget which. If it shows the entity name then find it in Dark Radiant's entity list then delete it. If it's a number then use menu > map > find brush.

 

edit: 3. after moving the rain and rainsplatter brushes off to a remote corner of the map, it still rains in the courtyard, and splashes on the ground. ....what??

Probably just needs you to dmap. But this may relate to your other question above. If the rogue black cube is in fact a rain patch func_static - perhaps you were resizing it then decided to drag it away elsewhere leaving its origin behind?
Link to post
Share on other sites

In any 2d view, is there a way to zoom in, via the mousewheel, to where the cursor is located (like it does in AutoCAD)? I find that very convenient.

And also, can we set up dark radiant so that all the views are synchronized?

 

thanks.

 

I've already requested that feature a while ago I think.

And what do you mean by synchronized? In what way?

I always assumed I'd taste like boot leather.

 

Link to post
Share on other sites

perhaps I used the wrong wording. What I mean is, when we are using the arrow keys to move the camera around, all the views actually move along with the camera (like in Dromed), and not just simply let the camera icon (in the 2d views) go outside of the views. hope that makes sense.

 

 

Link to post
Share on other sites

basically the camera stays in the center in all open viewports when the camera gets moved around, as long as there's an option to turn it off this is something I'lled like to see, as when you have lots of entities in a line its hard to see the camera icon, so when zooming in or out currently the viewports dont track with the camera. Filtering entities out doesn't work when you are placing entities on entites, like coffee table some chairs and stuff to go on table. I also noticed that while there's a complete tea/coffee set in the objects, there arn't any coffee/tea cups to drink it out of, I had to use the chinese method of drinking it out of a pewter bowl. The pot mugs just dont track with a silver tea set.

Link to post
Share on other sites

The wall surfaces must be within the radius to be illuminated so the ambient should reach or extend beyond the walls. If the pool is submerged then that should be no problem for the sides and bottom. But make the radius flush with the surface. It's not clear what you mean by glitching out. If that somehow looks ugly then try a different ambient light texture. Look for one that fades at the edges. You will then need to extend it further beyond the walls though to illuminate them. I can't recall exactly what I said about the pool and light in the tutorial but it might not even need a separate ambient light if your main ambient_world extends down into it (which it should.)

 

In the Dark Mod console enter g_showEntityInfo 1 and then noclip so you can fly up to the black box and you should see its name and/or number I forget which. If it shows the entity name then find it in Dark Radiant's entity list then delete it. If it's a number then use menu > map > find brush.

 

Probably just needs you to dmap. But this may relate to your other question above. If the rogue black cube is in fact a rain patch func_static - perhaps you were resizing it then decided to drag it away elsewhere leaving its origin behind?

 

thx for taking the time to respond to all that. the first issue i have resolved to be yet ANOTHER ati graphics card issue, as the camera in DR properly displays the pool lighting in preview mode in DR, but glitches in-game. fixed all the other issues except the morphing issue in camera view from DR, which can be sortof-fixed by komag(?)'s post in another thread, where i can temporarily fix the morphing by selecting a lightsource in preview mode and then deselect it. those are my only 2 remaining ATI card problems. so i didn't actually do anything wrong with that ambient light source. stupid ati...

 

2 and 3 i believe were indeed related to the rain patch which was a func_static that i removed to a remote corner somewhere, as when i deleted the patch, the black box went away, and before i deleted it i ran dmap and it found leaks. i guess you can't put patches (or func_statics?) out in the void...? deleting it did fix the leak, so meh. thx for the g_showEntityInfo 1 info, that'll be a handy trick if that problem shows up again.

 

./bow

Link to post
Share on other sites

basically the camera stays in the center in all open viewports when the camera gets moved around, as long as there's an option to turn it off this is something I'lled like to see, as when you have lots of entities in a line its hard to see the camera icon, so when zooming in or out currently the viewports dont track with the camera. Filtering entities out doesn't work when you are placing entities on entites, like coffee table some chairs and stuff to go on table. I also noticed that while there's a complete tea/coffee set in the objects, there arn't any coffee/tea cups to drink it out of, I had to use the chinese method of drinking it out of a pewter bowl. The pot mugs just dont track with a silver tea set.

 

Perhaps try moving the camera by middle-mouse clicking on the ortho viewports?

I always assumed I'd taste like boot leather.

 

Link to post
Share on other sites

thx for taking the time to respond to all that. the first issue i have resolved to be yet ANOTHER ati graphics card issue, as the camera in DR properly displays the pool lighting in preview mode in DR, but glitches in-game. fixed all the other issues except the morphing issue in camera view from DR, which can be sortof-fixed by komag(?)'s post in another thread, where i can temporarily fix the morphing by selecting a lightsource in preview mode and then deselect it. those are my only 2 remaining ATI card problems. so i didn't actually do anything wrong with that ambient light source. stupid ati...

 

Is it possible to give us two shots of this? one in DR one in TDM - If your light is exactly perpendicular to surfaces it will not illuminate them or might result in what looks like z-fighting on the surface with lit/unlit textures.

2 and 3 i believe were indeed related to the rain patch which was a func_static that i removed to a remote corner somewhere, as when i deleted the patch, the black box went away, and before i deleted it i ran dmap and it found leaks. i guess you can't put patches (or func_statics?) out in the void...? deleting it did fix the leak, so meh. thx for the g_showEntityInfo 1 info, that'll be a handy trick if that problem shows up again.

 

I think this issue is just to do with some DR code, it looks like the texture is linearly mapped or something close to that and the texture becomes un-clamped, and not perspective corrected as it is intended, I think its some kind of assumption taken by the code that certain cards/drivers dont take as a default. But that is a guess at best, would have to ask greebo :)

Link to post
Share on other sites

Is it possible to give us two shots of this? one in DR one in TDM - If your light is exactly perpendicular to surfaces it will not illuminate them or might result in what looks like z-fighting on the surface with lit/unlit textures.

 

yeah when i get up the gumption i'll edit this post later and slap 'em on.

 

It does sortof appear like z-fighting, except the ambient light effect is always predominant covering the surface when it wants to show up on a portion of the surface its NOT supposed to be on, so it doesn't blink or fidget uncontrollably fighting with it. but definitely illuminating portions of surfaces i told it not to. the light extends to weird angles up and down unilluminated portions of the same surfaces, and it seems to be directly dependent only on how my view is lined up with the surfaces. the illumination stays stock still when i stay still, and will change and move around as i move or look around the area.

 

And what do you mean by exactly perpendicular. i mean, if you use a light to illuminate a single room enclosed on all sides, no matter where you put the light inside the room, it will be perpendicular to each surface at exactly one point for each wall, so unless your lighting a room from outside the room.... but yes, that is the other portion of the problem. sometimes 2 or 3 of the 5 surfaces inside the pool will not illuminate at all in-game, and that light is definitely flush to the surfaces or extending farther than it needs to. I've experimented both ways. Is this a problem with ambient lighting only? never encountered that with torches / candles etc.

Link to post
Share on other sites

I worded that quite badly :)

 

Here's a screenshot :

winnar.th.png

 

If you place the light at place A as shown : No light will be emitted anywhere.

If you place the light at place A however you shorten the long wall to make an "X" shape(i.e the light is in the middle of the X), both sides of the wall will be hit.

If you place the light at place B " there is a small chance that it will not light the wall face that it is horizontally aligned to - I think that is to do with rounding if you use small units.

If you place a moving light at place B : you will get something that looks like z-fighting on the surface due to it moving in and out quite quickly, often caused by street lights on corners being aligned too perfectly.

 

These are just some ideas, but I dont think they are the cause of your issue - might be easier to just upload a part of the map somewhere for us to have a look at.

Edited by Serpentine
Link to post
Share on other sites

 

These are just some ideas, but I dont think they are the cause of your issue - might be easier to just upload a part of the map somewhere for us to have a look at.

 

i will probably do that. And yes, i see your point you are trying to make, but as my 2 ambient lights are in the middle of a courtyard and in the middle of a pool, not intersecting any surface axises, just out in open air, i don't see how that would have an effect, especially as they are ambient in the first place (so that shouldn't happen no matter where i put them, right?)

 

furthermore, another problem just popped up today while i was going to take a screenie in DR of that pool. my ambient_world light is now acting like a normal light in DR preview mode. casts shadows, and light fades towards the edge of the radius. so now, if i dont put my ambient_world light directly above the pool, it makes 2 of the side wall surfaces look black because of the 'shadow' (in DR only, in-game ambient_world light displays properly against all surfaces. but not that damn ambient_pool light which is the original problem)

 

on top of that, the in-game screenshots i took are not even accurate. instead of showing just the ambient_pool illuminated areas i was looking at, in the screenshots themselves, the ambient_pool light just extends and covers the entire surface of every wall in the pool (which is still erroneous and not even the same erroneousness that i was looking at, because what i saw with my waking eyes in-game was those damned walls partly illuminated by pool light, partly by ambient_world).

 

About ready to throw up my hands and walk away from this whole thing. driving me bonkers. DR doesn't display my lights properly and starts morphing all the textures every 30 seconds, and my lights don't display properly in the game, and in-game screenshots wont even display what i'm looking at either. AAARRRRRRRGGGHH

Link to post
Share on other sites

DR's detailed view is not accurate, never has been and until we know more of the doom3 render - it wont be. Most people just leave it in textured mode then work and preview in a windowed instance of TDM. So if you are basing any of this off what you see in DR and expecting it to be matching ingame, theres the problem :)

 

As for using multiple ambient world lights, I dont really understand the reasoning and it will most likely just cause problems (A wiiiiild guess, I cant say I've ever had a reason to)

Link to post
Share on other sites

About ready to throw up my hands and walk away from this whole thing. driving me bonkers. DR doesn't display my lights properly and starts morphing all the textures every 30 seconds, and my lights don't display properly in the game, and in-game screenshots wont even display what i'm looking at either. AAARRRRRRRGGGHH

 

Well, if you can work with us and give detailed info about your system and how to replicate these problems, perhaps it would help our coders find a solution.

Link to post
Share on other sites

DR's detailed view is not accurate, never has been and until we know more of the doom3 render - it wont be. Most people just leave it in textured mode then work and preview in a windowed instance of TDM. So if you are basing any of this off what you see in DR and expecting it to be matching ingame, theres the problem :)

 

As for using multiple ambient world lights, I dont really understand the reasoning and it will most likely just cause problems (A wiiiiild guess, I cant say I've ever had a reason to)

 

point noted about DR.

 

wait... multiple ambient world lights??? i'm following instructions on the beginner guide here. i have one light called ambient_world that encompasses the whole mission area, and one tiny ambient light called ambient_pool that sits inside of a pool. the radii do not intersect each other in any way. anyways, here's a screenshot from in-game, keep in mind, its not accurate.

th_shot00002.jpg

and heres a SS of the layout in DR.

th_DRshot.jpg

notice that the pool light is not supposed to extend all the way up to the edge of the walls. In-game, the light will actually creep up the side at weird angles and things, the but the screenshots will not show it. only shows the entire surface of the walls illuminated. so..... now what?

 

edit: you might note i did change the class name on pool_light atdm:ambient_world, and maybe changed other things too. just did that like an hour ago, fooling around to try get things working. even with everything on straight defaults, (except the texture) it still produces the problem

Edited by ungoliant
Link to post
Share on other sites

point noted about DR.

 

wait... multiple ambient world lights??? i'm following instructions on the beginner guide here. i have one light called ambient_world that encompasses the whole mission area, and one tiny ambient light called ambient_pool that sits inside of a pool. the radii do not intersect each other in any way. anyways, here's a screenshot from in-game, keep in mind, its not accurate.

th_shot00002.jpg

and heres a SS of the layout in DR.

th_DRshot.jpg

notice that the pool light is not supposed to extend all the way up to the edge of the walls. In-game, the light will actually creep up the side at weird angles and things, the but the screenshots will not show it. only shows the entire surface of the walls illuminated. so..... now what?

 

edit: you might note i did change the class name on pool_light atdm:ambient_world, and maybe changed other things too. just did that like an hour ago, fooling around to try get things working. even with everything on straight defaults, (except the texture) it still produces the problem

 

Please zip up your .map file and .darkradiant file and attach it to your next post, so we can try and replicate your errors on our systems. This is definitely weird.

I always assumed I'd taste like boot leather.

 

Link to post
Share on other sites

here it is... errr, no its not. file attachment is giving me grief that i am not permitted to upload zip or rar files.

 

Try renaming it from .zip to .txt and then upload it, we can rename it to .zip after we download it.

I always assumed I'd taste like boot leather.

 

Link to post
Share on other sites

I had a quick look at this and can confirm there's an issue.

 

- The pool_ambient light's edges get cut off depending on view angle

- Removing the world_ambient does not help it (so there is no conflict in overlapping ambient lights)

- Deleting the pool_ambient and recreating it leads to the same result (so it's not a specific problem with only this light)

 

Could it be ambient light volumes are not meant to be seen from the outside?

Link to post
Share on other sites

I think it might be an issue with the Ambient_World interfering with the other ambient light. I removed the world ambient and replaced it with a normal ambient light, and the issue seems to have gotten much better.

I always assumed I'd taste like boot leather.

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...