Jump to content
The Dark Mod Forums
stgatilov

Beta Testing 2.08

Recommended Posts

1 hour ago, lowenz said:

Ah, is it possible to modify alsoft.ini WITHOUT triggering the re-downloading of the tdm_stuff package when launching tdm_update?

It's important, not only to disable the HRTF in 4/5.1/7.1 audio systems

Yes, a sad problem.

Perhaps I should make HRTF an in-game option and remove the ini file. It seems to be possible via OpenAL-soft extension. Although many users will still have the file locally.

Share this post


Link to post
Share on other sites
1 hour ago, STiFU said:

Have you tried making it read-only?

tdm_update check the MD5 checksum I think, so if you change an option you'll get the redownload behaviour.

Problem is all about tdm_update.

Edited by lowenz

Task is not so much to see what no one has yet seen but to think what nobody has yet thought about that which everybody see. - E.S.

Share this post


Link to post
Share on other sites

Played one of the default missions with 2.08 and I most say I saw no glaring problems but I've yet to play more to have a better idea.

One thing I saw tho, with the ambient occlusion the game becomes way more dark, don't know if is caused by some bad gamma settings on my side or is normal, I also played with W10 "nocturn light" on, to make it easy for me to sleep. The flashlight was now much more necessary. 

Don't take with this that I didn't liked AO, I did, the game became more dark to me but also more atmospheric, in the shade objects got more grounded and I really love how you cast a "shadow" on the ground, when you crouch or when get next to objects and how the guards feet also do the same as they travel through the shade, very nice. 

What AO system have you guys implemented? SSAO?

Edited by HMart

Share this post


Link to post
Share on other sites
1 minute ago, HMart said:

Played one of the default missions with 2.08 and I most say I saw no glaring problems but I've yet to play more to have a better idea.

One thing I saw tho, with the ambient occlusion the game becomes way more dark, don't know if is caused by some bad gamma settings on my side or is normal, I also played with W10 "nocturn light" on to make it easy for me to sleep. The flashlight was now much more necessary. 

Don't take with this that I didn't liked AO, I did, the game became more dark to me but also more atmospheric, in the shade objects got more grounded and I really love how you cast a "shadow" on the ground when you crouch or when get next to objects and how the guards feet also do the same has they travel through the shade. 

What AO system have you guys implemented? SSAO?

"Scalable Ambient Obscurence"

Try lowering the r_ssao_base value to 0.3 or 0.4 (higher numbers are the cutoff to how dark it can be).

 

  • Like 1

Please visit TDM's IndieDB site and help promote the mod:

 

http://www.indiedb.com/mods/the-dark-mod

 

(Yeah, shameless promotion... but traffic is traffic folks...)

Share this post


Link to post
Share on other sites
2 minutes ago, nbohr1more said:

"Scalable Ambient Obscurence"

Try lowering the r_ssao_base value to 0.3 or 0.4 (higher numbers are the cutoff to how dark it can be).

 

Hum for a Nvidia tech it does seems to run well on my AMD GPU.  :D

Ok will do that but thinking more about it, perhaps personally I will let it be that dark, I liked that it forced me to use the lantern more often and so be more alert to the guards. :)

Share this post


Link to post
Share on other sites

Please experiment and compare to 2.07

You can also raise the r_ambientGamma to compensate for some of the darkening.

Find a sweet spot with

r_postprocess_brightness

r_postprocess_gamma

r_ambientGamma

r_postprocess_colorCurveBias

r_postprocess_desaturation

  • Like 1

Please visit TDM's IndieDB site and help promote the mod:

 

http://www.indiedb.com/mods/the-dark-mod

 

(Yeah, shameless promotion... but traffic is traffic folks...)

Share this post


Link to post
Share on other sites

Differences between SSAO levels? (1->2->3)


Task is not so much to see what no one has yet seen but to think what nobody has yet thought about that which everybody see. - E.S.

Share this post


Link to post
Share on other sites

The SSAO levels determine how far the effect spreads from the occlusion zones. They are presets that internally

affect the base levels of the cvars so your cvar adjustments are relative to them.

 

 
case 1:
uniforms->maxMipLevel.Set(0);
uniforms->numSpiralTurns.Set(5);
uniforms->numSamples.Set(7);
sampleRadius = 0.5f * r_ssao_radius.GetFloat();
break;
case 2:
uniforms->maxMipLevel.Set(MAX_DEPTH_MIPS);
uniforms->numSpiralTurns.Set(7);
uniforms->numSamples.Set(12);
sampleRadius = r_ssao_radius.GetFloat();
break;
case 3:
default:
uniforms->maxMipLevel.Set(MAX_DEPTH_MIPS);
uniforms->numSpiralTurns.Set(7);
uniforms->numSamples.Set(24);

sampleRadius = 2.0f * r_ssao_radius.GetFloat();

 


Please visit TDM's IndieDB site and help promote the mod:

 

http://www.indiedb.com/mods/the-dark-mod

 

(Yeah, shameless promotion... but traffic is traffic folks...)

Share this post


Link to post
Share on other sites

SSAO shouldn't noticeably darken the whole scene - are you sure it's not the new gamma/brightness system that makes TDM look darker than before? You can look at the actual SSAO output via "r_showFBO 4" - this should be a white image with the darkened AO shades. If that image is somehow gray, then the effect may be misbehaving on your GPU.

Share this post


Link to post
Share on other sites

Just for reference, this is what SSAO should look like:

ssao.thumb.gif.b628fd8d27a5be5e9f1ab9e6a21ea330.gif

So yeah, it does darken the (impression of the) scene, but it should not make a drastic difference. If you see different behaviour between SSAO turned on and off, please let me know so that we can debug the issue :)

  • Like 2

Share this post


Link to post
Share on other sites

Unrelated to SSAO, got this warning in A New Job:

newjob-2020-03-27-08-45-09.jpg

Edited by lowenz
  • Like 1

Task is not so much to see what no one has yet seen but to think what nobody has yet thought about that which everybody see. - E.S.

Share this post


Link to post
Share on other sites

Yes and it's SO good (temporally totally stable)

You can see "Medium" level in my screenshot.

Edited by lowenz

Task is not so much to see what no one has yet seen but to think what nobody has yet thought about that which everybody see. - E.S.

Share this post


Link to post
Share on other sites

Trying to update to 2.08 isnt working for me, i followed the steps for the updater but then it yells at me with VS.

image.png.be17757536a374b4da35e0d20835eb04.png

Running the named exe returns this:


image.png.ad6dfaa3df95b59b710ffc0213cc4541.png

My VS setup uses all the latest libraries already. I use Visual studio 17 and 19 in full setup.
I dont want to change this setup at all 😕

What can i do?


Can we have more scary Zombie Horror maps?

Share this post


Link to post
Share on other sites

Strange that it errors out, but if you have VS 2017 installed, you shouldn't need to install the redistributables, anyway. Have you tried starting the game?

Share this post


Link to post
Share on other sites

Yee, it still says 2.07 in console and menu. :o Maybe it cant finish the install now.


Can we have more scary Zombie Horror maps?

Share this post


Link to post
Share on other sites
54 minutes ago, Filizitas said:

Trying to update to 2.08 isnt working for me, i followed the steps for the updater but then it yells at me with VS.

image.png.be17757536a374b4da35e0d20835eb04.png

What can i do?

TDM 2.08 uses statically linked CRT, just like 2.05 and before did. So new tdm_update does not even attempt to install VCRedist. You have old tdm_update, which for some reason does not update itself.

  • Did you set checkbox "noselfupdate" ?  (hint: you should not)
  • Did you set checkbox "keep-mirrors" ? (hint: you should)
  • Did you download the tdm_mirrors.txt file by the link in the original post and put it near TDM executables? (hint: you should)

If you did all of this properly, then I'm afraid it might be some access issue again, like tdm_update cannot overwrite anything in its directory...

Share this post


Link to post
Share on other sites

So I updated to the latest 2.08 beta and went through the assets again. Good news is that the werebeast is all there now.

 

But here's some assets that are showing up a lil funky for me:

 

1) atdm:ai_manbeast & atdm:ai_manbeast_spear_thrower

YMezo2j.png

 

2) models/darkmod/junk/dirt_edge02_grass.lwo

vaZVrDe.png

 

3) models/darkmod/loot/jewellery/lionhead_amulet.lwo

mklLJvm.png

 

4) models/darkmod/nature/boom_shroom_flider.ase (I think this is an old one but thought i'd add it in anyway)

yWGy6bQ.png

 

5) models/darkmod/weapons/volta_spear.ASE

hsj1iph.png

 

6) models/darkmod/weapons/volta_spear_broken_shaft.ASE

4Adb50x.png

 

7) models/darkmod/weapons/volta_spear_broken_tip.ASE

K3H0bHE.png

 

8 ) models/darkmod/weapons/volta_spear_bundle.ASE

KoWu816.png

 

9) models/darkmod/wearables/headgear/broadbrim_hat.lwo

iderPoI.png

  • Like 2

Share this post


Link to post
Share on other sites
11 minutes ago, Filizitas said:

I reinstall TDM completly then

Did you check that all values are set correctly?

Share this post


Link to post
Share on other sites

I did it as you said.
It installed tdm without any start exe O.o

I reded the update and now everything is 2.08 :)

Edited by Filizitas

Can we have more scary Zombie Horror maps?

Share this post


Link to post
Share on other sites

@Goldwell I think lionhead_amulet.lwo has always been like that; it is on my 2.07 installation. The broken material is called tdm_blackheart_amulet so I suspect it's a Blackheart Manor asset that was only halfway added to core.

You're right about the shroom flinder problem being an old one; does https://bugs.thedarkmod.com/view.php?id=2559#c9479 help?

  • Like 1

Some things I'm repeatedly thinking about...

 

- louder scream when you're dying

Share this post


Link to post
Share on other sites
49 minutes ago, VanishedOne said:

@Goldwell I think lionhead_amulet.lwo has always been like that; it is on my 2.07 installation. The broken material is called tdm_blackheart_amulet so I suspect it's a Blackheart Manor asset that was only halfway added to core.

You're right about the shroom flinder problem being an old one; does https://bugs.thedarkmod.com/view.php?id=2559#c9479 help?

Well I guess that answers those ones, thanks! Hopefully they get fixed in 2.09.

 

Also I noticed that when the werebeast was in game it keeps displaying this message in the console

 

g1X8lTF.png

Share this post


Link to post
Share on other sites
Quote

1) atdm:ai_manbeast & atdm:ai_manbeast_spear_thrower

I think just the editor image is missing.  Do you see any issues in game? 

Quote

models/darkmod/weapons/volta_spear.ASE
2) models/darkmod/junk/dirt_edge02_grass.lwo


These two should be fixed in revision 15885

 

The other ones are super old models, so either something has broken, or they were never finished and were uploaded by mistake.

  • Like 1

Share this post


Link to post
Share on other sites
18 hours ago, cabalistic said:

SSAO shouldn't noticeably darken the whole scene - are you sure it's not the new gamma/brightness system that makes TDM look darker than before? You can look at the actual SSAO output via "r_showFBO 4" - this should be a white image with the darkened AO shades. If that image is somehow gray, then the effect may be misbehaving on your GPU.

By using gama 1.3 and brightness 1, the scene still looks a tad dark but much brighter than before, so yes gamma/brightness was the culprit, turning off or on, AO made almost no difference to the darkness but made a huge difference to the depth of the scene, sorry for my hasted "complaint". ;) Love the AO very nice guys.

Btw I also forgot to mention that i'm playing this on a new freesync monitor and it's gama is totally different to my old one, IMO the old one looked better but was only a 60hz screen and after experiencing higher refresh rates I just can't go back! 😜   

r_showFBO 4 shows like you said, a white texture with dark "shadows", btw some of the shadows (not that many) aren't smooth but noisy, like dither noise, is that normal?  

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...