Jump to content
The Dark Mod Forums

DarkRadiant 2.0.3 released


Recommended Posts

DarkRadiant 2.0.3 is ready for use. This is a bugifx/stabilisation release, people should stop using the 2.0.2 version (or older). There might still be some glitches hidden in this one, but it's still far better than 2.0.2.

Please refer to the github Release Page for downloading a Windows build: https://github.com/codereader/DarkRadiant/releases/tag/2.0.3

Thanks go out to all the pre-release testers!

 

You will need to download the VC++ redistributable to 2013 for your Windows system, get it here:

Please report any bugs or feature requests here in these forums, following these guidelines:

  • Bugs (including steps for reproduction) can go directly on the tracker. When unsure about a bug/issue, feel free to ask.
  • If you run into a crash, please record a crashdump: Crashdump Instructions
  • Feature requests should be suggested (and possibly discussed) here in these forums before they may be added to the tracker.

Changes

  • #4217: [Renderer] Portal Sky texture is transparent (again)
  • #4265: [GUI] Crash in Freezepointer code, during ParticlesChooser
  • #4187: [General] configure.ac: needs call to AM_GNU_GETTEXT_VERSION, does not find de.po
  • #4264: [shader System] texture browser not updating on media load
  • #4261: [GUI] Startup crash in release builds when .pid-file is present
  • #4194: [General] please update boost.m4 to avoid build failure with gcc-5
  • #4196: [Design/Coding] Please add Keywords to desktop file
  • #4208: [GUI] STIM_MOSS not listed in S/R editor
  • #4192: [General] spelling error in sound module
  • #4141: [Models] Reload models unhides hidden models
  • #4142: [Models] Changing model on an entity with a skin reverts skin to default
  • #4173: [Map Editing] Feature request: saved paths in prefab inspector
  • #4172: [GUI] TextureBrowser Setting "Max shadername length" ignored in Preferences
  • #4111: [selection System] 'select group parts' toolbar button stuck
  • #4134: [GUI] Readable Editor not working in SplitPane layout
  • #4171: [Design/Coding] Rare crash during startup due to duplicate worker threads
  • #4126: [Objectives] Instability in Objective Editor
  • #4091: [Objectives] Objective Component always reverting its value to 1 when selected
  • #3306: [Map Editing] func_door issues with models
  • #4102: [Map Editing] Crash when closing an additional XY view window
  • #0384: [Map Editing] Dragged entity loses angle field
  • #3150: [Design/Coding] "angle" spawnarg disappears when it's set to zero and the entity is moved
  • #4100: [Map Editing] Crash when moving single PatchNode over 512 units away from origin
  • #0692: [GUI] Find and Replace - seek to material
  • #3675: [GUI] find and replace texture dialog box. using mouse 3
  • #4096: [GUI] Show the keyboard shortcut in the toolbar button help texts
  • #4080: [Design/Coding] Startup Performance Improvements
    • #4093: [Design/Coding] Parse .def, .gui, .mtr and .sndshd files in separate threads during startup
    • #4081: [Design/Coding] Make logging subsystem thread-safe
    • #4069: [sound System] Offload sound shader loading to separate thread
  • #4092: [Objectives] Objectives Editor should remember its size and position
  • #4088: [Map Editing] Layers: after "Hide All", showing a single layer doesn't make it the default layer
  • #4089: [GUI] When clicking on the Layer Control Dialog, the scroll bar jumps to the bottom
  • #4086: [GUI] Add Find & Replace Textures command to the main menu
  • #4087: [Models] XreaL: MD3 models are loaded without texture
  • #4082: [GUI] Preload ModelSelector tree after startup
  • #4068: [GUI] Light Texture Chooser does not display the currently active texture
  • #4067: [GUI] ModelSelector forgets last selected model when hitting Cancel
  • #4066: [GUI] ESC key does not propagate as shortcut when a tool window's text control is focused
  • #4065: [Map Editing] Add "Select/deselect elements using this shader" to MediaBrowser context menu.
  • #4062: [sound System] Slashes in sound shader names / shader file decls problematic
  • #4049: [GUI] Fit texture spin controls too narrow
  • #4052: [scripting] Running non-existent script file crashes DR
  • #3822: [Models] Choosemodel fails to display models when realtime lights are enabled
  • #4047: [Map Editing] Improve ModelSelector / RenderPreview navigation and rendering
  • #4029: [GUI] Text box focus issue when creating new layer
  • #2881: [General] Texture pane isn't initialized when a new map is started
  • #4032: [Map Editing] Target Lines are rendered in every preview if names happen to match

The list of changes can be found on the our bugtracker changelog.

Have fun mapping!

Link to post
Share on other sites

Moved from the pre-release thread -

 

Bugs

  1. the lines/arrow to any targeted entity disappear in the orthoview window if said entity is not visible - this is a bad bug.
  2. manipulating a model in prefab inspector needs 'always on' free view mode as per 181, currently have to click once to select and click again to release.
  3. prefab inspector is rotating models off-axis compared to 181
  4. animation controls available in the prefab inspector.
  5. scroll movement increments too large in prefab inspector compared to 181.
  6. layers window position not remembered - nuking the prefs file and restarting DR a few times, fixes it but only after a lot of restarts of DR.
  7. entity inspector window divider position not being remembered - the abo
  8. when resizing brushes from the sides, said brushes keep snapping back to original location/size. Holding the LMB for 0.5 - 1 second longer is the work around

Request

  1. Cant create/save custom prefab paths as per DR181, so have to browse to the custom prefab folder every time.
  2. scrolling through model/entity/textures inspectors is still a tad too fast.

Wishlist

  1. have snapshots ticked by default and the autosave interval set to 15mins, in the save section in the prefs.
  2. camera movement speed far to high by default, suggest lowering to 33
  3. have freelook mode unticked by default.
Edited by Bikerdude
Link to post
Share on other sites

[feature request]

 

Is it possible at all to work with prefabs in the following manner: a prefab would be made in a separate .map file. It can be piece of a level, some building, etc. When imported into "final" map, it would be selected as one entity (so it would be easier to manage scene). If prefab's .map was updated, that prefab would automatically updated in the "final" scene/map .

 

This would allow working on individual components and then assemble/compose final release map from such pieces. Also would be easier collaborate as folks can just work on individual pieces without disturbing final map. Also useful for modular mapping.

 

I know they did it for Prey 2 in Preditor, when Prey 2 was in works using id Tech 4.

 

Is it something achievable in DR and relatively easy to implement?

Edited by motorsep
Link to post
Share on other sites

Happy new year everyone!

 

Coming from 2.0.2 (23.08.2015) the new 2.0.3 version startup DR three time faster on my PC. dmap takes at least half the time as it did before for the same map. Don't know if this is connected to the new DR built. 2.0.3. seam to be a huge improvement to the former version. No crash on my system so far (Win10).

Edited by fllood

"To rush is without doubt the most important enemy of joy" ~ Thieves Saying

Link to post
Share on other sites

Ok so bad news got my first DR 2.03 crash and it happened un-expectantly like pre5 did. Dump file below.

 

- mega

 

The crashdump you sent me doesn't match the 2.0.3 release version from December 30th. In fact it matches the 2.0.3pre6 pre-release build, so you might want to double-check your DR installation.

 

I still can open the dump using the older PDBs I've got backed up, so I'll see what I can extract from the crashdump.

Link to post
Share on other sites

I can see that the crash is happening while you hit the ESC key during a mouse operation. This is not a problem at all in itself, but perhaps there is some sort of event race going on. Can you recall what kind of operation you performed during that moment?

Link to post
Share on other sites

Regardless what you did, the program should never crash. I'm still trying to figure how the situation I'm seeing in the crashdump came to be. Looking at the code I would have thought that this is not possible at all, but obviously it can happen.

 

When you tried to deselect stuff using ESC, did you use the mouse at the same time? Or were you just hitting the ESC key without doing anything else?

Link to post
Share on other sites

Hi all, think I'm having a bit of a rendering issue with this version of Darkradiant. After a certain distance in camera view, things start disappearing. I don't remember this happening in 2.0.1, which is what I was using previously. Is this a bug? Is there any way to easily fix this?

 

[Edit]: Nevermind, found the issue. "Enable far-clip plane" was checked by default, I've now managed to turn it off. Derp.

Edited by Aosys
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...