Jump to content
The Dark Mod Forums

TDM 2.06 issues...


Recommended Posts

GUI scaling is demonstrated in the 2nd half of this video:

 

https://m.youtube.com/watch?v=g-6Ok7foV2Y

 

Please try a more standard resolution like 800x600.

 

Also, make these changes:

 

Seta tdm_lg_split 1

Seta tdm_lg_interleave_min 1

Seta tdm_lg_interleave 3

 

And see if things run better.

Please visit TDM's IndieDB site and help promote the mod:

 

http://www.indiedb.com/mods/the-dark-mod

 

(Yeah, shameless promotion... but traffic is traffic folks...)

Link to post
Share on other sites
  • Replies 170
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Behind Closed Doors (library), Briarwood Manor (outdoors), Rightful Property (city area closer to the bank), and No Honor Among Thieves (mission 1 cave and mission 3 forest) are good ways to stress te

You don't have to use FXAA in the global settings. You can use application settings (not sure about the English name) and choose TDM exe from the dropdown list, so it works just for TDM.

Shadow Quality just changes the transition gradients.   If you want the "look" to change, try r_softShadowsRadius 5.0 or any other value than 1.0. (larger numbers are blurrier)

Posted Images

OK.

 

One last try.

 

These cvars:

 

seta gui_mediumFontLimit "0.30"

seta gui_smallFontLimit "0.15"

 

control where we transition from one font size to another.

 

If the size of the area is below 0.30 we use medium. If it's below 0.15 we use small.

 

You could try lowering both to see if you can force the medium font version. Conversely, if this

looks this way because of some unnatural squeezing then increase both a little to see if

you can force the smaller font to stay active longer.

 

Finally, as a side note, I'm not sure about Intel GPU's but I know that on Nvidia "Index Buffers" cause lag.

Try disabling them:

 

seta r_useIndexBuffers "0"

Please visit TDM's IndieDB site and help promote the mod:

 

http://www.indiedb.com/mods/the-dark-mod

 

(Yeah, shameless promotion... but traffic is traffic folks...)

Link to post
Share on other sites

I would like to add my problems report too!

- The new shadows simply dont work at all, they just create fields of black spots. I have an onboard card, so it might just be a compability thingy, old shit n stuff.

- The rope arrow is suddenly broken... As soon as i climb on it, it freaks out and lashes itself into the first wall it can find. Unclimbable.

 

Thats all i care for :3 The update brought alot of new performance! And the SFX update really made a huge entrance <3

 

thx

Can we have more scary Zombie Horror maps?

Link to post
Share on other sites

I would like to add my problems report too!

 

- The new shadows simply dont work at all, they just create fields of black spots. I have an onboard card, so it might just be a compability thingy, old shit n stuff.

- The rope arrow is suddenly broken... As soon as i climb on it, it freaks out and lashes itself into the first wall it can find. Unclimbable.

 

Thats all i care for :3 The update brought alot of new performance! And the SFX update really made a huge entrance <3

 

thx

 

What hardware do you have?

 

OS, CPU, GPU, driver versions, etc?

Please visit TDM's IndieDB site and help promote the mod:

 

http://www.indiedb.com/mods/the-dark-mod

 

(Yeah, shameless promotion... but traffic is traffic folks...)

Link to post
Share on other sites

Windows 10

Intel HD graphics 4600 - OnBoard

 

Its not getting better so i stop here instantly XD

 

You have the latest driver:

 

https://downloadcenter.intel.com/download/27780/Graphics-Intel-Graphics-Driver-for-Windows-15-40-?product=81496

 

and the intel patch:

 

https://www.moddb.com/mods/the-dark-mod/downloads/the-dark-mod-206-intel-glsl-fix

 

?

Please visit TDM's IndieDB site and help promote the mod:

 

http://www.indiedb.com/mods/the-dark-mod

 

(Yeah, shameless promotion... but traffic is traffic folks...)

Link to post
Share on other sites

Oh shit an intel patch for tdm!!! Lemme try that out!

 

UPDATE_1

 

Nope both didnt work XD

Tdm patch did nothing and driver update crashed... :c

Says its not valid for my hardware!

Edited by Filizitas

Can we have more scary Zombie Horror maps?

Link to post
Share on other sites

Now for something completely different ;), namely sounds. I already complained a long time ago that many chests sound like doors which irritates me to no end as I always think someone is coming. So I looked into the prefab definitions and noticed that a lot of containers have their open and close sounds pointing to effects that don't exist, most of the time due to some minor naming mismatches. Could this be the reason that TDM then falls back to the default door sound? Will fixing this affect existing missions or only new build ones?

  • Like 1
Link to post
Share on other sites

No, prefabs don't fall back to default sounds if a broken sound is used.

 

Do you have an example of a container that points to a wrong sound?

Link to post
Share on other sites

No, prefabs don't fall back to default sounds if a broken sound is used.

 

Do you have an example of a container that points to a wrong sound?

cashbox_grey_patterned.pfb and -_glasstop.pfb want door_open_07 and door_shut_05 but the actual sounds are called door_open_7 and door_shut_5.

 

chest_wealthy_loot_high.pfb and -_high.pfb want old_creaky_door_shut_01 but the actual sound is called old_creaky_close_1.

 

crate_openable.pfb wants door_open_03 and door_shut_02 but the actual sounds are called door_open_3 and door_shut_2.

 

footlocker.pfb and -loot_high.pfb and -loot_low02.pfb want old_creaky_door_shut_01 and door_shut_02, see above.

 

jewellerybox.pfb and -silver.pfb want door_open_07 and door_shut_05, see above.

 

Or are these sounds hidden elsewhere, where I haven't found them?

Link to post
Share on other sites

Oh shit an intel patch for tdm!!! Lemme try that out!

 

UPDATE_1

 

Nope both didnt work XD

Tdm patch did nothing and driver update crashed... :c

Says its not valid for my hardware!

Hmm. Let's figure out your hardware.

 

Please post screenshots from:

 

CPU-Z

 

https://www.guru3d.com/files-details/cpu-z-download.html

 

GPU-Z

 

https://www.guru3d.com/files-details/gpu-z-download-techpowerup.html

 

and DxDiag

 

https://support.microsoft.com/en-us/help/4028644/windows-open-and-run-dxdiagexe

Please visit TDM's IndieDB site and help promote the mod:

 

http://www.indiedb.com/mods/the-dark-mod

 

(Yeah, shameless promotion... but traffic is traffic folks...)

Link to post
Share on other sites
footlocker.pfb and -loot_high.pfb and -loot_low02.pfb want old_creaky_door_shut_01 and door_shut_02, see above.

 

 

 

I looked at footlocker_loot_low.pfb, and it didn't have any sounds set for open/close, which is why it was falling back to the defaults.

 

I looked at footlocker_loot_high.pfb, and it correctly made the opening and closing sounds that were set for it.

 

What sound does footlocker_loot_high.pfb make for you when you open/close it?

Link to post
Share on other sites

 

 

I looked at footlocker_loot_low.pfb, and it didn't have any sounds set for open/close, which is why it was falling back to the defaults.

 

I looked at footlocker_loot_high.pfb, and it correctly made the opening and closing sounds that were set for it.

 

What sound does footlocker_loot_high.pfb make for you when you open/close it?

Can you point me to a FM where this is in easy reach for testing? And yes, loot_low had no sounds at all, but loot_low02 had the wrong ones. What sounds are the default ones? I have the feeling door_open_1 and door_close_1 are the ones that I hear most often, maybe just this prefab needs to be fixed...

Link to post
Share on other sites
but loot_low02 had the wrong ones

 

I just added it to a testmap and it works fine for me.

 

Can you point me to a FM where this is in easy reach for testing?

 

How did you establish that they weren't working if you couldn't test them?

 

I have the feeling door_open_1 and door_close_1 are the ones that I hear most often, maybe just this prefab needs to be fixed...

 

Yes, those are the default sounds for door entities.

Link to post
Share on other sites

How did you establish that they weren't working if you couldn't test them?

I didn't yet. I just compared the sounds mentioned in the prefabs with those in the sound pk4! Maybe TDM chooses the sound with the closest name if it can't find the specified one?

 

P.S.: I found an easy example: The first chest in the key and lockpicks section of the training mission. It has the standard door_open_1 and door_close_1 sounds and it shouldn't...

 

P.P.S.: ... and the prefab used for this might be chest_old_loot1.pfb, which has no sounds assigned either. Sadly changing anything in the prefab file doesn't fix the in-game sound :(.

Edited by wesp5
Link to post
Share on other sites

Remember how I reported in 2.05 that there's a bug which affects the mission results in Closemouthed Shadows if you quicksave once? Well, I inadvertently discovered a further development of this bug. Apparently, this affects the mission results of any mission if you don't quickload once after you quicksave once. I was recording The Elixir, and I thought I was lucky not having to reload a save, but of course, I was greeted by the same mission results bug from Closemouthed Shadows, thus having to re-record The Elixir all over again, delaying its upload to YouTube. I hope this helps, as it's still there in 2.06. This bug is more easy to reproduce in Closemouthed Shadows than other missions due to it being very simple, with only two enemies, one of which you have to assassinate.

 

Also, I think the zoned ambience tracks might not be working properly - the zoned tracks are supposed to be filtered, but they don't seem to work, playing exactly the same in-game as their unzoned counterparts. I've observed this in Somewhere Above The City.

  • Like 1

"Let me guess - little blue men with three heads stole your sweetroll?"

Link to post
Share on other sites

P.P.S.: ... and the prefab used for this might be chest_old_loot1.pfb, which has no sounds assigned either. Sadly changing anything in the prefab file doesn't fix the in-game sound :(.

That is because prefabs are just a couple of entities, that are stored together with their settings, so a map author does not have to set them up each time by himself. As soon as they are set into a mission, they are treated like the original entities. Thus, changing settings in the prefab will affect the used prefab in the future, but has no effect on the ones already used as they are not prefabs anymore. To change already used ones you would have to change the settings on the entity in general (which in this case is not possibel as they are customised doors).

Link to post
Share on other sites

Thus, changing settings in the prefab will affect the used prefab in the future, but has no effect on the ones already used as they are not prefabs anymore.

Ah, I feared as much. Still this issue should be looked into for TDM 2.07 then...

Link to post
Share on other sites

Remember how I reported in 2.05 that there's a bug which affects the mission results in Closemouthed Shadows if you quicksave once? Well, I inadvertently discovered a further development of this bug. Apparently, this affects the mission results of any mission if you don't quickload once after you quicksave once. I was recording The Elixir, and I thought I was lucky not having to reload a save, but of course, I was greeted by the same mission results bug from Closemouthed Shadows, thus having to re-record The Elixir all over again, delaying its upload to YouTube. I hope this helps, as it's still there in 2.06. This bug is more easy to reproduce in Closemouthed Shadows than other missions due to it being very simple, with only two enemies, one of which you have to assassinate.

I'm sorry but I cannot find your previous report.

I have just tried to reproduce it, and the stats look correct, except for Times Saved: 0 despite one quicksave.

It is the only problem you have?

 

Also, I think the zoned ambience tracks might not be working properly - the zoned tracks are supposed to be filtered, but they don't seem to work, playing exactly the same in-game as their unzoned counterparts. I've observed this in Somewhere Above The City.

 

I hope someone more competent in sound department will look into it.
If you explain what exactly you mean, I could create an issue myself. But I don't know what are zoned/unzoned sound, and what do you mean by "filtered" here :unsure:
Link to post
Share on other sites

Two more issues I noticed, although they are probably not 2.06 specific and might have been mentioned before:

 

- lack of support for ultrawide aspect ratios and resolutions, at least the following resolutions should be added:

* 21:9 (actual aspect ratio is 64:27) resolutions: 2560x1080 3440x1440 5120x2160

* 24:10 resolutions: 3840x1600

* 29:9 resolutions: 3840x1200

* 32:9 resolutions: 3840x1080 5120x1440

Maybe on this occasion support for 18:9 resolutions should be added as well in case someone wants to stream to a mobile device.

Since UHD2 monitors are available now I think 7680x4320 should be added to 16:9 as well.

 

- A few sound effects are apparently in stereo and thus receive no positional treatment. Only sound effects in mono can be used for positional audio. An example is sneeze01.ogg in tdm_sound_vocals04.pk4. There are a few more but I'm unsure if it's intentional (i.e. if some machine sounds should have more of a room filling sound rather than being able to pinpoint them to their origin). However, for the sneeze sound it's important to have positional audio, right now it sounds like a sneezing guard is very close/in the same room even if he is far away.

  • Like 1
Link to post
Share on other sites

I think Hiradur is referring to GUI settings to change to those resolutions.

It may be worthwhile to consider adding more resolutions to the GUI, sure.

Please visit TDM's IndieDB site and help promote the mod:

 

http://www.indiedb.com/mods/the-dark-mod

 

(Yeah, shameless promotion... but traffic is traffic folks...)

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...