Jump to content
The Dark Mod Forums

Assets with invalid data


Recommended Posts

Using the latest dev build, I'm noticing some of the default assets have issues with missing shaders or skins even certain meshes. Some entities appear as black boxes in-game whereas certain skins for good models come out as transparent white surfaces instead of a proper texture. I figured I should make a thread for reporting these seeing the issue is rather widespread to quite a few of the default models and entities.

Here's one to start off with: Create an atdm:ai_mage01 then give it the skin plain_robes. The outer coat looks fine but the inner clothing causes ghosting.

eTzrGCX.jpg

Link to comment
Share on other sites

Next one: I'm using a lovely building set in my FM called tudor_buildings which work wonderfully as a way to detail towns with quality structures that have no interior. Unfortunately the 4th building in the set (models/darkmod/architecture/buildings/tudor_buildings/building4.lwo) has a missing shader for the window, which in the world causes the same transparent whiteness and lets you see through the structure even some of the back faces of it.

u8Uapbf.jpg

Link to comment
Share on other sites

Last issue I'm personally aware of, please report any others here if you've seen them. In the bushes category there's one entity called atdm:nature_bush_large_3 which has an invalid model and appears as a black box. All other bushes are fine on my end and it's just this one that has a problem.

Link to comment
Share on other sites

Sorry for so many posts in a row, keep finding them as I add different assets to my FM. atdm:ai_mage01_female also has a missing texture for the boots, they too appear as the white transparency which is visible when she walks on stairs. And in her case it's with the default skin, happens even without me manually setting another skin from the list.

Link to comment
Share on other sites

23 hours ago, MirceaKitsune said:

Here's one to start off with: Create an atdm:ai_mage01 then give it the skin plain_robes. The outer coat looks fine but the inner clothing causes ghosting.

eTzrGCX.jpg

This looks pretty cool, could make a ghastly invisible enemy if applied to the whole skin. :awesome: Just a pair of disembodied hands.

Link to comment
Share on other sites

3 hours ago, roygato said:

This looks pretty cool, could make a ghastly invisible enemy if applied to the whole skin. :awesome: Just a pair of disembodied hands.

Would be nice as a controlled feature and not an unintended bug :)

Link to comment
Share on other sites

Until someone else can confirm that they're seeing the same thing, there's no way to rule out missing assets on your end.

Link to comment
Share on other sites

I checked a couple of these out. The justice fence has the same issue as Mircea here; I'm also getting a dmap warning that refers to it.

A6cPlTV.png

Is this something I can fix by downloading something?

As for the mage, the plain_robes skin does look a little funky on the model viewer, but I don't get this ghosting effect in-game.

Link to comment
Share on other sites

textures/darkmod/gleeful is not an official folder.  Where did that "justice fence" even come from?  It shouldn't be in the core assets.

 

 

Link to comment
Share on other sites

1 hour ago, Springheel said:

Until someone else can confirm that they're seeing the same thing, there's no way to rule out missing assets on your end.

I update via the official installer... should be no way to have missing data unless the installer can break and do incomplete pk4 updates, in which case I assume more stuff would be missing and even crashing. Note however that I'm using the latest dev snapshot, some of those assets might be okay in 2.09 but could have broken since.

Link to comment
Share on other sites

The dev build probably includes things that are specifically excluded in the release build packaging process, which might explain things.

Link to comment
Share on other sites

9 minutes ago, Springheel said:

The dev build probably includes things that are specifically excluded in the release build packaging process, which might explain things.

Could you elaborate on that? Do we have textures in release builds that don't exist in assets svn?

Link to comment
Share on other sites

There are assets that are specifically excluded from the release package because they aren't/weren't in a state suitable for release.  Sometimes those things get fixed, sometimes they get removed from SVN, and there are probably other times where neither happens.  I thought that wall that referred to a non-existent folder would be an example of the the latter, since it's been missing textures for at least a decade, but I just checked and it is indeed included in the core assets for some reason.

 

 

Link to comment
Share on other sites

2 hours ago, Springheel said:

There are assets that are specifically excluded from the release package because they aren't/weren't in a state suitable for release.  Sometimes those things get fixed, sometimes they get removed from SVN, and there are probably other times where neither happens.  I thought that wall that referred to a non-existent folder would be an example of the the latter, since it's been missing textures for at least a decade, but I just checked and it is indeed included in the core assets for some reason.

 

 

Yeah, that wall is in release. I know since I used it in a (yet unreleased) FM which I began in late 2016. Funny enough I don't remember it having the missing texture then.

The missing skins on the mages are probably a bug... the mage characters have always been there, unless I'm horribly mistaken and missing something. Same for the Tudor building set IIRC, probably just one texture that was missed on that one building.

Link to comment
Share on other sites

Which exact files are we talking about?

Perhaps the following thing has happened:

  1. @MirceaKitsune had some unofficial assets in archive named tdm_{somethinghere}.pk4 in the root TDM directory.
  2. tdm_installer treats all pk4/zip files starting with "tdm_" as core TDM packages.
  3. tdm_installer has deleted this archive on update, since the target version does not have it.

 

Link to comment
Share on other sites

On 7/3/2021 at 9:55 PM, Springheel said:

The dev build probably includes things that are specifically excluded in the release build packaging process, which might explain things.

Is this documented somewhere?

Link to comment
Share on other sites

9 hours ago, stgatilov said:

Which exact files are we talking about?

Perhaps the following thing has happened:

  1. @MirceaKitsune had some unofficial assets in archive named tdm_{somethinghere}.pk4 in the root TDM directory.
  2. tdm_installer treats all pk4/zip files starting with "tdm_" as core TDM packages.
  3. tdm_installer has deleted this archive on update, since the target version does not have it.

 

I'm not sure about the exact files that are missing. My first 5 posts document the models and entities I've found to be buggy in DarkRadiant and TDM though. IIRC DarkRadiant reports missing stuff in the console... perhaps I can copy the links from there and share them here later if that helps.

I'd be quite surprised if I somehow had unofficial assets put in by the installer: I never manually placed any assets in the core directory, except for my WIP cyberpunk mod TheDarkModule which I can obviously differentiate. If any assets are coming up, the installer placed them there one way or another... that being said my base installation is many years old.

I really hope there aren't issues with some of those assets not being official though. Considering not just that they're very good ones, but that I'm already using them in a FM I'm working on and designed my map around them; I'm looking to keep my FM small and would rather not include copies of big foreign assets with it.

That justice fence I'm not using so it can go. The mages, Tudor buildings, and grass entity are assets that I use however. IIRC they're all official and I'd be shocked if they weren't, though just in case perhaps someone can double-check just so we can put this possibility aside.

Link to comment
Share on other sites

On 7/3/2021 at 11:35 PM, roygato said:

A6cPlTV.png

The name refers to member @gleeful, maybe he knows where to get these files and what's their status.
I see his name put as author in SVN assets.
 

Two materials include "gleeful" in their name: models/gleeful/textures/winerack and models/gleeful/textures/winerack2, with a skin winerackSmooth turning one into another.
These materials are referenced in models/darkmod/furniture/shelves/winerack.ase.

There is also models/darkmod/architecture/fencing/justice_wall_fence2.ase, which uses materials textures/darkmod/gleeful/decals/fence and textures/darkmod/gleeful/stonewall_flat
These materials are not present anywhere... Although I see textures/darkmod/stone/flat/stonewall_flat, which may cover the first one.
 

I have checked TDM 2.00, it seems the situation is the same in it: the same model uses the same "gleeful" materials which don't exist.
So this is a very old problem.

Link to comment
Share on other sites

Alright: When I load my FM in DarkRadiant I see just a handful of relevant messages highlighted in orange or red in its console.

Stage keyword not recognised: portalrendermap
Stage keyword not recognised: screen
ShaderLibrary: definition not found: black
ShaderLibrary: definition not found: Default
ShaderLibrary: definition not found: textures/darkmod/wood/floor/boa
Error parsing mirrorRenderMap. Expected two integers: stoi
Stage keyword not recognised: _scratch2
[shaders] Unable to load texture: textures/decals/stain01bwet.tga
ShaderLibrary: definition not found: tudor01_doorwin_mix
ShaderLibrary: definition not found: models/md5/chars/nobles/noblewoman/noblelegs

The last two lines seem to address exactly what I'm seeing: Missing leg texture for the female mage, plus a missing window texture for one of the Tudor buildings.

Link to comment
Share on other sites

  • 4 weeks later...

The particle model pagan_orb_effect.prt contains a missing texture too, causing it to emanate white and gray rectangles instead of the glare texture it was using before. This is definitely a default asset and has been around for many years... I believe I remember seeing it work without issue very long ago, it likely broke later on.

a2gF8Fn.jpg

Link to comment
Share on other sites

5 minutes ago, Dragofer said:

Stuff like this really needs to be tracked in the bugtracker.

I agree. Problem is I'm finding a lot... kind of reporting just the important and obvious ones. Let me know if there's a better format to bring them to attention.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recent Status Updates

    • irg

      Watching warmly for The Black Parade, The Broken Goddess and Blood Death Wish Ep.4. Sometimes the best things in life actually are free.
      · 0 replies
    • STiFU

      We are taking our son on his very first holiday trip to see the sea for the first time. 🙂 Will be back in a week.
      · 2 replies
    • Gilkar

      When I was a young man my father was so ignorant I could hardly stand to have him around. As I grew older I was amazed at how much the old man had learned in such a short time.
      · 2 replies
    • jaxa

      RTX 3090 Super, RTX 3070 Ti 16 GB, RTX 2060 12 GB
      https://wccftech.com/nvidia-launching-rtx-3090-super-rtx-3070-ti-16gb-and-rtx-2060-12gb-by-january-2022/
      · 0 replies
    • duzenko

      CPU benchmark time - compiling DarkRadiant (2nd run)
      i5 8600K 6C/6T@4.4GHz DDR4 2x2133MHz 9MB cache
      Parallel builds: 1. 3:57 Parallel builds: 6 (default). 2:28 r5 1600AF 6C/12T@3.3GHz DDR4 1x2666MHz 16 MB cache, temp folder on HDD
      Parallel builds: 1. 5:05 Parallel builds: 4. 2:47 Parallel builds: 6. 2:55 Parallel builds: 12 (default). 2:57
      · 6 replies
×
×
  • Create New...