Jump to content
The Dark Mod Forums

Black Mage: performance problems (and fog)


Gadavre

Recommended Posts

Hi

I started testing the new "The Black Mage" mission in versions 2.09b and 2.10.  I wanted to turn off the fog for better visibility and better performance. But I couldn't as my favorite variable stopped working!

seta r_skipFogLights "1"

In version 2.07 this variable worked and I was able to disable fog in Thief's Den 3 mission (Heart of Lone Salvation)

Maybe there is other variables to disable fog in the latest versions of the game? If this is a bug, please fix it.

Link to comment
Share on other sites

3 hours ago, stgatilov said:

If you are talking about "fog" at the starting location, then technically it is not fog, it is particles.

You can disable all particles by "r_skipParticles 1".

 

I did it. In doing so, fire is gone all over the map and the map has become boring without fire. It's not a solution to the problem.

it may be possible to add a new variable to the version 2.10 that will only disable Fog of particles

 

Edited by Gadavre
Link to comment
Share on other sites

@GadavreUntil you get this new variable you could use this customised particle file to make the most common fog particles invisible. z_nofog.prt You have to be logged in to download it. (edit: should be renamed to a_nofog.prt)

To use it, close TDM and create a folder called "particles" in your "darkmod" folder and put this file inside it. Result: darkmod/particles/z_nofog.prt.

Some FMs like The Black Mage have custom versions of fog particles, which means this file might not work 100%. So you can create a folder called "particles" in the fm's folder and put a copy of the file inside it. Result: darkmod/fms/black_mage/particles/z_nofog.prt.

Link to comment
Share on other sites

1 hour ago, Dragofer said:

@GadavreUntil you get this new variable you could use this customised particle file to make the most common fog particles invisible. z_nofog.prt You have to be logged in to download it.

To use it, close TDM and create a folder called "particles" in your "darkmod" folder and put this file inside it. Result: darkmod/particles/z_nofog.prt.

Some FMs like The Black Mage have custom versions of fog particles, which means this file might not work 100%. So you can create a folder called "particles" in the fm's folder and put a copy of the file inside it. Result: darkmod/fms/black_mage/particles/z_nofog.prt.

I did everything like you wrote, but the fog didn't go away....version 2.09b

Edited by Gadavre
Link to comment
Share on other sites

2 hours ago, Gadavre said:

I did everything like you wrote, but the fog didn't go away....version 2.09b

Alright, try renaming both copies of the file from z_nofog.prt to a_nofog.prt.

  • Like 1
Link to comment
Share on other sites

There is no way the game engine can help you.
From its point of view, the fog particles and the fire particles are the same thing.

You best bet would be to modify the mission locally.
Like finding which particle it is and overriding its particle decl.

Anyway, you can just get indoors quickly, there is no fog indoors.

Link to comment
Share on other sites

You can ask @JackFarmer if he would be willing to add lod_bias args to all the fog particle emitters. Then you can set your LOD detail to low and it should prevent these from rendering.

https://wiki.thedarkmod.com/index.php?title=LOD_Bias

( Or edit the entity defs for the emitters in your local copy )

 

Please visit TDM's IndieDB site and help promote the mod:

 

http://www.indiedb.com/mods/the-dark-mod

 

(Yeah, shameless promotion... but traffic is traffic folks...)

Link to comment
Share on other sites

6 hours ago, Dragofer said:

Alright, try renaming both copies of the file from z_nofog.prt to a_nofog.prt.

yes! yes! You're a good wizard! Put a "particles" folder with your file in the TDM folder and the fog disappeared!

Edited by Gadavre
  • Like 1
Link to comment
Share on other sites

2 hours ago, jaxa said:

BTW, for reference, what are your specs?

is that a question for me? I've already answered it. I have good specs except for the video card. nvidia GT1030 2GB VRAM GDDR5. all missions on the old version of the game 2.07 go without lag (until approximately 2018).

New modern missions have become very large and video card demanding

Edited by Gadavre
  • Thanks 1
Link to comment
Share on other sites

9 hours ago, Gadavre said:

is that a question for me? I've already answered it. I have good specs except for the video card. nvidia GT1030 2GB VRAM GDDR5. all missions on the old version of the game 2.07 go without lag (until approximately 2018).

New modern missions have become very large and video card demanding

You realize that the mission creators don't target your PC specs? Why do you insist on having it with all bells and whistles at 60 fps? Feel free to contribute a source code patch that would achieve that, it would be very much welcome, but understand that the next mission that comes out after that will push the graphics details even further and you will have to start from scratch again

Did you try the parallel jobs cvar like I advised above?

Link to comment
Share on other sites

8 hours ago, duzenko said:

 

Did you try the parallel jobs cvar like I advised above?

I don't know what you mean. Which variable do I need to change?

I wrote above that I got a big boost in fps with this line,

r_SkipUpdates 1

but this line also introduced bugs to the mission... Turning off the shadows completely didn't help

Edited by Gadavre
Link to comment
Share on other sites

r_showsmp seems to spit out FFFFFF
I also see: Exceeded index frame limit (4096 kb), resizing...
New byffer size: 33285 kb
And: 16.0 to 24 milliseconds for asingle "R_AddSingleModel" job from list JOBLIST_RENDERED_FRONTEND on thread x
I set the jobs_numThreads to 8
Using 2 or 8 threads doesn't seem to hav an effect on GPU load.
Most part of the game the fps is above 60, in the lava cave it's between 4 and 12

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recent Status Updates

    • Ansome

      Query: when was the last time a zombie in a video game was unnerving or scary to you? I'm chipping away at my anniversary submission and I've been trying to gather opinions on the subject. I'm perfectly capable of lighting them well, changing their sfx, and creating effective ambience, but I'm worried that zombies at their core are just too overdone to be an effective payoff to the tension I'm creating.
      · 3 replies
    • nbohr1more

      The Lieutenant 3 is out! Congrats Frost_Salamander! ( raising awareness )
      · 2 replies
    • OrbWeaver

      Has anyone had any luck with textures from Polyhaven? Their OpenEXR normal maps seem too washed out and give incorrect shading in the engine.
      · 5 replies
    • datiswous

      I tried to upscale the TDM logo video. First try:

      briefing_video.mp4 You can test it ingame by making a copy of the core tdm_gui.mtr and place it in your-tdm-root/materials/ , then edit line 249 of that file into the location where you placed the new briefing.mp4 file.
      What I did was I extracted all the image files, then used Upscayl to upscale the images using General photo (Real-Esrgan) upscale setting and then turn it back into a video.
      I might have to crop it a bit, the logo looks smaller on screen (or maybe it's actually better this way?). My video editor turned it into a 16:9 video, which I think overal looks better than 1:1 video of original.
      · 1 reply
    • nbohr1more

      Trying to be productive on my down-time before Capcom releases Akuma and my son is constantly on my PC playing Street Fighter...
      · 1 reply
×
×
  • Create New...