Jump to content
The Dark Mod Forums

Beta testing 2.12


stgatilov

Recommended Posts

Volta 2 crashes to desktop on mission completion before the "mission complete" screen appears.

Edit:

Spoiler

It only happens when I put Belero on the elevator instead of shouldering him.

 

Edited by Baal
Link to comment
Share on other sites

On 2/12/2024 at 6:45 PM, nbohr1more said:

You made new saves under the latest build right?

Yes, however, did more tests now. The problem already starts with the first beta build. When downgrading to 2.11, everything works fine.

Link to comment
Share on other sites

2 minutes ago, JackFarmer said:

Yes, however, did more tests now. The problem already starts with the first beta build. When downgrading to 2.11, everything works fine.

Thank you!

Does is also happen in the first 2.12 Dev build

dev16778-10275

?

If not, can you bisect to the first dev build where it happens?

Please visit TDM's IndieDB site and help promote the mod:

 

http://www.indiedb.com/mods/the-dark-mod

 

(Yeah, shameless promotion... but traffic is traffic folks...)

Link to comment
Share on other sites

15 hours ago, nbohr1more said:

Thank you!

Does is also happen in the first 2.12 Dev build

dev16778-10275

?

If not, can you bisect to the first dev build where it happens?

The problem does not show up with all related dev builds. However, I cannot test with the last build (16854-10518), which I simply cannot start and get the report

image.png.d68833e6ea295ea514ad41ac9c0e7097.png


EDIT: As per our friend dragofer's suggestion, I made a blank script file in this build and removed the turrets from the WIP for a test. Then I can start the game and the mission and can save/load without problems.

 

Summary:

  • 16842-10488: no problems
  • 16854-10518: cannot test (see above)
  • 16854-10518 (modified scriptfile, no turrets) : no problems
  • beta 1: problem appears
Edited by JackFarmer
Link to comment
Share on other sites

2 hours ago, JackFarmer said:

The problem does not show up with all related dev builds. However, I cannot test with the last build (16854-10518), which I simply cannot start and get the report

image.png.d68833e6ea295ea514ad41ac9c0e7097.png

 

Summary:

  • 16842-10488: no problems
  • 16854-10518: cannot test (see above)
  • beta 1: problem appears

You can work around this error by putting a completely empty file called tdm_turret_scriptbased.script in your script folder, and temporarily removing all turrets from the map. Would still be interesting to see whether 10518 is the first build where the problem appears, or beta1.

Link to comment
Share on other sites

1 hour ago, Dragofer said:

You can work around this error by putting a completely empty file called tdm_turret_scriptbased.script in your script folder, and temporarily removing all turrets from the map. Would still be interesting to see whether 10518 is the first build where the problem appears, or beta1.

Just added a test as per your suggestion in my post above.

  • Like 1
Link to comment
Share on other sites

On 2/15/2024 at 7:18 PM, Baal said:

Volta 2 crashes to desktop on mission completion before the "mission complete" screen appears.

  Hide contents

It only happens when I put Belero on the elevator instead of shouldering him.

Maybe you can provide a savefile?

Link to comment
Share on other sites

13 hours ago, JackFarmer said:

The problem does not show up with all related dev builds. However, I cannot test with the last build (16854-10518), which I simply cannot start and get the report

image.png.d68833e6ea295ea514ad41ac9c0e7097.png


EDIT: As per our friend dragofer's suggestion, I made a blank script file in this build and removed the turrets from the WIP for a test. Then I can start the game and the mission and can save/load without problems.

 

Summary:

  • 16842-10488: no problems
  • 16854-10518: cannot test (see above)
  • 16854-10518 (modified scriptfile, no turrets) : no problems
  • beta 1: problem appears

@nbohr1more@Dragofer

Update to the post quoted above: only missions with turrets are concerned, all others work fine.

Link to comment
Share on other sites

On 2/15/2024 at 12:18 PM, Baal said:

Volta 2 crashes to desktop on mission completion before the "mission complete" screen appears.

I was able to reproduce this in 2.12 beta as well as 2.11.

  1. Start mission
  2. setviewpos -5727 974 292 24 -57 0
  3. Wait for new objective
  4. setviewpos 3795 5676 -3164 18 160 0
  5. Wait for objective complete
  6. Shoulder body
  7. setviewpos -1643 3574 -1903 4 180 0
  8. Drop body on elevator platform
  9. Press elevator button

Setting "logFile 2", I was able to capture some console messages before the crash. "MISSION COMPLETED" displays twice instead of once. I haven't had a chance to look further into this.

WARNING:idClipModel::Handle: clip model 0 on 'bellero' (dc8) is not a collision or trace model
WARNING:idClipModel::Handle: clip model 0 on 'bellero' (dc8) is not a collision or trace model
WARNING:idClipModel::Handle: clip model 0 on 'bellero' (dc8) is not a collision or trace model
MISSION COMPLETED
MISSION COMPLETED
----- idRenderModelManagerLocal::EndLevelLoad -----
    0 models purged from previous level,  1031 models kept.
---------------------------------------------------
Regenerated world, staticAllocCount = 0.
Getting threadname failed, reason: No such file or directory (2)
--------- Game Map Shutdown ----------
ModelGenerator memory: 133 LOD entries with 0 users using 2128 bytes.
WARNING:idClipModel::FreeTraceModel: tried to free uncached trace model (index=0)
--------- Game Map Shutdown done -----
Shutting down sound hardware
idRenderSystem::Shutdown()
...shutting down QGL
I18NLocal: Shutdown.
------------ Game Shutdown -----------
ModelGenerator memory: No LOD entries.
Shutdown event system
--------------------------------------

 

  • Like 1
Link to comment
Share on other sites

6 minutes ago, JackFarmer said:

@nbohr1more

Any updates here? Sorry for being a pain, but this is a critical problem preventing me from finishing my campaign beta preps.

This is being investigated.

2.12 has the needed save state features so the cause is still unclear.

If the problem cannot be solved in a reasonable time-frame, we may need to revert to 2.11 turret features and suggest completing any needed additions via local changes to your mission (... pretty unlikely, as we are highly motivated to retain the 2.12 turret improvements).

However this gets resolved, it is the last blocker issue for 2.12 to leave beta phase.

  • Like 3
  • Thanks 1

Please visit TDM's IndieDB site and help promote the mod:

 

http://www.indiedb.com/mods/the-dark-mod

 

(Yeah, shameless promotion... but traffic is traffic folks...)

Link to comment
Share on other sites

Update:

@JackFarmer

The root cause of the turret crash has been found.

It seems that it was given the same physics code as the security camera but does not have handling for cases where no clip model exists.

Removing the physics code fixes the issue.

That said, I guess we may look into adding it back so that the turret follows the same destruction features as the camera?

 

  • Thanks 2

Please visit TDM's IndieDB site and help promote the mod:

 

http://www.indiedb.com/mods/the-dark-mod

 

(Yeah, shameless promotion... but traffic is traffic folks...)

Link to comment
Share on other sites

On 2/22/2024 at 5:01 PM, nbohr1more said:

If the problem cannot be solved in a reasonable time-frame, we may need to revert to 2.11 turret features and suggest completing any needed additions via local changes to your mission (... pretty unlikely, as we are highly motivated to retain the 2.12 turret improvements).

In fact, there are no 2.11 turret features since it's a completely new thing for 2.12. Unofficial script versions of the turret also rely on code changes that were made during turret development for 2.12.

Link to comment
Share on other sites

I fixed another case of clipping into the ceiling during a mantle that starts in the standing position and ends in the crouching position (a.k.a forced-crouch mantle). The fix is included in beta212-07.

The fix changed a lot of code, so please let us know if you find any issues.

 

 

  • Like 1
Link to comment
Share on other sites

On 2/24/2024 at 12:57 PM, stgatilov said:

beta212-07 is available.

This one is considered release candidate, meaning that most likely it will be turned into official release soon.
For this reason, here are the deprecated 32-bit binaries.
It would be great if someone briefly checks the 32-bit Linux executable (cannot do it myself).

I don't have a 32-bit OS but I am able to launch the 32-bit executable on Linux Mint 21.3.

I think the story is similar to what I saw in 2.10.

Lots of large maps produce AAS errors on launch but seem mostly functional.

King of Diamonds seems to have lots of AI that are circling or having path finding issues.

On a positive note, I was able to launch "The Painter's Wife", "Penny Dreadful 3", "Behind Closed Doors", " Shadows of Northdale 1", "Not an Ordinary Guest" basically all the largest maps and no loading errors were seen and all allowed in-game play.

Oddly enough both Iris and The Painter's Wife have no AAS errors and no AI path-finding bugs even though they are the largest.

  • Thanks 1

Please visit TDM's IndieDB site and help promote the mod:

 

http://www.indiedb.com/mods/the-dark-mod

 

(Yeah, shameless promotion... but traffic is traffic folks...)

Link to comment
Share on other sites

I experience significant lower FPS in both TDM 2.12/64 #10644 (beta212-06) and TDM 2.12/64 #10651 (beta212-07) that I don't see when I run 2.11, and that I didn't notice in earlier 2.12 betas.

In Training Mission, when starting the mission and looking straight forward, the FPS is now 23 (was 32 FPS in 2.11), and when going down the short stairs and looking up to the skylight, the FPS is now 9 (was 18 PFS in 2.11).

The settings between the versions seem to be the same.

  • Like 1
Link to comment
Share on other sites

4 hours ago, Fiver said:

I experience significant lower FPS in both TDM 2.12/64 #10644 (beta212-06) and TDM 2.12/64 #10651 (beta212-07) that I don't see when I run 2.11, and that I didn't notice in earlier 2.12 betas.

In Training Mission, when starting the mission and looking straight forward, the FPS is now 23 (was 32 FPS in 2.11), and when going down the short stairs and looking up to the skylight, the FPS is now 9 (was 18 PFS in 2.11).

The settings between the versions seem to be the same.

Can you double-check and see if the performance loss also impacts beta 5.

I believe that a volumetric light was added to the skylight.

You can also try setting r_volumetricEnable 0 and see if performance returns to normal.

 

  • Like 1
  • Thanks 1
  • Confused 1

Please visit TDM's IndieDB site and help promote the mod:

 

http://www.indiedb.com/mods/the-dark-mod

 

(Yeah, shameless promotion... but traffic is traffic folks...)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recent Status Updates

    • The Black Arrow

      Hey @nbohr1morehow come the zombies in The Dark Mod don't have a "resurrection" mechanic to it, similar to how Thief has it?
      They're quite a weak creature as of right now, it's merely a walking corpse that slashes you, making attacking them to kill them an actual strategy.
      Would be better if they had some cool mechanism to it that truly makes them a danger, such as the resurrection idea itself.
      · 0 replies
    • Ansome

      Query: when was the last time a zombie in a video game was unnerving or scary to you? I'm chipping away at my anniversary submission and I've been trying to gather opinions on the subject. I'm perfectly capable of lighting them well, changing their sfx, and creating effective ambience, but I'm worried that zombies at their core are just too overdone to be an effective payoff to the tension I'm creating.
      · 4 replies
    • nbohr1more

      The Lieutenant 3 is out! Congrats Frost_Salamander! ( raising awareness )
      · 2 replies
    • OrbWeaver

      Has anyone had any luck with textures from Polyhaven? Their OpenEXR normal maps seem too washed out and give incorrect shading in the engine.
      · 5 replies
    • datiswous

      I tried to upscale the TDM logo video. First try:

      briefing_video.mp4 You can test it ingame by making a copy of the core tdm_gui.mtr and place it in your-tdm-root/materials/ , then edit line 249 of that file into the location where you placed the new briefing.mp4 file.
      What I did was I extracted all the image files, then used Upscayl to upscale the images using General photo (Real-Esrgan) upscale setting and then turn it back into a video.
      I might have to crop it a bit, the logo looks smaller on screen (or maybe it's actually better this way?). My video editor turned it into a 16:9 video, which I think overal looks better than 1:1 video of original.
      · 1 reply
×
×
  • Create New...