Jump to content
The Dark Mod Forums
stgatilov

Beta Testing 2.08

Recommended Posts

I just realized that immobilizing the player is actually not OK while the player is in mid-air. Sure, this is a very rare corner case ("grabbing an AI while in the air"), but playing out the animation and then dropping on the floor is really weird. It also still feels kind of weird, that the player view cannot be adjusted while the animation plays out. I will have to revisit the code.

  • Like 3

Share this post


Link to post
Share on other sites
16 hours ago, STiFU said:

I just realized that immobilizing the player is actually not OK while the player is in mid-air. Sure, this is a very rare corner case ("grabbing an AI while in the air"), but playing out the animation and then dropping on the floor is really weird. It also still feels kind of weird, that the player view cannot be adjusted while the animation plays out. I will have to revisit the code.

I have addressed both issues. The changes should be in the next beta release.

@kingsal, @lowenzI actually had a quick look into mobilizing the player during the shouldering animation, but apparently it is not easily possible because the player actually clips through the floor and allowing regular movement during that leads to the player falling through the floor. Sorry guys, this cannot be changed without creating a completely new type of viewport animation, which is way besond the scope of this beta-phase. However, I made sure that you can actually disable the animation via pm_shoulderAnim_msecs = 0.

  • Thanks 1

Share this post


Link to post
Share on other sites

@STiFU

Right on, thanks for looking into that. 

On a related note: The swimming animation feels pretty good. Any chance we can get hookups in the code for player swimming sounds?  I think it would make the animations feel more convincing. I remember making a bug for this I think back in 2.06.

Share this post


Link to post
Share on other sites
1 minute ago, kingsal said:

@STiFU

Right on, thanks for looking into that. 

On a related note: The swimming animation feels pretty good. Any chance we can get hookups in the code for player swimming sounds?  I think it would make the animations feel more convincing. I remember making a bug for this I think back in 2.06.

Both are already in place. 😉 Did you actually play with sound enabled? You can find more details here:

https://bugs.thedarkmod.com/view.php?id=4992

  • Like 1

Share this post


Link to post
Share on other sites
9 hours ago, kingsal said:

The water sounds aren't  working in my mission, but I'll investigate it and report back. Might be something on my end.

Custom tdm_player_thief.def or tdm_sfx_movement.sndshd in you mission?

Share this post


Link to post
Share on other sites
On 3/28/2020 at 8:51 PM, Springheel said:

The animations are present in the release SVN.  It's possible they were not included in the release package, as the werebeast used to be excluded.  Although that doesn't make sense, as the mesh and the animations are in the same folder.  If the mesh shows up in DR, the animations should as well.

If someone suspects that packaging dropped a file, please report either a file path (like models/md5/chars/monsters/werebeast/werebeast_mesh.md5mesh) or an in-game asset path (like textures/darkmod/fogs/real_fog_layer_moving).

Regarding werebeast, I see the following files with "werebeast" in their name in latest beta package (ignore the numbers):

Spoiler

af/werebeast.af: a066a38feca0de120f2ac790d25eda6db6da0e5ae5b6784ee9e5a67dc6faa09c
dds/models/md5/chars/monsters/werebeast_head.dds: 61c0cf7c316bdfc68c3851c3f1ded0b412f92125aff82f3d8d3a94a86e8e2e2e
def/tdm_ai_monster_werebeast.def: 929707cabccec7da1915b19b41ba759f8c22bc9412b520d42caab4345d952c60
materials/tdm_ai_monsters_werebeast.mtr: 0511c195a67c0631e1834be73dbb9952ef4c492be7dc940ceed8e7c4841e6bb2
models/md5/chars/monsters/werebeast/werebeast_diffuse.tga: f6d9ea9b1215ea96beec5be2f945971adbf51574678877c728869a1b8df9efcf
models/md5/chars/monsters/werebeast/werebeast_idle.md5anim: 2f852b81792dcf0fd894a06d31f70c79b0418274c256f7b7ddbe824159e28f1d
models/md5/chars/monsters/werebeast/werebeast_meleeattack.md5anim: 937956d6c8744d405352616f10226c16de67bc145f3c2f2dce9a14af5f4a8f1f
models/md5/chars/monsters/werebeast/werebeast_mesh - Kopie.md5mesh: 946c043b9cce060173621028473bbbcb4f9121fa8b14ca249a18037894c38418
models/md5/chars/monsters/werebeast/werebeast_mesh.md5mesh: b71a24b4fe8f7bb396257389c842d2f54500aad4c3c6ebf296a52b03e279a1c0
models/md5/chars/monsters/werebeast/werebeast_normal.tga: d96ca15933346378ac033026e65cbbf2ca1e58be413bac818ba370ba701157a0
models/md5/chars/monsters/werebeast/werebeast_pain1.md5anim: e282fe41c2b758282271c0f72693e12517ad58bb2f9c18830f678f3f3799c2ea
models/md5/chars/monsters/werebeast/werebeast_run_two_legs.md5anim: 37f63c32b945a6e23372967bf43389f76f581144d4b57528815920e6b16ff363
models/md5/chars/monsters/werebeast/werebeast_search1.md5anim: 241d5e1c912c2be86c104a20b19e39fc6643daf8654ac3b964ab42267ee219b2
models/md5/chars/monsters/werebeast/werebeast_walkcycle.md5anim: cc4e72b40d8529e361b87643e69268e23a698a13d44fe4d07e568f8572fed1b1
sound/tdm_ai_monster_werebeast.sndshd: 363f75468eec44864307242b71ad68b7bf1f0915f505a498ba090478c505d4fe
sound/voices/monster/werebeast/were_chatter1.ogg: 82f4e0d069be1f1f9cf7aa4c5baa42e2e6da9fa3391f270ecbee34b4ff51ae9c
sound/voices/monster/werebeast/were_chatter2.ogg: e76aa83935f0e435062cfac197f0077d25f0b58b60b8cfbe4434bf9638573ede
sound/voices/monster/werebeast/were_chatter3.ogg: abe8cd124c7764b51fd7a51853588b2144aaa7575a96034781d4e7658d4f38dc
sound/voices/monster/werebeast/were_chatter4.ogg: f1910e9aee30fa6229e7f6057bc1bfbcdd93018963c6bad9e1e2e7a2b0f1705f
sound/voices/monster/werebeast/were_idle5.ogg: 605dc2f9647df094b9469fd6cf150bdcce4d86078e1a85e0fa71e6992727fd24
sound/voices/monster/werebeast/were_melee1.ogg: c8f545f76b0a63afaca266c95ffdea43bc1cbafc8a8fc94a7e104f6b38bb074e
sound/voices/monster/werebeast/were_melee2.ogg: 5713e298f120cb0da17989374fbd07ea43f210459ef56d1d61569e05673ba8c5
sound/voices/monster/werebeast/were_melee3.ogg: 1fa12f57ed9578d0c5b1eabf2e1c6c2c109f71e3fbd789e5f09efba9eeffff3a
sound/voices/monster/werebeast/were_melee4.ogg: 520babe90f56c2f4c075a50ca47ab9b03c76f56ad65aa5d59d301ecf5e4592bd

Almost all of these files are in tdm_ai_humanoid_beasts01.pk4 archive, which is new. So check at least that it is present.

If it is not, then run game and verify that you see proper svn revision in game console (that's the last number in the lower-right corner of the console).

Finally, please verify that you have the following in tdm_mirrors.txt file (NOTE: latest beta is beta208-02, the last digit must be "two"):

[Mirror localhost]
url = http://tdmcdn.azureedge.net/beta208-02
weight = 1

Note that unlike previous betas, this time you must redownload tdm_mirrors.txt every time you want to get a new beta package. The link to this text file is given at the very first post, and I will update the underlying file every time a new beta version comes out.

Share this post


Link to post
Share on other sites

Everyone here, and especially people who had problems with aliased font.

Could you please verify that r_useFBO is 1, and set it if it is not?
I have seen cases when some errors reset it to 0, and it is never returned back.

Share this post


Link to post
Share on other sites

Installed the beta and played parts of the training mission:

Gamma and brightness settings don't affect the main menu and books when used. I can lighten and darken the game but menu and active/in-use readables always look the same.

I found some missing geometry faces (full faces, not just single tris) in the first part of the climbing area on some horizontal beams of the construction site.

training_mission_2020-04-02_21.53.52.jpg

  • Like 2

Share this post


Link to post
Share on other sites

beta208-03 has been released.
The list of changes is provided in its usual place.

Remember that you must download tdm_mirrors.txt again from the link in the original post before running tdm_update.
Otherwise you will not get the new beta release and will stay on beta208-02 instead.

  • Like 1

Share this post


Link to post
Share on other sites

Updating beta2 with a beta3 download ...

First part of the download went okay, but the 1Gb second part failed with this message:

"Initiating Download from http://tdmcdn.azureedge.net/beta208-03/tdm_ai_humanoid_guards01.pk4
Thread finished with error: Could not download from any mirror."

 

EDIT: No problem with a clean install of beta3 to an empty folder.

  • Like 1

Share this post


Link to post
Share on other sites
On 4/2/2020 at 7:51 AM, stgatilov said:

Everyone here, and especially people who had problems with aliased font.

Could you please verify that r_useFBO is 1, and set it if it is not?
I have seen cases when some errors reset it to 0, and it is never returned back.

I had had the aliased font problem as well, BUT it seems to be fixed now without me doing anything, no idea why. 

The only thing I changed was that I set image_useCompression and image_useNormalCompression to 0, that was the first and only time I ever touched the console, and now I cannot find any broken parchments. Changing compression back to 1 does not break it. r_useFBO is set to 1.

One perhaps important piece of information is that this is not a new 2.08 beta bug, I encountered it in fresh 2.07 installation as well (just forgot to report it among reporting other things), and it only happened with parchments using purple ink.

  • Like 1

Share this post


Link to post
Share on other sites
On 4/1/2020 at 1:09 AM, STiFU said:

Custom tdm_player_thief.def or tdm_sfx_movement.sndshd in you mission?

Yep thats its. I'll have to update volta 2 and do a new release once 2.8 is out. I'm not sure if the custom player def is even necessary, but I'll have a look.

@stgatilov - When I dmap it generates a bunch of MAPNAME_portaIL_00_000_000.lin files. What are these? Is there documentation on this some where?

EDIT: Okay I gathered these are missing / broken portals. Is there anyway to get DR to read these .lin files so I can easily jump to the missing portal? 

EDIT EDIT: Ha okay I sort of figured it out.  I found the additional dmap commands. Even after reading the console descriptions, Im still not totally sure what these new commands do. 

Edited by kingsal
  • Like 1

Share this post


Link to post
Share on other sites
9 hours ago, kingsal said:

When I dmap it generates a bunch of MAPNAME_portaIL_00_000_000.lin files. What are these? Is there documentation on this some where?

EDIT: Okay I gathered these are missing / broken portals. Is there anyway to get DR to read these .lin files so I can easily jump to the missing portal?

See p.2 and p.3 in the Mapping section of changelog, they provide a link to wiki.

4 hours ago, Spooks said:

r_useFBO was already set to 1 and updating to beta 3 did not fix the aliased font.

Ok.
If someone can reliably reproduce the problem with fonts, please provide darkmod.cfg and exact steps.

  • Like 1

Share this post


Link to post
Share on other sites
On 3/29/2020 at 1:23 PM, duzenko said:

SS samples uniform not set after shader reload

Call this from rendersystem_init "Uniforms::Interaction::SetForShadows"

?


Please visit TDM's IndieDB site and help promote the mod:

 

http://www.indiedb.com/mods/the-dark-mod

 

(Yeah, shameless promotion... but traffic is traffic folks...)

Share this post


Link to post
Share on other sites

Had a crash during dmap while working on my map So I made a post in the Newbie Thread, and as this crash during dmap happens with 2.08 (everything is working fine in 2.07) I thought I'd put the condump here too. What else can I provide?

https://drive.google.com/open?id=1AZ01aeKiFwZjAzrlcTIyOZCeYFeFumnE 

Edited by Jedi_Wannabe

Share this post


Link to post
Share on other sites
3 hours ago, Jedi_Wannabe said:

Had a crash during dmap while working on my map So I made a post in the Newbie Thread, and as this crash during dmap happens with 2.08 (everything is working fine in 2.07) I thought I'd put the condump here too. What else can I provide?

I'm afraid the dump does not contain crash. It looks like it is a dump of running TDM, probably with main menu or console open. The last console command was "dmap mill7", but probably it finished.

Are you sure you are meaning "crash", i.e. you see OS message about it and the TDM program terminates completely immediately after you click OK? If yes, maybe you captured the dump at the wrong moment? Normally, you should record dump after it has crashed, when the OS message is still shown.

  • Like 1

Share this post


Link to post
Share on other sites

Well thats the thing I never got a dialogue window saying it crashed. I just ASSUMED it crashed when the dmap did not complete and the the program force closed on it own. Mill 7 was the last version before this started happening and a ‘map mill8’ has some stuff about the aas being out of date. So I guess I’m just assuming now it’s really a non issue ?

You know what they say about people who assume things... haha

Idk I just want to rule out bugs if that’s the issue. For mapping purposes I’ll stick to 2.07 til 2.08’s beta is over .

Edited by Jedi_Wannabe

Share this post


Link to post
Share on other sites
1 hour ago, Jedi_Wannabe said:

Well thats the thing I never got a dialogue window saying it crashed. I just ASSUMED it crashed when the dmap did not complete and the the program force closed on it own.

Well, it does not sound like a crash. Although I don't remember: does modern Windows 10 shows the dialog on crash by default? 🤔

How did you get console dump?
Perhaps you could enable logFile as described here? If TDM closes without a pause, then this is the only way to know the whole console output for sure.

Quote

Idk I just want to rule out bugs if that’s the issue.

Thank you for doing this! I would be happy to know too what goes wrong, especially if this is a regression from 2.07.

Quote

For mapping purposes I’ll stick to 2.07 til 2.08’s beta is over .

That's your choice. Just keep in mind that there is a chance that the bug (if this is a bug) will get into final release without your attention 😥

 

By the way, it seems we didn't even try the easiest way to analyze the problem. As far as I understand, you can reproduce the problem perfectly on 2.08. Could you please send me the FM/map where you have the problem? I'll try to dmap it myself, and it would be much faster and easier to understand what's going on if it reproduces.

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites

No error message or dialogue box. Just right clicked it from Task Manager which explains why it was a dump of a running TDM. I'm still hit or miss packaging these into a working .pk4 so please find my entire FM folder, with qconsole.log, mylog.txt and all the maps. The last working version was mill7 so i guess start there and go to 8 and 9. Sorry if it is messy. Thanks a ton for looking into this. Builder Bless Ye.

https://drive.google.com/open?id=1wBeHFG_Bo5TZrQWJjwMEVPvPYIdXR6sn

Share this post


Link to post
Share on other sites
17 hours ago, Jedi_Wannabe said:

The last working version was mill7 so i guess start there and go to 8 and 9. Sorry if it is messy. Thanks a ton for looking into this. Builder Bless Ye.

Thank you!
I can reproduce the crash on mill8. It crashes when freeing BSP tree in AAS build 😫 I'm afraid it will need some time 😞

UPDATE: This is not the first time when dmap crashes at this place. It is due do to numeric problems.
By the way, I don't think it is a regression actually: numeric behavior of dmap has changed, so such issues can disappear or appear on complicated maps.

  • Like 2
  • Thanks 1

Share this post


Link to post
Share on other sites

You’re the man!

That last thing I want is unforeseen cascading effect of problems, so to stop that from happening I’m gonna wait for the A-OK to resume work on my map. I don’t find much time on weekends anymore to map so I’m in no rush. I’d hoped this quarantine would give me more time to map but not so much with two kids home from school!

Edited by Jedi_Wannabe
  • Sad 1

Share this post


Link to post
Share on other sites

Crucible of Omens: Behind Closed Doors

A few oil lamps are now black:

 

bcd_2020-04-11_23_28_57.thumb.jpg.1bc893a77d90341b0f2b611be871a7a8.jpg

 

Probably related to adding more Dragofer assets to the core mod or path renormalization?

  • Like 2

Please visit TDM's IndieDB site and help promote the mod:

 

http://www.indiedb.com/mods/the-dark-mod

 

(Yeah, shameless promotion... but traffic is traffic folks...)

Share this post


Link to post
Share on other sites

Not sure if this has been reported yet, but I found a weird bug with blackjacking.

If you happen to press middle mouse button + attack with the blackjack select, the animation will play with a weird distortion and the attack will produce neither a sound or damage.

Video below.

https://youtu.be/z4mRSA0kWyY

 

Edited by zergrush
  • Haha 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...