Jump to content
The Dark Mod Forums

Issues in 2.08 final


wesp5
 Share

Recommended Posts

Thanks Kingsal! Actually, it turns out I'm kinda dumb. Your screenshot example being really dark on my end helped me realize the issue. I had Brightness down really far on my monitor and that was helping to make my water super black. In my defense, though, I always drop the Brightness way down and Contrast way up when playing Thief I and 2. I do it for T1/2 because it really makes the colors vibrant and rich (but not over-saturated), with rich/deep blacks, too. It's a trick I use on my LCD display to replicate the look of Thief that I had on my old CRT monitor back in the day. It's really effective for me. Without it, the nature of the LCD monitor tech causes brightened, luminous greys instead of deep blacks. I thought, and have always assumed, I'd want/need to do that for TDM ūüėē Maybe that's why I've always had gamma woes with TDM

I'll have to do some TDM testing at some point now, as maybe TDM just isn't as compatible with that approach as T1/T2 is for me. In looking at your map (and my screenshots above) with Brightness up a bit, I think I'll be okay. The coloring for the missions, in general, won't have as much pop as I like, but at least I can see everything now :)

I can delete my above posts if mods want me to; or they can if they wish; since it takes up so much room on the page. But it might help future people see if they encounter the same issue, I suppose(?)

 

 

Edited by Darkness_Falls
  • Like 2
Link to comment
Share on other sites

17 hours ago, kingsal said:

As noted in that thread, the console command to turn off the boop is "s_playDefaultSound"  "0". I thought it was off by default but I guess not.

If it is not set to 0 by default it should be, because it sounds very much out of place most of the time! Or choose a more subtle sound than a beep.

Edited by wesp5
  • Like 1
Link to comment
Share on other sites

2 hours ago, wesp5 said:

If it is not set to 0 by default it should be, because it sounds very much out of place most of the time! Or choose a more subtle sound than a beep.

Well its meant to sound out of place so developers hear it and fix the sound, but yeah it shouldnt be on in the release build.

  • Like 2
Link to comment
Share on other sites

34 minutes ago, kingsal said:

Well its meant to sound out of place so developers hear it and fix the sound, but yeah it shouldnt be on in the release build.

So this is kind of a "the sound is missing" sound. Nice idea! With Bloodlines you always need to check the console for that ;).

  • Like 1
Link to comment
Share on other sites

FPS increase after the menu loading

0.jpg

1.jpg

 

Why???? GeForce 1050 Ti, lastest drivers
 

Edited by lowenz

Task is not so much to see what no one has yet seen but to think what nobody has yet thought about that which everybody see. - E.S.

Link to comment
Share on other sites

No VSync (I'm using an adaptive sync monitor) an 80 FPS Cap.....

Adaptive sync perfectly working in the declared range (48-75, so smooth!)

39 FPS after loading the savegame -> Esc->Menu->Esc -> 54 FPS......

Edited by lowenz

Task is not so much to see what no one has yet seen but to think what nobody has yet thought about that which everybody see. - E.S.

Link to comment
Share on other sites

18 minutes ago, lowenz said:

No VSync (I'm using an adaptive sync monitor) an 80 FPS Cap.....

Adaptive sync perfectly working in the declared range (48-75, so smooth!)

39 FPS after loading the savegame -> Esc->Menu->Esc -> 54 FPS......

Sounds like a driver issue. 39 is half of 80

Link to comment
Share on other sites

12 hours ago, lowenz said:

39 with 60 FPS cap too....

WTF, in other missions too!

0.jpg

1.jpg
 

Hmm... this looks a little familiar :)

Are you only getting the frame rate drop after having loaded a savegame? Or any time you access the menu, as though it toggles each time?

Edited by PranQster
  • Like 1

System: Mageia Linux Cauldron, aka Mageia 8

Link to comment
Share on other sites

Only after the savegame loading+ESC, then the situation goes normal !

 

And yes, for who's asking "What map is that!?!?!?".....it's a nice surprise coming to you from our good PranQster (with some little support by me) :D

Edited by lowenz
  • Like 2

Task is not so much to see what no one has yet seen but to think what nobody has yet thought about that which everybody see. - E.S.

Link to comment
Share on other sites

On 8/20/2020 at 4:23 AM, wesp5 said:

Okay, so I found another issue which may be connected to 2.08 or some specific missions: Sometimes for notes a font is used that is very pixelated and barely readable. See this example from Shadows of Northdale Act II:

I think it is fixed already, see here.
Should work properly on latest dev build.

  • Like 1
Link to comment
Share on other sites

14 minutes ago, wesp5 said:

Ah, I must have overlooked that thread. Good to hear it is already fixed! Anything new about the failed lockpicking sound playing all the time?

I think no.

I recall there is an issue about it somewhere.
I tried to listen more attentively to lockpicking sounds, but did not hear anything suspicious. I guess it causes to little harm to bother.

Link to comment
Share on other sites

31 minutes ago, stgatilov said:

I tried to listen more attentively to lockpicking sounds, but did not hear anything suspicious. I guess it causes to little harm to bother.

I find it very annoying! For each successfull attempt the failing sound is played. This wasn't the case in 2.07 and should thus be easy to fix.

  • Like 1
Link to comment
Share on other sites

Apart from the aliased text which has hopefully been fixed for next versions, and which I started seeing again i 2.08 after seeing it a couple times in 2.07 and then never again, I also encountered a couple black objects. 

Both screenshots are from Northdale part 2, first one is from the path to city watch station, second one is from inside the station. 

If I recall correctly, the round lamp was already fixed during the betatesting, but apparently only for the turned on state (or maybe it was a similar looking but different model). It looks fine when turned on and emitting light, but when you turn it off, it turns black. With the hanging lantern it's possible that nobody noticed, I only did after seeing it for about the third time. 

dark mod - bugged light near city watch - northdale 2.jpg

dark mod - light is dark when turned off and illuminated - northdale 2.jpg

Link to comment
Share on other sites

I think it's time to take a closer look at the "Open Doors on Unlock" feature, as I got once again stuck because I had this set to off. Missions that are affected are the upcoming "Now and then", according to the forum search function also "The painter's wife", "The Alchemist" and "Hidden Hands: Initiation", and I remember another mission where it happened to me.

Can this somehow be circumvented by updated dev or script files or do the mission authors need to fix this on their side? If there is no common solution, shouldn't this option be removed? I don't know how many players there are who don't come looking here for help, but if they don't some of these missions are just completely not playable when this option is set to off.
 

  • Like 1
Link to comment
Share on other sites

3 hours ago, wesp5 said:

I think it's time to take a closer look at the "Open Doors on Unlock" feature, as I got once again stuck because I had this set to off. Missions that are affected are the upcoming "Now and then", according to the forum search function also "The painter's wife", "The Alchemist" and "Hidden Hands: Initiation", and I remember another mission where it happened to me.

Can this somehow be circumvented by updated dev or script files or do the mission authors need to fix this on their side? If there is no common solution, shouldn't this option be removed? I don't know how many players there are who don't come looking here for help, but if they don't some of these missions are just completely not playable when this option is set to off.
 

I can only speak for my mission (the soon-to-be-released "Now and Then"), but this issue can be resolved in the mission scripts. I fixed it yesterday so it'll be in the released FM. Here are the details.

In this mission I use the atdm:combination_lock_small. As is discussed in various threads, when using this asset you have to include the appropriate script file(s) in your <fm>\script folder. In this case, atdm:combination_lock_small has spawnarg "scriptobject" = "numberwheel_lock". At some point, when I was developing my first FM, I got a hold of numberwheel_lock.script (which was at the time included the TDM release. Subsequently it was removed, I think). I've put this in my \script folder for each FM I've built, and it works fine.

Except in the following case: the door is a secret door that isn't frobable, and it has open_on_unlock=1. The default code in numberwheel_lock.script makes the following call when the combo is correctly entered:

t.Unlock();

The variable 't' is the target of the combo lock (the door). This statement unlocks the secret door, which, because open_on_unlock=1, opens it. Except: if the user has "Open Doors on Unlock" = Off, that overrides open_on_unlock. So in that case the door isn't opened. And since the door isn't frobable, there is no way to open it even if it is unlocked.

The fix is to modify numberwheel_lock.script to call t.Open() as well t.Unlock(). This unlocks and then opens the door. Oh, and you have to remove the open_on_unlock=1 spawnarg from the door too.

These changes work fine, and are appropriate IMHO, since each FM 'owns' their copy of numberwheel_lock.script. It's a shame that each FM developer may need to make this adjustment, but I think that's an artifact of numberwheel's history.

  • Like 2
Link to comment
Share on other sites

2 hours ago, wesp5 said:

Couldn't this be fixed for all missions by readding numberwheel_lock.script with the changes you added?

Possibly. But I think there were reasons for removing the script from the release. According to this post talks about it: 

  

On 1/10/2019 at 6:27 AM, nbohr1more said:

In 2.07 it was decided that the numberwheel script from "A New Job" was too specialized to that mission and

that it shouldn't be a mod asset because it was causing mission developers too much trouble when they tried to

use it. To my knowledge, we sent the word out that this change would be happening and any mission using the script

has been repacked to include it in the mission package rather than inheriting from the mod asset base.

Looks like I need to fix my "Mission of Mercy" FM. It is broken now - I guess I didn't see that notification.

 

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share


  • Recent Status Updates

    • STiFU

      I started skateboarding again after a 20 year hiatus. Whish me luck I don't break anything. ūüėĄ
      · 6 replies
    • freyk

      Some years earlier i created some launchers for TDM. uploaded today some new sourcecode and executables on my github repo.
       
      · 0 replies
    • Epifire

      Say, I know it's been a while since the site got overhauled from the crash. But did we ever figure out if/how to get the recent topics & replies list back? It's not a total deal breaker but it was nice for becoming a thread creeper again...


      · 2 replies
    • Epifire

      Some of you who've been on the TDM discord know I was out of work last Winter, just putting in hrs for the developer portfolio. Currently I've been working a seasonal job to pay the bills and now I'm finally in my last week before I get bumped off. Things will be tight but I'm planning a long off period to make as much content as I can. Big plans in Unreal Engine as well as my most ambitious TDM collab yet! Never been so excited to be a stuck at home to pursue my life's work. With a lotta time and maybe some luck, I'm hoping to get enough art work done that I may start applying around to studios.
      · 4 replies
    • STiFU

      I finally got around to play Prey and I truly loved it. It is an incredible homage to System Shock and Deus Ex. While the gameplay is not en par with those two titles, the game makes up for that with its well written lore and story. The whole "world" just feells so authentic and it features a ton of really god environmental story-telling. Recommended for every immersive sim fan, i.e., everyone on this forum.
      · 5 replies
×
×
  • Create New...