Jump to content


Photo

Post your System Configuration here


  • Please log in to reply
209 replies to this topic

#1 greebo

greebo

    Heroic Coder

  • Root
  • 15956 posts

Posted 19 October 2009 - 07:35 AM

I'd like to encourage everybody to post their system configuration either here or in our wiki article. This way it's easier for newcomers to check whether their system is capable and what performance or problems are to be expected.

Please include information like:

- Operating System
- CPU
- System RAM
- Video Card
- Video Drivers (if that info is available)
- Experienced Performance, Steps you had to perform to get it running or problematic driver versions, etc.

If you're posting here, somebody from the team can transfer that info to the wiki article.



#2 STiFU

STiFU

    Uber member

  • Development Role
  • PipPipPipPip
  • 3122 posts

Posted 19 October 2009 - 09:24 AM

Too lazy, to register at the wiki... =)

OS: Windows 7 Professional
CPU: Intel Core2 Q6600
RAM: 4 GB DDR2
GFX Card: GeForce 8800 GTS 640 MB
Driver: 191.07 WHQL
Performance: Playable at 45 to 60 fps at 1680x1050, 16xAF, 2xAA and maxed out detail-settings including bloom. Under water only 14 fps. (That blurred vision seems to hit performance really hard)
Notes: Doom 3 crashes on me every now and then, but it's rather rare (3 to 4 hours until crash). Once it crashed during a save-operation, which destroyed that savegame.

#3 Neb

Neb

    Member

  • Member
  • PipPip
  • 226 posts

Posted 19 October 2009 - 09:26 AM

Laptop

  • - Windows XP - Service Pack 2
  • - CPU - Intel T2300 Dual-core @ 1.66 GHz
  • - RAM - 1 GB
  • - Video Card - NVIDIA GeForce Go 7400

Running at 800 x 600 the current 4 maps are easily playable with a slight bit of slow-down. Bloom is off. Anisotropic filtering at 8. Fast ambient rendering.

I still need to tweak the config some more to find out what's best, but I'm not experiencing problems. FPS occassionally dips below 30. The current maps take no longer than 4 minutes to load.

EDIT [After reading SneaksieDave's post] - Water works perfectly fine on my machine.



#4 SneaksieDave

SneaksieDave

    QA Lead

  • Development Role
  • PipPipPipPipPip
  • 10124 posts

Posted 19 October 2009 - 09:47 AM

Strange to hear this underwater framerate hit can affect nvidia too? Maybe a driver thing; it doesn't affect either of my nvidias (6800 and 7600GT).

#5 Springheel

Springheel

    Creative Director (retired)

  • Admin
  • 36238 posts

Posted 19 October 2009 - 09:53 AM

Strange to hear this underwater framerate hit can affect nvidia too?


It seems like that is related to bloom. The people reporting serious fps drops underwater all have Bloom on.

#6 STiFU

STiFU

    Uber member

  • Development Role
  • PipPipPipPip
  • 3122 posts

Posted 19 October 2009 - 10:34 AM

Yup it is. Runs like a charm without bloom on my end. Hope there will be a fix soon, but for now I scripted a toggle button. If there is no fix, I'd prefer bloom over advanced underwatervision, so a config-setting would be nice here.

Kinda offtopic: Where do you put a script like that? It's somehow overwritten if I put it in darkmod\DoomConfig.cfg and the autoexec.cfg I created is aparently not autoloaded. :) I also noticed that there is a folder for each FM in my Doom3-folder, containing a seperate DoomConfig.cfg, as well as its pk4-file. Is that supposed to be like that? I guess not, since there is an extra folder designated for the fm-pk4's and there is no need to store them twice...

Edit: I just found the tdm_underwaterblur setting. However, zeroing it does not fix the problem, nor does any other value.

Edited by STiFU, 19 October 2009 - 10:55 AM.


#7 greebo

greebo

    Heroic Coder

  • Root
  • 15956 posts

Posted 19 October 2009 - 10:53 AM

I'd uninstall any FM, restart, go the console and type

bind "f8" "toggle r_bloom 1 0"


#8 PsymH

PsymH

    Member

  • Member
  • PipPip
  • 106 posts

Posted 19 October 2009 - 11:05 AM

  • - Windows XP Home SP3
  • - AMD Athlon 64 3500+
  • - 2,00 GB
  • - ATI Radeon HD3850
  • - Catalyst 9.4 (I can't user newer versions, because Thief II will not work with them)

With my 17" monitor and 1280x1024 resolution the game runs very smooth, no FPS drops underwater, the sky also works fine. I don't turned bloom on, because I encounter massive problems in the Saint Lucia demo.



#9 Carnage

Carnage

    Member

  • Member
  • PipPip
  • 170 posts

Posted 19 October 2009 - 04:00 PM

  • - Operating System - Windows XP
  • - CPU - AMD 3500+
  • - System RAM - 1 GB
  • - Video Card - Nvidia 7800 GT
  • 178.24 due to problems with newer drivers when playing Risen

Experienced Performance, Steps you had to perform to get it running or problematic driver versions, etc.
Have it on 1680x1050, 4xAA, 8xAS, Bloom off. FPS drops with bloom on especially when outside.



#10 Komag

Komag

    Uber member

  • Development Role
  • PipPipPipPip
  • 3279 posts

Posted 19 October 2009 - 04:36 PM

Maybe bloom should be de-supported? Taken off the menus? Left as an external hack/tweak that advanced users can mess with if they want? Because it sounds like turning it off solves a lot of problems for a lot of people
Posted Image Posted Image

#11 Springheel

Springheel

    Creative Director (retired)

  • Admin
  • 36238 posts

Posted 19 October 2009 - 05:08 PM

Bloom was never supposed to be officially supported by us in the first place, though that's not very clear when it's in the menu.

#12 Tirek

Tirek

    Member

  • Member
  • PipPip
  • 23 posts

Posted 19 October 2009 - 05:38 PM

  • - Operating System Windows 7 Ultimate 64-bit
  • - CPU Core 2 Duo E6400, running at stock speed which is 2.13 GHz I think
  • - System RAM 2 GB
  • - Video Card geforce 7900GTO 512 MB
  • - Video Drivers (if that info is available) 190.62

Experienced Performance, Steps you had to perform to get it running or problematic driver versions, etc.
Settings: 1024x768, no AA, 16x anisotropic, all details on high, bloom on.
Didn't get around to measuring the framerate yet, but it's been good enough to never present an annoyance.

Haven't yet noticed any particular problems. Subjective impression is that being underwater probably FPS drops somewhat, but not enough to bother me. Elsewhere it's generally very smooth.



#13 peispud

peispud

    Member

  • Member
  • PipPip
  • 48 posts

Posted 19 October 2009 - 06:11 PM

  • -OS
    • sda - WinXP,Linux Mint, Pardus Linux, Debian, Sabayon Linux
    • sdb - Ubuntu, PCLinuxOS, Mandriva
    • sdc - PC-BSD, Mepis Linux
    • sdh - Chakra ( Arch ) Linux, CrunchBang Linux
  • - Intel® Core™2 Duo CPU E4600 @ 2.40GHz , 3 gig RAM
  • - nvidia 185.18.36 driver on an 8600GS

Currently running on Chakra Linux with max settings, running fine smile.gif Tested on Mint and Ubuntu with similar results. I had an issue with the sound dissapearing, but it's good now.


Edited by Bikerdude, 05 March 2017 - 06:58 AM.


#14 Inimitable

Inimitable

    Member

  • Member
  • PipPip
  • 12 posts

Posted 19 October 2009 - 10:35 PM

  • - WinXP, SP3
  • - Pentium 4, 3.4ghz single core
  • - 2gb RAM
  • - Nvidia GeForce 6800 256mb
  • - 8/17/2009 Nvidia drivers update (190.62 I think?)

Running at 1024x768, framerate is stable after bloom is turned off. Haven't encountered any issues.

I really need to upgrade...


Edited by Bikerdude, 05 March 2017 - 06:58 AM.


#15 Sogi-Ya

Sogi-Ya

    Member

  • Member
  • PipPip
  • 36 posts

Posted 20 October 2009 - 03:11 AM

lol good to know I'm not the only one running off a single core amd chip :)

windows XP SP2

amd 3400+

ati 2600

2gigz ram

latest hot fix drivers for the 2600
( i doubt my exact driver version as important as the fact i run off the hit fix ones, yippee for AGP. Posted Image )

#16 TTH

TTH

    Newbie

  • Member
  • Pip
  • 7 posts

Posted 20 October 2009 - 04:50 AM

- Operating System: Windows 7 Ultimate x64
- CPU: Core 2 Duo E6750 @ 3.2GHz
- System RAM: 6 GB generic DDR2-800
- Video Card: Sapphire HD4870 1GB
- Video Drivers (if that info is available): Catalyst 9.9
- Experienced Performance, Steps you had to perform to get it running or problematic driver versions, etc.

Rarely drops below 60 FPS with everything maxed with the exception of Bloom which unless disabled causes freaky Mescaline vision. Steam version of Doom 3 takes a bit of tweaking with the mod (ie. need to use a command line switch to activate the mod at start). Need to disable Catalyst AI in order to play most of the missions.

Edited by TTH, 20 October 2009 - 04:51 AM.


#17 Chiron

Chiron

    Member

  • Member
  • PipPip
  • 192 posts

Posted 20 October 2009 - 05:27 AM

  • WinXP Pro SP3
  • 2 GB RAM
  • GeForce 7300 GS 512 MB
  • Driver: Nvidia 191.07 WHQL
  • AMD Athlon 64 X2 Dual Processor 4200+

Its playable, but I can only get a good framerate in 800x600 with AA Off.
As soon as its on, the FPS sometimes drops under 10.
Bloom is off, The Shaders setting barely has an effect on the FPS. I experienced this on all maps released so far.

This doesn't seem right, so if anyone has a tip.....

Edited by Chiron, 20 October 2009 - 07:05 AM.


#18 Hyeron

Hyeron

    Member

  • Member
  • PipPip
  • 164 posts

Posted 20 October 2009 - 05:58 AM

 
  • Windows Vista & 7 RC (x86)
  • Intel Core 2 Quad Q6600
  • 4 Gb RAM
  • Geforce 9600 GT 512 Mb
  • Driver: nVidia 191.07 WHQL
Highly playable (mean framerate ~45/50) @ 1680x1050, Bloom + AA and AF on (4x/8x IIRC, not on that computer right now). Slight hit on FPS while underwater, nothing unbearable. Sound-wise though : sometimes sound just turns off until I quit the current mission and/or the game. Audigy 4 w/ EAX HD on, problem doesn't occur with EAX off. 

Edited by Hyeron, 20 October 2009 - 06:03 AM.

"Lie to a liar, for lies are his coin; Steal from a thief, for that is easy; lay a trap for a trickster and catch him at first attempt, but beware of an honest man"
- Arab proverb

#19 Subjective Effect

Subjective Effect

    Advanced Member

  • Development Role
  • PipPipPip
  • 1046 posts

Posted 20 October 2009 - 06:10 AM

Vista Home Premium
Intel Core2Duo E6600 @2.4GHz
4GB Corsair
GeForce 8800GTS 184Mb
8.16.0011.9062

No installation problems.

Running at max res according to TDM settings page though it looks like 1650x which I think is the case because I just copied over an old beta-test install in which I'd custom set it.

Bloom on, no problems, smooth as you like. FPS unknown but likely 30ish due to smoothness.

Summary: perfect. Looks fantastic, plays fantastic.
I want your brain... to make his heart... beat faster.

#20 Mortal Monkey

Mortal Monkey

    Member

  • Member
  • PipPip
  • 10 posts

Posted 20 October 2009 - 10:32 AM

Dell Precision M90 (laptop):
OS: Windows XP SP3.
CPU: 64-bit Intel Core 2 Duo, 2.33 GHz each.
RAM: 2 GB.
Video card: NVIDIA Quadro FX 3500M.
Video drivers: From Dell.
Performance: Looks great and plays great at 1920x1200. I've never been a big fan of AA though.

Edited by Mortal Monkey, 20 October 2009 - 10:33 AM.


#21 veganMalcontent

veganMalcontent

    Newbie

  • Member
  • Pip
  • 3 posts

Posted 20 October 2009 - 11:54 AM

- Windows Vista Enterprise x64
- Intel Core 2 Duo 2.8GHz
- 4GB Patriot DDR2 800
- NVIDIA GeForce GTX 285
- Some fairly recent CUDA driver
- AWESOME AWESOME AWESOME everything up all the way at 1600 x 1200. Swimming underwater feels like it renders a little slowly. Object manipulation RAWKS HARD. Still can't quite rope-swing-jump successfully. Doom patch a little confusing - it kept defaulting to a directory within the Doom 3 directory.

This mod kicks so much ass, you guys are freaking artists.


Sam

#22 Alacritous

Alacritous

    Member

  • Member
  • PipPip
  • 17 posts

Posted 20 October 2009 - 03:11 PM

- Operating System : Win XP pro SP3
- CPU : AMD X2 5000+
- System RAM : 4GB
- Video Card: GeForce 8600 GTS 256 MB
- Video Drivers : 6.14.0011.9062
- Experienced Performance, Steps you had to perform to get it running or problematic driver versions, etc.

I installed to C:\games\doom3 and used the tdm_update.exe to install the mod.

So far, I can't see anything wrong at all. no flickering, water looks nice from above and below, missions load in under a minute. No crashes, nothing.
It works flawlessly. The only performance lag I saw was when I played the editor startmap and I woke up all the AI at the same time.. it got pretty laggy then. Even when I killed them all(god mode).. the lag never went away.. The only suggestion I might have is is there anyway to kill the AI processes when the NPC's are knocked out or killed?

Edited by Alacritous, 20 October 2009 - 03:20 PM.


#23 Mortem Desino

Mortem Desino

    Uber member

  • Development Role
  • PipPipPipPip
  • 2442 posts

Posted 20 October 2009 - 05:48 PM

Even when I killed them all(god mode).. the lag never went away.. The only suggestion I might have is is there anyway to kill the AI processes when the NPC's are knocked out or killed?

First (the biggest contributor to the lag), The startpack doesn't have the AI optimized for having several dozen NPCs.

Second (a very minor performance issue), the AI still have to "think" even when they're dead/KO, or else their physics goes wonky.
yay seuss crease touss dome in ouss nose tair

#24 Alacritous

Alacritous

    Member

  • Member
  • PipPip
  • 17 posts

Posted 20 October 2009 - 06:32 PM

First (the biggest contributor to the lag), The startpack doesn't have the AI optimized for having several dozen NPCs.

Second (a very minor performance issue), the AI still have to "think" even when they're dead/KO, or else their physics goes wonky.


yeah, I wasn't serious about that.. I was just screwing around in the starter map and had some fun..

I'm kinda sad for all the people that have had so many problems when I haven't had any at all.

#25 gog.bgbrendle

gog.bgbrendle

    Newbie

  • Member
  • Pip
  • 2 posts

Posted 21 October 2009 - 10:00 PM

- Windows Vista Home Premium
- Intel Core 2 Quad Q8300 (2.5 ghz x 4)
- 6 GB ram (ddr 3 i think)
- Intel G45/G43 Express Video card (onboard video)
- I've kept my video settings pretty low, i've found that it runs best at 800x600. I get good framerates in tighter environments (20-30) but i still seem to get tolerable fps rates in more 'decorated' areas. The performance drops really happen as soon as I get more than two guards on the screen at the same time. In a populated area like that I'm probably only getting about 3-5 fps (still more than playable) but it's a little tough. :) I haven't really seen an option to turn down model detail in the darkmod and not sure if it's even necessary since most folks will have a better video setup than me. (the reason I don't have a good gfx card is that if I buy one, I'll spend ALL my time playing video games instead of using this computer as a home office, which is what i bought it for--haha). Overall i'm very impressed that DM runs with an onboard chip at all, two thumbs up everyone!




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users