Jump to content
The Dark Mod Forums

Vertical Contest Mission: Somewhere Above the City by Grayman (Aug 20, 2010)


Somewhere Above the City by Grayman (2010/8/20) Summer FM Vertical Contest Entry  

70 members have voted

  1. 1. 1. Gameplay: Enjoyment. Fun duration. Smooth flow, ect. Versus Bugs. Frustration, Boredom, framelag

  2. 2. 2. Appearance: Vertical use, Visual pleasure, lighting, visual style, deduct bad texturing etc.

  3. 3. 3. Story & Text: Story. Text. Briefing. Graphic storytelling

Recommended Posts

Yes, that's the bug. Don't know what the cause is though.



I did see those flasks but I just never thought they were frobable. I did try blasting those where they were. Can't believe I didn't try frobbing them. Just never made the connection. Maybe a new skin would be good labeled handle with care and a bigger frob distance. I think I'm just using to seeing those flasks as of no use, just decoration. With hindsight, if they were skinned with a distinctive texture and a label so they look like a new object I might have treated them differently. But if all players had no problem with this then it might be just me.


Link to comment
Share on other sites

Oh my.


What a nice mission!



GAMEPLAY: Good. This indeed was a good mission. I loved the tunnels. The explosion in the tunnels was cool. I liked the tower. The thunderstorm was excellent... I was gonna give perfect grades but then again... There wasn't much sneaking. There weren't many guards. The few ones were rather easy to avoid. There was not much that 'omygodtheguardiscomingquickquickhide! "-feeling. There was no tense lockpicking. It was more like a smooth glide past the guards with no significant excitement.


Also I was rather confused how to deal with the bomb in the roof. First I thought: "Okay I cut the wires and carry the bomb inside, where it can't be hit by a lightning." Nope. Then: "HEY, there's a series of buttons in the rear." After twiddling with the buttons forever, I decided that they are just there for a show. I shot all kinds of arrows at the box. I beat it with sword. Finally I went to the room below the and for a brief whim, shot a fire arrow at the table. Kaboom! Objective completed! What the hell just happened?!!? Loaded. Carried one bottle upstairs and destroyed the box for good. I'm probably an idiot, but the solution didn't feel the most logical one to me. You know: preventing a bomb from detonating by... well. Detonating it. wacko.gif


APPEARANCE: Excellent. Everything looked gorgeous. I loved the thunder. (I said that already, but the lightnings from the windows.. Bliss!) I can't say much bad things. I'm not giving better than excellent, however. The reason is because there were many rather boring, empty rooms. Some slight details on those would have been nice.


STORY: Near Perfect. Ladies and Gentlemen! This mission is the pinnacle of TDM story telling so far! Cutscene animations! Custom conversations! I had to pick up my jaw from the floor when the drunk guard started mumbling about the chest. Where did you get the voice actors? You live near a theather? Also the ending cutscenes were most excellent. I would love to see a wiki article on that one..



All in all. Really good mission. I am quite sure this mission will fare very well in this contest.

Congratulations Grayman!

  • Like 1


-The mapper's best friend.

Link to comment
Share on other sites

Great mission, especially the beginning was a joy, so beautiful the mines. I bet it took quite some time to create those. Because the mines were that great, the middle part became really boring though. Took me quite a while to figure out what to do in the end but what a great ending. Story really is one of the best so far. Also loved the drunk guard in the beginning :).

Link to comment
Share on other sites

Thanks for the good comments.


My maps have to have few guards because my computer is 5+yo and I can't play/test with more than 2 on the screen at a time. If/When I get a new computer, I'll be able to do better in this area.


The voices are all me. I wasn't happy with how they turned out, but I didn't have time to redo them. My son does some pro voice work in Hollywood, and he volunteered to do voices on real pro-grade recording equipment, but I just didn't have the time to get him involved.


Every mushroom was hand-planted. Every ... effing ... mushroom. That's one reason why I was so perturbed that DR can't properly rotate a group of objects; origins go flying every which way, and I had to take the time to go fetch each one of those suckers. I was very happy when the mine was finished and I could move up into the building. Using jdude's tutorial on mines as a model, they turned out pretty nice. That, and some eerie pictures of a slate mine in Ireland.


My apologies if the ending is confusing. If I had it to do over again, I would do something that was easier to figure out.




The machine has a tray of the electricity-sensitive potion on its side. Only electricity will set it off. Blow up a fire-sensitive flask near the tray and the tray won't go off. Which is why it's "safe" to destroy the machine with a fire-sensitive flask and a fire arrow.


The skin on the flasks is different depending on your graphics card. On my desktop, it's white, and the flask looks very frobbable (anyway, it lights up well). On my laptop, it's practically invisible, and virtually loses its frobability look. I didn't discover this difference until late in the design, so I didn't have time to think up a different way to destroy the machine. Perhaps I was depending too much on people taking the time to read the journal through to the end to pick up the clues on how to destroy the machine. I left a bunch of fire arrows and extra fire-sensitive flasks (even labeled) right near where you need them, hoping that would help, and also allow for people not taking the flask from the chest way back near the start. (I played a game once a long time ago that required that you grab something in the first "room" and not use it until halfway through. If you hadn't taken it, you were hosed. Of course, I hadn't taken it, so I quit, swore a blue streak at the author, and never finished the game.)


In retrospect, I should have just put "UP" and "DOWN" buttons inside the elevators. Not very realistic, but it would have simplified the button situation.


For you mappers, if you want to have a good laugh, load the *.map into DR and look at the cutscene vault. It's in the group of rooms at the very bottom of the map. That room right there is why I missed the deadline. I asked my son for some pro "scene-shooting" help with that scene (he's a film editor), but, again, I ran out of time to get him involved. The only thing I know about shooting dialogue scenes is to never "break the axis". Given 2 actors, one on the left and one on the right, make sure you always shoot from the same side of the axis between them. That way you won't confuse the viewer. Other than that, I made up the rest of the shots.



Link to comment
Share on other sites

Once again trying to avoiding reading this thread until I have played the mission... staying spoiler free...


Can soomeone please PM me to let me know if there has been some sort of updated version of this mission? I think maybe I have come across slight hints of such in glimpses and glances...

"A Rhapsody Of Feigned And Ill-Invented Nonsense" - Thomas Aikenhead, On Theology, ca. 1696

Link to comment
Share on other sites

it could be really masterpiece but sadly it's not.



There was lack of objects, AI, loot etc. Besides, there was problem with sleeping citywatch. When you wake him up, he stands up in a black box. Probably it's not designed for sleeping on ground, instead on bed or something above from the ground.


Hovewer, good parts are much more than bad parts.:) Mine tunnels were well designed. I enjoyed the climbings.

I loved the lightning! It has even timing. First light comes, then sound. It makes great atmosphere. Cinematics was really stunning except vocals.





Anyway, I really wish this map was well polished but it wasn't possible in the circumstances of contest. So, I request long term contests in the future.

Link to comment
Share on other sites

 No Fidcal, you weren´t the only one who had problem with the flask.


Well, I did take it immediately after reading the journal, but I agree it shoud have some distincitve texture over it. When I had it in inventory, I coudn´t take any of those in laboratory, so I thought this was the only one. Also, as somebody pointed out, Journal was a bit too long. It would be better to shorten the message, or divide the main idea into different notes. I also didn´t knew I had to destroy that machine at the top of the tower. I tried to frob the buttons, but it didn´t work, so I let it be. And why did the electric trap at trapdoor didn´t stop to work, even when the source of it´s energy was destroyed? I noticed a button behind the ladder, is that suppose to disable the trap? Because I didn´t try to frob it, it would take too much of my life, and I didn´t had too much at that point.


But apart from that, it was excellent. It has atmosphere which graduated as you progressed, except that point when you reached the top of tower and you didn´t knew what to do (some other hints/more specific objectives would do the trick). For me the best mission of the contest, alongside with The Glenham Tower. Second place for Rift, Betrayal and then Illusionist tower.





I´d like to thank this way to all of you who are participating not only in this contest, but in creating these missions (and, of course, developers of darkmod+tools), which are getting better and better. It´s good to see one of my favorite games in up-to-date graphics and alive and well :)






Link to comment
Share on other sites

As said, a few bugs here and there, the middle part feels empty and the ending goals are a bit confusing.

However, this is a gorgeous FM dripping with atmosphere, detail, good ideas and interactivity. It's the first time that I feel really there in TDM. Keep up the good work Grayman!


This is my fave so far.

Link to comment
Share on other sites


I agree that there could have been more AI and more lockpicking, etc. to make it a bit more difficult. But besides that, I loved it!

Finished in 49 minutes and missed 200 loot on Expert mode, so I'll have to play it through again.

I'm thinking:


Perhaps there was another place when the mixture in the flask could be used? I'm not sure, but I was tempted to set it off in the temple area where the spiders were hanging out by the body. That decorative panel there made a hollow wooden sound when struck with the sword or blackjack... something behind it maybe?


System: Mageia Linux Cauldron, aka Mageia 8

Link to comment
Share on other sites

I'm thinking:


Perhaps there was another place when the mixture in the flask could be used? I'm not sure, but I was tempted to set it off in the temple area where the spiders were hanging out by the body. That decorative panel there made a hollow wooden sound when struck with the sword or blackjack... something behind it maybe?



Well ...



I'm afraid not.






Link to comment
Share on other sites

My maps have to have few guards because my computer is 5+yo and I can't play/test with more than 2 on the screen at a time. If/When I get a new computer, I'll be able to do better in this area.

Grayman, where do you live? If you live in Germany, I could offer you my spare ATI Radeon HD4870 for cheap. 


Oh, and yes, I had that font bug too. Must be something wrong with your FM, then.

My Eigenvalue is bigger than your Eigenvalue.

Link to comment
Share on other sites

Oh yeah - I also had that lost Hud font bug. This is new to me. I suspect it might be the default font bug but I think that was fixed. But that might have just prevented the default doom font showing? Better to have the doom font that nothing if so.


I didn't think I had control over the HUD fonts. Is there something I was supposed to do to make sure fonts showed up after a savegame reload? Thought all this kind of stuff was standard "comes with the game" stuff.




Link to comment
Share on other sites

No it's not your fault grayman, (AFAIK ;)) Some time ago we had quite a few instances where FMs changed to the default doom font. Not seen that for a while. Possibly that was fixed. Possibly the fix stopped it using the doom font but maybe the cause is still there so now it defaults to nothing. I just don't know. But there is nothing to set in the FM itself.

Link to comment
Share on other sites

I had a problem with all my text disappearing - is this the font bug spoken about earlier? I've started over as I don't remember what the key was for, whose journal I have and can't tell how many weapons I have ie number of rope arrows etc. Someone mentioned something about the quicksave so am going to try and stay away from that as I had text at the beginning of the mission and not sure when it disappeared. So far am almost back to where I was and still have text.


sad.gif I was wrong. I just went back into my game and all text has disappeared again. I hadn't used any quicksaves and it was there yesterday when I quit for the day, so I don't know.

Edited by Thiefette
Link to comment
Share on other sites

Ok, I'm stuck early on. The first time, I wasn't able to frob

the journal in the chest, so I just went all the way back up and couldn't go through any of the doors,

so wasn't sure what to do.


Restarted, this time the

journal frobbed, so I started searching the mines for some way into the temple. Still can't find anything. Just a caved in tunnel and a blocked off one. Even tried using the flask and fire arrow to blow it open but nothing happened.


It just occurs to me that there was one last place I didn't check, under the bridge with all the chains. I'll go back and check there but if that's not it, I'll need a hint.



edit: My thiefy senses are obviously not what they used to be. :blush:



Maybe a TDM bug, but in my quicksavegame the HUD font disappeared.


I had this bug as well.

Link to comment
Share on other sites


I'll go back and check there but if that's not it, I'll need a hint.




You're on the right path. Drop down to the tracks beneath the chain bridge. You'll find a skeleton on a ledge with some loot and a note. From there, you should continue to find ways to go down, down, down. You'll find the temple at the very bottom. From that point on, it's up, up, up to the finish.



Let me know if you need more hints.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recent Status Updates

    • Ansome

      Taking a break to alleviate burnout. In retrospect, I probably shouldn't have jumped into a map-making contest so quickly after just finishing another project and especially with my busy schedule, but I do believe I have something that the community will enjoy. No clue if I'll be able to finish it on time for the competition if I factor in a break, but I'd rather take my time and deliver something of quality rather than engage in development crunch or lose part of the map's soul to burnout.
      · 0 replies
    • Skaruts

      Working on an update for my mission By The Cookbook. If anyone that played it has any further bugs to report, please let me know.
      I posted more details about the update in the mission thread.
      · 1 reply
    • lucien

      being thankful for tdm is a good feeling
      · 0 replies
    • The Black Arrow

      Happy birthday to me!
      Yes, today's my birthday and as much as I want to play The Dark Mod, I won't until it's late Autumn, where it should be a bit chilly in my place and there's some wind too.
      For now, it's time to enjoy my birthday, if any of you want to play a great fan mission in my honour...Well that's asking too much, just play the mission because it's fun, not because of me, enjoy it yourself! 💪
      · 5 replies
    • nbohr1more

      New texture wiki article created: https://wiki.thedarkmod.com/index.php?title=Creating_textures_from_Ornate_Photos
      · 11 replies
  • Create New...